/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Diff of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.59 Revision 1.105
1# ChangeLog for sys-auth/polkit 1# ChangeLog for sys-auth/polkit
2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.59 2011/12/08 15:39:21 ssuominen Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.105 2012/10/08 06:24:32 ssuominen Exp $
4
5 08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
6 Use pax-mark in src_compile() instead of src_install() for src_test() wrt
7 #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
8 and emphatize it's an Portage issue instead of polkit issue in src_install()
9 message.
10
11 07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
12 Stable for amd64, wrt bug #436666
13
14*polkit-0.107-r1 (20 Sep 2012)
15
16 20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
17 +files/polkit-0.107-fallback.patch:
18 Introduce upstream patch for falling back to uid 0 for authentication if list
19 of admin identities is empty.
20
21 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
22 -polkit-0.106-r7.ebuild:
23 old
24
25*polkit-0.107 (13 Jul 2012)
26
27 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
28 Version bump.
29
30 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
31 -polkit-0.106-r6.ebuild:
32 old
33
34 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
35 Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
36 #391865 by Maksim Melnikau
37
38*polkit-0.106-r7 (02 Jul 2012)
39
40 02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
41 RESTRICT="multilib-strict" since it's not compatible with the whole
42 /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
43 polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
44
45*polkit-0.106-r6 (01 Jul 2012)
46
47 01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
48 Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
49 /usr/lib to /usr/lib64 symlink.
50
51 30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
52 polkit-0.106-r5.ebuild:
53 Adding dependency on SELinux policykit module if USE=selinux is set
54
55 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
56 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
57 'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
58
59 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
60 -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
61 old
62
63*polkit-0.106-r5 (27 Jun 2012)
64
65 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
66 Revert entire unix-group:wheel experiment back to unix-user:0 because
67 PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
68 Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
69 by Doug Goldstein.
70
71*polkit-0.106-r4 (27 Jun 2012)
72
73 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
74 Stop installing polkit-backend-1.pc because upstream changed
75 libpolkit-backend-1.la to be noinst_LTLIBRARIES in
76 src/polkitbackend/Makefile.am wrt #423431 by Pim Vullers
77
78 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r3.ebuild:
79 Redefine libprivdir in install for multilib-strict wrt #423381 by Michael
80 Palimaka
81
82*polkit-0.106-r3 (25 Jun 2012)
83
84 25 Jun 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
85 +polkit-0.106-r3.ebuild:
86 pax-mark polkitd to fix crashes on hardened/PaX systems.
87
88 23 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
89 Convert pkg_postinst() message about polkitd home directory to new
90 user.eclass function esethome().
91
92 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
93 Check for mozjs187.pc for >=dev-lang/spidermonkey-1.8.7 compability.
94
95 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
96 Adapt to sys-auth/pambase with USE="systemd" wrt #372229 by Michał Górny
97
98 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r1.ebuild:
99 old
100
101*polkit-0.106-r2 (17 Jun 2012)
102
103 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r2.ebuild:
104 Revision bump to chown /var/lib/polkit-1 because diropts has no effect on
105 existing directories.
106
107 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106.ebuild:
108 old
109
110*polkit-0.106-r1 (17 Jun 2012)
111
112 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r1.ebuild:
113 Update /etc/pam.d/polkit-1 from system-login to system-local-login. Use
114 unix-group "adm" for administrators. Use /var/lib/polkit-1 as home directory
115 for unix-user polkitd. Update owners of /etc/polkit-1/rules.d and
116 /usr/share/polkit-1/rules.d to polkitd:root wrt #420269.
117
118 13 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106.ebuild:
119 Pull in dev-lang/spidermonkey >= 1.8.5 and dev-libs/glib >= 2.32 wrt
120 #420173 and #420307.
121
122*polkit-0.106 (07 Jun 2012)
123
124 07 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106.ebuild:
125 Version bump.
126
127 20 May 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.105.ebuild:
128 Improve systemd handling wrt #416317 by Christoph Brill
129
130*polkit-0.105 (14 May 2012)
131
132 14 May 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.105.ebuild:
133 Version bump.
134
135 04 May 2012; Jeff Horelick <jdhore@gentoo.org> polkit-0.104-r1.ebuild:
136 dev-util/pkgconfig -> virtual/pkgconfig
137
138 18 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.102.ebuild,
139 -polkit-0.103.ebuild, -polkit-0.104.ebuild:
140 old
141
142 25 Mar 2012; Raúl Porcel <armin76@gentoo.org> polkit-0.104-r1.ebuild:
143 ia64/sh/sparc stable wrt #401513
144
145 09 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.104-r1.ebuild:
146 ppc/ppc64 stable wrt #401513
147
148 17 Feb 2012; Tobias Klausmann <klausman@gentoo.org> polkit-0.104-r1.ebuild:
149 Stable on alpha, bug #401513
150
151 17 Feb 2012; Thomas Kahle <tomka@gentoo.org> polkit-0.104-r1.ebuild:
152 marked x86 per bug 401513
153
154 13 Feb 2012; Markus Meier <maekke@gentoo.org> polkit-0.104-r1.ebuild:
155 arm stable, bug #401513
156
157 02 Feb 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild:
158 Stable for HPPA (bug #401513).
159
160 30 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.104-r1.ebuild:
161 Stable for AMD64, wrt security bug #401513
162
163*polkit-0.104-r1 (30 Jan 2012)
164
165 30 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104-r1.ebuild:
166 Restore the default value of AdminIdentities from "wheel" to "0" like it was
167 in polkit-0.102 and ones before that. You should see files
168 50-localauthority.conf and 60-gentoo.conf in
169 /etc/polkit-1/localauthority.conf.d. You should also familiarize yourself
170 with "man 8 pklocalauthority" as soon as possible.
171
172 29 Jan 2012; Markus Meier <maekke@gentoo.org> polkit-0.103.ebuild:
173 arm stable, bug #397755
174
175 07 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.103.ebuild:
176 Stable for AMD64, wrt bug #397755
177
178*polkit-0.104 (05 Jan 2012)
179
180 05 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104.ebuild,
181 metadata.xml:
182 Version bump.
183
184 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.101-r1.ebuild:
185 old
186
187 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.102.ebuild:
188 ppc/ppc64 stable wrt #387163
4 189
5 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild: 190 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild:
6 Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo 191 Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo
7 192
8*polkit-0.103 (07 Dec 2011) 193*polkit-0.103 (07 Dec 2011)

Legend:
Removed from v.1.59  
changed lines
  Added in v.1.105

  ViewVC Help
Powered by ViewVC 1.1.20