/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Diff of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.59 Revision 1.106
1# ChangeLog for sys-auth/polkit 1# ChangeLog for sys-auth/polkit
2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.59 2011/12/08 15:39:21 ssuominen Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.106 2012/10/09 22:14:44 jer Exp $
4
5 09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
6 Marked ~hppa (bug #436668).
7
8 08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
9 Use pax-mark in src_compile() instead of src_install() for src_test() wrt
10 #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
11 and emphatize it's an Portage issue instead of polkit issue in src_install()
12 message.
13
14 07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
15 Stable for amd64, wrt bug #436666
16
17*polkit-0.107-r1 (20 Sep 2012)
18
19 20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
20 +files/polkit-0.107-fallback.patch:
21 Introduce upstream patch for falling back to uid 0 for authentication if list
22 of admin identities is empty.
23
24 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
25 -polkit-0.106-r7.ebuild:
26 old
27
28*polkit-0.107 (13 Jul 2012)
29
30 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
31 Version bump.
32
33 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
34 -polkit-0.106-r6.ebuild:
35 old
36
37 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
38 Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
39 #391865 by Maksim Melnikau
40
41*polkit-0.106-r7 (02 Jul 2012)
42
43 02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
44 RESTRICT="multilib-strict" since it's not compatible with the whole
45 /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
46 polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
47
48*polkit-0.106-r6 (01 Jul 2012)
49
50 01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
51 Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
52 /usr/lib to /usr/lib64 symlink.
53
54 30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
55 polkit-0.106-r5.ebuild:
56 Adding dependency on SELinux policykit module if USE=selinux is set
57
58 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
59 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
60 'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
61
62 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
63 -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
64 old
65
66*polkit-0.106-r5 (27 Jun 2012)
67
68 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
69 Revert entire unix-group:wheel experiment back to unix-user:0 because
70 PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
71 Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
72 by Doug Goldstein.
73
74*polkit-0.106-r4 (27 Jun 2012)
75
76 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
77 Stop installing polkit-backend-1.pc because upstream changed
78 libpolkit-backend-1.la to be noinst_LTLIBRARIES in
79 src/polkitbackend/Makefile.am wrt #423431 by Pim Vullers
80
81 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r3.ebuild:
82 Redefine libprivdir in install for multilib-strict wrt #423381 by Michael
83 Palimaka
84
85*polkit-0.106-r3 (25 Jun 2012)
86
87 25 Jun 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
88 +polkit-0.106-r3.ebuild:
89 pax-mark polkitd to fix crashes on hardened/PaX systems.
90
91 23 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
92 Convert pkg_postinst() message about polkitd home directory to new
93 user.eclass function esethome().
94
95 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
96 Check for mozjs187.pc for >=dev-lang/spidermonkey-1.8.7 compability.
97
98 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
99 Adapt to sys-auth/pambase with USE="systemd" wrt #372229 by Michał Górny
100
101 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r1.ebuild:
102 old
103
104*polkit-0.106-r2 (17 Jun 2012)
105
106 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r2.ebuild:
107 Revision bump to chown /var/lib/polkit-1 because diropts has no effect on
108 existing directories.
109
110 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106.ebuild:
111 old
112
113*polkit-0.106-r1 (17 Jun 2012)
114
115 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r1.ebuild:
116 Update /etc/pam.d/polkit-1 from system-login to system-local-login. Use
117 unix-group "adm" for administrators. Use /var/lib/polkit-1 as home directory
118 for unix-user polkitd. Update owners of /etc/polkit-1/rules.d and
119 /usr/share/polkit-1/rules.d to polkitd:root wrt #420269.
120
121 13 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106.ebuild:
122 Pull in dev-lang/spidermonkey >= 1.8.5 and dev-libs/glib >= 2.32 wrt
123 #420173 and #420307.
124
125*polkit-0.106 (07 Jun 2012)
126
127 07 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106.ebuild:
128 Version bump.
129
130 20 May 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.105.ebuild:
131 Improve systemd handling wrt #416317 by Christoph Brill
132
133*polkit-0.105 (14 May 2012)
134
135 14 May 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.105.ebuild:
136 Version bump.
137
138 04 May 2012; Jeff Horelick <jdhore@gentoo.org> polkit-0.104-r1.ebuild:
139 dev-util/pkgconfig -> virtual/pkgconfig
140
141 18 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.102.ebuild,
142 -polkit-0.103.ebuild, -polkit-0.104.ebuild:
143 old
144
145 25 Mar 2012; Raúl Porcel <armin76@gentoo.org> polkit-0.104-r1.ebuild:
146 ia64/sh/sparc stable wrt #401513
147
148 09 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.104-r1.ebuild:
149 ppc/ppc64 stable wrt #401513
150
151 17 Feb 2012; Tobias Klausmann <klausman@gentoo.org> polkit-0.104-r1.ebuild:
152 Stable on alpha, bug #401513
153
154 17 Feb 2012; Thomas Kahle <tomka@gentoo.org> polkit-0.104-r1.ebuild:
155 marked x86 per bug 401513
156
157 13 Feb 2012; Markus Meier <maekke@gentoo.org> polkit-0.104-r1.ebuild:
158 arm stable, bug #401513
159
160 02 Feb 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild:
161 Stable for HPPA (bug #401513).
162
163 30 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.104-r1.ebuild:
164 Stable for AMD64, wrt security bug #401513
165
166*polkit-0.104-r1 (30 Jan 2012)
167
168 30 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104-r1.ebuild:
169 Restore the default value of AdminIdentities from "wheel" to "0" like it was
170 in polkit-0.102 and ones before that. You should see files
171 50-localauthority.conf and 60-gentoo.conf in
172 /etc/polkit-1/localauthority.conf.d. You should also familiarize yourself
173 with "man 8 pklocalauthority" as soon as possible.
174
175 29 Jan 2012; Markus Meier <maekke@gentoo.org> polkit-0.103.ebuild:
176 arm stable, bug #397755
177
178 07 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.103.ebuild:
179 Stable for AMD64, wrt bug #397755
180
181*polkit-0.104 (05 Jan 2012)
182
183 05 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104.ebuild,
184 metadata.xml:
185 Version bump.
186
187 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.101-r1.ebuild:
188 old
189
190 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.102.ebuild:
191 ppc/ppc64 stable wrt #387163
4 192
5 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild: 193 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild:
6 Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo 194 Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo
7 195
8*polkit-0.103 (07 Dec 2011) 196*polkit-0.103 (07 Dec 2011)

Legend:
Removed from v.1.59  
changed lines
  Added in v.1.106

  ViewVC Help
Powered by ViewVC 1.1.20