/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Diff of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.59 Revision 1.166
1# ChangeLog for sys-auth/polkit 1# ChangeLog for sys-auth/polkit
2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.59 2011/12/08 15:39:21 ssuominen Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.166 2014/02/25 20:52:29 maekke Exp $
4
5 25 Feb 2014; Markus Meier <maekke@gentoo.org> polkit-0.112-r1.ebuild:
6 arm stable, bug #500758
7
8 23 Feb 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r1.ebuild:
9 x86 stable, bug #500758
10
11 23 Feb 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r1.ebuild:
12 amd64 stable, bug #500758
13
14 28 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
15 Fix ia64 where the order of the configure options was overridden by mips,
16 thanks Arfrever
17
18 27 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
19 Because sometimes portage is stupid
20
21 24 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
22 Fix dependence on spidermonkey for mips, bug #495168
23
24 23 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
25 Stable for sparc, wrt bug #484486
26
27 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
28 Stable for alpha, wrt bug #484486
29
30 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
31 Stable for ia64, wrt bug #484486
32
33 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
34 Stable for ppc64, wrt bug #484486
35
36 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
37 Stable for ppc, wrt bug #484486
38
39 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
40 Stable for arm, wrt bug #484486
41
42 21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
43 Stable for x86, wrt bug #484486
44
45 21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
46 Stable for amd64, wrt bug #484486
47
48 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.110-r1.ebuild,
49 -files/polkit-0.110-CVE-2013-4288.patch:
50 old
51
52*polkit-0.112-r1 (19 Sep 2013)
53
54 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.112-r1.ebuild,
55 polkit-0.112.ebuild:
56 -r0 is for stabilization w/ mozjs185 and -r1 is for ~arch with mozjs 17.0
57
58 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> -polkit-0.111-r1.ebuild:
59 Remove vulnerable version
60
61*polkit-0.110-r1 (19 Sep 2013)
62
63 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org>
64 +files/polkit-0.110-CVE-2013-4288.patch, +polkit-0.110-r1.ebuild:
65 Bump for CVE-2013-4288
66
67*polkit-0.112 (19 Sep 2013)
68
69 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> +polkit-0.112.ebuild:
70 Bump for CVE-2013-4288
71
72 10 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
73 polkit-0.111-r1.ebuild:
74 Stop forcing USE="consolekit systemd" for sys-auth/pambase in PDEPEND because
75 CONFIG_AUDITSYSCALL=y is not possible on every arch and the dependency was
76 always more about convinience than being strict requirement.
77
78 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> -polkit-0.111.ebuild:
79 dropped polkit-111 in favour of -r1 now that spidermonkey-17 is unmasked, as
80 per ssuominen's approval
81
82 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> polkit-0.110.ebuild,
83 polkit-0.111-r1.ebuild:
84 Adjusted deps for dev-lang/spidermonkey to ensure SLOT=0
85
86*polkit-0.111-r1 (08 Aug 2013)
87
88 08 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111-r1.ebuild:
89 Force use of dev-lang/spidermonkey:17 because automagic dependencies are bad.
90
91*polkit-0.111 (15 May 2013)
92
93 15 May 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111.ebuild:
94 Version bump by "okias" from Freenode
95
96 19 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107-r1.ebuild,
97 -files/polkit-0.107-fallback.patch:
98 old
99
100 19 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
101 Stable for sh, wrt bug #452688
102
103 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
104 files/polkit-0.110-W_define.patch:
105 Include link to upstream bug.
106
107 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
108 +files/polkit-0.110-W_define.patch:
109 Fix missing #include <sys/wait.h> for #define's of WIFEXITED, WEXITSTATUS,
110 WIFSIGNALED and WTERMSIG (to fix building on arch "sh")
111
112 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
113 Stable for sparc, wrt bug #452688
114
115 03 Mar 2013; Mike Frysinger <vapier@gentoo.org> polkit-0.110.ebuild:
116 Add s390 keywords #457078 by Michael Palimaka.
117
118 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
119 Stable for alpha, wrt bug #452688
120
121 10 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
122 Stable for ppc64, wrt bug #452688
123
124 09 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
125 Stable for ia64, wrt bug #452688
126
127 31 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
128 Stable for ppc, wrt bug #452688
129
130 29 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
131 Force USE="debug" to be disabled in dev-lang/spidermonkey to avoid asseration
132 errors as noted by _AxS_.
133
134 26 Jan 2013; Markus Meier <maekke@gentoo.org> polkit-0.110.ebuild:
135 arm stable, bug #452688
136
137 20 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
138 x86 stable wrt #452688
139
140 19 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
141 amd64 stable wrt #452688
142
143 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.104-r1.ebuild,
144 -polkit-0.109-r1.ebuild, -files/polkit-0.109-XAUTHORITY-fallback.patch:
145 old
146
147*polkit-0.110 (11 Jan 2013)
148
149 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.110.ebuild:
150 Version bump.
151
152 06 Jan 2013; Raúl Porcel <armin76@gentoo.org> polkit-0.107-r1.ebuild,
153 polkit-0.109-r1.ebuild:
154 Add ~sh wrt #436668
155
156 01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.109-r1.ebuild:
157 Add ~ia64, wrt bug #436668
158
159 30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
160 Stable for sparc, wrt bug #436666
161
162 29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
163 Stable for alpha, wrt bug #436666
164
165 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.108.ebuild,
166 -polkit-0.109.ebuild:
167 old
168
169*polkit-0.109-r1 (21 Dec 2012)
170
171 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109-r1.ebuild,
172 +files/polkit-0.109-XAUTHORITY-fallback.patch:
173 Backport XAUTHORITY fallback support from upstream git.
174
175 19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.108.ebuild:
176 Add ~ia64, wrt bug #436668
177
178*polkit-0.109 (19 Dec 2012)
179
180 19 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109.ebuild:
181 Version bump. Fix PaX marking logic wrt #444446 by Maxim Kammerer
182
183 18 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
184 Stable for ia64, wrt bug #436666
185
186 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
187 stable arm, bug #436666
188
189 22 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107.ebuild:
190 old
191
192 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
193 stable ppc64, bug #436666
194
195 22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
196 Stable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt
197 bug #436666
198
199 21 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
200 stable ppc, bug #436666, thanks peratu
201
202 19 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.108.ebuild:
203 Link against -lgmodule-2.0 to prevent underlinking (backported from upstream,
204 but using sed to avoid eautoreconf) wrt #443798
205
206*polkit-0.108 (18 Nov 2012)
207
208 18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
209 Version bump.
210
211 28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
212 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
213 Drop ~x86-fbsd due to bug #439968.
214
215 15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
216 polkit-0.107-r1.ebuild:
217 Drop HPPA keywording (bug #438368).
218
219 15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
220 Set QA_MULTILIB_PATHS for bug #424423.
221
222 09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
223 Marked ~hppa (bug #436668).
224
225 08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
226 Use pax-mark in src_compile() instead of src_install() for src_test() wrt
227 #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
228 and emphatize it's an Portage issue instead of polkit issue in src_install()
229 message.
230
231 07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
232 Stable for amd64, wrt bug #436666
233
234*polkit-0.107-r1 (20 Sep 2012)
235
236 20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
237 +files/polkit-0.107-fallback.patch:
238 Introduce upstream patch for falling back to uid 0 for authentication if list
239 of admin identities is empty.
240
241 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
242 -polkit-0.106-r7.ebuild:
243 old
244
245*polkit-0.107 (13 Jul 2012)
246
247 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
248 Version bump.
249
250 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
251 -polkit-0.106-r6.ebuild:
252 old
253
254 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
255 Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
256 #391865 by Maksim Melnikau
257
258*polkit-0.106-r7 (02 Jul 2012)
259
260 02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
261 RESTRICT="multilib-strict" since it's not compatible with the whole
262 /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
263 polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
264
265*polkit-0.106-r6 (01 Jul 2012)
266
267 01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
268 Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
269 /usr/lib to /usr/lib64 symlink.
270
271 30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
272 polkit-0.106-r5.ebuild:
273 Adding dependency on SELinux policykit module if USE=selinux is set
274
275 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
276 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
277 'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
278
279 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
280 -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
281 old
282
283*polkit-0.106-r5 (27 Jun 2012)
284
285 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
286 Revert entire unix-group:wheel experiment back to unix-user:0 because
287 PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
288 Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
289 by Doug Goldstein.
290
291*polkit-0.106-r4 (27 Jun 2012)
292
293 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
294 Stop installing polkit-backend-1.pc because upstream changed
295 libpolkit-backend-1.la to be noinst_LTLIBRARIES in
296 src/polkitbackend/Makefile.am wrt #423431 by Pim Vullers
297
298 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r3.ebuild:
299 Redefine libprivdir in install for multilib-strict wrt #423381 by Michael
300 Palimaka
301
302*polkit-0.106-r3 (25 Jun 2012)
303
304 25 Jun 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
305 +polkit-0.106-r3.ebuild:
306 pax-mark polkitd to fix crashes on hardened/PaX systems.
307
308 23 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
309 Convert pkg_postinst() message about polkitd home directory to new
310 user.eclass function esethome().
311
312 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
313 Check for mozjs187.pc for >=dev-lang/spidermonkey-1.8.7 compability.
314
315 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
316 Adapt to sys-auth/pambase with USE="systemd" wrt #372229 by Michał Górny
317
318 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r1.ebuild:
319 old
320
321*polkit-0.106-r2 (17 Jun 2012)
322
323 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r2.ebuild:
324 Revision bump to chown /var/lib/polkit-1 because diropts has no effect on
325 existing directories.
326
327 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106.ebuild:
328 old
329
330*polkit-0.106-r1 (17 Jun 2012)
331
332 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r1.ebuild:
333 Update /etc/pam.d/polkit-1 from system-login to system-local-login. Use
334 unix-group "adm" for administrators. Use /var/lib/polkit-1 as home directory
335 for unix-user polkitd. Update owners of /etc/polkit-1/rules.d and
336 /usr/share/polkit-1/rules.d to polkitd:root wrt #420269.
337
338 13 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106.ebuild:
339 Pull in dev-lang/spidermonkey >= 1.8.5 and dev-libs/glib >= 2.32 wrt
340 #420173 and #420307.
341
342*polkit-0.106 (07 Jun 2012)
343
344 07 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106.ebuild:
345 Version bump.
346
347 20 May 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.105.ebuild:
348 Improve systemd handling wrt #416317 by Christoph Brill
349
350*polkit-0.105 (14 May 2012)
351
352 14 May 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.105.ebuild:
353 Version bump.
354
355 04 May 2012; Jeff Horelick <jdhore@gentoo.org> polkit-0.104-r1.ebuild:
356 dev-util/pkgconfig -> virtual/pkgconfig
357
358 18 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.102.ebuild,
359 -polkit-0.103.ebuild, -polkit-0.104.ebuild:
360 old
361
362 25 Mar 2012; Raúl Porcel <armin76@gentoo.org> polkit-0.104-r1.ebuild:
363 ia64/sh/sparc stable wrt #401513
364
365 09 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.104-r1.ebuild:
366 ppc/ppc64 stable wrt #401513
367
368 17 Feb 2012; Tobias Klausmann <klausman@gentoo.org> polkit-0.104-r1.ebuild:
369 Stable on alpha, bug #401513
370
371 17 Feb 2012; Thomas Kahle <tomka@gentoo.org> polkit-0.104-r1.ebuild:
372 marked x86 per bug 401513
373
374 13 Feb 2012; Markus Meier <maekke@gentoo.org> polkit-0.104-r1.ebuild:
375 arm stable, bug #401513
376
377 02 Feb 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild:
378 Stable for HPPA (bug #401513).
379
380 30 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.104-r1.ebuild:
381 Stable for AMD64, wrt security bug #401513
382
383*polkit-0.104-r1 (30 Jan 2012)
384
385 30 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104-r1.ebuild:
386 Restore the default value of AdminIdentities from "wheel" to "0" like it was
387 in polkit-0.102 and ones before that. You should see files
388 50-localauthority.conf and 60-gentoo.conf in
389 /etc/polkit-1/localauthority.conf.d. You should also familiarize yourself
390 with "man 8 pklocalauthority" as soon as possible.
391
392 29 Jan 2012; Markus Meier <maekke@gentoo.org> polkit-0.103.ebuild:
393 arm stable, bug #397755
394
395 07 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.103.ebuild:
396 Stable for AMD64, wrt bug #397755
397
398*polkit-0.104 (05 Jan 2012)
399
400 05 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104.ebuild,
401 metadata.xml:
402 Version bump.
403
404 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.101-r1.ebuild:
405 old
406
407 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.102.ebuild:
408 ppc/ppc64 stable wrt #387163
4 409
5 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild: 410 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild:
6 Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo 411 Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo
7 412
8*polkit-0.103 (07 Dec 2011) 413*polkit-0.103 (07 Dec 2011)
214 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org> 619 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
215 +files/polkit-0.92-zsh-completions.patch, 620 +files/polkit-0.92-zsh-completions.patch,
216 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild, 621 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
217 +metadata.xml: 622 +metadata.xml:
218 Initial ebuild for GNOME 2.28. 623 Initial ebuild for GNOME 2.28.
219

Legend:
Removed from v.1.59  
changed lines
  Added in v.1.166

  ViewVC Help
Powered by ViewVC 1.1.20