/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Diff of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.89 Revision 1.110
1# ChangeLog for sys-auth/polkit 1# ChangeLog for sys-auth/polkit
2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.89 2012/06/27 10:06:14 ssuominen Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.110 2012/11/18 07:11:54 ssuominen Exp $
4
5*polkit-0.108 (18 Nov 2012)
6
7 18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
8 Version bump.
9
10 28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
11 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
12 Drop ~x86-fbsd due to bug #439968.
13
14 15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
15 polkit-0.107-r1.ebuild:
16 Drop HPPA keywording (bug #438368).
17
18 15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
19 Set QA_MULTILIB_PATHS for bug #424423.
20
21 09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
22 Marked ~hppa (bug #436668).
23
24 08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
25 Use pax-mark in src_compile() instead of src_install() for src_test() wrt
26 #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
27 and emphatize it's an Portage issue instead of polkit issue in src_install()
28 message.
29
30 07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
31 Stable for amd64, wrt bug #436666
32
33*polkit-0.107-r1 (20 Sep 2012)
34
35 20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
36 +files/polkit-0.107-fallback.patch:
37 Introduce upstream patch for falling back to uid 0 for authentication if list
38 of admin identities is empty.
39
40 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
41 -polkit-0.106-r7.ebuild:
42 old
43
44*polkit-0.107 (13 Jul 2012)
45
46 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
47 Version bump.
48
49 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
50 -polkit-0.106-r6.ebuild:
51 old
52
53 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
54 Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
55 #391865 by Maksim Melnikau
56
57*polkit-0.106-r7 (02 Jul 2012)
58
59 02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
60 RESTRICT="multilib-strict" since it's not compatible with the whole
61 /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
62 polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
63
64*polkit-0.106-r6 (01 Jul 2012)
65
66 01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
67 Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
68 /usr/lib to /usr/lib64 symlink.
69
70 30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
71 polkit-0.106-r5.ebuild:
72 Adding dependency on SELinux policykit module if USE=selinux is set
73
74 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
75 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
76 'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
77
78 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
79 -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
80 old
81
82*polkit-0.106-r5 (27 Jun 2012)
83
84 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
85 Revert entire unix-group:wheel experiment back to unix-user:0 because
86 PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
87 Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
88 by Doug Goldstein.
4 89
5*polkit-0.106-r4 (27 Jun 2012) 90*polkit-0.106-r4 (27 Jun 2012)
6 91
7 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild: 92 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
8 Stop installing polkit-backend-1.pc because upstream changed 93 Stop installing polkit-backend-1.pc because upstream changed
333 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org> 418 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
334 +files/polkit-0.92-zsh-completions.patch, 419 +files/polkit-0.92-zsh-completions.patch,
335 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild, 420 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
336 +metadata.xml: 421 +metadata.xml:
337 Initial ebuild for GNOME 2.28. 422 Initial ebuild for GNOME 2.28.
338

Legend:
Removed from v.1.89  
changed lines
  Added in v.1.110

  ViewVC Help
Powered by ViewVC 1.1.20