/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Diff of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.89 Revision 1.160
1# ChangeLog for sys-auth/polkit 1# ChangeLog for sys-auth/polkit
2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.89 2012/06/27 10:06:14 ssuominen Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.160 2013/09/23 19:17:01 ago Exp $
4
5 23 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
6 Stable for sparc, wrt bug #484486
7
8 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
9 Stable for alpha, wrt bug #484486
10
11 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
12 Stable for ia64, wrt bug #484486
13
14 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
15 Stable for ppc64, wrt bug #484486
16
17 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
18 Stable for ppc, wrt bug #484486
19
20 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
21 Stable for arm, wrt bug #484486
22
23 21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
24 Stable for x86, wrt bug #484486
25
26 21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
27 Stable for amd64, wrt bug #484486
28
29 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.110-r1.ebuild,
30 -files/polkit-0.110-CVE-2013-4288.patch:
31 old
32
33*polkit-0.112-r1 (19 Sep 2013)
34
35 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.112-r1.ebuild,
36 polkit-0.112.ebuild:
37 -r0 is for stabilization w/ mozjs185 and -r1 is for ~arch with mozjs 17.0
38
39 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> -polkit-0.111-r1.ebuild:
40 Remove vulnerable version
41
42*polkit-0.110-r1 (19 Sep 2013)
43
44 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org>
45 +files/polkit-0.110-CVE-2013-4288.patch, +polkit-0.110-r1.ebuild:
46 Bump for CVE-2013-4288
47
48*polkit-0.112 (19 Sep 2013)
49
50 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> +polkit-0.112.ebuild:
51 Bump for CVE-2013-4288
52
53 10 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
54 polkit-0.111-r1.ebuild:
55 Stop forcing USE="consolekit systemd" for sys-auth/pambase in PDEPEND because
56 CONFIG_AUDITSYSCALL=y is not possible on every arch and the dependency was
57 always more about convinience than being strict requirement.
58
59 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> -polkit-0.111.ebuild:
60 dropped polkit-111 in favour of -r1 now that spidermonkey-17 is unmasked, as
61 per ssuominen's approval
62
63 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> polkit-0.110.ebuild,
64 polkit-0.111-r1.ebuild:
65 Adjusted deps for dev-lang/spidermonkey to ensure SLOT=0
66
67*polkit-0.111-r1 (08 Aug 2013)
68
69 08 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111-r1.ebuild:
70 Force use of dev-lang/spidermonkey:17 because automagic dependencies are bad.
71
72*polkit-0.111 (15 May 2013)
73
74 15 May 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111.ebuild:
75 Version bump by "okias" from Freenode
76
77 19 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107-r1.ebuild,
78 -files/polkit-0.107-fallback.patch:
79 old
80
81 19 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
82 Stable for sh, wrt bug #452688
83
84 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
85 files/polkit-0.110-W_define.patch:
86 Include link to upstream bug.
87
88 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
89 +files/polkit-0.110-W_define.patch:
90 Fix missing #include <sys/wait.h> for #define's of WIFEXITED, WEXITSTATUS,
91 WIFSIGNALED and WTERMSIG (to fix building on arch "sh")
92
93 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
94 Stable for sparc, wrt bug #452688
95
96 03 Mar 2013; Mike Frysinger <vapier@gentoo.org> polkit-0.110.ebuild:
97 Add s390 keywords #457078 by Michael Palimaka.
98
99 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
100 Stable for alpha, wrt bug #452688
101
102 10 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
103 Stable for ppc64, wrt bug #452688
104
105 09 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
106 Stable for ia64, wrt bug #452688
107
108 31 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
109 Stable for ppc, wrt bug #452688
110
111 29 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
112 Force USE="debug" to be disabled in dev-lang/spidermonkey to avoid asseration
113 errors as noted by _AxS_.
114
115 26 Jan 2013; Markus Meier <maekke@gentoo.org> polkit-0.110.ebuild:
116 arm stable, bug #452688
117
118 20 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
119 x86 stable wrt #452688
120
121 19 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
122 amd64 stable wrt #452688
123
124 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.104-r1.ebuild,
125 -polkit-0.109-r1.ebuild, -files/polkit-0.109-XAUTHORITY-fallback.patch:
126 old
127
128*polkit-0.110 (11 Jan 2013)
129
130 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.110.ebuild:
131 Version bump.
132
133 06 Jan 2013; Raúl Porcel <armin76@gentoo.org> polkit-0.107-r1.ebuild,
134 polkit-0.109-r1.ebuild:
135 Add ~sh wrt #436668
136
137 01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.109-r1.ebuild:
138 Add ~ia64, wrt bug #436668
139
140 30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
141 Stable for sparc, wrt bug #436666
142
143 29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
144 Stable for alpha, wrt bug #436666
145
146 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.108.ebuild,
147 -polkit-0.109.ebuild:
148 old
149
150*polkit-0.109-r1 (21 Dec 2012)
151
152 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109-r1.ebuild,
153 +files/polkit-0.109-XAUTHORITY-fallback.patch:
154 Backport XAUTHORITY fallback support from upstream git.
155
156 19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.108.ebuild:
157 Add ~ia64, wrt bug #436668
158
159*polkit-0.109 (19 Dec 2012)
160
161 19 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109.ebuild:
162 Version bump. Fix PaX marking logic wrt #444446 by Maxim Kammerer
163
164 18 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
165 Stable for ia64, wrt bug #436666
166
167 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
168 stable arm, bug #436666
169
170 22 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107.ebuild:
171 old
172
173 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
174 stable ppc64, bug #436666
175
176 22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
177 Stable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt
178 bug #436666
179
180 21 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
181 stable ppc, bug #436666, thanks peratu
182
183 19 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.108.ebuild:
184 Link against -lgmodule-2.0 to prevent underlinking (backported from upstream,
185 but using sed to avoid eautoreconf) wrt #443798
186
187*polkit-0.108 (18 Nov 2012)
188
189 18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
190 Version bump.
191
192 28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
193 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
194 Drop ~x86-fbsd due to bug #439968.
195
196 15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
197 polkit-0.107-r1.ebuild:
198 Drop HPPA keywording (bug #438368).
199
200 15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
201 Set QA_MULTILIB_PATHS for bug #424423.
202
203 09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
204 Marked ~hppa (bug #436668).
205
206 08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
207 Use pax-mark in src_compile() instead of src_install() for src_test() wrt
208 #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
209 and emphatize it's an Portage issue instead of polkit issue in src_install()
210 message.
211
212 07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
213 Stable for amd64, wrt bug #436666
214
215*polkit-0.107-r1 (20 Sep 2012)
216
217 20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
218 +files/polkit-0.107-fallback.patch:
219 Introduce upstream patch for falling back to uid 0 for authentication if list
220 of admin identities is empty.
221
222 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
223 -polkit-0.106-r7.ebuild:
224 old
225
226*polkit-0.107 (13 Jul 2012)
227
228 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
229 Version bump.
230
231 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
232 -polkit-0.106-r6.ebuild:
233 old
234
235 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
236 Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
237 #391865 by Maksim Melnikau
238
239*polkit-0.106-r7 (02 Jul 2012)
240
241 02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
242 RESTRICT="multilib-strict" since it's not compatible with the whole
243 /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
244 polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
245
246*polkit-0.106-r6 (01 Jul 2012)
247
248 01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
249 Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
250 /usr/lib to /usr/lib64 symlink.
251
252 30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
253 polkit-0.106-r5.ebuild:
254 Adding dependency on SELinux policykit module if USE=selinux is set
255
256 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
257 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
258 'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
259
260 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
261 -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
262 old
263
264*polkit-0.106-r5 (27 Jun 2012)
265
266 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
267 Revert entire unix-group:wheel experiment back to unix-user:0 because
268 PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
269 Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
270 by Doug Goldstein.
4 271
5*polkit-0.106-r4 (27 Jun 2012) 272*polkit-0.106-r4 (27 Jun 2012)
6 273
7 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild: 274 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
8 Stop installing polkit-backend-1.pc because upstream changed 275 Stop installing polkit-backend-1.pc because upstream changed
333 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org> 600 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
334 +files/polkit-0.92-zsh-completions.patch, 601 +files/polkit-0.92-zsh-completions.patch,
335 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild, 602 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
336 +metadata.xml: 603 +metadata.xml:
337 Initial ebuild for GNOME 2.28. 604 Initial ebuild for GNOME 2.28.
338

Legend:
Removed from v.1.89  
changed lines
  Added in v.1.160

  ViewVC Help
Powered by ViewVC 1.1.20