/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Diff of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.89 Revision 1.172
1# ChangeLog for sys-auth/polkit 1# ChangeLog for sys-auth/polkit
2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.89 2012/06/27 10:06:14 ssuominen Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.172 2014/05/11 08:26:27 ago Exp $
4
5 11 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
6 Stable for ppc64, wrt bug #508862
7
8 10 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
9 Stable for ppc, wrt bug #508862
10
11 06 Apr 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r2.ebuild:
12 Needs to be rebuilt with systemd subslot bumps
13
14 15 Mar 2014; Samuli Suominen <ssuominen@gentoo.org> metadata.xml:
15 Add proper metadata for freedesktop-bugs@g.o
16
17*polkit-0.112-r2 (15 Mar 2014)
18
19 15 Mar 2014; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.112-r2.ebuild:
20 USE="jit" to determine which pax-mark, if any, should be applied wrt #485910
21
22 11 Mar 2014; Pacho Ramos <pacho@gentoo.org> metadata.xml:
23 Cleanup due #239126
24
25 25 Feb 2014; Markus Meier <maekke@gentoo.org> polkit-0.112-r1.ebuild:
26 arm stable, bug #500758
27
28 23 Feb 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r1.ebuild:
29 x86 stable, bug #500758
30
31 23 Feb 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r1.ebuild:
32 amd64 stable, bug #500758
33
34 28 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
35 Fix ia64 where the order of the configure options was overridden by mips,
36 thanks Arfrever
37
38 27 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
39 Because sometimes portage is stupid
40
41 24 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
42 Fix dependence on spidermonkey for mips, bug #495168
43
44 23 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
45 Stable for sparc, wrt bug #484486
46
47 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
48 Stable for alpha, wrt bug #484486
49
50 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
51 Stable for ia64, wrt bug #484486
52
53 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
54 Stable for ppc64, wrt bug #484486
55
56 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
57 Stable for ppc, wrt bug #484486
58
59 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
60 Stable for arm, wrt bug #484486
61
62 21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
63 Stable for x86, wrt bug #484486
64
65 21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
66 Stable for amd64, wrt bug #484486
67
68 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.110-r1.ebuild,
69 -files/polkit-0.110-CVE-2013-4288.patch:
70 old
71
72*polkit-0.112-r1 (19 Sep 2013)
73
74 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.112-r1.ebuild,
75 polkit-0.112.ebuild:
76 -r0 is for stabilization w/ mozjs185 and -r1 is for ~arch with mozjs 17.0
77
78 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> -polkit-0.111-r1.ebuild:
79 Remove vulnerable version
80
81*polkit-0.110-r1 (19 Sep 2013)
82
83 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org>
84 +files/polkit-0.110-CVE-2013-4288.patch, +polkit-0.110-r1.ebuild:
85 Bump for CVE-2013-4288
86
87*polkit-0.112 (19 Sep 2013)
88
89 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> +polkit-0.112.ebuild:
90 Bump for CVE-2013-4288
91
92 10 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
93 polkit-0.111-r1.ebuild:
94 Stop forcing USE="consolekit systemd" for sys-auth/pambase in PDEPEND because
95 CONFIG_AUDITSYSCALL=y is not possible on every arch and the dependency was
96 always more about convinience than being strict requirement.
97
98 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> -polkit-0.111.ebuild:
99 dropped polkit-111 in favour of -r1 now that spidermonkey-17 is unmasked, as
100 per ssuominen's approval
101
102 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> polkit-0.110.ebuild,
103 polkit-0.111-r1.ebuild:
104 Adjusted deps for dev-lang/spidermonkey to ensure SLOT=0
105
106*polkit-0.111-r1 (08 Aug 2013)
107
108 08 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111-r1.ebuild:
109 Force use of dev-lang/spidermonkey:17 because automagic dependencies are bad.
110
111*polkit-0.111 (15 May 2013)
112
113 15 May 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111.ebuild:
114 Version bump by "okias" from Freenode
115
116 19 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107-r1.ebuild,
117 -files/polkit-0.107-fallback.patch:
118 old
119
120 19 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
121 Stable for sh, wrt bug #452688
122
123 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
124 files/polkit-0.110-W_define.patch:
125 Include link to upstream bug.
126
127 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
128 +files/polkit-0.110-W_define.patch:
129 Fix missing #include <sys/wait.h> for #define's of WIFEXITED, WEXITSTATUS,
130 WIFSIGNALED and WTERMSIG (to fix building on arch "sh")
131
132 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
133 Stable for sparc, wrt bug #452688
134
135 03 Mar 2013; Mike Frysinger <vapier@gentoo.org> polkit-0.110.ebuild:
136 Add s390 keywords #457078 by Michael Palimaka.
137
138 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
139 Stable for alpha, wrt bug #452688
140
141 10 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
142 Stable for ppc64, wrt bug #452688
143
144 09 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
145 Stable for ia64, wrt bug #452688
146
147 31 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
148 Stable for ppc, wrt bug #452688
149
150 29 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
151 Force USE="debug" to be disabled in dev-lang/spidermonkey to avoid asseration
152 errors as noted by _AxS_.
153
154 26 Jan 2013; Markus Meier <maekke@gentoo.org> polkit-0.110.ebuild:
155 arm stable, bug #452688
156
157 20 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
158 x86 stable wrt #452688
159
160 19 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
161 amd64 stable wrt #452688
162
163 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.104-r1.ebuild,
164 -polkit-0.109-r1.ebuild, -files/polkit-0.109-XAUTHORITY-fallback.patch:
165 old
166
167*polkit-0.110 (11 Jan 2013)
168
169 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.110.ebuild:
170 Version bump.
171
172 06 Jan 2013; Raúl Porcel <armin76@gentoo.org> polkit-0.107-r1.ebuild,
173 polkit-0.109-r1.ebuild:
174 Add ~sh wrt #436668
175
176 01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.109-r1.ebuild:
177 Add ~ia64, wrt bug #436668
178
179 30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
180 Stable for sparc, wrt bug #436666
181
182 29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
183 Stable for alpha, wrt bug #436666
184
185 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.108.ebuild,
186 -polkit-0.109.ebuild:
187 old
188
189*polkit-0.109-r1 (21 Dec 2012)
190
191 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109-r1.ebuild,
192 +files/polkit-0.109-XAUTHORITY-fallback.patch:
193 Backport XAUTHORITY fallback support from upstream git.
194
195 19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.108.ebuild:
196 Add ~ia64, wrt bug #436668
197
198*polkit-0.109 (19 Dec 2012)
199
200 19 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109.ebuild:
201 Version bump. Fix PaX marking logic wrt #444446 by Maxim Kammerer
202
203 18 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
204 Stable for ia64, wrt bug #436666
205
206 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
207 stable arm, bug #436666
208
209 22 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107.ebuild:
210 old
211
212 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
213 stable ppc64, bug #436666
214
215 22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
216 Stable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt
217 bug #436666
218
219 21 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
220 stable ppc, bug #436666, thanks peratu
221
222 19 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.108.ebuild:
223 Link against -lgmodule-2.0 to prevent underlinking (backported from upstream,
224 but using sed to avoid eautoreconf) wrt #443798
225
226*polkit-0.108 (18 Nov 2012)
227
228 18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
229 Version bump.
230
231 28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
232 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
233 Drop ~x86-fbsd due to bug #439968.
234
235 15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
236 polkit-0.107-r1.ebuild:
237 Drop HPPA keywording (bug #438368).
238
239 15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
240 Set QA_MULTILIB_PATHS for bug #424423.
241
242 09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
243 Marked ~hppa (bug #436668).
244
245 08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
246 Use pax-mark in src_compile() instead of src_install() for src_test() wrt
247 #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
248 and emphatize it's an Portage issue instead of polkit issue in src_install()
249 message.
250
251 07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
252 Stable for amd64, wrt bug #436666
253
254*polkit-0.107-r1 (20 Sep 2012)
255
256 20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
257 +files/polkit-0.107-fallback.patch:
258 Introduce upstream patch for falling back to uid 0 for authentication if list
259 of admin identities is empty.
260
261 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
262 -polkit-0.106-r7.ebuild:
263 old
264
265*polkit-0.107 (13 Jul 2012)
266
267 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
268 Version bump.
269
270 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
271 -polkit-0.106-r6.ebuild:
272 old
273
274 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
275 Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
276 #391865 by Maksim Melnikau
277
278*polkit-0.106-r7 (02 Jul 2012)
279
280 02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
281 RESTRICT="multilib-strict" since it's not compatible with the whole
282 /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
283 polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
284
285*polkit-0.106-r6 (01 Jul 2012)
286
287 01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
288 Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
289 /usr/lib to /usr/lib64 symlink.
290
291 30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
292 polkit-0.106-r5.ebuild:
293 Adding dependency on SELinux policykit module if USE=selinux is set
294
295 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
296 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
297 'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
298
299 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
300 -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
301 old
302
303*polkit-0.106-r5 (27 Jun 2012)
304
305 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
306 Revert entire unix-group:wheel experiment back to unix-user:0 because
307 PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
308 Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
309 by Doug Goldstein.
4 310
5*polkit-0.106-r4 (27 Jun 2012) 311*polkit-0.106-r4 (27 Jun 2012)
6 312
7 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild: 313 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
8 Stop installing polkit-backend-1.pc because upstream changed 314 Stop installing polkit-backend-1.pc because upstream changed
333 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org> 639 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
334 +files/polkit-0.92-zsh-completions.patch, 640 +files/polkit-0.92-zsh-completions.patch,
335 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild, 641 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
336 +metadata.xml: 642 +metadata.xml:
337 Initial ebuild for GNOME 2.28. 643 Initial ebuild for GNOME 2.28.
338

Legend:
Removed from v.1.89  
changed lines
  Added in v.1.172

  ViewVC Help
Powered by ViewVC 1.1.20