/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Diff of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.89 Revision 1.199
1# ChangeLog for sys-auth/polkit 1# ChangeLog for sys-auth/polkit
2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.89 2012/06/27 10:06:14 ssuominen Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.199 2015/07/14 16:17:55 klausman Exp $
4
5 14 Jul 2015; Tobias Klausmann <klausman@gentoo.org> polkit-0.113.ebuild:
6 Stable on alpha, bug 551316
7
8 07 Jul 2015; Jeroen Roovers <jer@gentoo.org> polkit-0.112-r3.ebuild:
9 Stable for HPPA PPC64 (bug #551316).
10
11 05 Jul 2015; Mikle Kolyada <zlogene@gentoo.org> polkit-0.112-r3.ebuild:
12 arm stable wrt bug #551316
13
14 05 Jul 2015; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r3.ebuild:
15 Stable for x86, wrt bug #551316
16
17 05 Jul 2015; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r3.ebuild:
18 Stable for amd64, wrt bug #551316
19
20*polkit-0.113 (04 Jul 2015)
21
22 04 Jul 2015; Pacho Ramos <pacho@gentoo.org> +polkit-0.113.ebuild,
23 -files/polkit-0.110-W_define.patch, -polkit-0.110.ebuild,
24 -polkit-0.112-r1.ebuild, -polkit-0.112.ebuild:
25 Version bump, use spidermonkey-185 because of problems with memory handling
26 when using mozjs-17 (#553334)
27
28*polkit-0.112-r3 (06 Jun 2015)
29
30 06 Jun 2015; Jason Zaman <perfinion@gentoo.org> +files/polkit-0.112-0001-backe
31 nd-Handle-invalid-object-paths-in-RegisterAuthe.patch,
32 +polkit-0.112-r3.ebuild:
33 fix bug 551316 CVE-2015-3218: crash authentication_agent_new with invalid
34 object path in RegisterAuthenticationAgent
35
36 03 Mar 2015; Yixun Lan <dlan@gentoo.org> polkit-0.110.ebuild:
37 add arm64 support, tested on A53 board
38
39 11 Feb 2015; Patrick Lauer <patrick@gentoo.org> polkit-0.112-r2.ebuild:
40 Whitespace
41
42 14 Jan 2015; Manuel Rüger <mrueg@gentoo.org> polkit-0.112-r2.ebuild:
43 Add dep on kde-plasma/polkit-kde-agent as suggested by Elias Probst. Fixes bug
44 #536550.
45
46 11 Nov 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
47 Stable for ia64, wrt bug #525252
48
49 06 Nov 2014; Samuli Suominen <ssuominen@gentoo.org> polkit-0.112-r2.ebuild:
50 Don't run pax-mark when variable "m" is empty wrt #485910 by "Nikoli"
51
52 04 Nov 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
53 Stable for sparc, wrt bug #525252
54
55 03 Nov 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
56 Stable for x86, wrt bug #525252
57
58 02 Nov 2014; Sven Vermeulen <swift@gentoo.org> polkit-0.112-r2.ebuild:
59 Remove sec-policy/selinux-* dependency from DEPEND but keep in RDEPEND (bug
60 #527698)
61
62 02 Nov 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
63 Stable for alpha, wrt bug #525252
64
65 01 Nov 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
66 Stable for ppc, wrt bug #525252
67
68 31 Oct 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
69 Stable for ppc64, wrt bug #525252
70
71 30 Oct 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
72 Stable for amd64, wrt bug #525252
73
74 23 Oct 2014; Markus Meier <maekke@gentoo.org> polkit-0.112-r2.ebuild:
75 arm stable, bug #525252
76
77 16 Oct 2014; Jeroen Roovers <jer@gentoo.org> polkit-0.112-r2.ebuild:
78 Stable for HPPA (bug #525252).
79
80 14 Aug 2014; Samuli Suominen <ssuominen@gentoo.org> polkit-0.112-r1.ebuild,
81 polkit-0.112-r2.ebuild:
82 Fix the arch logic for HPPA (to match how IA64 and MIPS are handled in the
83 ebuild)
84
85 14 Aug 2014; Jeroen Roovers <jer@gentoo.org> polkit-0.112-r1.ebuild:
86 Stable for HPPA (bug #519870).
87
88 13 Aug 2014; Jeroen Roovers <jer@gentoo.org> polkit-0.112-r2.ebuild:
89 Marked ~hppa (bug #517804).
90
91 17 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
92 Stable for alpha, wrt bug #508862
93
94 14 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
95 Stable for sparc, wrt bug #508862
96
97 13 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
98 Stable for ia64, wrt bug #508862
99
100 11 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
101 Stable for ppc64, wrt bug #508862
102
103 10 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
104 Stable for ppc, wrt bug #508862
105
106 06 Apr 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r2.ebuild:
107 Needs to be rebuilt with systemd subslot bumps
108
109 15 Mar 2014; Samuli Suominen <ssuominen@gentoo.org> metadata.xml:
110 Add proper metadata for freedesktop-bugs@g.o
111
112*polkit-0.112-r2 (15 Mar 2014)
113
114 15 Mar 2014; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.112-r2.ebuild:
115 USE="jit" to determine which pax-mark, if any, should be applied wrt #485910
116
117 11 Mar 2014; Pacho Ramos <pacho@gentoo.org> metadata.xml:
118 Cleanup due #239126
119
120 25 Feb 2014; Markus Meier <maekke@gentoo.org> polkit-0.112-r1.ebuild:
121 arm stable, bug #500758
122
123 23 Feb 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r1.ebuild:
124 x86 stable, bug #500758
125
126 23 Feb 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r1.ebuild:
127 amd64 stable, bug #500758
128
129 28 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
130 Fix ia64 where the order of the configure options was overridden by mips,
131 thanks Arfrever
132
133 27 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
134 Because sometimes portage is stupid
135
136 24 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
137 Fix dependence on spidermonkey for mips, bug #495168
138
139 23 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
140 Stable for sparc, wrt bug #484486
141
142 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
143 Stable for alpha, wrt bug #484486
144
145 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
146 Stable for ia64, wrt bug #484486
147
148 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
149 Stable for ppc64, wrt bug #484486
150
151 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
152 Stable for ppc, wrt bug #484486
153
154 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
155 Stable for arm, wrt bug #484486
156
157 21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
158 Stable for x86, wrt bug #484486
159
160 21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
161 Stable for amd64, wrt bug #484486
162
163 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.110-r1.ebuild,
164 -files/polkit-0.110-CVE-2013-4288.patch:
165 old
166
167*polkit-0.112-r1 (19 Sep 2013)
168
169 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.112-r1.ebuild,
170 polkit-0.112.ebuild:
171 -r0 is for stabilization w/ mozjs185 and -r1 is for ~arch with mozjs 17.0
172
173 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> -polkit-0.111-r1.ebuild:
174 Remove vulnerable version
175
176*polkit-0.110-r1 (19 Sep 2013)
177
178 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org>
179 +files/polkit-0.110-CVE-2013-4288.patch, +polkit-0.110-r1.ebuild:
180 Bump for CVE-2013-4288
181
182*polkit-0.112 (19 Sep 2013)
183
184 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> +polkit-0.112.ebuild:
185 Bump for CVE-2013-4288
186
187 10 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
188 polkit-0.111-r1.ebuild:
189 Stop forcing USE="consolekit systemd" for sys-auth/pambase in PDEPEND because
190 CONFIG_AUDITSYSCALL=y is not possible on every arch and the dependency was
191 always more about convinience than being strict requirement.
192
193 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> -polkit-0.111.ebuild:
194 dropped polkit-111 in favour of -r1 now that spidermonkey-17 is unmasked, as
195 per ssuominen's approval
196
197 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> polkit-0.110.ebuild,
198 polkit-0.111-r1.ebuild:
199 Adjusted deps for dev-lang/spidermonkey to ensure SLOT=0
200
201*polkit-0.111-r1 (08 Aug 2013)
202
203 08 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111-r1.ebuild:
204 Force use of dev-lang/spidermonkey:17 because automagic dependencies are bad.
205
206*polkit-0.111 (15 May 2013)
207
208 15 May 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111.ebuild:
209 Version bump by "okias" from Freenode
210
211 19 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107-r1.ebuild,
212 -files/polkit-0.107-fallback.patch:
213 old
214
215 19 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
216 Stable for sh, wrt bug #452688
217
218 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
219 files/polkit-0.110-W_define.patch:
220 Include link to upstream bug.
221
222 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
223 +files/polkit-0.110-W_define.patch:
224 Fix missing #include <sys/wait.h> for #define's of WIFEXITED, WEXITSTATUS,
225 WIFSIGNALED and WTERMSIG (to fix building on arch "sh")
226
227 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
228 Stable for sparc, wrt bug #452688
229
230 03 Mar 2013; Mike Frysinger <vapier@gentoo.org> polkit-0.110.ebuild:
231 Add s390 keywords #457078 by Michael Palimaka.
232
233 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
234 Stable for alpha, wrt bug #452688
235
236 10 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
237 Stable for ppc64, wrt bug #452688
238
239 09 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
240 Stable for ia64, wrt bug #452688
241
242 31 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
243 Stable for ppc, wrt bug #452688
244
245 29 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
246 Force USE="debug" to be disabled in dev-lang/spidermonkey to avoid asseration
247 errors as noted by _AxS_.
248
249 26 Jan 2013; Markus Meier <maekke@gentoo.org> polkit-0.110.ebuild:
250 arm stable, bug #452688
251
252 20 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
253 x86 stable wrt #452688
254
255 19 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
256 amd64 stable wrt #452688
257
258 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.104-r1.ebuild,
259 -polkit-0.109-r1.ebuild, -files/polkit-0.109-XAUTHORITY-fallback.patch:
260 old
261
262*polkit-0.110 (11 Jan 2013)
263
264 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.110.ebuild:
265 Version bump.
266
267 06 Jan 2013; Raúl Porcel <armin76@gentoo.org> polkit-0.107-r1.ebuild,
268 polkit-0.109-r1.ebuild:
269 Add ~sh wrt #436668
270
271 01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.109-r1.ebuild:
272 Add ~ia64, wrt bug #436668
273
274 30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
275 Stable for sparc, wrt bug #436666
276
277 29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
278 Stable for alpha, wrt bug #436666
279
280 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.108.ebuild,
281 -polkit-0.109.ebuild:
282 old
283
284*polkit-0.109-r1 (21 Dec 2012)
285
286 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109-r1.ebuild,
287 +files/polkit-0.109-XAUTHORITY-fallback.patch:
288 Backport XAUTHORITY fallback support from upstream git.
289
290 19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.108.ebuild:
291 Add ~ia64, wrt bug #436668
292
293*polkit-0.109 (19 Dec 2012)
294
295 19 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109.ebuild:
296 Version bump. Fix PaX marking logic wrt #444446 by Maxim Kammerer
297
298 18 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
299 Stable for ia64, wrt bug #436666
300
301 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
302 stable arm, bug #436666
303
304 22 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107.ebuild:
305 old
306
307 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
308 stable ppc64, bug #436666
309
310 22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
311 Stable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt
312 bug #436666
313
314 21 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
315 stable ppc, bug #436666, thanks peratu
316
317 19 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.108.ebuild:
318 Link against -lgmodule-2.0 to prevent underlinking (backported from upstream,
319 but using sed to avoid eautoreconf) wrt #443798
320
321*polkit-0.108 (18 Nov 2012)
322
323 18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
324 Version bump.
325
326 28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
327 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
328 Drop ~x86-fbsd due to bug #439968.
329
330 15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
331 polkit-0.107-r1.ebuild:
332 Drop HPPA keywording (bug #438368).
333
334 15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
335 Set QA_MULTILIB_PATHS for bug #424423.
336
337 09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
338 Marked ~hppa (bug #436668).
339
340 08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
341 Use pax-mark in src_compile() instead of src_install() for src_test() wrt
342 #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
343 and emphatize it's an Portage issue instead of polkit issue in src_install()
344 message.
345
346 07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
347 Stable for amd64, wrt bug #436666
348
349*polkit-0.107-r1 (20 Sep 2012)
350
351 20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
352 +files/polkit-0.107-fallback.patch:
353 Introduce upstream patch for falling back to uid 0 for authentication if list
354 of admin identities is empty.
355
356 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
357 -polkit-0.106-r7.ebuild:
358 old
359
360*polkit-0.107 (13 Jul 2012)
361
362 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
363 Version bump.
364
365 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
366 -polkit-0.106-r6.ebuild:
367 old
368
369 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
370 Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
371 #391865 by Maksim Melnikau
372
373*polkit-0.106-r7 (02 Jul 2012)
374
375 02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
376 RESTRICT="multilib-strict" since it's not compatible with the whole
377 /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
378 polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
379
380*polkit-0.106-r6 (01 Jul 2012)
381
382 01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
383 Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
384 /usr/lib to /usr/lib64 symlink.
385
386 30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
387 polkit-0.106-r5.ebuild:
388 Adding dependency on SELinux policykit module if USE=selinux is set
389
390 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
391 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
392 'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
393
394 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
395 -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
396 old
397
398*polkit-0.106-r5 (27 Jun 2012)
399
400 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
401 Revert entire unix-group:wheel experiment back to unix-user:0 because
402 PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
403 Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
404 by Doug Goldstein.
4 405
5*polkit-0.106-r4 (27 Jun 2012) 406*polkit-0.106-r4 (27 Jun 2012)
6 407
7 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild: 408 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
8 Stop installing polkit-backend-1.pc because upstream changed 409 Stop installing polkit-backend-1.pc because upstream changed
333 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org> 734 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
334 +files/polkit-0.92-zsh-completions.patch, 735 +files/polkit-0.92-zsh-completions.patch,
335 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild, 736 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
336 +metadata.xml: 737 +metadata.xml:
337 Initial ebuild for GNOME 2.28. 738 Initial ebuild for GNOME 2.28.
338

Legend:
Removed from v.1.89  
changed lines
  Added in v.1.199

  ViewVC Help
Powered by ViewVC 1.1.20