/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Diff of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.89 Revision 1.201
1# ChangeLog for sys-auth/polkit 1# ChangeLog for sys-auth/polkit
2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.89 2012/06/27 10:06:14 ssuominen Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.201 2015/07/23 09:00:58 ago Exp $
4
5 23 Jul 2015; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r3.ebuild:
6 Stable for ppc, wrt bug #551316
7
8 17 Jul 2015; Mikle Kolyada <zlogene@gentoo.org> polkit-0.112-r3.ebuild:
9 ia64 stable wrt bug #551316
10
11 14 Jul 2015; Tobias Klausmann <klausman@gentoo.org> polkit-0.113.ebuild:
12 Stable on alpha, bug 551316
13
14 07 Jul 2015; Jeroen Roovers <jer@gentoo.org> polkit-0.112-r3.ebuild:
15 Stable for HPPA PPC64 (bug #551316).
16
17 05 Jul 2015; Mikle Kolyada <zlogene@gentoo.org> polkit-0.112-r3.ebuild:
18 arm stable wrt bug #551316
19
20 05 Jul 2015; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r3.ebuild:
21 Stable for x86, wrt bug #551316
22
23 05 Jul 2015; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r3.ebuild:
24 Stable for amd64, wrt bug #551316
25
26*polkit-0.113 (04 Jul 2015)
27
28 04 Jul 2015; Pacho Ramos <pacho@gentoo.org> +polkit-0.113.ebuild,
29 -files/polkit-0.110-W_define.patch, -polkit-0.110.ebuild,
30 -polkit-0.112-r1.ebuild, -polkit-0.112.ebuild:
31 Version bump, use spidermonkey-185 because of problems with memory handling
32 when using mozjs-17 (#553334)
33
34*polkit-0.112-r3 (06 Jun 2015)
35
36 06 Jun 2015; Jason Zaman <perfinion@gentoo.org> +files/polkit-0.112-0001-backe
37 nd-Handle-invalid-object-paths-in-RegisterAuthe.patch,
38 +polkit-0.112-r3.ebuild:
39 fix bug 551316 CVE-2015-3218: crash authentication_agent_new with invalid
40 object path in RegisterAuthenticationAgent
41
42 03 Mar 2015; Yixun Lan <dlan@gentoo.org> polkit-0.110.ebuild:
43 add arm64 support, tested on A53 board
44
45 11 Feb 2015; Patrick Lauer <patrick@gentoo.org> polkit-0.112-r2.ebuild:
46 Whitespace
47
48 14 Jan 2015; Manuel Rüger <mrueg@gentoo.org> polkit-0.112-r2.ebuild:
49 Add dep on kde-plasma/polkit-kde-agent as suggested by Elias Probst. Fixes bug
50 #536550.
51
52 11 Nov 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
53 Stable for ia64, wrt bug #525252
54
55 06 Nov 2014; Samuli Suominen <ssuominen@gentoo.org> polkit-0.112-r2.ebuild:
56 Don't run pax-mark when variable "m" is empty wrt #485910 by "Nikoli"
57
58 04 Nov 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
59 Stable for sparc, wrt bug #525252
60
61 03 Nov 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
62 Stable for x86, wrt bug #525252
63
64 02 Nov 2014; Sven Vermeulen <swift@gentoo.org> polkit-0.112-r2.ebuild:
65 Remove sec-policy/selinux-* dependency from DEPEND but keep in RDEPEND (bug
66 #527698)
67
68 02 Nov 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
69 Stable for alpha, wrt bug #525252
70
71 01 Nov 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
72 Stable for ppc, wrt bug #525252
73
74 31 Oct 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
75 Stable for ppc64, wrt bug #525252
76
77 30 Oct 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
78 Stable for amd64, wrt bug #525252
79
80 23 Oct 2014; Markus Meier <maekke@gentoo.org> polkit-0.112-r2.ebuild:
81 arm stable, bug #525252
82
83 16 Oct 2014; Jeroen Roovers <jer@gentoo.org> polkit-0.112-r2.ebuild:
84 Stable for HPPA (bug #525252).
85
86 14 Aug 2014; Samuli Suominen <ssuominen@gentoo.org> polkit-0.112-r1.ebuild,
87 polkit-0.112-r2.ebuild:
88 Fix the arch logic for HPPA (to match how IA64 and MIPS are handled in the
89 ebuild)
90
91 14 Aug 2014; Jeroen Roovers <jer@gentoo.org> polkit-0.112-r1.ebuild:
92 Stable for HPPA (bug #519870).
93
94 13 Aug 2014; Jeroen Roovers <jer@gentoo.org> polkit-0.112-r2.ebuild:
95 Marked ~hppa (bug #517804).
96
97 17 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
98 Stable for alpha, wrt bug #508862
99
100 14 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
101 Stable for sparc, wrt bug #508862
102
103 13 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
104 Stable for ia64, wrt bug #508862
105
106 11 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
107 Stable for ppc64, wrt bug #508862
108
109 10 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
110 Stable for ppc, wrt bug #508862
111
112 06 Apr 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r2.ebuild:
113 Needs to be rebuilt with systemd subslot bumps
114
115 15 Mar 2014; Samuli Suominen <ssuominen@gentoo.org> metadata.xml:
116 Add proper metadata for freedesktop-bugs@g.o
117
118*polkit-0.112-r2 (15 Mar 2014)
119
120 15 Mar 2014; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.112-r2.ebuild:
121 USE="jit" to determine which pax-mark, if any, should be applied wrt #485910
122
123 11 Mar 2014; Pacho Ramos <pacho@gentoo.org> metadata.xml:
124 Cleanup due #239126
125
126 25 Feb 2014; Markus Meier <maekke@gentoo.org> polkit-0.112-r1.ebuild:
127 arm stable, bug #500758
128
129 23 Feb 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r1.ebuild:
130 x86 stable, bug #500758
131
132 23 Feb 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r1.ebuild:
133 amd64 stable, bug #500758
134
135 28 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
136 Fix ia64 where the order of the configure options was overridden by mips,
137 thanks Arfrever
138
139 27 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
140 Because sometimes portage is stupid
141
142 24 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
143 Fix dependence on spidermonkey for mips, bug #495168
144
145 23 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
146 Stable for sparc, wrt bug #484486
147
148 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
149 Stable for alpha, wrt bug #484486
150
151 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
152 Stable for ia64, wrt bug #484486
153
154 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
155 Stable for ppc64, wrt bug #484486
156
157 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
158 Stable for ppc, wrt bug #484486
159
160 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
161 Stable for arm, wrt bug #484486
162
163 21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
164 Stable for x86, wrt bug #484486
165
166 21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
167 Stable for amd64, wrt bug #484486
168
169 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.110-r1.ebuild,
170 -files/polkit-0.110-CVE-2013-4288.patch:
171 old
172
173*polkit-0.112-r1 (19 Sep 2013)
174
175 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.112-r1.ebuild,
176 polkit-0.112.ebuild:
177 -r0 is for stabilization w/ mozjs185 and -r1 is for ~arch with mozjs 17.0
178
179 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> -polkit-0.111-r1.ebuild:
180 Remove vulnerable version
181
182*polkit-0.110-r1 (19 Sep 2013)
183
184 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org>
185 +files/polkit-0.110-CVE-2013-4288.patch, +polkit-0.110-r1.ebuild:
186 Bump for CVE-2013-4288
187
188*polkit-0.112 (19 Sep 2013)
189
190 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> +polkit-0.112.ebuild:
191 Bump for CVE-2013-4288
192
193 10 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
194 polkit-0.111-r1.ebuild:
195 Stop forcing USE="consolekit systemd" for sys-auth/pambase in PDEPEND because
196 CONFIG_AUDITSYSCALL=y is not possible on every arch and the dependency was
197 always more about convinience than being strict requirement.
198
199 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> -polkit-0.111.ebuild:
200 dropped polkit-111 in favour of -r1 now that spidermonkey-17 is unmasked, as
201 per ssuominen's approval
202
203 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> polkit-0.110.ebuild,
204 polkit-0.111-r1.ebuild:
205 Adjusted deps for dev-lang/spidermonkey to ensure SLOT=0
206
207*polkit-0.111-r1 (08 Aug 2013)
208
209 08 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111-r1.ebuild:
210 Force use of dev-lang/spidermonkey:17 because automagic dependencies are bad.
211
212*polkit-0.111 (15 May 2013)
213
214 15 May 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111.ebuild:
215 Version bump by "okias" from Freenode
216
217 19 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107-r1.ebuild,
218 -files/polkit-0.107-fallback.patch:
219 old
220
221 19 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
222 Stable for sh, wrt bug #452688
223
224 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
225 files/polkit-0.110-W_define.patch:
226 Include link to upstream bug.
227
228 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
229 +files/polkit-0.110-W_define.patch:
230 Fix missing #include <sys/wait.h> for #define's of WIFEXITED, WEXITSTATUS,
231 WIFSIGNALED and WTERMSIG (to fix building on arch "sh")
232
233 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
234 Stable for sparc, wrt bug #452688
235
236 03 Mar 2013; Mike Frysinger <vapier@gentoo.org> polkit-0.110.ebuild:
237 Add s390 keywords #457078 by Michael Palimaka.
238
239 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
240 Stable for alpha, wrt bug #452688
241
242 10 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
243 Stable for ppc64, wrt bug #452688
244
245 09 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
246 Stable for ia64, wrt bug #452688
247
248 31 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
249 Stable for ppc, wrt bug #452688
250
251 29 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
252 Force USE="debug" to be disabled in dev-lang/spidermonkey to avoid asseration
253 errors as noted by _AxS_.
254
255 26 Jan 2013; Markus Meier <maekke@gentoo.org> polkit-0.110.ebuild:
256 arm stable, bug #452688
257
258 20 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
259 x86 stable wrt #452688
260
261 19 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
262 amd64 stable wrt #452688
263
264 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.104-r1.ebuild,
265 -polkit-0.109-r1.ebuild, -files/polkit-0.109-XAUTHORITY-fallback.patch:
266 old
267
268*polkit-0.110 (11 Jan 2013)
269
270 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.110.ebuild:
271 Version bump.
272
273 06 Jan 2013; Raúl Porcel <armin76@gentoo.org> polkit-0.107-r1.ebuild,
274 polkit-0.109-r1.ebuild:
275 Add ~sh wrt #436668
276
277 01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.109-r1.ebuild:
278 Add ~ia64, wrt bug #436668
279
280 30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
281 Stable for sparc, wrt bug #436666
282
283 29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
284 Stable for alpha, wrt bug #436666
285
286 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.108.ebuild,
287 -polkit-0.109.ebuild:
288 old
289
290*polkit-0.109-r1 (21 Dec 2012)
291
292 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109-r1.ebuild,
293 +files/polkit-0.109-XAUTHORITY-fallback.patch:
294 Backport XAUTHORITY fallback support from upstream git.
295
296 19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.108.ebuild:
297 Add ~ia64, wrt bug #436668
298
299*polkit-0.109 (19 Dec 2012)
300
301 19 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109.ebuild:
302 Version bump. Fix PaX marking logic wrt #444446 by Maxim Kammerer
303
304 18 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
305 Stable for ia64, wrt bug #436666
306
307 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
308 stable arm, bug #436666
309
310 22 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107.ebuild:
311 old
312
313 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
314 stable ppc64, bug #436666
315
316 22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
317 Stable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt
318 bug #436666
319
320 21 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
321 stable ppc, bug #436666, thanks peratu
322
323 19 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.108.ebuild:
324 Link against -lgmodule-2.0 to prevent underlinking (backported from upstream,
325 but using sed to avoid eautoreconf) wrt #443798
326
327*polkit-0.108 (18 Nov 2012)
328
329 18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
330 Version bump.
331
332 28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
333 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
334 Drop ~x86-fbsd due to bug #439968.
335
336 15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
337 polkit-0.107-r1.ebuild:
338 Drop HPPA keywording (bug #438368).
339
340 15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
341 Set QA_MULTILIB_PATHS for bug #424423.
342
343 09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
344 Marked ~hppa (bug #436668).
345
346 08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
347 Use pax-mark in src_compile() instead of src_install() for src_test() wrt
348 #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
349 and emphatize it's an Portage issue instead of polkit issue in src_install()
350 message.
351
352 07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
353 Stable for amd64, wrt bug #436666
354
355*polkit-0.107-r1 (20 Sep 2012)
356
357 20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
358 +files/polkit-0.107-fallback.patch:
359 Introduce upstream patch for falling back to uid 0 for authentication if list
360 of admin identities is empty.
361
362 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
363 -polkit-0.106-r7.ebuild:
364 old
365
366*polkit-0.107 (13 Jul 2012)
367
368 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
369 Version bump.
370
371 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
372 -polkit-0.106-r6.ebuild:
373 old
374
375 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
376 Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
377 #391865 by Maksim Melnikau
378
379*polkit-0.106-r7 (02 Jul 2012)
380
381 02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
382 RESTRICT="multilib-strict" since it's not compatible with the whole
383 /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
384 polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
385
386*polkit-0.106-r6 (01 Jul 2012)
387
388 01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
389 Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
390 /usr/lib to /usr/lib64 symlink.
391
392 30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
393 polkit-0.106-r5.ebuild:
394 Adding dependency on SELinux policykit module if USE=selinux is set
395
396 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
397 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
398 'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
399
400 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
401 -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
402 old
403
404*polkit-0.106-r5 (27 Jun 2012)
405
406 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
407 Revert entire unix-group:wheel experiment back to unix-user:0 because
408 PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
409 Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
410 by Doug Goldstein.
4 411
5*polkit-0.106-r4 (27 Jun 2012) 412*polkit-0.106-r4 (27 Jun 2012)
6 413
7 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild: 414 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
8 Stop installing polkit-backend-1.pc because upstream changed 415 Stop installing polkit-backend-1.pc because upstream changed
333 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org> 740 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
334 +files/polkit-0.92-zsh-completions.patch, 741 +files/polkit-0.92-zsh-completions.patch,
335 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild, 742 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
336 +metadata.xml: 743 +metadata.xml:
337 Initial ebuild for GNOME 2.28. 744 Initial ebuild for GNOME 2.28.
338

Legend:
Removed from v.1.89  
changed lines
  Added in v.1.201

  ViewVC Help
Powered by ViewVC 1.1.20