/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Contents of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.149 - (show annotations) (download)
Thu Sep 19 16:08:57 2013 UTC (4 years, 10 months ago) by cardoe
Branch: MAIN
Changes since 1.148: +4 -1 lines
Remove vulnerable version

(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)

1 # ChangeLog for sys-auth/polkit
2 # Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.148 2013/09/19 16:07:41 cardoe Exp $
4
5 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> -polkit-0.111-r1.ebuild:
6 Remove vulnerable version
7
8 *polkit-0.110-r1 (19 Sep 2013)
9
10 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org>
11 +files/polkit-0.110-CVE-2013-4288.patch, +polkit-0.110-r1.ebuild:
12 Bump for CVE-2013-4288
13
14 *polkit-0.112 (19 Sep 2013)
15
16 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> +polkit-0.112.ebuild:
17 Bump for CVE-2013-4288
18
19 10 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
20 polkit-0.111-r1.ebuild:
21 Stop forcing USE="consolekit systemd" for sys-auth/pambase in PDEPEND because
22 CONFIG_AUDITSYSCALL=y is not possible on every arch and the dependency was
23 always more about convinience than being strict requirement.
24
25 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> -polkit-0.111.ebuild:
26 dropped polkit-111 in favour of -r1 now that spidermonkey-17 is unmasked, as
27 per ssuominen's approval
28
29 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> polkit-0.110.ebuild,
30 polkit-0.111-r1.ebuild:
31 Adjusted deps for dev-lang/spidermonkey to ensure SLOT=0
32
33 *polkit-0.111-r1 (08 Aug 2013)
34
35 08 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111-r1.ebuild:
36 Force use of dev-lang/spidermonkey:17 because automagic dependencies are bad.
37
38 *polkit-0.111 (15 May 2013)
39
40 15 May 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111.ebuild:
41 Version bump by "okias" from Freenode
42
43 19 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107-r1.ebuild,
44 -files/polkit-0.107-fallback.patch:
45 old
46
47 19 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
48 Stable for sh, wrt bug #452688
49
50 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
51 files/polkit-0.110-W_define.patch:
52 Include link to upstream bug.
53
54 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
55 +files/polkit-0.110-W_define.patch:
56 Fix missing #include <sys/wait.h> for #define's of WIFEXITED, WEXITSTATUS,
57 WIFSIGNALED and WTERMSIG (to fix building on arch "sh")
58
59 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
60 Stable for sparc, wrt bug #452688
61
62 03 Mar 2013; Mike Frysinger <vapier@gentoo.org> polkit-0.110.ebuild:
63 Add s390 keywords #457078 by Michael Palimaka.
64
65 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
66 Stable for alpha, wrt bug #452688
67
68 10 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
69 Stable for ppc64, wrt bug #452688
70
71 09 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
72 Stable for ia64, wrt bug #452688
73
74 31 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
75 Stable for ppc, wrt bug #452688
76
77 29 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
78 Force USE="debug" to be disabled in dev-lang/spidermonkey to avoid asseration
79 errors as noted by _AxS_.
80
81 26 Jan 2013; Markus Meier <maekke@gentoo.org> polkit-0.110.ebuild:
82 arm stable, bug #452688
83
84 20 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
85 x86 stable wrt #452688
86
87 19 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
88 amd64 stable wrt #452688
89
90 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.104-r1.ebuild,
91 -polkit-0.109-r1.ebuild, -files/polkit-0.109-XAUTHORITY-fallback.patch:
92 old
93
94 *polkit-0.110 (11 Jan 2013)
95
96 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.110.ebuild:
97 Version bump.
98
99 06 Jan 2013; Raúl Porcel <armin76@gentoo.org> polkit-0.107-r1.ebuild,
100 polkit-0.109-r1.ebuild:
101 Add ~sh wrt #436668
102
103 01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.109-r1.ebuild:
104 Add ~ia64, wrt bug #436668
105
106 30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
107 Stable for sparc, wrt bug #436666
108
109 29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
110 Stable for alpha, wrt bug #436666
111
112 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.108.ebuild,
113 -polkit-0.109.ebuild:
114 old
115
116 *polkit-0.109-r1 (21 Dec 2012)
117
118 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109-r1.ebuild,
119 +files/polkit-0.109-XAUTHORITY-fallback.patch:
120 Backport XAUTHORITY fallback support from upstream git.
121
122 19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.108.ebuild:
123 Add ~ia64, wrt bug #436668
124
125 *polkit-0.109 (19 Dec 2012)
126
127 19 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109.ebuild:
128 Version bump. Fix PaX marking logic wrt #444446 by Maxim Kammerer
129
130 18 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
131 Stable for ia64, wrt bug #436666
132
133 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
134 stable arm, bug #436666
135
136 22 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107.ebuild:
137 old
138
139 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
140 stable ppc64, bug #436666
141
142 22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
143 Stable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt
144 bug #436666
145
146 21 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
147 stable ppc, bug #436666, thanks peratu
148
149 19 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.108.ebuild:
150 Link against -lgmodule-2.0 to prevent underlinking (backported from upstream,
151 but using sed to avoid eautoreconf) wrt #443798
152
153 *polkit-0.108 (18 Nov 2012)
154
155 18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
156 Version bump.
157
158 28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
159 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
160 Drop ~x86-fbsd due to bug #439968.
161
162 15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
163 polkit-0.107-r1.ebuild:
164 Drop HPPA keywording (bug #438368).
165
166 15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
167 Set QA_MULTILIB_PATHS for bug #424423.
168
169 09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
170 Marked ~hppa (bug #436668).
171
172 08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
173 Use pax-mark in src_compile() instead of src_install() for src_test() wrt
174 #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
175 and emphatize it's an Portage issue instead of polkit issue in src_install()
176 message.
177
178 07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
179 Stable for amd64, wrt bug #436666
180
181 *polkit-0.107-r1 (20 Sep 2012)
182
183 20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
184 +files/polkit-0.107-fallback.patch:
185 Introduce upstream patch for falling back to uid 0 for authentication if list
186 of admin identities is empty.
187
188 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
189 -polkit-0.106-r7.ebuild:
190 old
191
192 *polkit-0.107 (13 Jul 2012)
193
194 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
195 Version bump.
196
197 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
198 -polkit-0.106-r6.ebuild:
199 old
200
201 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
202 Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
203 #391865 by Maksim Melnikau
204
205 *polkit-0.106-r7 (02 Jul 2012)
206
207 02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
208 RESTRICT="multilib-strict" since it's not compatible with the whole
209 /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
210 polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
211
212 *polkit-0.106-r6 (01 Jul 2012)
213
214 01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
215 Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
216 /usr/lib to /usr/lib64 symlink.
217
218 30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
219 polkit-0.106-r5.ebuild:
220 Adding dependency on SELinux policykit module if USE=selinux is set
221
222 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
223 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
224 'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
225
226 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
227 -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
228 old
229
230 *polkit-0.106-r5 (27 Jun 2012)
231
232 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
233 Revert entire unix-group:wheel experiment back to unix-user:0 because
234 PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
235 Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
236 by Doug Goldstein.
237
238 *polkit-0.106-r4 (27 Jun 2012)
239
240 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
241 Stop installing polkit-backend-1.pc because upstream changed
242 libpolkit-backend-1.la to be noinst_LTLIBRARIES in
243 src/polkitbackend/Makefile.am wrt #423431 by Pim Vullers
244
245 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r3.ebuild:
246 Redefine libprivdir in install for multilib-strict wrt #423381 by Michael
247 Palimaka
248
249 *polkit-0.106-r3 (25 Jun 2012)
250
251 25 Jun 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
252 +polkit-0.106-r3.ebuild:
253 pax-mark polkitd to fix crashes on hardened/PaX systems.
254
255 23 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
256 Convert pkg_postinst() message about polkitd home directory to new
257 user.eclass function esethome().
258
259 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
260 Check for mozjs187.pc for >=dev-lang/spidermonkey-1.8.7 compability.
261
262 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
263 Adapt to sys-auth/pambase with USE="systemd" wrt #372229 by Michał Górny
264
265 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r1.ebuild:
266 old
267
268 *polkit-0.106-r2 (17 Jun 2012)
269
270 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r2.ebuild:
271 Revision bump to chown /var/lib/polkit-1 because diropts has no effect on
272 existing directories.
273
274 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106.ebuild:
275 old
276
277 *polkit-0.106-r1 (17 Jun 2012)
278
279 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r1.ebuild:
280 Update /etc/pam.d/polkit-1 from system-login to system-local-login. Use
281 unix-group "adm" for administrators. Use /var/lib/polkit-1 as home directory
282 for unix-user polkitd. Update owners of /etc/polkit-1/rules.d and
283 /usr/share/polkit-1/rules.d to polkitd:root wrt #420269.
284
285 13 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106.ebuild:
286 Pull in dev-lang/spidermonkey >= 1.8.5 and dev-libs/glib >= 2.32 wrt
287 #420173 and #420307.
288
289 *polkit-0.106 (07 Jun 2012)
290
291 07 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106.ebuild:
292 Version bump.
293
294 20 May 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.105.ebuild:
295 Improve systemd handling wrt #416317 by Christoph Brill
296
297 *polkit-0.105 (14 May 2012)
298
299 14 May 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.105.ebuild:
300 Version bump.
301
302 04 May 2012; Jeff Horelick <jdhore@gentoo.org> polkit-0.104-r1.ebuild:
303 dev-util/pkgconfig -> virtual/pkgconfig
304
305 18 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.102.ebuild,
306 -polkit-0.103.ebuild, -polkit-0.104.ebuild:
307 old
308
309 25 Mar 2012; Raúl Porcel <armin76@gentoo.org> polkit-0.104-r1.ebuild:
310 ia64/sh/sparc stable wrt #401513
311
312 09 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.104-r1.ebuild:
313 ppc/ppc64 stable wrt #401513
314
315 17 Feb 2012; Tobias Klausmann <klausman@gentoo.org> polkit-0.104-r1.ebuild:
316 Stable on alpha, bug #401513
317
318 17 Feb 2012; Thomas Kahle <tomka@gentoo.org> polkit-0.104-r1.ebuild:
319 marked x86 per bug 401513
320
321 13 Feb 2012; Markus Meier <maekke@gentoo.org> polkit-0.104-r1.ebuild:
322 arm stable, bug #401513
323
324 02 Feb 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild:
325 Stable for HPPA (bug #401513).
326
327 30 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.104-r1.ebuild:
328 Stable for AMD64, wrt security bug #401513
329
330 *polkit-0.104-r1 (30 Jan 2012)
331
332 30 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104-r1.ebuild:
333 Restore the default value of AdminIdentities from "wheel" to "0" like it was
334 in polkit-0.102 and ones before that. You should see files
335 50-localauthority.conf and 60-gentoo.conf in
336 /etc/polkit-1/localauthority.conf.d. You should also familiarize yourself
337 with "man 8 pklocalauthority" as soon as possible.
338
339 29 Jan 2012; Markus Meier <maekke@gentoo.org> polkit-0.103.ebuild:
340 arm stable, bug #397755
341
342 07 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.103.ebuild:
343 Stable for AMD64, wrt bug #397755
344
345 *polkit-0.104 (05 Jan 2012)
346
347 05 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104.ebuild,
348 metadata.xml:
349 Version bump.
350
351 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.101-r1.ebuild:
352 old
353
354 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.102.ebuild:
355 ppc/ppc64 stable wrt #387163
356
357 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild:
358 Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo
359
360 *polkit-0.103 (07 Dec 2011)
361
362 07 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.103.ebuild:
363 Version bump. Remove unrequired keepdir of /var/run/polkit-1 wrt #387903 by
364 "i.Dark_Templar"
365
366 05 Nov 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.102.ebuild:
367 alpha/arm/ia64/sh/sparc stable wrt #387163
368
369 29 Oct 2011; Markus Meier <maekke@gentoo.org> polkit-0.102.ebuild:
370 arm stable, bug #387163
371
372 19 Oct 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.102.ebuild:
373 Stable for HPPA (bug #387163).
374
375 18 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> polkit-0.102.ebuild:
376 x86 stable wrt bug #387163
377
378 15 Oct 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.102.ebuild:
379 Stable on amd64 wrt bug #387163
380
381 28 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101-r1.ebuild,
382 polkit-0.102.ebuild:
383 pambase[consolekit] support is needed to use polkit with pam, add to PDEPEND
384
385 *polkit-0.102 (06 Aug 2011)
386
387 06 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.102.ebuild:
388 Version bump.
389
390 10 Jul 2011; Matt Turner <mattst88@gentoo.org> polkit-0.101-r1.ebuild:
391 Added ~mips, bug 296548
392
393 14 May 2011; Gilles Dartiguelongue <eva@gentoo.org> polkit-0.101-r1.ebuild:
394 Add missing dtd to DEPEND, bug #355505.
395
396 30 Apr 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.101-r1.ebuild:
397 alpha/arm/ia64/sh/sparc stable wrt #364973
398
399 28 Apr 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
400 polkit-0.101-r1.ebuild:
401 x86 stable wrt security bug #364973
402
403 27 Apr 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.101-r1.ebuild:
404 Stable for HPPA (bug #364973).
405
406 27 Apr 2011; Christoph Mende <angelos@gentoo.org> polkit-0.101-r1.ebuild:
407 Stable on amd64 wrt bug #364973
408
409 27 Apr 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.101-r1.ebuild:
410 ppc/ppc64 stable wrt #364973
411
412 *polkit-0.101-r1 (25 Apr 2011)
413
414 25 Apr 2011; Nirbheek Chauhan <nirbheek@gentoo.org> -polkit-0.100.ebuild,
415 +polkit-0.101-r1.ebuild:
416 Add patches for CVE-2011-1485, remove vulnerable 0.100 version
417
418 22 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.99-r1.ebuild:
419 ppc/ppc64 stable wrt #354509
420
421 19 Mar 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.99-r1.ebuild:
422 alpha/ia64/sh/sparc stable wrt #354509
423
424 15 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101.ebuild:
425 PDEPEND on 0.101 version of polkit-gnome
426
427 13 Mar 2011; Markus Meier <maekke@gentoo.org> polkit-0.99-r1.ebuild:
428 arm stable, bug #354509
429
430 *polkit-0.101 (11 Mar 2011)
431
432 11 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.101.ebuild:
433 Version bump.
434
435 07 Mar 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
436 Stable for HPPA (bug #354509).
437
438 04 Mar 2011; Thomas Kahle <tomka@gentoo.org> polkit-0.99-r1.ebuild:
439 x86 stable per bug 354509
440
441 23 Feb 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.99-r1.ebuild:
442 Stable on amd64 wrt bug #354509
443
444 *polkit-0.100 (23 Feb 2011)
445
446 23 Feb 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.100.ebuild:
447 Bump to 0.100
448
449 24 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.99-r1.ebuild:
450 USE="kde" to pull in authentication agent for KDE.
451
452 21 Jan 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
453 Marked ~hppa (bug #296548).
454
455 *polkit-0.99-r1 (25 Dec 2010)
456
457 25 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.99-r1.ebuild:
458 Revision bump to remove static archives (.a) and libtool archives (.la).
459 USE="gtk" to pull in authentication agent for GTK+ based desktops.
460
461 *polkit-0.99 (25 Sep 2010)
462
463 25 Sep 2010; <nirbheek@gentoo.org> +polkit-0.99.ebuild:
464 Bump to 0.99, masked due to >=glib-2.25 requirement
465
466 18 Aug 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
467 arm stable, bug #314899
468
469 14 Aug 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96-r1.ebuild,
470 polkit-0.96-r2.ebuild:
471 alpha/ia64/sh/sparc stable
472
473 09 Aug 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96-r1.ebuild:
474 Marked ppc/ppc64 stable.
475
476 25 Jul 2010; Tobias Klausmann <klausman@gentoo.org> polkit-0.96-r2.ebuild:
477 Stable on alpha, bug #329621
478
479 20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
480 polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
481 Stable for HPPA (bug #314899).
482
483 20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
484 polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
485 Drop HPPA keywording (bug #324511).
486
487 07 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96-r1.ebuild,
488 polkit-0.96-r2.ebuild:
489 Add ewarn about ensuring that consolekit sessions are working. Either the
490 user needs to login using a login-manager with consolekit support, or use
491 ck-launch-session to launch the DE as suggested in bug 291116 comment 13
492
493 *polkit-0.96-r2 (02 Jul 2010)
494
495 02 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
496 +polkit-0.96-r2.ebuild, metadata.xml:
497 USE=expat was quite useless, expat is mandatory in polkit. Don't create
498 user 'polkituser', it was used by policykit, but isn't by polkit. Also,
499 add introspection support
500
501 04 Jun 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
502 x86 stable, bug #314899
503
504 03 May 2010; Olivier Crête <tester@gentoo.org> polkit-0.96-r1.ebuild:
505 amd64 stable, bug #314899
506
507 25 Apr 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild,
508 polkit-0.96-r1.ebuild:
509 Add ~sh
510
511 13 Apr 2010; Alexis Ballier <aballier@gentoo.org> polkit-0.96-r1.ebuild,
512 +files/polkit-0.96-getcwd.patch:
513 Fix build on fbsd and keyword it x86-fbsd
514
515 25 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild,
516 polkit-0.96-r1.ebuild:
517 Raise gtk-doc{,-am} dependencies. Fixes bug 311085
518
519 21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
520 -files/polkit-0.93-fix-daemon-name.patch, -polkit-0.94.ebuild,
521 -polkit-0.95.ebuild:
522 Remove old
523
524 *polkit-0.96-r1 (21 Mar 2010)
525
526 21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
527 +polkit-0.96-r1.ebuild:
528 Update with newer version of polkit-shadow patch
529
530 07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
531 Fix minor problems with SRC_URI
532
533 07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
534 Add experimental shadow support, bug 291116 . Patch thanks to the
535 slackware folks.
536
537 28 Feb 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild:
538 Add ~alpha/~arm/~ia64/~sparc
539
540 16 Feb 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96.ebuild:
541 Marked ~ppc/~ppc64 for bug #296548.
542
543 *polkit-0.96 (23 Jan 2010)
544
545 23 Jan 2010; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.96.ebuild:
546 Version bump to 0.96; lots of bugfixes, see NEWS
547
548 06 Jan 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.95.ebuild:
549 Marked ~hppa (bug #296548).
550
551 11 Dec 2009; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.95.ebuild:
552 Add sys-auth/consolekit-0.4.0[polkit] to PDEPEND; needed for checking if
553 the user is in an active/local session via dbus methods
554
555 *polkit-0.95 (14 Nov 2009)
556
557 14 Nov 2009; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.95.ebuild:
558 Bump to 0.95 -- new lockdown API, last dev version till 1.0
559
560 30 Oct 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
561 -files/polkit-0.92-zsh-completions.patch, polkit-0.94.ebuild:
562 Remove zsh-completion (bug 291114), force pam support on (bug 291116)
563
564 *polkit-0.94 (29 Oct 2009)
565
566 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
567 +files/polkit-0.92-zsh-completions.patch,
568 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
569 +metadata.xml:
570 Initial ebuild for GNOME 2.28.

  ViewVC Help
Powered by ViewVC 1.1.20