/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Contents of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.150 - (show annotations) (download)
Thu Sep 19 17:08:30 2013 UTC (4 years, 2 months ago) by ssuominen
Branch: MAIN
Changes since 1.149: +7 -1 lines
-r0 is for stabilization w/ mozjs185 and -r1 is for ~arch with mozjs 17.0

(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)

1 # ChangeLog for sys-auth/polkit
2 # Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.149 2013/09/19 16:08:57 cardoe Exp $
4
5 *polkit-0.112-r1 (19 Sep 2013)
6
7 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.112-r1.ebuild,
8 polkit-0.112.ebuild:
9 -r0 is for stabilization w/ mozjs185 and -r1 is for ~arch with mozjs 17.0
10
11 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> -polkit-0.111-r1.ebuild:
12 Remove vulnerable version
13
14 *polkit-0.110-r1 (19 Sep 2013)
15
16 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org>
17 +files/polkit-0.110-CVE-2013-4288.patch, +polkit-0.110-r1.ebuild:
18 Bump for CVE-2013-4288
19
20 *polkit-0.112 (19 Sep 2013)
21
22 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> +polkit-0.112.ebuild:
23 Bump for CVE-2013-4288
24
25 10 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
26 polkit-0.111-r1.ebuild:
27 Stop forcing USE="consolekit systemd" for sys-auth/pambase in PDEPEND because
28 CONFIG_AUDITSYSCALL=y is not possible on every arch and the dependency was
29 always more about convinience than being strict requirement.
30
31 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> -polkit-0.111.ebuild:
32 dropped polkit-111 in favour of -r1 now that spidermonkey-17 is unmasked, as
33 per ssuominen's approval
34
35 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> polkit-0.110.ebuild,
36 polkit-0.111-r1.ebuild:
37 Adjusted deps for dev-lang/spidermonkey to ensure SLOT=0
38
39 *polkit-0.111-r1 (08 Aug 2013)
40
41 08 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111-r1.ebuild:
42 Force use of dev-lang/spidermonkey:17 because automagic dependencies are bad.
43
44 *polkit-0.111 (15 May 2013)
45
46 15 May 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111.ebuild:
47 Version bump by "okias" from Freenode
48
49 19 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107-r1.ebuild,
50 -files/polkit-0.107-fallback.patch:
51 old
52
53 19 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
54 Stable for sh, wrt bug #452688
55
56 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
57 files/polkit-0.110-W_define.patch:
58 Include link to upstream bug.
59
60 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
61 +files/polkit-0.110-W_define.patch:
62 Fix missing #include <sys/wait.h> for #define's of WIFEXITED, WEXITSTATUS,
63 WIFSIGNALED and WTERMSIG (to fix building on arch "sh")
64
65 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
66 Stable for sparc, wrt bug #452688
67
68 03 Mar 2013; Mike Frysinger <vapier@gentoo.org> polkit-0.110.ebuild:
69 Add s390 keywords #457078 by Michael Palimaka.
70
71 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
72 Stable for alpha, wrt bug #452688
73
74 10 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
75 Stable for ppc64, wrt bug #452688
76
77 09 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
78 Stable for ia64, wrt bug #452688
79
80 31 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
81 Stable for ppc, wrt bug #452688
82
83 29 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
84 Force USE="debug" to be disabled in dev-lang/spidermonkey to avoid asseration
85 errors as noted by _AxS_.
86
87 26 Jan 2013; Markus Meier <maekke@gentoo.org> polkit-0.110.ebuild:
88 arm stable, bug #452688
89
90 20 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
91 x86 stable wrt #452688
92
93 19 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
94 amd64 stable wrt #452688
95
96 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.104-r1.ebuild,
97 -polkit-0.109-r1.ebuild, -files/polkit-0.109-XAUTHORITY-fallback.patch:
98 old
99
100 *polkit-0.110 (11 Jan 2013)
101
102 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.110.ebuild:
103 Version bump.
104
105 06 Jan 2013; Raúl Porcel <armin76@gentoo.org> polkit-0.107-r1.ebuild,
106 polkit-0.109-r1.ebuild:
107 Add ~sh wrt #436668
108
109 01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.109-r1.ebuild:
110 Add ~ia64, wrt bug #436668
111
112 30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
113 Stable for sparc, wrt bug #436666
114
115 29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
116 Stable for alpha, wrt bug #436666
117
118 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.108.ebuild,
119 -polkit-0.109.ebuild:
120 old
121
122 *polkit-0.109-r1 (21 Dec 2012)
123
124 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109-r1.ebuild,
125 +files/polkit-0.109-XAUTHORITY-fallback.patch:
126 Backport XAUTHORITY fallback support from upstream git.
127
128 19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.108.ebuild:
129 Add ~ia64, wrt bug #436668
130
131 *polkit-0.109 (19 Dec 2012)
132
133 19 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109.ebuild:
134 Version bump. Fix PaX marking logic wrt #444446 by Maxim Kammerer
135
136 18 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
137 Stable for ia64, wrt bug #436666
138
139 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
140 stable arm, bug #436666
141
142 22 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107.ebuild:
143 old
144
145 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
146 stable ppc64, bug #436666
147
148 22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
149 Stable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt
150 bug #436666
151
152 21 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
153 stable ppc, bug #436666, thanks peratu
154
155 19 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.108.ebuild:
156 Link against -lgmodule-2.0 to prevent underlinking (backported from upstream,
157 but using sed to avoid eautoreconf) wrt #443798
158
159 *polkit-0.108 (18 Nov 2012)
160
161 18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
162 Version bump.
163
164 28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
165 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
166 Drop ~x86-fbsd due to bug #439968.
167
168 15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
169 polkit-0.107-r1.ebuild:
170 Drop HPPA keywording (bug #438368).
171
172 15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
173 Set QA_MULTILIB_PATHS for bug #424423.
174
175 09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
176 Marked ~hppa (bug #436668).
177
178 08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
179 Use pax-mark in src_compile() instead of src_install() for src_test() wrt
180 #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
181 and emphatize it's an Portage issue instead of polkit issue in src_install()
182 message.
183
184 07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
185 Stable for amd64, wrt bug #436666
186
187 *polkit-0.107-r1 (20 Sep 2012)
188
189 20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
190 +files/polkit-0.107-fallback.patch:
191 Introduce upstream patch for falling back to uid 0 for authentication if list
192 of admin identities is empty.
193
194 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
195 -polkit-0.106-r7.ebuild:
196 old
197
198 *polkit-0.107 (13 Jul 2012)
199
200 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
201 Version bump.
202
203 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
204 -polkit-0.106-r6.ebuild:
205 old
206
207 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
208 Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
209 #391865 by Maksim Melnikau
210
211 *polkit-0.106-r7 (02 Jul 2012)
212
213 02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
214 RESTRICT="multilib-strict" since it's not compatible with the whole
215 /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
216 polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
217
218 *polkit-0.106-r6 (01 Jul 2012)
219
220 01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
221 Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
222 /usr/lib to /usr/lib64 symlink.
223
224 30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
225 polkit-0.106-r5.ebuild:
226 Adding dependency on SELinux policykit module if USE=selinux is set
227
228 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
229 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
230 'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
231
232 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
233 -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
234 old
235
236 *polkit-0.106-r5 (27 Jun 2012)
237
238 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
239 Revert entire unix-group:wheel experiment back to unix-user:0 because
240 PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
241 Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
242 by Doug Goldstein.
243
244 *polkit-0.106-r4 (27 Jun 2012)
245
246 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
247 Stop installing polkit-backend-1.pc because upstream changed
248 libpolkit-backend-1.la to be noinst_LTLIBRARIES in
249 src/polkitbackend/Makefile.am wrt #423431 by Pim Vullers
250
251 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r3.ebuild:
252 Redefine libprivdir in install for multilib-strict wrt #423381 by Michael
253 Palimaka
254
255 *polkit-0.106-r3 (25 Jun 2012)
256
257 25 Jun 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
258 +polkit-0.106-r3.ebuild:
259 pax-mark polkitd to fix crashes on hardened/PaX systems.
260
261 23 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
262 Convert pkg_postinst() message about polkitd home directory to new
263 user.eclass function esethome().
264
265 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
266 Check for mozjs187.pc for >=dev-lang/spidermonkey-1.8.7 compability.
267
268 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
269 Adapt to sys-auth/pambase with USE="systemd" wrt #372229 by Michał Górny
270
271 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r1.ebuild:
272 old
273
274 *polkit-0.106-r2 (17 Jun 2012)
275
276 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r2.ebuild:
277 Revision bump to chown /var/lib/polkit-1 because diropts has no effect on
278 existing directories.
279
280 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106.ebuild:
281 old
282
283 *polkit-0.106-r1 (17 Jun 2012)
284
285 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r1.ebuild:
286 Update /etc/pam.d/polkit-1 from system-login to system-local-login. Use
287 unix-group "adm" for administrators. Use /var/lib/polkit-1 as home directory
288 for unix-user polkitd. Update owners of /etc/polkit-1/rules.d and
289 /usr/share/polkit-1/rules.d to polkitd:root wrt #420269.
290
291 13 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106.ebuild:
292 Pull in dev-lang/spidermonkey >= 1.8.5 and dev-libs/glib >= 2.32 wrt
293 #420173 and #420307.
294
295 *polkit-0.106 (07 Jun 2012)
296
297 07 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106.ebuild:
298 Version bump.
299
300 20 May 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.105.ebuild:
301 Improve systemd handling wrt #416317 by Christoph Brill
302
303 *polkit-0.105 (14 May 2012)
304
305 14 May 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.105.ebuild:
306 Version bump.
307
308 04 May 2012; Jeff Horelick <jdhore@gentoo.org> polkit-0.104-r1.ebuild:
309 dev-util/pkgconfig -> virtual/pkgconfig
310
311 18 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.102.ebuild,
312 -polkit-0.103.ebuild, -polkit-0.104.ebuild:
313 old
314
315 25 Mar 2012; Raúl Porcel <armin76@gentoo.org> polkit-0.104-r1.ebuild:
316 ia64/sh/sparc stable wrt #401513
317
318 09 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.104-r1.ebuild:
319 ppc/ppc64 stable wrt #401513
320
321 17 Feb 2012; Tobias Klausmann <klausman@gentoo.org> polkit-0.104-r1.ebuild:
322 Stable on alpha, bug #401513
323
324 17 Feb 2012; Thomas Kahle <tomka@gentoo.org> polkit-0.104-r1.ebuild:
325 marked x86 per bug 401513
326
327 13 Feb 2012; Markus Meier <maekke@gentoo.org> polkit-0.104-r1.ebuild:
328 arm stable, bug #401513
329
330 02 Feb 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild:
331 Stable for HPPA (bug #401513).
332
333 30 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.104-r1.ebuild:
334 Stable for AMD64, wrt security bug #401513
335
336 *polkit-0.104-r1 (30 Jan 2012)
337
338 30 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104-r1.ebuild:
339 Restore the default value of AdminIdentities from "wheel" to "0" like it was
340 in polkit-0.102 and ones before that. You should see files
341 50-localauthority.conf and 60-gentoo.conf in
342 /etc/polkit-1/localauthority.conf.d. You should also familiarize yourself
343 with "man 8 pklocalauthority" as soon as possible.
344
345 29 Jan 2012; Markus Meier <maekke@gentoo.org> polkit-0.103.ebuild:
346 arm stable, bug #397755
347
348 07 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.103.ebuild:
349 Stable for AMD64, wrt bug #397755
350
351 *polkit-0.104 (05 Jan 2012)
352
353 05 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104.ebuild,
354 metadata.xml:
355 Version bump.
356
357 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.101-r1.ebuild:
358 old
359
360 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.102.ebuild:
361 ppc/ppc64 stable wrt #387163
362
363 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild:
364 Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo
365
366 *polkit-0.103 (07 Dec 2011)
367
368 07 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.103.ebuild:
369 Version bump. Remove unrequired keepdir of /var/run/polkit-1 wrt #387903 by
370 "i.Dark_Templar"
371
372 05 Nov 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.102.ebuild:
373 alpha/arm/ia64/sh/sparc stable wrt #387163
374
375 29 Oct 2011; Markus Meier <maekke@gentoo.org> polkit-0.102.ebuild:
376 arm stable, bug #387163
377
378 19 Oct 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.102.ebuild:
379 Stable for HPPA (bug #387163).
380
381 18 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> polkit-0.102.ebuild:
382 x86 stable wrt bug #387163
383
384 15 Oct 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.102.ebuild:
385 Stable on amd64 wrt bug #387163
386
387 28 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101-r1.ebuild,
388 polkit-0.102.ebuild:
389 pambase[consolekit] support is needed to use polkit with pam, add to PDEPEND
390
391 *polkit-0.102 (06 Aug 2011)
392
393 06 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.102.ebuild:
394 Version bump.
395
396 10 Jul 2011; Matt Turner <mattst88@gentoo.org> polkit-0.101-r1.ebuild:
397 Added ~mips, bug 296548
398
399 14 May 2011; Gilles Dartiguelongue <eva@gentoo.org> polkit-0.101-r1.ebuild:
400 Add missing dtd to DEPEND, bug #355505.
401
402 30 Apr 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.101-r1.ebuild:
403 alpha/arm/ia64/sh/sparc stable wrt #364973
404
405 28 Apr 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
406 polkit-0.101-r1.ebuild:
407 x86 stable wrt security bug #364973
408
409 27 Apr 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.101-r1.ebuild:
410 Stable for HPPA (bug #364973).
411
412 27 Apr 2011; Christoph Mende <angelos@gentoo.org> polkit-0.101-r1.ebuild:
413 Stable on amd64 wrt bug #364973
414
415 27 Apr 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.101-r1.ebuild:
416 ppc/ppc64 stable wrt #364973
417
418 *polkit-0.101-r1 (25 Apr 2011)
419
420 25 Apr 2011; Nirbheek Chauhan <nirbheek@gentoo.org> -polkit-0.100.ebuild,
421 +polkit-0.101-r1.ebuild:
422 Add patches for CVE-2011-1485, remove vulnerable 0.100 version
423
424 22 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.99-r1.ebuild:
425 ppc/ppc64 stable wrt #354509
426
427 19 Mar 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.99-r1.ebuild:
428 alpha/ia64/sh/sparc stable wrt #354509
429
430 15 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101.ebuild:
431 PDEPEND on 0.101 version of polkit-gnome
432
433 13 Mar 2011; Markus Meier <maekke@gentoo.org> polkit-0.99-r1.ebuild:
434 arm stable, bug #354509
435
436 *polkit-0.101 (11 Mar 2011)
437
438 11 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.101.ebuild:
439 Version bump.
440
441 07 Mar 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
442 Stable for HPPA (bug #354509).
443
444 04 Mar 2011; Thomas Kahle <tomka@gentoo.org> polkit-0.99-r1.ebuild:
445 x86 stable per bug 354509
446
447 23 Feb 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.99-r1.ebuild:
448 Stable on amd64 wrt bug #354509
449
450 *polkit-0.100 (23 Feb 2011)
451
452 23 Feb 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.100.ebuild:
453 Bump to 0.100
454
455 24 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.99-r1.ebuild:
456 USE="kde" to pull in authentication agent for KDE.
457
458 21 Jan 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
459 Marked ~hppa (bug #296548).
460
461 *polkit-0.99-r1 (25 Dec 2010)
462
463 25 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.99-r1.ebuild:
464 Revision bump to remove static archives (.a) and libtool archives (.la).
465 USE="gtk" to pull in authentication agent for GTK+ based desktops.
466
467 *polkit-0.99 (25 Sep 2010)
468
469 25 Sep 2010; <nirbheek@gentoo.org> +polkit-0.99.ebuild:
470 Bump to 0.99, masked due to >=glib-2.25 requirement
471
472 18 Aug 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
473 arm stable, bug #314899
474
475 14 Aug 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96-r1.ebuild,
476 polkit-0.96-r2.ebuild:
477 alpha/ia64/sh/sparc stable
478
479 09 Aug 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96-r1.ebuild:
480 Marked ppc/ppc64 stable.
481
482 25 Jul 2010; Tobias Klausmann <klausman@gentoo.org> polkit-0.96-r2.ebuild:
483 Stable on alpha, bug #329621
484
485 20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
486 polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
487 Stable for HPPA (bug #314899).
488
489 20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
490 polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
491 Drop HPPA keywording (bug #324511).
492
493 07 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96-r1.ebuild,
494 polkit-0.96-r2.ebuild:
495 Add ewarn about ensuring that consolekit sessions are working. Either the
496 user needs to login using a login-manager with consolekit support, or use
497 ck-launch-session to launch the DE as suggested in bug 291116 comment 13
498
499 *polkit-0.96-r2 (02 Jul 2010)
500
501 02 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
502 +polkit-0.96-r2.ebuild, metadata.xml:
503 USE=expat was quite useless, expat is mandatory in polkit. Don't create
504 user 'polkituser', it was used by policykit, but isn't by polkit. Also,
505 add introspection support
506
507 04 Jun 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
508 x86 stable, bug #314899
509
510 03 May 2010; Olivier Crête <tester@gentoo.org> polkit-0.96-r1.ebuild:
511 amd64 stable, bug #314899
512
513 25 Apr 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild,
514 polkit-0.96-r1.ebuild:
515 Add ~sh
516
517 13 Apr 2010; Alexis Ballier <aballier@gentoo.org> polkit-0.96-r1.ebuild,
518 +files/polkit-0.96-getcwd.patch:
519 Fix build on fbsd and keyword it x86-fbsd
520
521 25 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild,
522 polkit-0.96-r1.ebuild:
523 Raise gtk-doc{,-am} dependencies. Fixes bug 311085
524
525 21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
526 -files/polkit-0.93-fix-daemon-name.patch, -polkit-0.94.ebuild,
527 -polkit-0.95.ebuild:
528 Remove old
529
530 *polkit-0.96-r1 (21 Mar 2010)
531
532 21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
533 +polkit-0.96-r1.ebuild:
534 Update with newer version of polkit-shadow patch
535
536 07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
537 Fix minor problems with SRC_URI
538
539 07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
540 Add experimental shadow support, bug 291116 . Patch thanks to the
541 slackware folks.
542
543 28 Feb 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild:
544 Add ~alpha/~arm/~ia64/~sparc
545
546 16 Feb 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96.ebuild:
547 Marked ~ppc/~ppc64 for bug #296548.
548
549 *polkit-0.96 (23 Jan 2010)
550
551 23 Jan 2010; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.96.ebuild:
552 Version bump to 0.96; lots of bugfixes, see NEWS
553
554 06 Jan 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.95.ebuild:
555 Marked ~hppa (bug #296548).
556
557 11 Dec 2009; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.95.ebuild:
558 Add sys-auth/consolekit-0.4.0[polkit] to PDEPEND; needed for checking if
559 the user is in an active/local session via dbus methods
560
561 *polkit-0.95 (14 Nov 2009)
562
563 14 Nov 2009; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.95.ebuild:
564 Bump to 0.95 -- new lockdown API, last dev version till 1.0
565
566 30 Oct 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
567 -files/polkit-0.92-zsh-completions.patch, polkit-0.94.ebuild:
568 Remove zsh-completion (bug 291114), force pam support on (bug 291116)
569
570 *polkit-0.94 (29 Oct 2009)
571
572 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
573 +files/polkit-0.92-zsh-completions.patch,
574 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
575 +metadata.xml:
576 Initial ebuild for GNOME 2.28.

  ViewVC Help
Powered by ViewVC 1.1.20