/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Contents of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.165 - (show annotations) (download)
Sun Feb 23 17:11:26 2014 UTC (3 years, 7 months ago) by pacho
Branch: MAIN
Changes since 1.164: +4 -1 lines
x86 stable, bug #500758

(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)

1 # ChangeLog for sys-auth/polkit
2 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.164 2014/02/23 16:08:24 pacho Exp $
4
5 23 Feb 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r1.ebuild:
6 x86 stable, bug #500758
7
8 23 Feb 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r1.ebuild:
9 amd64 stable, bug #500758
10
11 28 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
12 Fix ia64 where the order of the configure options was overridden by mips,
13 thanks Arfrever
14
15 27 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
16 Because sometimes portage is stupid
17
18 24 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
19 Fix dependence on spidermonkey for mips, bug #495168
20
21 23 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
22 Stable for sparc, wrt bug #484486
23
24 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
25 Stable for alpha, wrt bug #484486
26
27 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
28 Stable for ia64, wrt bug #484486
29
30 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
31 Stable for ppc64, wrt bug #484486
32
33 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
34 Stable for ppc, wrt bug #484486
35
36 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
37 Stable for arm, wrt bug #484486
38
39 21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
40 Stable for x86, wrt bug #484486
41
42 21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
43 Stable for amd64, wrt bug #484486
44
45 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.110-r1.ebuild,
46 -files/polkit-0.110-CVE-2013-4288.patch:
47 old
48
49 *polkit-0.112-r1 (19 Sep 2013)
50
51 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.112-r1.ebuild,
52 polkit-0.112.ebuild:
53 -r0 is for stabilization w/ mozjs185 and -r1 is for ~arch with mozjs 17.0
54
55 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> -polkit-0.111-r1.ebuild:
56 Remove vulnerable version
57
58 *polkit-0.110-r1 (19 Sep 2013)
59
60 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org>
61 +files/polkit-0.110-CVE-2013-4288.patch, +polkit-0.110-r1.ebuild:
62 Bump for CVE-2013-4288
63
64 *polkit-0.112 (19 Sep 2013)
65
66 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> +polkit-0.112.ebuild:
67 Bump for CVE-2013-4288
68
69 10 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
70 polkit-0.111-r1.ebuild:
71 Stop forcing USE="consolekit systemd" for sys-auth/pambase in PDEPEND because
72 CONFIG_AUDITSYSCALL=y is not possible on every arch and the dependency was
73 always more about convinience than being strict requirement.
74
75 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> -polkit-0.111.ebuild:
76 dropped polkit-111 in favour of -r1 now that spidermonkey-17 is unmasked, as
77 per ssuominen's approval
78
79 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> polkit-0.110.ebuild,
80 polkit-0.111-r1.ebuild:
81 Adjusted deps for dev-lang/spidermonkey to ensure SLOT=0
82
83 *polkit-0.111-r1 (08 Aug 2013)
84
85 08 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111-r1.ebuild:
86 Force use of dev-lang/spidermonkey:17 because automagic dependencies are bad.
87
88 *polkit-0.111 (15 May 2013)
89
90 15 May 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111.ebuild:
91 Version bump by "okias" from Freenode
92
93 19 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107-r1.ebuild,
94 -files/polkit-0.107-fallback.patch:
95 old
96
97 19 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
98 Stable for sh, wrt bug #452688
99
100 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
101 files/polkit-0.110-W_define.patch:
102 Include link to upstream bug.
103
104 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
105 +files/polkit-0.110-W_define.patch:
106 Fix missing #include <sys/wait.h> for #define's of WIFEXITED, WEXITSTATUS,
107 WIFSIGNALED and WTERMSIG (to fix building on arch "sh")
108
109 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
110 Stable for sparc, wrt bug #452688
111
112 03 Mar 2013; Mike Frysinger <vapier@gentoo.org> polkit-0.110.ebuild:
113 Add s390 keywords #457078 by Michael Palimaka.
114
115 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
116 Stable for alpha, wrt bug #452688
117
118 10 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
119 Stable for ppc64, wrt bug #452688
120
121 09 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
122 Stable for ia64, wrt bug #452688
123
124 31 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
125 Stable for ppc, wrt bug #452688
126
127 29 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
128 Force USE="debug" to be disabled in dev-lang/spidermonkey to avoid asseration
129 errors as noted by _AxS_.
130
131 26 Jan 2013; Markus Meier <maekke@gentoo.org> polkit-0.110.ebuild:
132 arm stable, bug #452688
133
134 20 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
135 x86 stable wrt #452688
136
137 19 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
138 amd64 stable wrt #452688
139
140 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.104-r1.ebuild,
141 -polkit-0.109-r1.ebuild, -files/polkit-0.109-XAUTHORITY-fallback.patch:
142 old
143
144 *polkit-0.110 (11 Jan 2013)
145
146 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.110.ebuild:
147 Version bump.
148
149 06 Jan 2013; Raúl Porcel <armin76@gentoo.org> polkit-0.107-r1.ebuild,
150 polkit-0.109-r1.ebuild:
151 Add ~sh wrt #436668
152
153 01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.109-r1.ebuild:
154 Add ~ia64, wrt bug #436668
155
156 30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
157 Stable for sparc, wrt bug #436666
158
159 29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
160 Stable for alpha, wrt bug #436666
161
162 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.108.ebuild,
163 -polkit-0.109.ebuild:
164 old
165
166 *polkit-0.109-r1 (21 Dec 2012)
167
168 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109-r1.ebuild,
169 +files/polkit-0.109-XAUTHORITY-fallback.patch:
170 Backport XAUTHORITY fallback support from upstream git.
171
172 19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.108.ebuild:
173 Add ~ia64, wrt bug #436668
174
175 *polkit-0.109 (19 Dec 2012)
176
177 19 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109.ebuild:
178 Version bump. Fix PaX marking logic wrt #444446 by Maxim Kammerer
179
180 18 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
181 Stable for ia64, wrt bug #436666
182
183 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
184 stable arm, bug #436666
185
186 22 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107.ebuild:
187 old
188
189 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
190 stable ppc64, bug #436666
191
192 22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
193 Stable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt
194 bug #436666
195
196 21 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
197 stable ppc, bug #436666, thanks peratu
198
199 19 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.108.ebuild:
200 Link against -lgmodule-2.0 to prevent underlinking (backported from upstream,
201 but using sed to avoid eautoreconf) wrt #443798
202
203 *polkit-0.108 (18 Nov 2012)
204
205 18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
206 Version bump.
207
208 28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
209 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
210 Drop ~x86-fbsd due to bug #439968.
211
212 15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
213 polkit-0.107-r1.ebuild:
214 Drop HPPA keywording (bug #438368).
215
216 15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
217 Set QA_MULTILIB_PATHS for bug #424423.
218
219 09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
220 Marked ~hppa (bug #436668).
221
222 08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
223 Use pax-mark in src_compile() instead of src_install() for src_test() wrt
224 #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
225 and emphatize it's an Portage issue instead of polkit issue in src_install()
226 message.
227
228 07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
229 Stable for amd64, wrt bug #436666
230
231 *polkit-0.107-r1 (20 Sep 2012)
232
233 20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
234 +files/polkit-0.107-fallback.patch:
235 Introduce upstream patch for falling back to uid 0 for authentication if list
236 of admin identities is empty.
237
238 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
239 -polkit-0.106-r7.ebuild:
240 old
241
242 *polkit-0.107 (13 Jul 2012)
243
244 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
245 Version bump.
246
247 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
248 -polkit-0.106-r6.ebuild:
249 old
250
251 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
252 Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
253 #391865 by Maksim Melnikau
254
255 *polkit-0.106-r7 (02 Jul 2012)
256
257 02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
258 RESTRICT="multilib-strict" since it's not compatible with the whole
259 /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
260 polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
261
262 *polkit-0.106-r6 (01 Jul 2012)
263
264 01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
265 Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
266 /usr/lib to /usr/lib64 symlink.
267
268 30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
269 polkit-0.106-r5.ebuild:
270 Adding dependency on SELinux policykit module if USE=selinux is set
271
272 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
273 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
274 'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
275
276 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
277 -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
278 old
279
280 *polkit-0.106-r5 (27 Jun 2012)
281
282 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
283 Revert entire unix-group:wheel experiment back to unix-user:0 because
284 PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
285 Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
286 by Doug Goldstein.
287
288 *polkit-0.106-r4 (27 Jun 2012)
289
290 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
291 Stop installing polkit-backend-1.pc because upstream changed
292 libpolkit-backend-1.la to be noinst_LTLIBRARIES in
293 src/polkitbackend/Makefile.am wrt #423431 by Pim Vullers
294
295 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r3.ebuild:
296 Redefine libprivdir in install for multilib-strict wrt #423381 by Michael
297 Palimaka
298
299 *polkit-0.106-r3 (25 Jun 2012)
300
301 25 Jun 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
302 +polkit-0.106-r3.ebuild:
303 pax-mark polkitd to fix crashes on hardened/PaX systems.
304
305 23 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
306 Convert pkg_postinst() message about polkitd home directory to new
307 user.eclass function esethome().
308
309 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
310 Check for mozjs187.pc for >=dev-lang/spidermonkey-1.8.7 compability.
311
312 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
313 Adapt to sys-auth/pambase with USE="systemd" wrt #372229 by Michał Górny
314
315 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r1.ebuild:
316 old
317
318 *polkit-0.106-r2 (17 Jun 2012)
319
320 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r2.ebuild:
321 Revision bump to chown /var/lib/polkit-1 because diropts has no effect on
322 existing directories.
323
324 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106.ebuild:
325 old
326
327 *polkit-0.106-r1 (17 Jun 2012)
328
329 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r1.ebuild:
330 Update /etc/pam.d/polkit-1 from system-login to system-local-login. Use
331 unix-group "adm" for administrators. Use /var/lib/polkit-1 as home directory
332 for unix-user polkitd. Update owners of /etc/polkit-1/rules.d and
333 /usr/share/polkit-1/rules.d to polkitd:root wrt #420269.
334
335 13 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106.ebuild:
336 Pull in dev-lang/spidermonkey >= 1.8.5 and dev-libs/glib >= 2.32 wrt
337 #420173 and #420307.
338
339 *polkit-0.106 (07 Jun 2012)
340
341 07 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106.ebuild:
342 Version bump.
343
344 20 May 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.105.ebuild:
345 Improve systemd handling wrt #416317 by Christoph Brill
346
347 *polkit-0.105 (14 May 2012)
348
349 14 May 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.105.ebuild:
350 Version bump.
351
352 04 May 2012; Jeff Horelick <jdhore@gentoo.org> polkit-0.104-r1.ebuild:
353 dev-util/pkgconfig -> virtual/pkgconfig
354
355 18 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.102.ebuild,
356 -polkit-0.103.ebuild, -polkit-0.104.ebuild:
357 old
358
359 25 Mar 2012; Raúl Porcel <armin76@gentoo.org> polkit-0.104-r1.ebuild:
360 ia64/sh/sparc stable wrt #401513
361
362 09 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.104-r1.ebuild:
363 ppc/ppc64 stable wrt #401513
364
365 17 Feb 2012; Tobias Klausmann <klausman@gentoo.org> polkit-0.104-r1.ebuild:
366 Stable on alpha, bug #401513
367
368 17 Feb 2012; Thomas Kahle <tomka@gentoo.org> polkit-0.104-r1.ebuild:
369 marked x86 per bug 401513
370
371 13 Feb 2012; Markus Meier <maekke@gentoo.org> polkit-0.104-r1.ebuild:
372 arm stable, bug #401513
373
374 02 Feb 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild:
375 Stable for HPPA (bug #401513).
376
377 30 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.104-r1.ebuild:
378 Stable for AMD64, wrt security bug #401513
379
380 *polkit-0.104-r1 (30 Jan 2012)
381
382 30 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104-r1.ebuild:
383 Restore the default value of AdminIdentities from "wheel" to "0" like it was
384 in polkit-0.102 and ones before that. You should see files
385 50-localauthority.conf and 60-gentoo.conf in
386 /etc/polkit-1/localauthority.conf.d. You should also familiarize yourself
387 with "man 8 pklocalauthority" as soon as possible.
388
389 29 Jan 2012; Markus Meier <maekke@gentoo.org> polkit-0.103.ebuild:
390 arm stable, bug #397755
391
392 07 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.103.ebuild:
393 Stable for AMD64, wrt bug #397755
394
395 *polkit-0.104 (05 Jan 2012)
396
397 05 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104.ebuild,
398 metadata.xml:
399 Version bump.
400
401 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.101-r1.ebuild:
402 old
403
404 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.102.ebuild:
405 ppc/ppc64 stable wrt #387163
406
407 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild:
408 Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo
409
410 *polkit-0.103 (07 Dec 2011)
411
412 07 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.103.ebuild:
413 Version bump. Remove unrequired keepdir of /var/run/polkit-1 wrt #387903 by
414 "i.Dark_Templar"
415
416 05 Nov 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.102.ebuild:
417 alpha/arm/ia64/sh/sparc stable wrt #387163
418
419 29 Oct 2011; Markus Meier <maekke@gentoo.org> polkit-0.102.ebuild:
420 arm stable, bug #387163
421
422 19 Oct 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.102.ebuild:
423 Stable for HPPA (bug #387163).
424
425 18 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> polkit-0.102.ebuild:
426 x86 stable wrt bug #387163
427
428 15 Oct 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.102.ebuild:
429 Stable on amd64 wrt bug #387163
430
431 28 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101-r1.ebuild,
432 polkit-0.102.ebuild:
433 pambase[consolekit] support is needed to use polkit with pam, add to PDEPEND
434
435 *polkit-0.102 (06 Aug 2011)
436
437 06 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.102.ebuild:
438 Version bump.
439
440 10 Jul 2011; Matt Turner <mattst88@gentoo.org> polkit-0.101-r1.ebuild:
441 Added ~mips, bug 296548
442
443 14 May 2011; Gilles Dartiguelongue <eva@gentoo.org> polkit-0.101-r1.ebuild:
444 Add missing dtd to DEPEND, bug #355505.
445
446 30 Apr 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.101-r1.ebuild:
447 alpha/arm/ia64/sh/sparc stable wrt #364973
448
449 28 Apr 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
450 polkit-0.101-r1.ebuild:
451 x86 stable wrt security bug #364973
452
453 27 Apr 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.101-r1.ebuild:
454 Stable for HPPA (bug #364973).
455
456 27 Apr 2011; Christoph Mende <angelos@gentoo.org> polkit-0.101-r1.ebuild:
457 Stable on amd64 wrt bug #364973
458
459 27 Apr 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.101-r1.ebuild:
460 ppc/ppc64 stable wrt #364973
461
462 *polkit-0.101-r1 (25 Apr 2011)
463
464 25 Apr 2011; Nirbheek Chauhan <nirbheek@gentoo.org> -polkit-0.100.ebuild,
465 +polkit-0.101-r1.ebuild:
466 Add patches for CVE-2011-1485, remove vulnerable 0.100 version
467
468 22 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.99-r1.ebuild:
469 ppc/ppc64 stable wrt #354509
470
471 19 Mar 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.99-r1.ebuild:
472 alpha/ia64/sh/sparc stable wrt #354509
473
474 15 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101.ebuild:
475 PDEPEND on 0.101 version of polkit-gnome
476
477 13 Mar 2011; Markus Meier <maekke@gentoo.org> polkit-0.99-r1.ebuild:
478 arm stable, bug #354509
479
480 *polkit-0.101 (11 Mar 2011)
481
482 11 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.101.ebuild:
483 Version bump.
484
485 07 Mar 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
486 Stable for HPPA (bug #354509).
487
488 04 Mar 2011; Thomas Kahle <tomka@gentoo.org> polkit-0.99-r1.ebuild:
489 x86 stable per bug 354509
490
491 23 Feb 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.99-r1.ebuild:
492 Stable on amd64 wrt bug #354509
493
494 *polkit-0.100 (23 Feb 2011)
495
496 23 Feb 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.100.ebuild:
497 Bump to 0.100
498
499 24 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.99-r1.ebuild:
500 USE="kde" to pull in authentication agent for KDE.
501
502 21 Jan 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
503 Marked ~hppa (bug #296548).
504
505 *polkit-0.99-r1 (25 Dec 2010)
506
507 25 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.99-r1.ebuild:
508 Revision bump to remove static archives (.a) and libtool archives (.la).
509 USE="gtk" to pull in authentication agent for GTK+ based desktops.
510
511 *polkit-0.99 (25 Sep 2010)
512
513 25 Sep 2010; <nirbheek@gentoo.org> +polkit-0.99.ebuild:
514 Bump to 0.99, masked due to >=glib-2.25 requirement
515
516 18 Aug 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
517 arm stable, bug #314899
518
519 14 Aug 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96-r1.ebuild,
520 polkit-0.96-r2.ebuild:
521 alpha/ia64/sh/sparc stable
522
523 09 Aug 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96-r1.ebuild:
524 Marked ppc/ppc64 stable.
525
526 25 Jul 2010; Tobias Klausmann <klausman@gentoo.org> polkit-0.96-r2.ebuild:
527 Stable on alpha, bug #329621
528
529 20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
530 polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
531 Stable for HPPA (bug #314899).
532
533 20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
534 polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
535 Drop HPPA keywording (bug #324511).
536
537 07 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96-r1.ebuild,
538 polkit-0.96-r2.ebuild:
539 Add ewarn about ensuring that consolekit sessions are working. Either the
540 user needs to login using a login-manager with consolekit support, or use
541 ck-launch-session to launch the DE as suggested in bug 291116 comment 13
542
543 *polkit-0.96-r2 (02 Jul 2010)
544
545 02 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
546 +polkit-0.96-r2.ebuild, metadata.xml:
547 USE=expat was quite useless, expat is mandatory in polkit. Don't create
548 user 'polkituser', it was used by policykit, but isn't by polkit. Also,
549 add introspection support
550
551 04 Jun 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
552 x86 stable, bug #314899
553
554 03 May 2010; Olivier Crête <tester@gentoo.org> polkit-0.96-r1.ebuild:
555 amd64 stable, bug #314899
556
557 25 Apr 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild,
558 polkit-0.96-r1.ebuild:
559 Add ~sh
560
561 13 Apr 2010; Alexis Ballier <aballier@gentoo.org> polkit-0.96-r1.ebuild,
562 +files/polkit-0.96-getcwd.patch:
563 Fix build on fbsd and keyword it x86-fbsd
564
565 25 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild,
566 polkit-0.96-r1.ebuild:
567 Raise gtk-doc{,-am} dependencies. Fixes bug 311085
568
569 21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
570 -files/polkit-0.93-fix-daemon-name.patch, -polkit-0.94.ebuild,
571 -polkit-0.95.ebuild:
572 Remove old
573
574 *polkit-0.96-r1 (21 Mar 2010)
575
576 21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
577 +polkit-0.96-r1.ebuild:
578 Update with newer version of polkit-shadow patch
579
580 07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
581 Fix minor problems with SRC_URI
582
583 07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
584 Add experimental shadow support, bug 291116 . Patch thanks to the
585 slackware folks.
586
587 28 Feb 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild:
588 Add ~alpha/~arm/~ia64/~sparc
589
590 16 Feb 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96.ebuild:
591 Marked ~ppc/~ppc64 for bug #296548.
592
593 *polkit-0.96 (23 Jan 2010)
594
595 23 Jan 2010; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.96.ebuild:
596 Version bump to 0.96; lots of bugfixes, see NEWS
597
598 06 Jan 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.95.ebuild:
599 Marked ~hppa (bug #296548).
600
601 11 Dec 2009; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.95.ebuild:
602 Add sys-auth/consolekit-0.4.0[polkit] to PDEPEND; needed for checking if
603 the user is in an active/local session via dbus methods
604
605 *polkit-0.95 (14 Nov 2009)
606
607 14 Nov 2009; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.95.ebuild:
608 Bump to 0.95 -- new lockdown API, last dev version till 1.0
609
610 30 Oct 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
611 -files/polkit-0.92-zsh-completions.patch, polkit-0.94.ebuild:
612 Remove zsh-completion (bug 291114), force pam support on (bug 291116)
613
614 *polkit-0.94 (29 Oct 2009)
615
616 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
617 +files/polkit-0.92-zsh-completions.patch,
618 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
619 +metadata.xml:
620 Initial ebuild for GNOME 2.28.

  ViewVC Help
Powered by ViewVC 1.1.20