/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Contents of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.168 - (show annotations) (download)
Sat Mar 15 12:17:34 2014 UTC (3 years, 7 months ago) by ssuominen
Branch: MAIN
Changes since 1.167: +6 -1 lines
USE="jit" to determine which pax-mark, if any, should be applied wrt #485910

(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)

1 # ChangeLog for sys-auth/polkit
2 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.167 2014/03/11 20:08:55 pacho Exp $
4
5 *polkit-0.112-r2 (15 Mar 2014)
6
7 15 Mar 2014; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.112-r2.ebuild:
8 USE="jit" to determine which pax-mark, if any, should be applied wrt #485910
9
10 11 Mar 2014; Pacho Ramos <pacho@gentoo.org> metadata.xml:
11 Cleanup due #239126
12
13 25 Feb 2014; Markus Meier <maekke@gentoo.org> polkit-0.112-r1.ebuild:
14 arm stable, bug #500758
15
16 23 Feb 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r1.ebuild:
17 x86 stable, bug #500758
18
19 23 Feb 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r1.ebuild:
20 amd64 stable, bug #500758
21
22 28 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
23 Fix ia64 where the order of the configure options was overridden by mips,
24 thanks Arfrever
25
26 27 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
27 Because sometimes portage is stupid
28
29 24 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
30 Fix dependence on spidermonkey for mips, bug #495168
31
32 23 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
33 Stable for sparc, wrt bug #484486
34
35 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
36 Stable for alpha, wrt bug #484486
37
38 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
39 Stable for ia64, wrt bug #484486
40
41 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
42 Stable for ppc64, wrt bug #484486
43
44 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
45 Stable for ppc, wrt bug #484486
46
47 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
48 Stable for arm, wrt bug #484486
49
50 21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
51 Stable for x86, wrt bug #484486
52
53 21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
54 Stable for amd64, wrt bug #484486
55
56 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.110-r1.ebuild,
57 -files/polkit-0.110-CVE-2013-4288.patch:
58 old
59
60 *polkit-0.112-r1 (19 Sep 2013)
61
62 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.112-r1.ebuild,
63 polkit-0.112.ebuild:
64 -r0 is for stabilization w/ mozjs185 and -r1 is for ~arch with mozjs 17.0
65
66 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> -polkit-0.111-r1.ebuild:
67 Remove vulnerable version
68
69 *polkit-0.110-r1 (19 Sep 2013)
70
71 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org>
72 +files/polkit-0.110-CVE-2013-4288.patch, +polkit-0.110-r1.ebuild:
73 Bump for CVE-2013-4288
74
75 *polkit-0.112 (19 Sep 2013)
76
77 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> +polkit-0.112.ebuild:
78 Bump for CVE-2013-4288
79
80 10 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
81 polkit-0.111-r1.ebuild:
82 Stop forcing USE="consolekit systemd" for sys-auth/pambase in PDEPEND because
83 CONFIG_AUDITSYSCALL=y is not possible on every arch and the dependency was
84 always more about convinience than being strict requirement.
85
86 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> -polkit-0.111.ebuild:
87 dropped polkit-111 in favour of -r1 now that spidermonkey-17 is unmasked, as
88 per ssuominen's approval
89
90 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> polkit-0.110.ebuild,
91 polkit-0.111-r1.ebuild:
92 Adjusted deps for dev-lang/spidermonkey to ensure SLOT=0
93
94 *polkit-0.111-r1 (08 Aug 2013)
95
96 08 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111-r1.ebuild:
97 Force use of dev-lang/spidermonkey:17 because automagic dependencies are bad.
98
99 *polkit-0.111 (15 May 2013)
100
101 15 May 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111.ebuild:
102 Version bump by "okias" from Freenode
103
104 19 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107-r1.ebuild,
105 -files/polkit-0.107-fallback.patch:
106 old
107
108 19 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
109 Stable for sh, wrt bug #452688
110
111 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
112 files/polkit-0.110-W_define.patch:
113 Include link to upstream bug.
114
115 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
116 +files/polkit-0.110-W_define.patch:
117 Fix missing #include <sys/wait.h> for #define's of WIFEXITED, WEXITSTATUS,
118 WIFSIGNALED and WTERMSIG (to fix building on arch "sh")
119
120 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
121 Stable for sparc, wrt bug #452688
122
123 03 Mar 2013; Mike Frysinger <vapier@gentoo.org> polkit-0.110.ebuild:
124 Add s390 keywords #457078 by Michael Palimaka.
125
126 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
127 Stable for alpha, wrt bug #452688
128
129 10 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
130 Stable for ppc64, wrt bug #452688
131
132 09 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
133 Stable for ia64, wrt bug #452688
134
135 31 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
136 Stable for ppc, wrt bug #452688
137
138 29 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
139 Force USE="debug" to be disabled in dev-lang/spidermonkey to avoid asseration
140 errors as noted by _AxS_.
141
142 26 Jan 2013; Markus Meier <maekke@gentoo.org> polkit-0.110.ebuild:
143 arm stable, bug #452688
144
145 20 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
146 x86 stable wrt #452688
147
148 19 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
149 amd64 stable wrt #452688
150
151 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.104-r1.ebuild,
152 -polkit-0.109-r1.ebuild, -files/polkit-0.109-XAUTHORITY-fallback.patch:
153 old
154
155 *polkit-0.110 (11 Jan 2013)
156
157 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.110.ebuild:
158 Version bump.
159
160 06 Jan 2013; Raúl Porcel <armin76@gentoo.org> polkit-0.107-r1.ebuild,
161 polkit-0.109-r1.ebuild:
162 Add ~sh wrt #436668
163
164 01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.109-r1.ebuild:
165 Add ~ia64, wrt bug #436668
166
167 30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
168 Stable for sparc, wrt bug #436666
169
170 29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
171 Stable for alpha, wrt bug #436666
172
173 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.108.ebuild,
174 -polkit-0.109.ebuild:
175 old
176
177 *polkit-0.109-r1 (21 Dec 2012)
178
179 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109-r1.ebuild,
180 +files/polkit-0.109-XAUTHORITY-fallback.patch:
181 Backport XAUTHORITY fallback support from upstream git.
182
183 19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.108.ebuild:
184 Add ~ia64, wrt bug #436668
185
186 *polkit-0.109 (19 Dec 2012)
187
188 19 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109.ebuild:
189 Version bump. Fix PaX marking logic wrt #444446 by Maxim Kammerer
190
191 18 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
192 Stable for ia64, wrt bug #436666
193
194 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
195 stable arm, bug #436666
196
197 22 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107.ebuild:
198 old
199
200 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
201 stable ppc64, bug #436666
202
203 22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
204 Stable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt
205 bug #436666
206
207 21 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
208 stable ppc, bug #436666, thanks peratu
209
210 19 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.108.ebuild:
211 Link against -lgmodule-2.0 to prevent underlinking (backported from upstream,
212 but using sed to avoid eautoreconf) wrt #443798
213
214 *polkit-0.108 (18 Nov 2012)
215
216 18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
217 Version bump.
218
219 28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
220 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
221 Drop ~x86-fbsd due to bug #439968.
222
223 15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
224 polkit-0.107-r1.ebuild:
225 Drop HPPA keywording (bug #438368).
226
227 15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
228 Set QA_MULTILIB_PATHS for bug #424423.
229
230 09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
231 Marked ~hppa (bug #436668).
232
233 08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
234 Use pax-mark in src_compile() instead of src_install() for src_test() wrt
235 #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
236 and emphatize it's an Portage issue instead of polkit issue in src_install()
237 message.
238
239 07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
240 Stable for amd64, wrt bug #436666
241
242 *polkit-0.107-r1 (20 Sep 2012)
243
244 20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
245 +files/polkit-0.107-fallback.patch:
246 Introduce upstream patch for falling back to uid 0 for authentication if list
247 of admin identities is empty.
248
249 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
250 -polkit-0.106-r7.ebuild:
251 old
252
253 *polkit-0.107 (13 Jul 2012)
254
255 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
256 Version bump.
257
258 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
259 -polkit-0.106-r6.ebuild:
260 old
261
262 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
263 Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
264 #391865 by Maksim Melnikau
265
266 *polkit-0.106-r7 (02 Jul 2012)
267
268 02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
269 RESTRICT="multilib-strict" since it's not compatible with the whole
270 /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
271 polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
272
273 *polkit-0.106-r6 (01 Jul 2012)
274
275 01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
276 Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
277 /usr/lib to /usr/lib64 symlink.
278
279 30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
280 polkit-0.106-r5.ebuild:
281 Adding dependency on SELinux policykit module if USE=selinux is set
282
283 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
284 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
285 'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
286
287 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
288 -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
289 old
290
291 *polkit-0.106-r5 (27 Jun 2012)
292
293 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
294 Revert entire unix-group:wheel experiment back to unix-user:0 because
295 PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
296 Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
297 by Doug Goldstein.
298
299 *polkit-0.106-r4 (27 Jun 2012)
300
301 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
302 Stop installing polkit-backend-1.pc because upstream changed
303 libpolkit-backend-1.la to be noinst_LTLIBRARIES in
304 src/polkitbackend/Makefile.am wrt #423431 by Pim Vullers
305
306 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r3.ebuild:
307 Redefine libprivdir in install for multilib-strict wrt #423381 by Michael
308 Palimaka
309
310 *polkit-0.106-r3 (25 Jun 2012)
311
312 25 Jun 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
313 +polkit-0.106-r3.ebuild:
314 pax-mark polkitd to fix crashes on hardened/PaX systems.
315
316 23 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
317 Convert pkg_postinst() message about polkitd home directory to new
318 user.eclass function esethome().
319
320 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
321 Check for mozjs187.pc for >=dev-lang/spidermonkey-1.8.7 compability.
322
323 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
324 Adapt to sys-auth/pambase with USE="systemd" wrt #372229 by Michał Górny
325
326 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r1.ebuild:
327 old
328
329 *polkit-0.106-r2 (17 Jun 2012)
330
331 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r2.ebuild:
332 Revision bump to chown /var/lib/polkit-1 because diropts has no effect on
333 existing directories.
334
335 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106.ebuild:
336 old
337
338 *polkit-0.106-r1 (17 Jun 2012)
339
340 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r1.ebuild:
341 Update /etc/pam.d/polkit-1 from system-login to system-local-login. Use
342 unix-group "adm" for administrators. Use /var/lib/polkit-1 as home directory
343 for unix-user polkitd. Update owners of /etc/polkit-1/rules.d and
344 /usr/share/polkit-1/rules.d to polkitd:root wrt #420269.
345
346 13 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106.ebuild:
347 Pull in dev-lang/spidermonkey >= 1.8.5 and dev-libs/glib >= 2.32 wrt
348 #420173 and #420307.
349
350 *polkit-0.106 (07 Jun 2012)
351
352 07 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106.ebuild:
353 Version bump.
354
355 20 May 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.105.ebuild:
356 Improve systemd handling wrt #416317 by Christoph Brill
357
358 *polkit-0.105 (14 May 2012)
359
360 14 May 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.105.ebuild:
361 Version bump.
362
363 04 May 2012; Jeff Horelick <jdhore@gentoo.org> polkit-0.104-r1.ebuild:
364 dev-util/pkgconfig -> virtual/pkgconfig
365
366 18 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.102.ebuild,
367 -polkit-0.103.ebuild, -polkit-0.104.ebuild:
368 old
369
370 25 Mar 2012; Raúl Porcel <armin76@gentoo.org> polkit-0.104-r1.ebuild:
371 ia64/sh/sparc stable wrt #401513
372
373 09 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.104-r1.ebuild:
374 ppc/ppc64 stable wrt #401513
375
376 17 Feb 2012; Tobias Klausmann <klausman@gentoo.org> polkit-0.104-r1.ebuild:
377 Stable on alpha, bug #401513
378
379 17 Feb 2012; Thomas Kahle <tomka@gentoo.org> polkit-0.104-r1.ebuild:
380 marked x86 per bug 401513
381
382 13 Feb 2012; Markus Meier <maekke@gentoo.org> polkit-0.104-r1.ebuild:
383 arm stable, bug #401513
384
385 02 Feb 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild:
386 Stable for HPPA (bug #401513).
387
388 30 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.104-r1.ebuild:
389 Stable for AMD64, wrt security bug #401513
390
391 *polkit-0.104-r1 (30 Jan 2012)
392
393 30 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104-r1.ebuild:
394 Restore the default value of AdminIdentities from "wheel" to "0" like it was
395 in polkit-0.102 and ones before that. You should see files
396 50-localauthority.conf and 60-gentoo.conf in
397 /etc/polkit-1/localauthority.conf.d. You should also familiarize yourself
398 with "man 8 pklocalauthority" as soon as possible.
399
400 29 Jan 2012; Markus Meier <maekke@gentoo.org> polkit-0.103.ebuild:
401 arm stable, bug #397755
402
403 07 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.103.ebuild:
404 Stable for AMD64, wrt bug #397755
405
406 *polkit-0.104 (05 Jan 2012)
407
408 05 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104.ebuild,
409 metadata.xml:
410 Version bump.
411
412 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.101-r1.ebuild:
413 old
414
415 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.102.ebuild:
416 ppc/ppc64 stable wrt #387163
417
418 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild:
419 Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo
420
421 *polkit-0.103 (07 Dec 2011)
422
423 07 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.103.ebuild:
424 Version bump. Remove unrequired keepdir of /var/run/polkit-1 wrt #387903 by
425 "i.Dark_Templar"
426
427 05 Nov 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.102.ebuild:
428 alpha/arm/ia64/sh/sparc stable wrt #387163
429
430 29 Oct 2011; Markus Meier <maekke@gentoo.org> polkit-0.102.ebuild:
431 arm stable, bug #387163
432
433 19 Oct 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.102.ebuild:
434 Stable for HPPA (bug #387163).
435
436 18 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> polkit-0.102.ebuild:
437 x86 stable wrt bug #387163
438
439 15 Oct 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.102.ebuild:
440 Stable on amd64 wrt bug #387163
441
442 28 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101-r1.ebuild,
443 polkit-0.102.ebuild:
444 pambase[consolekit] support is needed to use polkit with pam, add to PDEPEND
445
446 *polkit-0.102 (06 Aug 2011)
447
448 06 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.102.ebuild:
449 Version bump.
450
451 10 Jul 2011; Matt Turner <mattst88@gentoo.org> polkit-0.101-r1.ebuild:
452 Added ~mips, bug 296548
453
454 14 May 2011; Gilles Dartiguelongue <eva@gentoo.org> polkit-0.101-r1.ebuild:
455 Add missing dtd to DEPEND, bug #355505.
456
457 30 Apr 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.101-r1.ebuild:
458 alpha/arm/ia64/sh/sparc stable wrt #364973
459
460 28 Apr 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
461 polkit-0.101-r1.ebuild:
462 x86 stable wrt security bug #364973
463
464 27 Apr 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.101-r1.ebuild:
465 Stable for HPPA (bug #364973).
466
467 27 Apr 2011; Christoph Mende <angelos@gentoo.org> polkit-0.101-r1.ebuild:
468 Stable on amd64 wrt bug #364973
469
470 27 Apr 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.101-r1.ebuild:
471 ppc/ppc64 stable wrt #364973
472
473 *polkit-0.101-r1 (25 Apr 2011)
474
475 25 Apr 2011; Nirbheek Chauhan <nirbheek@gentoo.org> -polkit-0.100.ebuild,
476 +polkit-0.101-r1.ebuild:
477 Add patches for CVE-2011-1485, remove vulnerable 0.100 version
478
479 22 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.99-r1.ebuild:
480 ppc/ppc64 stable wrt #354509
481
482 19 Mar 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.99-r1.ebuild:
483 alpha/ia64/sh/sparc stable wrt #354509
484
485 15 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101.ebuild:
486 PDEPEND on 0.101 version of polkit-gnome
487
488 13 Mar 2011; Markus Meier <maekke@gentoo.org> polkit-0.99-r1.ebuild:
489 arm stable, bug #354509
490
491 *polkit-0.101 (11 Mar 2011)
492
493 11 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.101.ebuild:
494 Version bump.
495
496 07 Mar 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
497 Stable for HPPA (bug #354509).
498
499 04 Mar 2011; Thomas Kahle <tomka@gentoo.org> polkit-0.99-r1.ebuild:
500 x86 stable per bug 354509
501
502 23 Feb 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.99-r1.ebuild:
503 Stable on amd64 wrt bug #354509
504
505 *polkit-0.100 (23 Feb 2011)
506
507 23 Feb 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.100.ebuild:
508 Bump to 0.100
509
510 24 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.99-r1.ebuild:
511 USE="kde" to pull in authentication agent for KDE.
512
513 21 Jan 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
514 Marked ~hppa (bug #296548).
515
516 *polkit-0.99-r1 (25 Dec 2010)
517
518 25 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.99-r1.ebuild:
519 Revision bump to remove static archives (.a) and libtool archives (.la).
520 USE="gtk" to pull in authentication agent for GTK+ based desktops.
521
522 *polkit-0.99 (25 Sep 2010)
523
524 25 Sep 2010; <nirbheek@gentoo.org> +polkit-0.99.ebuild:
525 Bump to 0.99, masked due to >=glib-2.25 requirement
526
527 18 Aug 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
528 arm stable, bug #314899
529
530 14 Aug 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96-r1.ebuild,
531 polkit-0.96-r2.ebuild:
532 alpha/ia64/sh/sparc stable
533
534 09 Aug 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96-r1.ebuild:
535 Marked ppc/ppc64 stable.
536
537 25 Jul 2010; Tobias Klausmann <klausman@gentoo.org> polkit-0.96-r2.ebuild:
538 Stable on alpha, bug #329621
539
540 20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
541 polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
542 Stable for HPPA (bug #314899).
543
544 20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
545 polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
546 Drop HPPA keywording (bug #324511).
547
548 07 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96-r1.ebuild,
549 polkit-0.96-r2.ebuild:
550 Add ewarn about ensuring that consolekit sessions are working. Either the
551 user needs to login using a login-manager with consolekit support, or use
552 ck-launch-session to launch the DE as suggested in bug 291116 comment 13
553
554 *polkit-0.96-r2 (02 Jul 2010)
555
556 02 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
557 +polkit-0.96-r2.ebuild, metadata.xml:
558 USE=expat was quite useless, expat is mandatory in polkit. Don't create
559 user 'polkituser', it was used by policykit, but isn't by polkit. Also,
560 add introspection support
561
562 04 Jun 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
563 x86 stable, bug #314899
564
565 03 May 2010; Olivier Crête <tester@gentoo.org> polkit-0.96-r1.ebuild:
566 amd64 stable, bug #314899
567
568 25 Apr 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild,
569 polkit-0.96-r1.ebuild:
570 Add ~sh
571
572 13 Apr 2010; Alexis Ballier <aballier@gentoo.org> polkit-0.96-r1.ebuild,
573 +files/polkit-0.96-getcwd.patch:
574 Fix build on fbsd and keyword it x86-fbsd
575
576 25 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild,
577 polkit-0.96-r1.ebuild:
578 Raise gtk-doc{,-am} dependencies. Fixes bug 311085
579
580 21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
581 -files/polkit-0.93-fix-daemon-name.patch, -polkit-0.94.ebuild,
582 -polkit-0.95.ebuild:
583 Remove old
584
585 *polkit-0.96-r1 (21 Mar 2010)
586
587 21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
588 +polkit-0.96-r1.ebuild:
589 Update with newer version of polkit-shadow patch
590
591 07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
592 Fix minor problems with SRC_URI
593
594 07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
595 Add experimental shadow support, bug 291116 . Patch thanks to the
596 slackware folks.
597
598 28 Feb 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild:
599 Add ~alpha/~arm/~ia64/~sparc
600
601 16 Feb 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96.ebuild:
602 Marked ~ppc/~ppc64 for bug #296548.
603
604 *polkit-0.96 (23 Jan 2010)
605
606 23 Jan 2010; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.96.ebuild:
607 Version bump to 0.96; lots of bugfixes, see NEWS
608
609 06 Jan 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.95.ebuild:
610 Marked ~hppa (bug #296548).
611
612 11 Dec 2009; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.95.ebuild:
613 Add sys-auth/consolekit-0.4.0[polkit] to PDEPEND; needed for checking if
614 the user is in an active/local session via dbus methods
615
616 *polkit-0.95 (14 Nov 2009)
617
618 14 Nov 2009; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.95.ebuild:
619 Bump to 0.95 -- new lockdown API, last dev version till 1.0
620
621 30 Oct 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
622 -files/polkit-0.92-zsh-completions.patch, polkit-0.94.ebuild:
623 Remove zsh-completion (bug 291114), force pam support on (bug 291116)
624
625 *polkit-0.94 (29 Oct 2009)
626
627 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
628 +files/polkit-0.92-zsh-completions.patch,
629 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
630 +metadata.xml:
631 Initial ebuild for GNOME 2.28.

  ViewVC Help
Powered by ViewVC 1.1.20