/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Contents of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.171 - (show annotations) (download)
Sat May 10 13:40:54 2014 UTC (4 years, 1 month ago) by ago
Branch: MAIN
Changes since 1.170: +4 -1 lines
Stable for ppc, wrt bug #508862

(Portage version: 2.2.8-r1/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 7194459F)

1 # ChangeLog for sys-auth/polkit
2 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.170 2014/04/06 15:39:36 pacho Exp $
4
5 10 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
6 Stable for ppc, wrt bug #508862
7
8 06 Apr 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r2.ebuild:
9 Needs to be rebuilt with systemd subslot bumps
10
11 15 Mar 2014; Samuli Suominen <ssuominen@gentoo.org> metadata.xml:
12 Add proper metadata for freedesktop-bugs@g.o
13
14 *polkit-0.112-r2 (15 Mar 2014)
15
16 15 Mar 2014; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.112-r2.ebuild:
17 USE="jit" to determine which pax-mark, if any, should be applied wrt #485910
18
19 11 Mar 2014; Pacho Ramos <pacho@gentoo.org> metadata.xml:
20 Cleanup due #239126
21
22 25 Feb 2014; Markus Meier <maekke@gentoo.org> polkit-0.112-r1.ebuild:
23 arm stable, bug #500758
24
25 23 Feb 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r1.ebuild:
26 x86 stable, bug #500758
27
28 23 Feb 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r1.ebuild:
29 amd64 stable, bug #500758
30
31 28 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
32 Fix ia64 where the order of the configure options was overridden by mips,
33 thanks Arfrever
34
35 27 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
36 Because sometimes portage is stupid
37
38 24 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
39 Fix dependence on spidermonkey for mips, bug #495168
40
41 23 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
42 Stable for sparc, wrt bug #484486
43
44 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
45 Stable for alpha, wrt bug #484486
46
47 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
48 Stable for ia64, wrt bug #484486
49
50 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
51 Stable for ppc64, wrt bug #484486
52
53 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
54 Stable for ppc, wrt bug #484486
55
56 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
57 Stable for arm, wrt bug #484486
58
59 21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
60 Stable for x86, wrt bug #484486
61
62 21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
63 Stable for amd64, wrt bug #484486
64
65 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.110-r1.ebuild,
66 -files/polkit-0.110-CVE-2013-4288.patch:
67 old
68
69 *polkit-0.112-r1 (19 Sep 2013)
70
71 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.112-r1.ebuild,
72 polkit-0.112.ebuild:
73 -r0 is for stabilization w/ mozjs185 and -r1 is for ~arch with mozjs 17.0
74
75 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> -polkit-0.111-r1.ebuild:
76 Remove vulnerable version
77
78 *polkit-0.110-r1 (19 Sep 2013)
79
80 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org>
81 +files/polkit-0.110-CVE-2013-4288.patch, +polkit-0.110-r1.ebuild:
82 Bump for CVE-2013-4288
83
84 *polkit-0.112 (19 Sep 2013)
85
86 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> +polkit-0.112.ebuild:
87 Bump for CVE-2013-4288
88
89 10 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
90 polkit-0.111-r1.ebuild:
91 Stop forcing USE="consolekit systemd" for sys-auth/pambase in PDEPEND because
92 CONFIG_AUDITSYSCALL=y is not possible on every arch and the dependency was
93 always more about convinience than being strict requirement.
94
95 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> -polkit-0.111.ebuild:
96 dropped polkit-111 in favour of -r1 now that spidermonkey-17 is unmasked, as
97 per ssuominen's approval
98
99 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> polkit-0.110.ebuild,
100 polkit-0.111-r1.ebuild:
101 Adjusted deps for dev-lang/spidermonkey to ensure SLOT=0
102
103 *polkit-0.111-r1 (08 Aug 2013)
104
105 08 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111-r1.ebuild:
106 Force use of dev-lang/spidermonkey:17 because automagic dependencies are bad.
107
108 *polkit-0.111 (15 May 2013)
109
110 15 May 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111.ebuild:
111 Version bump by "okias" from Freenode
112
113 19 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107-r1.ebuild,
114 -files/polkit-0.107-fallback.patch:
115 old
116
117 19 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
118 Stable for sh, wrt bug #452688
119
120 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
121 files/polkit-0.110-W_define.patch:
122 Include link to upstream bug.
123
124 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
125 +files/polkit-0.110-W_define.patch:
126 Fix missing #include <sys/wait.h> for #define's of WIFEXITED, WEXITSTATUS,
127 WIFSIGNALED and WTERMSIG (to fix building on arch "sh")
128
129 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
130 Stable for sparc, wrt bug #452688
131
132 03 Mar 2013; Mike Frysinger <vapier@gentoo.org> polkit-0.110.ebuild:
133 Add s390 keywords #457078 by Michael Palimaka.
134
135 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
136 Stable for alpha, wrt bug #452688
137
138 10 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
139 Stable for ppc64, wrt bug #452688
140
141 09 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
142 Stable for ia64, wrt bug #452688
143
144 31 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
145 Stable for ppc, wrt bug #452688
146
147 29 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
148 Force USE="debug" to be disabled in dev-lang/spidermonkey to avoid asseration
149 errors as noted by _AxS_.
150
151 26 Jan 2013; Markus Meier <maekke@gentoo.org> polkit-0.110.ebuild:
152 arm stable, bug #452688
153
154 20 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
155 x86 stable wrt #452688
156
157 19 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
158 amd64 stable wrt #452688
159
160 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.104-r1.ebuild,
161 -polkit-0.109-r1.ebuild, -files/polkit-0.109-XAUTHORITY-fallback.patch:
162 old
163
164 *polkit-0.110 (11 Jan 2013)
165
166 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.110.ebuild:
167 Version bump.
168
169 06 Jan 2013; Raúl Porcel <armin76@gentoo.org> polkit-0.107-r1.ebuild,
170 polkit-0.109-r1.ebuild:
171 Add ~sh wrt #436668
172
173 01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.109-r1.ebuild:
174 Add ~ia64, wrt bug #436668
175
176 30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
177 Stable for sparc, wrt bug #436666
178
179 29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
180 Stable for alpha, wrt bug #436666
181
182 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.108.ebuild,
183 -polkit-0.109.ebuild:
184 old
185
186 *polkit-0.109-r1 (21 Dec 2012)
187
188 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109-r1.ebuild,
189 +files/polkit-0.109-XAUTHORITY-fallback.patch:
190 Backport XAUTHORITY fallback support from upstream git.
191
192 19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.108.ebuild:
193 Add ~ia64, wrt bug #436668
194
195 *polkit-0.109 (19 Dec 2012)
196
197 19 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109.ebuild:
198 Version bump. Fix PaX marking logic wrt #444446 by Maxim Kammerer
199
200 18 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
201 Stable for ia64, wrt bug #436666
202
203 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
204 stable arm, bug #436666
205
206 22 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107.ebuild:
207 old
208
209 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
210 stable ppc64, bug #436666
211
212 22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
213 Stable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt
214 bug #436666
215
216 21 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
217 stable ppc, bug #436666, thanks peratu
218
219 19 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.108.ebuild:
220 Link against -lgmodule-2.0 to prevent underlinking (backported from upstream,
221 but using sed to avoid eautoreconf) wrt #443798
222
223 *polkit-0.108 (18 Nov 2012)
224
225 18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
226 Version bump.
227
228 28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
229 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
230 Drop ~x86-fbsd due to bug #439968.
231
232 15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
233 polkit-0.107-r1.ebuild:
234 Drop HPPA keywording (bug #438368).
235
236 15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
237 Set QA_MULTILIB_PATHS for bug #424423.
238
239 09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
240 Marked ~hppa (bug #436668).
241
242 08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
243 Use pax-mark in src_compile() instead of src_install() for src_test() wrt
244 #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
245 and emphatize it's an Portage issue instead of polkit issue in src_install()
246 message.
247
248 07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
249 Stable for amd64, wrt bug #436666
250
251 *polkit-0.107-r1 (20 Sep 2012)
252
253 20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
254 +files/polkit-0.107-fallback.patch:
255 Introduce upstream patch for falling back to uid 0 for authentication if list
256 of admin identities is empty.
257
258 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
259 -polkit-0.106-r7.ebuild:
260 old
261
262 *polkit-0.107 (13 Jul 2012)
263
264 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
265 Version bump.
266
267 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
268 -polkit-0.106-r6.ebuild:
269 old
270
271 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
272 Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
273 #391865 by Maksim Melnikau
274
275 *polkit-0.106-r7 (02 Jul 2012)
276
277 02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
278 RESTRICT="multilib-strict" since it's not compatible with the whole
279 /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
280 polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
281
282 *polkit-0.106-r6 (01 Jul 2012)
283
284 01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
285 Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
286 /usr/lib to /usr/lib64 symlink.
287
288 30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
289 polkit-0.106-r5.ebuild:
290 Adding dependency on SELinux policykit module if USE=selinux is set
291
292 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
293 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
294 'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
295
296 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
297 -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
298 old
299
300 *polkit-0.106-r5 (27 Jun 2012)
301
302 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
303 Revert entire unix-group:wheel experiment back to unix-user:0 because
304 PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
305 Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
306 by Doug Goldstein.
307
308 *polkit-0.106-r4 (27 Jun 2012)
309
310 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
311 Stop installing polkit-backend-1.pc because upstream changed
312 libpolkit-backend-1.la to be noinst_LTLIBRARIES in
313 src/polkitbackend/Makefile.am wrt #423431 by Pim Vullers
314
315 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r3.ebuild:
316 Redefine libprivdir in install for multilib-strict wrt #423381 by Michael
317 Palimaka
318
319 *polkit-0.106-r3 (25 Jun 2012)
320
321 25 Jun 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
322 +polkit-0.106-r3.ebuild:
323 pax-mark polkitd to fix crashes on hardened/PaX systems.
324
325 23 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
326 Convert pkg_postinst() message about polkitd home directory to new
327 user.eclass function esethome().
328
329 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
330 Check for mozjs187.pc for >=dev-lang/spidermonkey-1.8.7 compability.
331
332 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
333 Adapt to sys-auth/pambase with USE="systemd" wrt #372229 by Michał Górny
334
335 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r1.ebuild:
336 old
337
338 *polkit-0.106-r2 (17 Jun 2012)
339
340 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r2.ebuild:
341 Revision bump to chown /var/lib/polkit-1 because diropts has no effect on
342 existing directories.
343
344 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106.ebuild:
345 old
346
347 *polkit-0.106-r1 (17 Jun 2012)
348
349 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r1.ebuild:
350 Update /etc/pam.d/polkit-1 from system-login to system-local-login. Use
351 unix-group "adm" for administrators. Use /var/lib/polkit-1 as home directory
352 for unix-user polkitd. Update owners of /etc/polkit-1/rules.d and
353 /usr/share/polkit-1/rules.d to polkitd:root wrt #420269.
354
355 13 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106.ebuild:
356 Pull in dev-lang/spidermonkey >= 1.8.5 and dev-libs/glib >= 2.32 wrt
357 #420173 and #420307.
358
359 *polkit-0.106 (07 Jun 2012)
360
361 07 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106.ebuild:
362 Version bump.
363
364 20 May 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.105.ebuild:
365 Improve systemd handling wrt #416317 by Christoph Brill
366
367 *polkit-0.105 (14 May 2012)
368
369 14 May 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.105.ebuild:
370 Version bump.
371
372 04 May 2012; Jeff Horelick <jdhore@gentoo.org> polkit-0.104-r1.ebuild:
373 dev-util/pkgconfig -> virtual/pkgconfig
374
375 18 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.102.ebuild,
376 -polkit-0.103.ebuild, -polkit-0.104.ebuild:
377 old
378
379 25 Mar 2012; Raúl Porcel <armin76@gentoo.org> polkit-0.104-r1.ebuild:
380 ia64/sh/sparc stable wrt #401513
381
382 09 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.104-r1.ebuild:
383 ppc/ppc64 stable wrt #401513
384
385 17 Feb 2012; Tobias Klausmann <klausman@gentoo.org> polkit-0.104-r1.ebuild:
386 Stable on alpha, bug #401513
387
388 17 Feb 2012; Thomas Kahle <tomka@gentoo.org> polkit-0.104-r1.ebuild:
389 marked x86 per bug 401513
390
391 13 Feb 2012; Markus Meier <maekke@gentoo.org> polkit-0.104-r1.ebuild:
392 arm stable, bug #401513
393
394 02 Feb 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild:
395 Stable for HPPA (bug #401513).
396
397 30 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.104-r1.ebuild:
398 Stable for AMD64, wrt security bug #401513
399
400 *polkit-0.104-r1 (30 Jan 2012)
401
402 30 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104-r1.ebuild:
403 Restore the default value of AdminIdentities from "wheel" to "0" like it was
404 in polkit-0.102 and ones before that. You should see files
405 50-localauthority.conf and 60-gentoo.conf in
406 /etc/polkit-1/localauthority.conf.d. You should also familiarize yourself
407 with "man 8 pklocalauthority" as soon as possible.
408
409 29 Jan 2012; Markus Meier <maekke@gentoo.org> polkit-0.103.ebuild:
410 arm stable, bug #397755
411
412 07 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.103.ebuild:
413 Stable for AMD64, wrt bug #397755
414
415 *polkit-0.104 (05 Jan 2012)
416
417 05 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104.ebuild,
418 metadata.xml:
419 Version bump.
420
421 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.101-r1.ebuild:
422 old
423
424 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.102.ebuild:
425 ppc/ppc64 stable wrt #387163
426
427 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild:
428 Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo
429
430 *polkit-0.103 (07 Dec 2011)
431
432 07 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.103.ebuild:
433 Version bump. Remove unrequired keepdir of /var/run/polkit-1 wrt #387903 by
434 "i.Dark_Templar"
435
436 05 Nov 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.102.ebuild:
437 alpha/arm/ia64/sh/sparc stable wrt #387163
438
439 29 Oct 2011; Markus Meier <maekke@gentoo.org> polkit-0.102.ebuild:
440 arm stable, bug #387163
441
442 19 Oct 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.102.ebuild:
443 Stable for HPPA (bug #387163).
444
445 18 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> polkit-0.102.ebuild:
446 x86 stable wrt bug #387163
447
448 15 Oct 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.102.ebuild:
449 Stable on amd64 wrt bug #387163
450
451 28 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101-r1.ebuild,
452 polkit-0.102.ebuild:
453 pambase[consolekit] support is needed to use polkit with pam, add to PDEPEND
454
455 *polkit-0.102 (06 Aug 2011)
456
457 06 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.102.ebuild:
458 Version bump.
459
460 10 Jul 2011; Matt Turner <mattst88@gentoo.org> polkit-0.101-r1.ebuild:
461 Added ~mips, bug 296548
462
463 14 May 2011; Gilles Dartiguelongue <eva@gentoo.org> polkit-0.101-r1.ebuild:
464 Add missing dtd to DEPEND, bug #355505.
465
466 30 Apr 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.101-r1.ebuild:
467 alpha/arm/ia64/sh/sparc stable wrt #364973
468
469 28 Apr 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
470 polkit-0.101-r1.ebuild:
471 x86 stable wrt security bug #364973
472
473 27 Apr 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.101-r1.ebuild:
474 Stable for HPPA (bug #364973).
475
476 27 Apr 2011; Christoph Mende <angelos@gentoo.org> polkit-0.101-r1.ebuild:
477 Stable on amd64 wrt bug #364973
478
479 27 Apr 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.101-r1.ebuild:
480 ppc/ppc64 stable wrt #364973
481
482 *polkit-0.101-r1 (25 Apr 2011)
483
484 25 Apr 2011; Nirbheek Chauhan <nirbheek@gentoo.org> -polkit-0.100.ebuild,
485 +polkit-0.101-r1.ebuild:
486 Add patches for CVE-2011-1485, remove vulnerable 0.100 version
487
488 22 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.99-r1.ebuild:
489 ppc/ppc64 stable wrt #354509
490
491 19 Mar 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.99-r1.ebuild:
492 alpha/ia64/sh/sparc stable wrt #354509
493
494 15 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101.ebuild:
495 PDEPEND on 0.101 version of polkit-gnome
496
497 13 Mar 2011; Markus Meier <maekke@gentoo.org> polkit-0.99-r1.ebuild:
498 arm stable, bug #354509
499
500 *polkit-0.101 (11 Mar 2011)
501
502 11 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.101.ebuild:
503 Version bump.
504
505 07 Mar 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
506 Stable for HPPA (bug #354509).
507
508 04 Mar 2011; Thomas Kahle <tomka@gentoo.org> polkit-0.99-r1.ebuild:
509 x86 stable per bug 354509
510
511 23 Feb 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.99-r1.ebuild:
512 Stable on amd64 wrt bug #354509
513
514 *polkit-0.100 (23 Feb 2011)
515
516 23 Feb 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.100.ebuild:
517 Bump to 0.100
518
519 24 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.99-r1.ebuild:
520 USE="kde" to pull in authentication agent for KDE.
521
522 21 Jan 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
523 Marked ~hppa (bug #296548).
524
525 *polkit-0.99-r1 (25 Dec 2010)
526
527 25 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.99-r1.ebuild:
528 Revision bump to remove static archives (.a) and libtool archives (.la).
529 USE="gtk" to pull in authentication agent for GTK+ based desktops.
530
531 *polkit-0.99 (25 Sep 2010)
532
533 25 Sep 2010; <nirbheek@gentoo.org> +polkit-0.99.ebuild:
534 Bump to 0.99, masked due to >=glib-2.25 requirement
535
536 18 Aug 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
537 arm stable, bug #314899
538
539 14 Aug 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96-r1.ebuild,
540 polkit-0.96-r2.ebuild:
541 alpha/ia64/sh/sparc stable
542
543 09 Aug 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96-r1.ebuild:
544 Marked ppc/ppc64 stable.
545
546 25 Jul 2010; Tobias Klausmann <klausman@gentoo.org> polkit-0.96-r2.ebuild:
547 Stable on alpha, bug #329621
548
549 20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
550 polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
551 Stable for HPPA (bug #314899).
552
553 20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
554 polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
555 Drop HPPA keywording (bug #324511).
556
557 07 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96-r1.ebuild,
558 polkit-0.96-r2.ebuild:
559 Add ewarn about ensuring that consolekit sessions are working. Either the
560 user needs to login using a login-manager with consolekit support, or use
561 ck-launch-session to launch the DE as suggested in bug 291116 comment 13
562
563 *polkit-0.96-r2 (02 Jul 2010)
564
565 02 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
566 +polkit-0.96-r2.ebuild, metadata.xml:
567 USE=expat was quite useless, expat is mandatory in polkit. Don't create
568 user 'polkituser', it was used by policykit, but isn't by polkit. Also,
569 add introspection support
570
571 04 Jun 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
572 x86 stable, bug #314899
573
574 03 May 2010; Olivier Crête <tester@gentoo.org> polkit-0.96-r1.ebuild:
575 amd64 stable, bug #314899
576
577 25 Apr 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild,
578 polkit-0.96-r1.ebuild:
579 Add ~sh
580
581 13 Apr 2010; Alexis Ballier <aballier@gentoo.org> polkit-0.96-r1.ebuild,
582 +files/polkit-0.96-getcwd.patch:
583 Fix build on fbsd and keyword it x86-fbsd
584
585 25 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild,
586 polkit-0.96-r1.ebuild:
587 Raise gtk-doc{,-am} dependencies. Fixes bug 311085
588
589 21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
590 -files/polkit-0.93-fix-daemon-name.patch, -polkit-0.94.ebuild,
591 -polkit-0.95.ebuild:
592 Remove old
593
594 *polkit-0.96-r1 (21 Mar 2010)
595
596 21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
597 +polkit-0.96-r1.ebuild:
598 Update with newer version of polkit-shadow patch
599
600 07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
601 Fix minor problems with SRC_URI
602
603 07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
604 Add experimental shadow support, bug 291116 . Patch thanks to the
605 slackware folks.
606
607 28 Feb 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild:
608 Add ~alpha/~arm/~ia64/~sparc
609
610 16 Feb 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96.ebuild:
611 Marked ~ppc/~ppc64 for bug #296548.
612
613 *polkit-0.96 (23 Jan 2010)
614
615 23 Jan 2010; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.96.ebuild:
616 Version bump to 0.96; lots of bugfixes, see NEWS
617
618 06 Jan 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.95.ebuild:
619 Marked ~hppa (bug #296548).
620
621 11 Dec 2009; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.95.ebuild:
622 Add sys-auth/consolekit-0.4.0[polkit] to PDEPEND; needed for checking if
623 the user is in an active/local session via dbus methods
624
625 *polkit-0.95 (14 Nov 2009)
626
627 14 Nov 2009; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.95.ebuild:
628 Bump to 0.95 -- new lockdown API, last dev version till 1.0
629
630 30 Oct 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
631 -files/polkit-0.92-zsh-completions.patch, polkit-0.94.ebuild:
632 Remove zsh-completion (bug 291114), force pam support on (bug 291116)
633
634 *polkit-0.94 (29 Oct 2009)
635
636 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
637 +files/polkit-0.92-zsh-completions.patch,
638 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
639 +metadata.xml:
640 Initial ebuild for GNOME 2.28.

  ViewVC Help
Powered by ViewVC 1.1.20