/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Contents of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.182 - (show annotations) (download)
Fri Oct 31 15:59:12 2014 UTC (3 years, 7 months ago) by ago
Branch: MAIN
Changes since 1.181: +4 -1 lines
Stable for ppc64, wrt bug #525252

(Portage version: 2.2.8-r2/cvs/Linux x86_64, RepoMan options: --include-arches="ppc64", signed Manifest commit with key 7194459F)

1 # ChangeLog for sys-auth/polkit
2 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.181 2014/10/30 14:04:51 ago Exp $
4
5 31 Oct 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
6 Stable for ppc64, wrt bug #525252
7
8 30 Oct 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
9 Stable for amd64, wrt bug #525252
10
11 23 Oct 2014; Markus Meier <maekke@gentoo.org> polkit-0.112-r2.ebuild:
12 arm stable, bug #525252
13
14 16 Oct 2014; Jeroen Roovers <jer@gentoo.org> polkit-0.112-r2.ebuild:
15 Stable for HPPA (bug #525252).
16
17 14 Aug 2014; Samuli Suominen <ssuominen@gentoo.org> polkit-0.112-r1.ebuild,
18 polkit-0.112-r2.ebuild:
19 Fix the arch logic for HPPA (to match how IA64 and MIPS are handled in the
20 ebuild)
21
22 14 Aug 2014; Jeroen Roovers <jer@gentoo.org> polkit-0.112-r1.ebuild:
23 Stable for HPPA (bug #519870).
24
25 13 Aug 2014; Jeroen Roovers <jer@gentoo.org> polkit-0.112-r2.ebuild:
26 Marked ~hppa (bug #517804).
27
28 17 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
29 Stable for alpha, wrt bug #508862
30
31 14 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
32 Stable for sparc, wrt bug #508862
33
34 13 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
35 Stable for ia64, wrt bug #508862
36
37 11 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
38 Stable for ppc64, wrt bug #508862
39
40 10 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
41 Stable for ppc, wrt bug #508862
42
43 06 Apr 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r2.ebuild:
44 Needs to be rebuilt with systemd subslot bumps
45
46 15 Mar 2014; Samuli Suominen <ssuominen@gentoo.org> metadata.xml:
47 Add proper metadata for freedesktop-bugs@g.o
48
49 *polkit-0.112-r2 (15 Mar 2014)
50
51 15 Mar 2014; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.112-r2.ebuild:
52 USE="jit" to determine which pax-mark, if any, should be applied wrt #485910
53
54 11 Mar 2014; Pacho Ramos <pacho@gentoo.org> metadata.xml:
55 Cleanup due #239126
56
57 25 Feb 2014; Markus Meier <maekke@gentoo.org> polkit-0.112-r1.ebuild:
58 arm stable, bug #500758
59
60 23 Feb 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r1.ebuild:
61 x86 stable, bug #500758
62
63 23 Feb 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r1.ebuild:
64 amd64 stable, bug #500758
65
66 28 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
67 Fix ia64 where the order of the configure options was overridden by mips,
68 thanks Arfrever
69
70 27 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
71 Because sometimes portage is stupid
72
73 24 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
74 Fix dependence on spidermonkey for mips, bug #495168
75
76 23 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
77 Stable for sparc, wrt bug #484486
78
79 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
80 Stable for alpha, wrt bug #484486
81
82 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
83 Stable for ia64, wrt bug #484486
84
85 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
86 Stable for ppc64, wrt bug #484486
87
88 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
89 Stable for ppc, wrt bug #484486
90
91 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
92 Stable for arm, wrt bug #484486
93
94 21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
95 Stable for x86, wrt bug #484486
96
97 21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
98 Stable for amd64, wrt bug #484486
99
100 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.110-r1.ebuild,
101 -files/polkit-0.110-CVE-2013-4288.patch:
102 old
103
104 *polkit-0.112-r1 (19 Sep 2013)
105
106 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.112-r1.ebuild,
107 polkit-0.112.ebuild:
108 -r0 is for stabilization w/ mozjs185 and -r1 is for ~arch with mozjs 17.0
109
110 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> -polkit-0.111-r1.ebuild:
111 Remove vulnerable version
112
113 *polkit-0.110-r1 (19 Sep 2013)
114
115 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org>
116 +files/polkit-0.110-CVE-2013-4288.patch, +polkit-0.110-r1.ebuild:
117 Bump for CVE-2013-4288
118
119 *polkit-0.112 (19 Sep 2013)
120
121 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> +polkit-0.112.ebuild:
122 Bump for CVE-2013-4288
123
124 10 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
125 polkit-0.111-r1.ebuild:
126 Stop forcing USE="consolekit systemd" for sys-auth/pambase in PDEPEND because
127 CONFIG_AUDITSYSCALL=y is not possible on every arch and the dependency was
128 always more about convinience than being strict requirement.
129
130 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> -polkit-0.111.ebuild:
131 dropped polkit-111 in favour of -r1 now that spidermonkey-17 is unmasked, as
132 per ssuominen's approval
133
134 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> polkit-0.110.ebuild,
135 polkit-0.111-r1.ebuild:
136 Adjusted deps for dev-lang/spidermonkey to ensure SLOT=0
137
138 *polkit-0.111-r1 (08 Aug 2013)
139
140 08 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111-r1.ebuild:
141 Force use of dev-lang/spidermonkey:17 because automagic dependencies are bad.
142
143 *polkit-0.111 (15 May 2013)
144
145 15 May 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111.ebuild:
146 Version bump by "okias" from Freenode
147
148 19 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107-r1.ebuild,
149 -files/polkit-0.107-fallback.patch:
150 old
151
152 19 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
153 Stable for sh, wrt bug #452688
154
155 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
156 files/polkit-0.110-W_define.patch:
157 Include link to upstream bug.
158
159 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
160 +files/polkit-0.110-W_define.patch:
161 Fix missing #include <sys/wait.h> for #define's of WIFEXITED, WEXITSTATUS,
162 WIFSIGNALED and WTERMSIG (to fix building on arch "sh")
163
164 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
165 Stable for sparc, wrt bug #452688
166
167 03 Mar 2013; Mike Frysinger <vapier@gentoo.org> polkit-0.110.ebuild:
168 Add s390 keywords #457078 by Michael Palimaka.
169
170 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
171 Stable for alpha, wrt bug #452688
172
173 10 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
174 Stable for ppc64, wrt bug #452688
175
176 09 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
177 Stable for ia64, wrt bug #452688
178
179 31 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
180 Stable for ppc, wrt bug #452688
181
182 29 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
183 Force USE="debug" to be disabled in dev-lang/spidermonkey to avoid asseration
184 errors as noted by _AxS_.
185
186 26 Jan 2013; Markus Meier <maekke@gentoo.org> polkit-0.110.ebuild:
187 arm stable, bug #452688
188
189 20 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
190 x86 stable wrt #452688
191
192 19 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
193 amd64 stable wrt #452688
194
195 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.104-r1.ebuild,
196 -polkit-0.109-r1.ebuild, -files/polkit-0.109-XAUTHORITY-fallback.patch:
197 old
198
199 *polkit-0.110 (11 Jan 2013)
200
201 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.110.ebuild:
202 Version bump.
203
204 06 Jan 2013; Raúl Porcel <armin76@gentoo.org> polkit-0.107-r1.ebuild,
205 polkit-0.109-r1.ebuild:
206 Add ~sh wrt #436668
207
208 01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.109-r1.ebuild:
209 Add ~ia64, wrt bug #436668
210
211 30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
212 Stable for sparc, wrt bug #436666
213
214 29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
215 Stable for alpha, wrt bug #436666
216
217 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.108.ebuild,
218 -polkit-0.109.ebuild:
219 old
220
221 *polkit-0.109-r1 (21 Dec 2012)
222
223 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109-r1.ebuild,
224 +files/polkit-0.109-XAUTHORITY-fallback.patch:
225 Backport XAUTHORITY fallback support from upstream git.
226
227 19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.108.ebuild:
228 Add ~ia64, wrt bug #436668
229
230 *polkit-0.109 (19 Dec 2012)
231
232 19 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109.ebuild:
233 Version bump. Fix PaX marking logic wrt #444446 by Maxim Kammerer
234
235 18 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
236 Stable for ia64, wrt bug #436666
237
238 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
239 stable arm, bug #436666
240
241 22 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107.ebuild:
242 old
243
244 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
245 stable ppc64, bug #436666
246
247 22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
248 Stable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt
249 bug #436666
250
251 21 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
252 stable ppc, bug #436666, thanks peratu
253
254 19 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.108.ebuild:
255 Link against -lgmodule-2.0 to prevent underlinking (backported from upstream,
256 but using sed to avoid eautoreconf) wrt #443798
257
258 *polkit-0.108 (18 Nov 2012)
259
260 18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
261 Version bump.
262
263 28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
264 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
265 Drop ~x86-fbsd due to bug #439968.
266
267 15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
268 polkit-0.107-r1.ebuild:
269 Drop HPPA keywording (bug #438368).
270
271 15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
272 Set QA_MULTILIB_PATHS for bug #424423.
273
274 09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
275 Marked ~hppa (bug #436668).
276
277 08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
278 Use pax-mark in src_compile() instead of src_install() for src_test() wrt
279 #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
280 and emphatize it's an Portage issue instead of polkit issue in src_install()
281 message.
282
283 07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
284 Stable for amd64, wrt bug #436666
285
286 *polkit-0.107-r1 (20 Sep 2012)
287
288 20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
289 +files/polkit-0.107-fallback.patch:
290 Introduce upstream patch for falling back to uid 0 for authentication if list
291 of admin identities is empty.
292
293 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
294 -polkit-0.106-r7.ebuild:
295 old
296
297 *polkit-0.107 (13 Jul 2012)
298
299 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
300 Version bump.
301
302 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
303 -polkit-0.106-r6.ebuild:
304 old
305
306 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
307 Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
308 #391865 by Maksim Melnikau
309
310 *polkit-0.106-r7 (02 Jul 2012)
311
312 02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
313 RESTRICT="multilib-strict" since it's not compatible with the whole
314 /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
315 polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
316
317 *polkit-0.106-r6 (01 Jul 2012)
318
319 01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
320 Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
321 /usr/lib to /usr/lib64 symlink.
322
323 30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
324 polkit-0.106-r5.ebuild:
325 Adding dependency on SELinux policykit module if USE=selinux is set
326
327 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
328 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
329 'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
330
331 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
332 -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
333 old
334
335 *polkit-0.106-r5 (27 Jun 2012)
336
337 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
338 Revert entire unix-group:wheel experiment back to unix-user:0 because
339 PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
340 Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
341 by Doug Goldstein.
342
343 *polkit-0.106-r4 (27 Jun 2012)
344
345 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
346 Stop installing polkit-backend-1.pc because upstream changed
347 libpolkit-backend-1.la to be noinst_LTLIBRARIES in
348 src/polkitbackend/Makefile.am wrt #423431 by Pim Vullers
349
350 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r3.ebuild:
351 Redefine libprivdir in install for multilib-strict wrt #423381 by Michael
352 Palimaka
353
354 *polkit-0.106-r3 (25 Jun 2012)
355
356 25 Jun 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
357 +polkit-0.106-r3.ebuild:
358 pax-mark polkitd to fix crashes on hardened/PaX systems.
359
360 23 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
361 Convert pkg_postinst() message about polkitd home directory to new
362 user.eclass function esethome().
363
364 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
365 Check for mozjs187.pc for >=dev-lang/spidermonkey-1.8.7 compability.
366
367 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
368 Adapt to sys-auth/pambase with USE="systemd" wrt #372229 by Michał Górny
369
370 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r1.ebuild:
371 old
372
373 *polkit-0.106-r2 (17 Jun 2012)
374
375 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r2.ebuild:
376 Revision bump to chown /var/lib/polkit-1 because diropts has no effect on
377 existing directories.
378
379 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106.ebuild:
380 old
381
382 *polkit-0.106-r1 (17 Jun 2012)
383
384 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r1.ebuild:
385 Update /etc/pam.d/polkit-1 from system-login to system-local-login. Use
386 unix-group "adm" for administrators. Use /var/lib/polkit-1 as home directory
387 for unix-user polkitd. Update owners of /etc/polkit-1/rules.d and
388 /usr/share/polkit-1/rules.d to polkitd:root wrt #420269.
389
390 13 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106.ebuild:
391 Pull in dev-lang/spidermonkey >= 1.8.5 and dev-libs/glib >= 2.32 wrt
392 #420173 and #420307.
393
394 *polkit-0.106 (07 Jun 2012)
395
396 07 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106.ebuild:
397 Version bump.
398
399 20 May 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.105.ebuild:
400 Improve systemd handling wrt #416317 by Christoph Brill
401
402 *polkit-0.105 (14 May 2012)
403
404 14 May 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.105.ebuild:
405 Version bump.
406
407 04 May 2012; Jeff Horelick <jdhore@gentoo.org> polkit-0.104-r1.ebuild:
408 dev-util/pkgconfig -> virtual/pkgconfig
409
410 18 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.102.ebuild,
411 -polkit-0.103.ebuild, -polkit-0.104.ebuild:
412 old
413
414 25 Mar 2012; Raúl Porcel <armin76@gentoo.org> polkit-0.104-r1.ebuild:
415 ia64/sh/sparc stable wrt #401513
416
417 09 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.104-r1.ebuild:
418 ppc/ppc64 stable wrt #401513
419
420 17 Feb 2012; Tobias Klausmann <klausman@gentoo.org> polkit-0.104-r1.ebuild:
421 Stable on alpha, bug #401513
422
423 17 Feb 2012; Thomas Kahle <tomka@gentoo.org> polkit-0.104-r1.ebuild:
424 marked x86 per bug 401513
425
426 13 Feb 2012; Markus Meier <maekke@gentoo.org> polkit-0.104-r1.ebuild:
427 arm stable, bug #401513
428
429 02 Feb 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild:
430 Stable for HPPA (bug #401513).
431
432 30 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.104-r1.ebuild:
433 Stable for AMD64, wrt security bug #401513
434
435 *polkit-0.104-r1 (30 Jan 2012)
436
437 30 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104-r1.ebuild:
438 Restore the default value of AdminIdentities from "wheel" to "0" like it was
439 in polkit-0.102 and ones before that. You should see files
440 50-localauthority.conf and 60-gentoo.conf in
441 /etc/polkit-1/localauthority.conf.d. You should also familiarize yourself
442 with "man 8 pklocalauthority" as soon as possible.
443
444 29 Jan 2012; Markus Meier <maekke@gentoo.org> polkit-0.103.ebuild:
445 arm stable, bug #397755
446
447 07 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.103.ebuild:
448 Stable for AMD64, wrt bug #397755
449
450 *polkit-0.104 (05 Jan 2012)
451
452 05 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104.ebuild,
453 metadata.xml:
454 Version bump.
455
456 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.101-r1.ebuild:
457 old
458
459 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.102.ebuild:
460 ppc/ppc64 stable wrt #387163
461
462 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild:
463 Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo
464
465 *polkit-0.103 (07 Dec 2011)
466
467 07 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.103.ebuild:
468 Version bump. Remove unrequired keepdir of /var/run/polkit-1 wrt #387903 by
469 "i.Dark_Templar"
470
471 05 Nov 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.102.ebuild:
472 alpha/arm/ia64/sh/sparc stable wrt #387163
473
474 29 Oct 2011; Markus Meier <maekke@gentoo.org> polkit-0.102.ebuild:
475 arm stable, bug #387163
476
477 19 Oct 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.102.ebuild:
478 Stable for HPPA (bug #387163).
479
480 18 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> polkit-0.102.ebuild:
481 x86 stable wrt bug #387163
482
483 15 Oct 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.102.ebuild:
484 Stable on amd64 wrt bug #387163
485
486 28 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101-r1.ebuild,
487 polkit-0.102.ebuild:
488 pambase[consolekit] support is needed to use polkit with pam, add to PDEPEND
489
490 *polkit-0.102 (06 Aug 2011)
491
492 06 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.102.ebuild:
493 Version bump.
494
495 10 Jul 2011; Matt Turner <mattst88@gentoo.org> polkit-0.101-r1.ebuild:
496 Added ~mips, bug 296548
497
498 14 May 2011; Gilles Dartiguelongue <eva@gentoo.org> polkit-0.101-r1.ebuild:
499 Add missing dtd to DEPEND, bug #355505.
500
501 30 Apr 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.101-r1.ebuild:
502 alpha/arm/ia64/sh/sparc stable wrt #364973
503
504 28 Apr 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
505 polkit-0.101-r1.ebuild:
506 x86 stable wrt security bug #364973
507
508 27 Apr 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.101-r1.ebuild:
509 Stable for HPPA (bug #364973).
510
511 27 Apr 2011; Christoph Mende <angelos@gentoo.org> polkit-0.101-r1.ebuild:
512 Stable on amd64 wrt bug #364973
513
514 27 Apr 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.101-r1.ebuild:
515 ppc/ppc64 stable wrt #364973
516
517 *polkit-0.101-r1 (25 Apr 2011)
518
519 25 Apr 2011; Nirbheek Chauhan <nirbheek@gentoo.org> -polkit-0.100.ebuild,
520 +polkit-0.101-r1.ebuild:
521 Add patches for CVE-2011-1485, remove vulnerable 0.100 version
522
523 22 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.99-r1.ebuild:
524 ppc/ppc64 stable wrt #354509
525
526 19 Mar 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.99-r1.ebuild:
527 alpha/ia64/sh/sparc stable wrt #354509
528
529 15 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101.ebuild:
530 PDEPEND on 0.101 version of polkit-gnome
531
532 13 Mar 2011; Markus Meier <maekke@gentoo.org> polkit-0.99-r1.ebuild:
533 arm stable, bug #354509
534
535 *polkit-0.101 (11 Mar 2011)
536
537 11 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.101.ebuild:
538 Version bump.
539
540 07 Mar 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
541 Stable for HPPA (bug #354509).
542
543 04 Mar 2011; Thomas Kahle <tomka@gentoo.org> polkit-0.99-r1.ebuild:
544 x86 stable per bug 354509
545
546 23 Feb 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.99-r1.ebuild:
547 Stable on amd64 wrt bug #354509
548
549 *polkit-0.100 (23 Feb 2011)
550
551 23 Feb 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.100.ebuild:
552 Bump to 0.100
553
554 24 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.99-r1.ebuild:
555 USE="kde" to pull in authentication agent for KDE.
556
557 21 Jan 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
558 Marked ~hppa (bug #296548).
559
560 *polkit-0.99-r1 (25 Dec 2010)
561
562 25 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.99-r1.ebuild:
563 Revision bump to remove static archives (.a) and libtool archives (.la).
564 USE="gtk" to pull in authentication agent for GTK+ based desktops.
565
566 *polkit-0.99 (25 Sep 2010)
567
568 25 Sep 2010; <nirbheek@gentoo.org> +polkit-0.99.ebuild:
569 Bump to 0.99, masked due to >=glib-2.25 requirement
570
571 18 Aug 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
572 arm stable, bug #314899
573
574 14 Aug 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96-r1.ebuild,
575 polkit-0.96-r2.ebuild:
576 alpha/ia64/sh/sparc stable
577
578 09 Aug 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96-r1.ebuild:
579 Marked ppc/ppc64 stable.
580
581 25 Jul 2010; Tobias Klausmann <klausman@gentoo.org> polkit-0.96-r2.ebuild:
582 Stable on alpha, bug #329621
583
584 20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
585 polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
586 Stable for HPPA (bug #314899).
587
588 20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
589 polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
590 Drop HPPA keywording (bug #324511).
591
592 07 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96-r1.ebuild,
593 polkit-0.96-r2.ebuild:
594 Add ewarn about ensuring that consolekit sessions are working. Either the
595 user needs to login using a login-manager with consolekit support, or use
596 ck-launch-session to launch the DE as suggested in bug 291116 comment 13
597
598 *polkit-0.96-r2 (02 Jul 2010)
599
600 02 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
601 +polkit-0.96-r2.ebuild, metadata.xml:
602 USE=expat was quite useless, expat is mandatory in polkit. Don't create
603 user 'polkituser', it was used by policykit, but isn't by polkit. Also,
604 add introspection support
605
606 04 Jun 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
607 x86 stable, bug #314899
608
609 03 May 2010; Olivier Crête <tester@gentoo.org> polkit-0.96-r1.ebuild:
610 amd64 stable, bug #314899
611
612 25 Apr 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild,
613 polkit-0.96-r1.ebuild:
614 Add ~sh
615
616 13 Apr 2010; Alexis Ballier <aballier@gentoo.org> polkit-0.96-r1.ebuild,
617 +files/polkit-0.96-getcwd.patch:
618 Fix build on fbsd and keyword it x86-fbsd
619
620 25 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild,
621 polkit-0.96-r1.ebuild:
622 Raise gtk-doc{,-am} dependencies. Fixes bug 311085
623
624 21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
625 -files/polkit-0.93-fix-daemon-name.patch, -polkit-0.94.ebuild,
626 -polkit-0.95.ebuild:
627 Remove old
628
629 *polkit-0.96-r1 (21 Mar 2010)
630
631 21 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
632 +polkit-0.96-r1.ebuild:
633 Update with newer version of polkit-shadow patch
634
635 07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
636 Fix minor problems with SRC_URI
637
638 07 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96.ebuild:
639 Add experimental shadow support, bug 291116 . Patch thanks to the
640 slackware folks.
641
642 28 Feb 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild:
643 Add ~alpha/~arm/~ia64/~sparc
644
645 16 Feb 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96.ebuild:
646 Marked ~ppc/~ppc64 for bug #296548.
647
648 *polkit-0.96 (23 Jan 2010)
649
650 23 Jan 2010; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.96.ebuild:
651 Version bump to 0.96; lots of bugfixes, see NEWS
652
653 06 Jan 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.95.ebuild:
654 Marked ~hppa (bug #296548).
655
656 11 Dec 2009; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.95.ebuild:
657 Add sys-auth/consolekit-0.4.0[polkit] to PDEPEND; needed for checking if
658 the user is in an active/local session via dbus methods
659
660 *polkit-0.95 (14 Nov 2009)
661
662 14 Nov 2009; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.95.ebuild:
663 Bump to 0.95 -- new lockdown API, last dev version till 1.0
664
665 30 Oct 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
666 -files/polkit-0.92-zsh-completions.patch, polkit-0.94.ebuild:
667 Remove zsh-completion (bug 291114), force pam support on (bug 291116)
668
669 *polkit-0.94 (29 Oct 2009)
670
671 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
672 +files/polkit-0.92-zsh-completions.patch,
673 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
674 +metadata.xml:
675 Initial ebuild for GNOME 2.28.

  ViewVC Help
Powered by ViewVC 1.1.20