/[gentoo-x86]/sys-kernel/hardened-sources/hardened-sources-3.7.5-r1.ebuild
Gentoo

Contents of /sys-kernel/hardened-sources/hardened-sources-3.7.5-r1.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.4 - (hide annotations) (download)
Sun Mar 10 02:57:48 2013 UTC (5 years, 4 months ago) by blueness
Branch: MAIN
Changes since 1.3: +4 -7 lines
Remove message about old predefined grsecurity level

(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)

1 blueness 1.1 # Copyright 1999-2013 Gentoo Foundation
2     # Distributed under the terms of the GNU General Public License v2
3 blueness 1.4 # $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.7.5-r1.ebuild,v 1.3 2013/03/09 21:07:30 tomwij Exp $
4 blueness 1.1
5 tomwij 1.3 EAPI="5"
6 blueness 1.1
7     ETYPE="sources"
8     K_WANT_GENPATCHES="base"
9     K_GENPATCHES_VER="7"
10     K_DEBLOB_AVAILABLE="1"
11    
12     inherit kernel-2
13     detect_version
14    
15     HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-2"
16     HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
17     SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
18    
19     UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
20     UNIPATCH_EXCLUDE="2900_dev-root-proc-mount-fix.patch 4200_fbcondecor-0.9.6.patch"
21    
22     DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
23     HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
24     IUSE="deblob"
25    
26 blueness 1.2 KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
27 blueness 1.1
28     RDEPEND=">=sys-devel/gcc-4.5"
29    
30     pkg_postinst() {
31     kernel-2_pkg_postinst
32    
33     local GRADM_COMPAT="sys-apps/gradm-2.9.1*"
34    
35     ewarn
36 blueness 1.4 ewarn "Because some options require >=gcc-4.5, users with more than"
37     ewarn "one version of gcc installed should use gcc-config to select"
38     ewarn "a compatible version."
39 blueness 1.1 ewarn
40     ewarn "Users of grsecurity's RBAC system must ensure they are using"
41     ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
42     ewarn "It is strongly recommended that the following command is issued"
43     ewarn "prior to booting a ${PF} kernel for the first time:"
44     ewarn
45     ewarn "emerge -na =${GRADM_COMPAT}"
46     ewarn
47     }

  ViewVC Help
Powered by ViewVC 1.1.20