/[gentoo-x86]/sys-libs/libsemanage/ChangeLog
Gentoo

Diff of /sys-libs/libsemanage/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.25 Revision 1.87
1# ChangeLog for sys-libs/libsemanage 1# ChangeLog for sys-libs/libsemanage
2# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/ChangeLog,v 1.25 2009/08/02 01:14:14 pebenito Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/ChangeLog,v 1.87 2015/01/26 10:35:34 ago Exp $
4
5 26 Jan 2015; Agostino Sarubbo <ago@gentoo.org> libsemanage-2.3-r4.ebuild:
6 Stable for x86, wrt bug #535684
7
8 22 Jan 2015; Agostino Sarubbo <ago@gentoo.org> libsemanage-2.3-r4.ebuild:
9 Stable for amd64, wrt bug #535684
10
11*libsemanage-2.4_rc7 (06 Dec 2014)
12
13 06 Dec 2014; Jason Zaman <perfinion@gentoo.org> +libsemanage-2.4_rc7.ebuild,
14 -libsemanage-2.3-r2.ebuild, -libsemanage-2.4_rc2.ebuild,
15 -libsemanage-2.4_rc5.ebuild, -libsemanage-2.4_rc6-r1.ebuild,
16 -libsemanage-2.4_rc6.ebuild:
17 version bump and ebuild clean up, drop old RC
18
19*libsemanage-2.3-r4 (04 Dec 2014)
20
21 04 Dec 2014; Jason Zaman <perfinion@gentoo.org> +libsemanage-2.3-r4.ebuild,
22 libsemanage-2.4_rc6-r2.ebuild:
23 Call python_optimize, bug 531638
24
25*libsemanage-2.4_rc6-r2 (27 Nov 2014)
26
27 27 Nov 2014; Sven Vermeulen <swift@gentoo.org> +libsemanage-2.4_rc6-r2.ebuild:
28 Migrate store as soon as possible, but do not reload policy (bug 530864)
29
30*libsemanage-2.4_rc6-r1 (22 Nov 2014)
31
32 22 Nov 2014; Jason Zaman <perfinion@gentoo.org>
33 +files/0002-semanage_migrate_store-Python3-support.patch,
34 +libsemanage-2.4_rc6-r1.ebuild:
35 python3 support for semanage_migrate_store. bug 529252
36
37*libsemanage-2.4_rc6 (14 Nov 2014)
38
39 14 Nov 2014; Sven Vermeulen <swift@gentoo.org> +libsemanage-2.4_rc6.ebuild:
40 Bump to rc6, add python3_4 to PYTHON_COMPAT (fixes bug 529176); rc6 also fixes
41 unconfined issue when USE=-unconfined is set
42
43 01 Nov 2014; Sven Vermeulen <swift@gentoo.org> libsemanage-2.3-r3.ebuild:
44 Stabilize libsemanage-2.3-r3 (fix for bug #520608)
45
46*libsemanage-2.4_rc5 (29 Oct 2014)
47
48 29 Oct 2014; Sven Vermeulen <swift@gentoo.org> +libsemanage-2.4_rc5.ebuild,
49 -libsemanage-2.4_rc4.ebuild:
50 Bump to 2.4_rc5
51
52*libsemanage-2.4_rc4 (07 Oct 2014)
53
54 07 Oct 2014; Sven Vermeulen <swift@gentoo.org> +libsemanage-2.4_rc4.ebuild:
55 Bump to 2.4-rc4
56
57*libsemanage-2.4_rc2 (21 Sep 2014)
58
59 21 Sep 2014; Sven Vermeulen <swift@gentoo.org> +libsemanage-2.4_rc2.ebuild,
60 libsemanage-2.3-r2.ebuild, libsemanage-2.3-r3.ebuild:
61 Noved to github; also add in masked 2.4 series
62
63 16 Sep 2014; Brian Dolbec <dolsen@gentoo.org> libsemanage-2.3-r3.ebuild:
64 Add python-3.4 target. Tested and confirmed working by perfinion.
65
66*libsemanage-2.3-r3 (23 Aug 2014)
67
68 23 Aug 2014; Sven Vermeulen <swift@gentoo.org> +libsemanage-2.3-r3.ebuild:
69 Fix bug #520608 - Install .so in correct multilib location
70
71 05 Aug 2014; Sven Vermeulen <swift@gentoo.org> -libsemanage-2.2.ebuild,
72 -libsemanage-2.3-r1.ebuild, -libsemanage-2.3.ebuild:
73 Remove obsoleted ebuilds
74
75 05 Aug 2014; Sven Vermeulen <swift@gentoo.org> libsemanage-2.2-r2.ebuild:
76 Stabilize latest libsemanage-2.2
77
78 30 Jul 2014; Sven Vermeulen <swift@gentoo.org> libsemanage-2.3-r2.ebuild:
79 Fix bug #514194 - Stabilization of SELinux userspace 2.3
80
81 18 Jun 2014; Michał Górny <mgorny@gentoo.org> libsemanage-2.3-r2.ebuild:
82 Update dependencies to require guaranteed EAPI=5 or multilib ebuilds, bug
83 #513718.
84
85*libsemanage-2.3-r2 (02 Jun 2014)
86
87 02 Jun 2014; Sven Vermeulen <swift@gentoo.org> +libsemanage-2.3-r2.ebuild:
88 Update multilib support in libsemanage with thanks to Arfrever
89
90*libsemanage-2.3-r1 (01 Jun 2014)
91
92 01 Jun 2014; Sven Vermeulen <swift@gentoo.org> +libsemanage-2.3-r1.ebuild:
93 Fixing multilib support (bug #506460) with thanks to Sven Eden. Package has
94 dep on audit-2.2.2 which is p.masked so added same package to p.mask combo
95
96 10 May 2014; Sven Vermeulen <swift@gentoo.org> -libsemanage-2.1.10.ebuild,
97 -libsemanage-2.2-r1.ebuild, -libsemanage-2.3_rc1.ebuild:
98 Spring cleanup
99
100*libsemanage-2.3 (09 May 2014)
101
102 09 May 2014; Sven Vermeulen <swift@gentoo.org> +libsemanage-2.3.ebuild:
103 Bump to 2.3
104
105*libsemanage-2.3_rc1 (28 Apr 2014)
106
107 28 Apr 2014; Sven Vermeulen <swift@gentoo.org> +libsemanage-2.3_rc1.ebuild:
108 2.3-rc1 release
109
110*libsemanage-2.2-r2 (23 Mar 2014)
111
112 23 Mar 2014; Sven Vermeulen <swift@gentoo.org> +libsemanage-2.2-r2.ebuild:
113 Fix bug #502078 - have SHLIBS use PREFIX, not DESTDIR
114
115 02 Feb 2014; Sven Vermeulen <swift@gentoo.org> +libsemanage-2.2-r1.ebuild:
116 Support multilib
117
118*libsemanage-2.2-r1 (02 Feb 2014)
119
120 02 Feb 2014; Sven Vermeulen <swift@gentoo.org> +libsemanage-2.2-r1.ebuild:
121 Removing ruby support for libsemanage for now (libselinux has it removed as
122 we)
123
124 01 Feb 2014; Sven Vermeulen <swift@gentoo.org> libsemanage-2.2.ebuild:
125 Adding python3_3 to supported Pythons, see bug #499606
126
127 20 Jan 2014; Sven Vermeulen <swift@gentoo.org> libsemanage-2.2.ebuild:
128 Fix bug #497754 - Add in dep on virtual/pgkconfig
129
130 20 Jan 2014; Sven Vermeulen <swift@gentoo.org> libsemanage-2.2.ebuild:
131 Stabilize for amd64 and x86
132
133 23 Dec 2013; Sven Vermeulen <swift@gentoo.org> -libsemanage-2.1.9.ebuild:
134 Cleanup old version
135
136 10 Nov 2013; Sven Vermeulen <swift@gentoo.org> libsemanage-2.2.ebuild:
137 Adding dependency to audit (bug #490488)
138
139*libsemanage-2.2 (04 Nov 2013)
140
141 04 Nov 2013; Sven Vermeulen <swift@gentoo.org> +libsemanage-2.2.ebuild:
142 New libsemanage release
143
144 07 Jul 2013; Sven Vermeulen <swift@gentoo.org> -libsemanage-2.1.6.ebuild,
145 -libsemanage-2.1.6-r2.ebuild:
146 Summer cleaning
147
148 16 Jun 2013; Sven Vermeulen <swift@gentoo.org> libsemanage-2.1.10.ebuild:
149 Stabilization
150
151*libsemanage-2.1.10 (25 Apr 2013)
152
153 25 Apr 2013; Sven Vermeulen <swift@gentoo.org> +libsemanage-2.1.10.ebuild:
154 New upstream release
155
156 07 Feb 2013; Sven Vermeulen <swift@gentoo.org> libsemanage-2.1.9.ebuild:
157 Python 2.6 is not supported with libsemanage, see bug #445216
158
159 17 Nov 2012; <swift@gentoo.org> libsemanage-2.1.9.ebuild:
160 Stabilization
161
162 13 Oct 2012; <swift@gentoo.org> libsemanage-2.1.9.ebuild:
163 Supporting user-provided patches using epatch_user
164
165*libsemanage-2.1.9 (09 Oct 2012)
166
167 09 Oct 2012; <swift@gentoo.org> +libsemanage-2.1.9.ebuild:
168 Introduce new upstream version
169
170 26 Jun 2012; Mike Gilbert <floppym@gentoo.org> libsemanage-2.1.6-r2.ebuild,
171 libsemanage-2.1.6.ebuild:
172 Restrict pypy per Arfrever.
173
174*libsemanage-2.1.6-r2 (25 Jun 2012)
175
176 25 Jun 2012; <swift@gentoo.org> +libsemanage-2.1.6-r2.ebuild:
177 Fix python3 support
178
179 13 May 2012; <swift@gentoo.org> -libsemanage-2.1.0.ebuild:
180 Removing obsoleted ebuild
181
182 29 Apr 2012; <swift@gentoo.org> libsemanage-2.1.6.ebuild:
183 Stabilization
184
185 05 Apr 2012; <swift@gentoo.org> libsemanage-2.1.0.ebuild,
186 libsemanage-2.1.6.ebuild:
187 Depending on swig-2.0.4-r1 to fix build failures as per bug #409959
188
189*libsemanage-2.1.6 (31 Mar 2012)
190
191 31 Mar 2012; <swift@gentoo.org> +libsemanage-2.1.6.ebuild:
192 Bump to version 2.1.6
193
194 12 Nov 2011; <swift@gentoo.org> -libsemanage-2.0.45.ebuild,
195 -libsemanage-2.0.46.ebuild:
196 Remove deprecated ebuilds
197
198 23 Oct 2011; <swift@gentoo.org> libsemanage-2.1.0.ebuild:
199 Stabilization (tracker #384231)
200
201 17 Sep 2011; <swift@gentoo.org> libsemanage-2.0.45.ebuild,
202 libsemanage-2.0.46.ebuild:
203 Adding dependencies on bison and flex as per bug #382583
204
205 17 Sep 2011; <swift@gentoo.org> libsemanage-2.1.0.ebuild:
206 Add dependency for flex and bison
207
208 12 Aug 2011; Anthony G. Basile <blueness@gentoo.org> ChangeLog:
209 Fix failed gpg signing of Manifest
210
211 12 Aug 2011; Anthony G. Basile <blueness@gentoo.org>
212 -libsemanage-2.0.27.ebuild, -libsemanage-2.0.33.ebuild,
213 -libsemanage-2.0.33-r1.ebuild, -files/libsemanage-2.0.33-bzip.diff:
214 Removed deprecated versions
215
216*libsemanage-2.1.0 (03 Aug 2011)
217
218 03 Aug 2011; Anthony G. Basile <blueness@gentoo.org>
219 +libsemanage-2.1.0.ebuild:
220 Bump to 20110727 SELinux userspace release
221
222*libsemanage-2.0.46 (15 Jul 2011)
223
224 15 Jul 2011; Anthony G. Basile <blueness@gentoo.org>
225 +libsemanage-2.0.46.ebuild:
226 Bump to 2.0.46 - proxy for SwifT
227
228 30 Jun 2011; Anthony G. Basile <blueness@gentoo.org>
229 libsemanage-2.0.45.ebuild:
230 Only build libsemanage for python-2, fixes bug #369089
231
232 28 May 2011; Anthony G. Basile <blueness@gentoo.org>
233 libsemanage-2.0.27.ebuild, libsemanage-2.0.33.ebuild:
234 Make RDEPEND explicit
235
236 28 May 2011; Anthony G. Basile <blueness@gentoo.org>
237 libsemanage-2.0.45.ebuild:
238 Stable amd64 x86
239
240 13 Feb 2011; Anthony G. Basile <blueness@gentoo.org> metadata.xml:
241 Updated metadata.xml to reflect new selinux herd.
242
243 06 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
244 libsemanage-2.0.45.ebuild:
245 Add "python" and "ruby" USE flags.
246
247 05 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
248 libsemanage-2.0.45.ebuild:
249 Set SUPPORT_PYTHON_ABIS (bug #353764). Respect AR and CC.
250
251*libsemanage-2.0.45 (05 Feb 2011)
252
253 05 Feb 2011; Anthony G. Basile <blueness@gentoo.org>
254 +libsemanage-2.0.45.ebuild:
255 New upstream release.
256
257 16 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
258 libsemanage-2.0.27.ebuild, libsemanage-2.0.33.ebuild,
259 libsemanage-2.0.33-r1.ebuild:
260 Delete calls to deprecated python_version().
261
262*libsemanage-2.0.33-r1 (24 Aug 2009)
263
264 24 Aug 2009; Chris PeBenito <pebenito@gentoo.org>
265 +libsemanage-2.0.33-r1.ebuild, +files/libsemanage-2.0.33-bzip.diff:
266 Add patch to make bzip2 compression configurable.
267
268 03 Aug 2009; Chris PeBenito <pebenito@gentoo.org>
269 libsemanage-2.0.33.ebuild:
270 Fix libsepol dependency.
271
272 02 Aug 2009; Chris PeBenito <pebenito@gentoo.org>
273 libsemanage-2.0.27.ebuild, libsemanage-2.0.33.ebuild:
274 Add python_need_rebuild to libsemanage.
4 275
5*libsemanage-2.0.33 (02 Aug 2009) 276*libsemanage-2.0.33 (02 Aug 2009)
6 277
7 02 Aug 2009; Chris PeBenito <pebenito@gentoo.org> 278 02 Aug 2009; Chris PeBenito <pebenito@gentoo.org>
8 +libsemanage-2.0.33.ebuild: 279 +libsemanage-2.0.33.ebuild:
106*libsemanage-1.4 (09 Dec 2005) 377*libsemanage-1.4 (09 Dec 2005)
107 378
108 09 Dec 2005; Chris PeBenito <pebenito@gentoo.org> +metadata.xml, 379 09 Dec 2005; Chris PeBenito <pebenito@gentoo.org> +metadata.xml,
109 +libsemanage-1.4.ebuild: 380 +libsemanage-1.4.ebuild:
110 Initial commit. 381 Initial commit.
111

Legend:
Removed from v.1.25  
changed lines
  Added in v.1.87

  ViewVC Help
Powered by ViewVC 1.1.20