/[gentoo-x86]/sys-libs/libsemanage/ChangeLog
Gentoo

Diff of /sys-libs/libsemanage/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.29 Revision 1.69
1# ChangeLog for sys-libs/libsemanage 1# ChangeLog for sys-libs/libsemanage
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/ChangeLog,v 1.29 2010/04/16 19:36:39 arfrever Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsemanage/ChangeLog,v 1.69 2014/06/01 12:21:16 swift Exp $
4
5*libsemanage-2.3-r1 (01 Jun 2014)
6
7 01 Jun 2014; Sven Vermeulen <swift@gentoo.org> +libsemanage-2.3-r1.ebuild:
8 Fixing multilib support (bug #506460) with thanks to Sven Eden. Package has
9 dep on audit-2.2.2 which is p.masked so added same package to p.mask combo
10
11 10 May 2014; Sven Vermeulen <swift@gentoo.org> -libsemanage-2.1.10.ebuild,
12 -libsemanage-2.2-r1.ebuild, -libsemanage-2.3_rc1.ebuild:
13 Spring cleanup
14
15*libsemanage-2.3 (09 May 2014)
16
17 09 May 2014; Sven Vermeulen <swift@gentoo.org> +libsemanage-2.3.ebuild:
18 Bump to 2.3
19
20*libsemanage-2.3_rc1 (28 Apr 2014)
21
22 28 Apr 2014; Sven Vermeulen <swift@gentoo.org> +libsemanage-2.3_rc1.ebuild:
23 2.3-rc1 release
24
25*libsemanage-2.2-r2 (23 Mar 2014)
26
27 23 Mar 2014; Sven Vermeulen <swift@gentoo.org> +libsemanage-2.2-r2.ebuild:
28 Fix bug #502078 - have SHLIBS use PREFIX, not DESTDIR
29
30 02 Feb 2014; Sven Vermeulen <swift@gentoo.org> +libsemanage-2.2-r1.ebuild:
31 Support multilib
32
33*libsemanage-2.2-r1 (02 Feb 2014)
34
35 02 Feb 2014; Sven Vermeulen <swift@gentoo.org> +libsemanage-2.2-r1.ebuild:
36 Removing ruby support for libsemanage for now (libselinux has it removed as
37 we)
38
39 01 Feb 2014; Sven Vermeulen <swift@gentoo.org> libsemanage-2.2.ebuild:
40 Adding python3_3 to supported Pythons, see bug #499606
41
42 20 Jan 2014; Sven Vermeulen <swift@gentoo.org> libsemanage-2.2.ebuild:
43 Fix bug #497754 - Add in dep on virtual/pgkconfig
44
45 20 Jan 2014; Sven Vermeulen <swift@gentoo.org> libsemanage-2.2.ebuild:
46 Stabilize for amd64 and x86
47
48 23 Dec 2013; Sven Vermeulen <swift@gentoo.org> -libsemanage-2.1.9.ebuild:
49 Cleanup old version
50
51 10 Nov 2013; Sven Vermeulen <swift@gentoo.org> libsemanage-2.2.ebuild:
52 Adding dependency to audit (bug #490488)
53
54*libsemanage-2.2 (04 Nov 2013)
55
56 04 Nov 2013; Sven Vermeulen <swift@gentoo.org> +libsemanage-2.2.ebuild:
57 New libsemanage release
58
59 07 Jul 2013; Sven Vermeulen <swift@gentoo.org> -libsemanage-2.1.6.ebuild,
60 -libsemanage-2.1.6-r2.ebuild:
61 Summer cleaning
62
63 16 Jun 2013; Sven Vermeulen <swift@gentoo.org> libsemanage-2.1.10.ebuild:
64 Stabilization
65
66*libsemanage-2.1.10 (25 Apr 2013)
67
68 25 Apr 2013; Sven Vermeulen <swift@gentoo.org> +libsemanage-2.1.10.ebuild:
69 New upstream release
70
71 07 Feb 2013; Sven Vermeulen <swift@gentoo.org> libsemanage-2.1.9.ebuild:
72 Python 2.6 is not supported with libsemanage, see bug #445216
73
74 17 Nov 2012; <swift@gentoo.org> libsemanage-2.1.9.ebuild:
75 Stabilization
76
77 13 Oct 2012; <swift@gentoo.org> libsemanage-2.1.9.ebuild:
78 Supporting user-provided patches using epatch_user
79
80*libsemanage-2.1.9 (09 Oct 2012)
81
82 09 Oct 2012; <swift@gentoo.org> +libsemanage-2.1.9.ebuild:
83 Introduce new upstream version
84
85 26 Jun 2012; Mike Gilbert <floppym@gentoo.org> libsemanage-2.1.6-r2.ebuild,
86 libsemanage-2.1.6.ebuild:
87 Restrict pypy per Arfrever.
88
89*libsemanage-2.1.6-r2 (25 Jun 2012)
90
91 25 Jun 2012; <swift@gentoo.org> +libsemanage-2.1.6-r2.ebuild:
92 Fix python3 support
93
94 13 May 2012; <swift@gentoo.org> -libsemanage-2.1.0.ebuild:
95 Removing obsoleted ebuild
96
97 29 Apr 2012; <swift@gentoo.org> libsemanage-2.1.6.ebuild:
98 Stabilization
99
100 05 Apr 2012; <swift@gentoo.org> libsemanage-2.1.0.ebuild,
101 libsemanage-2.1.6.ebuild:
102 Depending on swig-2.0.4-r1 to fix build failures as per bug #409959
103
104*libsemanage-2.1.6 (31 Mar 2012)
105
106 31 Mar 2012; <swift@gentoo.org> +libsemanage-2.1.6.ebuild:
107 Bump to version 2.1.6
108
109 12 Nov 2011; <swift@gentoo.org> -libsemanage-2.0.45.ebuild,
110 -libsemanage-2.0.46.ebuild:
111 Remove deprecated ebuilds
112
113 23 Oct 2011; <swift@gentoo.org> libsemanage-2.1.0.ebuild:
114 Stabilization (tracker #384231)
115
116 17 Sep 2011; <swift@gentoo.org> libsemanage-2.0.45.ebuild,
117 libsemanage-2.0.46.ebuild:
118 Adding dependencies on bison and flex as per bug #382583
119
120 17 Sep 2011; <swift@gentoo.org> libsemanage-2.1.0.ebuild:
121 Add dependency for flex and bison
122
123 12 Aug 2011; Anthony G. Basile <blueness@gentoo.org> ChangeLog:
124 Fix failed gpg signing of Manifest
125
126 12 Aug 2011; Anthony G. Basile <blueness@gentoo.org>
127 -libsemanage-2.0.27.ebuild, -libsemanage-2.0.33.ebuild,
128 -libsemanage-2.0.33-r1.ebuild, -files/libsemanage-2.0.33-bzip.diff:
129 Removed deprecated versions
130
131*libsemanage-2.1.0 (03 Aug 2011)
132
133 03 Aug 2011; Anthony G. Basile <blueness@gentoo.org>
134 +libsemanage-2.1.0.ebuild:
135 Bump to 20110727 SELinux userspace release
136
137*libsemanage-2.0.46 (15 Jul 2011)
138
139 15 Jul 2011; Anthony G. Basile <blueness@gentoo.org>
140 +libsemanage-2.0.46.ebuild:
141 Bump to 2.0.46 - proxy for SwifT
142
143 30 Jun 2011; Anthony G. Basile <blueness@gentoo.org>
144 libsemanage-2.0.45.ebuild:
145 Only build libsemanage for python-2, fixes bug #369089
146
147 28 May 2011; Anthony G. Basile <blueness@gentoo.org>
148 libsemanage-2.0.27.ebuild, libsemanage-2.0.33.ebuild:
149 Make RDEPEND explicit
150
151 28 May 2011; Anthony G. Basile <blueness@gentoo.org>
152 libsemanage-2.0.45.ebuild:
153 Stable amd64 x86
154
155 13 Feb 2011; Anthony G. Basile <blueness@gentoo.org> metadata.xml:
156 Updated metadata.xml to reflect new selinux herd.
157
158 06 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
159 libsemanage-2.0.45.ebuild:
160 Add "python" and "ruby" USE flags.
161
162 05 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
163 libsemanage-2.0.45.ebuild:
164 Set SUPPORT_PYTHON_ABIS (bug #353764). Respect AR and CC.
165
166*libsemanage-2.0.45 (05 Feb 2011)
167
168 05 Feb 2011; Anthony G. Basile <blueness@gentoo.org>
169 +libsemanage-2.0.45.ebuild:
170 New upstream release.
4 171
5 16 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org> 172 16 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
6 libsemanage-2.0.27.ebuild, libsemanage-2.0.33.ebuild, 173 libsemanage-2.0.27.ebuild, libsemanage-2.0.33.ebuild,
7 libsemanage-2.0.33-r1.ebuild: 174 libsemanage-2.0.33-r1.ebuild:
8 Delete calls to deprecated python_version(). 175 Delete calls to deprecated python_version().
125*libsemanage-1.4 (09 Dec 2005) 292*libsemanage-1.4 (09 Dec 2005)
126 293
127 09 Dec 2005; Chris PeBenito <pebenito@gentoo.org> +metadata.xml, 294 09 Dec 2005; Chris PeBenito <pebenito@gentoo.org> +metadata.xml,
128 +libsemanage-1.4.ebuild: 295 +libsemanage-1.4.ebuild:
129 Initial commit. 296 Initial commit.
130

Legend:
Removed from v.1.29  
changed lines
  Added in v.1.69

  ViewVC Help
Powered by ViewVC 1.1.20