aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2020-04-14 07:39:54 -0500
committerJory Pratt <anarchy@gentoo.org>2020-04-14 07:39:54 -0500
commit987bbf44350beea8c805775f0e8bc7fcd7df0b30 (patch)
tree75f6cdcada6c0fae6f283e7f54b1aacbefaa0e27 /media-libs
parentsys-devel/gcc: Update metadata to fix IUSE="ada" (diff)
downloadmusl-987bbf44350beea8c805775f0e8bc7fcd7df0b30.tar.gz
musl-987bbf44350beea8c805775f0e8bc7fcd7df0b30.tar.bz2
musl-987bbf44350beea8c805775f0e8bc7fcd7df0b30.zip
media-libs/mesa: Revbump in order to rebuild against libdrm
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jory Pratt <anarchy@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/files/mesa-20.0.4-meson-Specify-the-maximum-required-libdrm-in-dri.pc.patch33
-rw-r--r--media-libs/mesa/mesa-20.0.4-r1.ebuild (renamed from media-libs/mesa/mesa-20.0.4.ebuild)3
2 files changed, 35 insertions, 1 deletions
diff --git a/media-libs/mesa/files/mesa-20.0.4-meson-Specify-the-maximum-required-libdrm-in-dri.pc.patch b/media-libs/mesa/files/mesa-20.0.4-meson-Specify-the-maximum-required-libdrm-in-dri.pc.patch
new file mode 100644
index 0000000..0989752
--- /dev/null
+++ b/media-libs/mesa/files/mesa-20.0.4-meson-Specify-the-maximum-required-libdrm-in-dri.pc.patch
@@ -0,0 +1,33 @@
+From 316b352e946a9993a20f28abc741d34455a957a8 Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Mon, 13 Apr 2020 09:20:18 -0700
+Subject: [PATCH] meson: Specify the maximum required libdrm in dri.pc
+
+When dealing with a regression in libdrm-2.4.101, I masked the package
+in Gentoo. In doing so, we discovered that Mesa's dri.pc specifies a
+version requirement in dri.pc for >= the version of libdrm Mesa was
+built against, thus preventing packages from being rebuilt with the
+older version of libdrm installed.
+
+Let's reduce this version requirement to the latest libdrm required by
+Mesa instead, since libdrm is backward compatible.
+---
+ src/mesa/drivers/dri/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/mesa/drivers/dri/meson.build b/src/mesa/drivers/dri/meson.build
+index acf7d2eb128..b09ca16e38a 100644
+--- a/src/mesa/drivers/dri/meson.build
++++ b/src/mesa/drivers/dri/meson.build
+@@ -86,7 +86,7 @@ endif
+ if with_dri
+ dri_req_private = []
+ if dep_libdrm.found()
+- dri_req_private = ['libdrm >= ' + dep_libdrm.version()]
++ dri_req_private = ['libdrm >= ' + _drm_ver]
+ endif
+
+ pkg.generate(
+--
+2.24.1
+
diff --git a/media-libs/mesa/mesa-20.0.4.ebuild b/media-libs/mesa/mesa-20.0.4-r1.ebuild
index 2861ed0..0f4c37a 100644
--- a/media-libs/mesa/mesa-20.0.4.ebuild
+++ b/media-libs/mesa/mesa-20.0.4-r1.ebuild
@@ -98,7 +98,7 @@ RDEPEND="
)
lm-sensors? ( sys-apps/lm-sensors:=[${MULTILIB_USEDEP}] )
opencl? (
- dev-libs/ocl-icd[khronos-headers,${MULTILIB_USEDEP}]
+ >=virtual/opencl-3[${MULTILIB_USEDEP}]
dev-libs/libclc
virtual/libelf:0=[${MULTILIB_USEDEP}]
)
@@ -248,6 +248,7 @@ x86? (
PATCHES=(
"${FILESDIR}"/${PN}-19.3.0-add-disable-tls-support.patch
+ "${FILESDIR}"/${P}-meson-Specify-the-maximum-required-libdrm-in-dri.pc.patch
)
llvm_check_deps() {