aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-02-28 13:42:30 -0500
committerAnthony G. Basile <blueness@gentoo.org>2016-02-28 13:43:19 -0500
commit3054881d9ab58674e28f2ec4cd17afbfed762cb4 (patch)
treebe7b787f5a1edd18dd132ef35fe30d6dc8dfe833 /dev-libs/openssl
parentMerge pull request #123 from lluixhi/master (diff)
downloadlibressl-3054881d9ab58674e28f2ec4cd17afbfed762cb4.tar.gz
libressl-3054881d9ab58674e28f2ec4cd17afbfed762cb4.tar.bz2
libressl-3054881d9ab58674e28f2ec4cd17afbfed762cb4.zip
Update metatada.xml files
Diffstat (limited to 'dev-libs/openssl')
-rw-r--r--dev-libs/openssl/metadata.xml19
1 files changed, 15 insertions, 4 deletions
diff --git a/dev-libs/openssl/metadata.xml b/dev-libs/openssl/metadata.xml
index 9bfb67e..34ef368 100644
--- a/dev-libs/openssl/metadata.xml
+++ b/dev-libs/openssl/metadata.xml
@@ -1,13 +1,24 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>maintainer-wanted@gentoo.org</email>
- </maintainer>
+<maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+</maintainer>
<use>
- <flag name='bindist'>Disable EC/RC5 algorithms (as they seem to be patented) -- note: changes the ABI</flag>
+ <flag name="asm">Support assembly hand optimized crypto functions (i.e. faster run time)</flag>
+ <flag name="bindist">Disable EC algorithms (as they seem to be patented) -- note: changes the ABI</flag>
+ <flag name="sctp">Support for Stream Control Transmission Protocol</flag>
+ <flag name="rfc3779">Enable support for RFC 3779 (X.509 Extensions for IP Addresses and AS Identifiers)</flag>
+ <flag name="tls-heartbeat">Enable the Heartbeat Extension in TLS and DTLS</flag>
</use>
<upstream>
<remote-id type="cpe">cpe:/a:openssl:openssl</remote-id>
</upstream>
+<slots>
+ <slot name="0">For building against. This is the only slot
+ that provides headers and command line tools.</slot>
+ <slot name="0.9.8">For binary compatibility, provides libcrypto.so.0.9.8
+ and libssl.so.0.9.8 only.</slot>
+</slots>
</pkgmetadata>