aboutsummaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* Rev bump LibreSSL 3.4.0-r1: patch to fix CVE-2021-41581itZzenXX2021-10-022-0/+54
| | | | | | Signed-off-by: itZzenXX <codeberg.giovanni@aleeas.com> Closes: https://github.com/gentoo/libressl/pull/360 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
* Bump LibreSSL 3.2.7,3.3.5. Mask LibreSSL 3.4.0itZzenXX2021-10-023-1/+64
| | | | | | | Signed-off-by: itZzenXX <codeberg.giovanni@aleeas.com> Closes: https://github.com/gentoo/libressl/pull/359 Closes: https://github.com/gentoo/libressl/pull/355 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
* Bump LibreSSL to version 3.4.0itZzenXX2021-09-172-1/+1
| | | | | | Signed-off-by: itZzenXX <codeberg.giovanni@aleeas.com> Closes: https://github.com/gentoo/libressl/pull/352 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
* Bump LibreSSL to 3.3.4, Stabalize 3.2.6, Drop old LibreSSL ebuildsitZzenXX2021-08-2914-700/+3
| | | | | | Signed-off-by: itZzenXX <codeberg.giovanni@aleeas.com> Closes: https://github.com/gentoo/libressl/pull/350 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
* =dev-libs/libp11-0.4.11 libressl supportSandino Araico Sanchez2021-05-063-0/+64
| | | | | | | Signed-off-by: Sandino Araico Sanchez <sandino@sandino.net> Bug: https://bugs.gentoo.org/692240 Closes: https://github.com/gentoo/libressl/pull/331 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
* dev-libs/openssl: Add a dummy sslv3 USEorbea2021-05-061-1/+2
| | | | | | Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/libressl/pull/339 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
* Bump dev-libs/libressl to 3.3.3itZzenXX2021-05-062-0/+64
| | | | | | Closes: https://github.com/gentoo/libressl/pull/338 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
* dev-libs/softhsm: remove libressl USE flagQuentin Retornaz2021-05-031-3/+2
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
* dev-libs/mongo-c-driver: remove libressl USE flagQuentin Retornaz2021-05-031-6/+3
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
* dev-libs/libstrophe: remove libressl USE flagQuentin Retornaz2021-05-031-3/+2
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
* dev-libs/libretls: new dummy packageQuentin Retornaz2021-05-032-0/+30
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
* dev-libs/openssl: add transversal USE flagsQuentin Retornaz2021-05-033-4/+15
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
* dev-libs/openssl: add USE flags for reverse dependenciesQuentin Retornaz2021-05-022-0/+2
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
* dev-libs/libressl: version bump to 3.3.2Quentin Retornaz2021-04-252-0/+64
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
* dev-libs/libressl: version bump to 3.2.5Quentin Retornaz2021-04-252-0/+63
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
* dev-libs/libressl: move from ::gentooQuentin Retornaz2021-04-2515-0/+820
| | | | | Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
* dev-libs/openssl: new packageQuentin Retornaz2021-01-263-0/+39
| | | | | Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
* dev-libs/softhsm: new packageQuentin Retornaz2021-01-264-0/+92
| | | | | Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
* dev-libs/mongo-c-driver: new packageQuentin Retornaz2021-01-265-0/+140
| | | | | Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
* dev-libs/libstrophe: new packageQuentin Retornaz2021-01-264-0/+90
| | | | | Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
* dev-libs/libgit2: drop; fixed upstream and in gentoo.gitStefan Strogin2019-03-014-138/+0
| | | | | | | | Upstream patch for LibreSSL >=2.7.0: https://github.com/libgit2/libgit2/commit/7490d449b518115a1ae86b01397e95c38e39cff1 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* dev-libs/libevent: drop; fixed upstream and in gentoo.gitStefan Strogin2019-03-014-178/+0
| | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* dev-libs/boost: drop; fixed in the upstream and main treeStefan Strogin2019-02-2013-955/+0
| | | | | Package-Manager: Portage-2.3.61, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* Drop =dev-libs/xmlsec-1.2.25Ian Moone2018-12-094-143/+0
| | | | Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
* dev-libs/boost: drop 1.62-r1, depends on dropped boost-build-1.62Stefan Strogin2018-10-262-446/+0
| | | | | Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* dev-libs/libgit2: remove vulnerable 0.27.1Ian Moone2018-08-043-124/+0
| | | | | | The 0.27.3 (available in main tree) supports libressl 2.7.x Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-libs/libgit2: Sec-bump to 0.26.5Ian Moone2018-08-042-1/+1
| | | | | Bug: https://bugs.gentoo.org/660834 Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-libs/libgit2-{0.26.4,0.27.1}: version bump solves CVE-2018-11235Ian Moone2018-06-053-2/+2
| | | | | Bug: https://bugs.gentoo.org/656874 Package-Manager: Portage-2.3.40, Repoman-2.3.9
* Backport libressl 2.7 fix for libgit2 0.26.3Ben Chaney2018-05-273-0/+111
|
* Fix dev-libs/libgit2 to work with libressl >= 2.7maurerpe2018-05-276-111/+72
|
* Fix dev-libs/xmlsec to work with libressl >= 2.7maurerpe2018-05-274-0/+143
|
* dev-libs/libevent: update patch to support LibreSSL 2.7.xIan Moone2018-05-242-6/+87
| | | | | | | | Thanks to brnrd from FreeBSD: https://svnweb.freebsd.org/ports/?pathrev=467904 Bug: https://bugs.gentoo.org/629982 Package-Manager: Portage-2.3.38, Repoman-2.3.9
* dev-libs/libevent: sync with upstreamAric Belsito2018-01-241-2/+2
|
* dev-libs/boost: sync with upstreamAric Belsito2017-09-031-1/+1
| | | | boost-1.65.0 includes libressl patch.
* dev-libs/libevent: add most recent versionAric Belsito2017-07-134-0/+97
| | | | implicit function names.
* dev-libs/libgit2: drop `r1Aric Belsito2017-04-121-0/+0
|
* dev-libs/boost: adjust patch pathAric Belsito2017-04-121-4/+4
|
* dev-libs/boost: version bump to 1.63.0Aric Belsito2017-04-1213-1342/+290
| | | | cleanup.
* dev-libs/libgit2: add libgit2 with libressl patch; see bug #606556csmk2017-02-285-0/+190
| | | | Close #189
* dev-libs/libevent: RemoveAric Belsito2017-02-043-86/+0
| | | | 2.0.22-r2 was added back into the tree.
* dev-libs/libevent: Add 2.0.22Aric Belsito2017-02-033-0/+86
| | | | @jergentoo removed 2.0.22-r2, which had support for LibreSSL..
* dev-libs/boost: Add libressl patch; see https://bugs.gentoo.org/596666csmk2017-01-293-0/+489
|
* dev-libs/boost: Sync with tree.Aric Belsito2016-11-3011-432/+27
| | | | We don't patch boost-1.60.0, so we can remove it from this repo.
* boost-1.60.0: no need anymore for the no-ssl-v3 patchTristan Mahe2016-04-291-1/+0
|
* boost manifestTristan Mahe2016-04-281-0/+1
|
* bump boost to 1.60.0Tristan Mahe2016-04-281-0/+410
|
* [dev-libs/boost] Removed oldcsmk2016-04-222-414/+0
|
* dev-libs/openssl: remove faux ebuildAnthony G. Basile2016-03-072-44/+0
| | | | | | | We're no longer going to use this in the effort to push to get all ebuilds which need it to get the libressl flag. Package-Manager: portage-2.2.26
* Update metatada.xml filesAnthony G. Basile2016-02-281-4/+15
|
* Update boost.Aric Belsito2016-02-274-2/+652
|