/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.285 Revision 1.537
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.285 2007/06/20 14:17:14 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.537 2012/07/07 07:20:48 graaff Exp $
4
5*ruby-1.8.7_p370 (07 Jul 2012)
6
7 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p370.ebuild:
8 Version bump. Fix bug 378567 thanks to slyfox.
9
10 25 Jun 2012; Andreas Schuerch <nativemad@gentoo.org> ruby-1.9.3_p125.ebuild:
11 x86 stable, see bug 411507
12
13 27 May 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p125.ebuild:
14 arm stable, bug #411507
15
16 20 May 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p125.ebuild:
17 Stable for amd64, wrt bug #411507
18
19*ruby-1.9.3_p194-r1 (12 May 2012)
20
21 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
22 +ruby-1.9.3_p194-r1.ebuild:
23 Revision bump to fix mkmf for parallel build/install. Also enable verbose
24 build, so that the log makes sense if it fails.
25
26*ruby-1.9.3_p194 (30 Apr 2012)
27
28 30 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p194.ebuild:
29 Version bump.
30
31 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
32 keyword ~amd64-fbsd
33
34*ruby-1.8.7_p358 (20 Apr 2012)
35
36 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
37 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
38 Rails 3.2.
39
40 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
41 Add ~x86-fbsd, #332593
42
43*ruby-1.9.3_p125 (18 Feb 2012)
44
45 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
46 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
47
48 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
49 add ~arm, bug #332593
50
51 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
52 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
53
54 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
55 x86 stable wrt bug #396301
56
57 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
58 Stable for HPPA (bug #396301).
59
60 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
61 Stable for ppc/ppc64; bug #396301
62
63 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
64 Marked ~hppa (bug #332593).
65
66 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
67 Add back ~alpha keyword now that rubygems is keyworded.
68
69 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
70 Stable for AMD64, wrt security bug #396301
71
72*ruby-1.8.7_p357 (28 Dec 2011)
73
74 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
75 Version bump for security bug 396301.
76
77 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
78 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
79
80 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
81 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
82 keyworded, bug 332593.
83
84 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
85 Block older versions of packages that are no longer compatible. Remove
86 ancient blocks on packags long gone from the tree.
87
88 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
89 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
90 Remove old versions.
91
92*ruby-1.9.3_p0 (18 Dec 2011)
93
94 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
95 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
96 suite which need to be diagnosed first.
97
98 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
99 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
100 #332593).
101
102 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
103 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
104 #332593).
105
106 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
107 alpha/ia64/s390/sh/sparc stable wrt #386369
108
109*ruby-1.9.3_rc1 (22 Oct 2011)
110
111 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
112 Version bump.
113
114 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
115 arm stable, bug #386369
116
117 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
118 x86 stable, bug 386369
119
120 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
121 Stable for HPPA (bug #386369).
122
123 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
124 ppc/ppc64 stable wrt #386369
125
126 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
127 Stable on amd64 wrt bug #386369
128
129 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
130 Remove vulnerable version, bug 386369.
131
132*ruby-1.8.7_p352 (30 Aug 2011)
133
134 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
135 +ruby-1.8.7_p352.ebuild:
136 Patchlevel bump for ruby:1.8. Removing old version
137
138*ruby-1.9.2_p290 (30 Aug 2011)
139
140 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
141 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
142 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
143 old patchlevels.
144
145 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
146 ruby-1.8.7_p334-r2.ebuild:
147 ppc/ppc64 stable wrt #378691
148
149*ruby-1.8.7_p334-r2 (22 Jul 2011)
150
151 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
152 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
153 for chasing down upstream and us.
154
155 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
156 Added ~mips, bug 332593
157
158 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
159 ruby-1.8.7_p334-r1.ebuild:
160 ppc64 stable wrt #369141
161
162 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
163 ia64/s390/sh/sparc stable wrt #369141
164
165 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
166 Stable for HPPA (bug #369141).
167
168 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
169 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
170
171 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
172 arm/x86 stable, bug #369141
173
174 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
175 Stable on amd64 wrt bug #369141
176
177 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
178 ruby-1.8.7_p334-r1.ebuild:
179 Stable on alpha, bug #369141
180
181*ruby-1.8.7_p334-r1 (31 May 2011)
182
183 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
184 Revision bump for security bug 369141 (CVE-2011-0188)
185
186*ruby-1.9.2-r1 (16 May 2011)
187
188 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
189 Don't remove racc files since all other ruby targets ship these files
190 themselves as well. Closes bug 363419.
191
192 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
193 ruby-1.8.7_p334.ebuild:
194 Remove old version. Remove obsolete and unused old-style virtual/ruby.
195
196 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
197 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
198
199 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
200 Add append-flags -mieee on sh, bug #357559
201
202 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
203 alpha/arm/ia64/s390/sh stable wrt #355439
204
205 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
206 Marked ~ppc64 wrt #332593
207
208 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
209 ruby-1.8.7_p334.ebuild:
210 x86 stable wrt security bug #355439
211
212 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
213 ruby-1.8.7_p334.ebuild:
214 ppc/ppc64 stable wrt #355439
215
216 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
217 Stable on amd64 wrt bug #355439
218
219 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
220 Stable for HPPA (bug #355439).
221
222*ruby-1.8.7_p334 (19 Feb 2011)
223
224 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
225 Version bump 1.8.7 series, security bug 355439
226
227 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
228 ruby-1.9.2.ebuild:
229 Remove PROVIDE for old-style virtual/ruby per bug 265054.
230
231 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
232 Remove masked ruby 1.8.6 per bug 332597.
233
234 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
235 -ruby-1.9.2_rc2.ebuild:
236 Removing old and vulnerable ebuilds
237
238 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
239 Marking ruby-1.8.7_p302 ppc64 for bug 332957
240
241 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
242 alpha/ia64/s390/sh/sparc stable wrt #332957
243
244*ruby-1.9.2 (24 Aug 2010)
245
246 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
247 metadata.xml:
248 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
249 and x86-fbsd due to a new dependency on rdoc.
250
251 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
252 arm stable, bug #332957
253
254 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
255 ruby-1.8.7_p302.ebuild:
256 x86 stable wrt security bug #332957
257
258 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
259 Stable on amd64 wrt bug #332957
260
261 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
262 Stable for PPC (bug #332957).
263
264 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
265 Stable for HPPA (bug #332957).
266
267*ruby-1.8.7_p302 (21 Aug 2010)
268
269 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
270 +ruby-1.8.7_p302.ebuild:
271 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
272 installation path.
273
274*ruby-1.8.6_p399 (19 Aug 2010)
275
276 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
277 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
278 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
279 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
280 installation path (reported by the x86 team in bug 332597)
281
282*ruby-1.9.2_rc2-r1 (18 Aug 2010)
283
284 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
285 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
286 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
287 the rubygems loading code. Add USE flag for psych.
288
289 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
290 ruby-1.9.2_rc2.ebuild:
291 Remove two keepdir that will try to keep an empty path, closes bug
292 #333163.
293
294 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
295 Marked ~ppc (bug #332593).
296
297 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
298 ruby-1.9.2_rc2.ebuild:
299 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
300
301 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
302 ruby-1.8.7_p299.ebuild:
303 Bump eselect-ruby dependency
304
305 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
306 -ruby-1.9.1_p429.ebuild:
307 Remove ebuild that is not target for unmask anyway.
308
309 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
310 ruby-1.9.2_rc2.ebuild:
311 Try 2 to fix the berkdb 5 issue on 1.9.
312
313 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
314 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
315 ruby-1.9.2_rc2.ebuild:
316 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
317 support for adding new patchsets without bumping the revision for all the
318 old ebuilds as well.
319
320*ruby-1.9.2_rc2 (14 Jul 2010)
321
322 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
323 +ruby-1.9.2_rc2.ebuild:
324 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
325 might cause _further_ build failures as it changed slightly behaviour.
326 You're going to need to rebuild rubygems and then all the packages
327 previously installed after upgrading to this.
328
329 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
330 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
331 -ruby-1.9.1_p376.ebuild:
332 Cleanup old versions.
333
334*ruby-1.9.1_p429 (04 Jul 2010)
335
336 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
337 +ruby-1.9.1_p429.ebuild:
338 Version bump to new 1.9.1 release.
339
340*ruby-1.8.7_p299 (23 Jun 2010)
341
342 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
343 +ruby-1.8.7_p299.ebuild:
344 Version bump.
345
346 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
347 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
348 remove useless comments
349
350 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
351 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
352 ruby-1.9.1_p376.ebuild:
353 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
354 dev.gentoo.org now.
355
356 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
357 ruby-1.9.1_p376.ebuild:
358 Use the correct RUBYLIB.
359
360*ruby-1.8.7_p249-r2 (18 May 2010)
361*ruby-1.8.6_p388-r1 (18 May 2010)
362
363 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
364 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
365 ruby-1.9.1_p376.ebuild, metadata.xml:
366 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
367 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
368 add USE flags for ncurses, readline and libedit, and properly depend on
369 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
370 Emacs versions support ruby-mode themselves and it should be even more
371 updated.
372
373*ruby-1.8.7_p249-r1 (06 May 2010)
374
375 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
376 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
377 309789 by Sune Kloppenborg Jeppesen.
378
379 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
380 ruby-1.8.7_p249.ebuild:
381 Use $PVR instead of $PV in patchset names
382
383 06 May 2010; Alex Legler <a3li@gentoo.org>
384 -files/ruby-1.8.6-memory-leak.diff,
385 -files/ruby18-mkmf-parallel-install.patch,
386 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
387 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
388 Remove old version. Cleanup in files/
389
390*ruby-1.9.1_p376 (01 May 2010)
391
392 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
393 Version bump. Fixes security bugs 296052 and 300468. No longer installs
394 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
395 instead.
396
397 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
398 -ruby-1.8.7_p174-r1.ebuild:
399 Remove vulnerable ebuilds, 300468
400
401 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
402 ruby-1.8.7_p249.ebuild:
403 amd64 stable, security bug 300468
404
405 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
406 ruby-1.8.7_p249.ebuild:
407 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
408
409 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
410 Stable for HPPA (bug #300468).
411
412 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
413 Stable for HPPA (bug #300468).
414
415 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
416 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
417
418 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
419 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
420
421 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
422 ruby-1.8.6_p388.ebuild:
423 stable x86, security bug 300468
424
425 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
426 ruby-1.8.7_p249.ebuild:
427 stable x86, security bug 300468
428
429*ruby-1.8.6_p388 (10 Jan 2010)
430
431 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
432 +ruby-1.8.6_p388.ebuild:
433 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
434 version. The new ebuild also has the fix for bug 168939.
435
436*ruby-1.8.7_p249 (10 Jan 2010)
437
438 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
439 +ruby-1.8.7_p249.ebuild:
440 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
441 version
442
443 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
444 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
445
446*ruby-1.8.7_p248 (25 Dec 2009)
447
448 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
449 Version bump
450
451 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
452 Remove old version.
453
454 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
455 Remove old version.
456
457 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
458 ia64/s390/sh stable wrt #288699
459
460 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
461 stable sparc, bug 288699
462
463 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
464 arm stable, bug #288699
465
466 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
467 amd64/x86 stable, bug #288699
468
469 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
470 ruby-1.8.7_p174-r1.ebuild:
471 Stable on alpha, bug #288699
472
473 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
474 ppc stable #288699
475
476 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
477 Stable for HPPA (bug #288699).
478
479 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
480 Marked ~hppa too.
481
482*ruby-1.8.7_p174-r1 (06 Oct 2009)
483
484 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
485 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
486 eselect-ruby cleanup feature.
487
488*ruby-1.9.1_p243 (09 Sep 2009)
489
490 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
491 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
492 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
493 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
494 -files/ruby19-rubygems-proxy.patch,
495 -files/ruby-1.9.1_p129-parallelmake.patch,
496 -files/ruby19-mkmf-parallel-install.patch:
497 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
498 168939. Cleaning up old patches.
499
500*ruby-1.8.6_p383 (20 Aug 2009)
501
502 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
503 Patchlevel bump.
504
505 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
506 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
507 ruby-1.9.1_p129-r1.ebuild:
508 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
509
510 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
511 Removing vulnerable ebuild, bug 273213.
512
513 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
514 Marking ruby-1.8.6_p369 ppc for bug 273213
515
516 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
517 ruby-1.9.1_p129-r1.ebuild:
518 Prepend our library path instead of overwriting it during src_install.
519 Thanks to the reporter of bug #274824.
520
521*ruby-1.8.7_p174 (18 Jun 2009)
522
523 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
524 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
525 Replacing 187_p173 with _p174 because of a regression. Unifying the
526 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
527 patchsets.
528
529 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
530 Marking ruby-1.8.6_p369 ppc64 for bug 273213
531
532 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
533 arm/ia64/s390/sh/sparc stable wrt #273213
534
535 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
536 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
537 Removing old version, minor cleanup
538
539 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
540 -files/ruby-1.8.6-openssl.patch,
541 -files/ruby-1.8.6-shortname_constants.patch,
542 -files/ruby-1.8.6_p111-r13657.patch,
543 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
544 Removing vulnerable old Ruby version and stale patches, bug 274108.
545
546 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
547 ruby-1.8.6_p369.ebuild:
548 Stable on alpha, bug #273213
549
550 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
551 Stable for HPPA (bug #273213).
552
553 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
554 ruby-1.8.6_p369.ebuild:
555 stable x86, security bug 273213
556
557 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
558 amd64 stable, security bug 273213.
559
560*ruby-1.8.7_p173 (10 Jun 2009)
561*ruby-1.8.6_p369 (10 Jun 2009)
562
563 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
564 +ruby-1.8.7_p173.ebuild:
565 Version bumps for bug #273213.
566
567*ruby-1.9.1_p129-r1 (27 May 2009)
568
569 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
570 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
571 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
572 +files/ruby-1.9.1_p129-parallelmake.patch:
573 Revision bump, add patches 1) to make Ruby behave more similarly between
574 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
575 extensions (undefined symbols in them will cause abort at runtime 3) to
576 remove a concurrency issue when building the dl extension that could
577 result in a broken dl.so.
578
579 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
580 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
581 Don't block rdoc-2 or later (which may enter Portage one day as it's
582 needed by some Rakefiles).
583
584 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
585 ruby-1.9.1_p129.ebuild:
586 Add ~x86-fbsd keyword.
587
588 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
589 keyword ~sparc-fbsd, bug #252315
590
591*ruby-1.9.1_p129 (15 May 2009)
592
593 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
594 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
595 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
596 included in every release.
597
598 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
599 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
600 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
601 ruby-1.8.7_p160.ebuild:
602 Removing vulnerable versions (#268515), fixing license (#233747).
603
604 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
605 Stable for HPPA (bug #268515).
606
607 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
608 Adapting rubygems notice.
609
610 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
611 amd64 stable, bug #268515.
612
613 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
614 arm/ia64/s390/sh/sparc stable wrt #268515
615
616 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
617 ruby-1.8.6_p368.ebuild:
618 stable x86, security bug 268515
619
620 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
621 ruby-1.8.6_p368.ebuild:
622 Stable on alpha, bug #268515
623
624 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
625 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
626
627*ruby-1.8.7_p160 (07 May 2009)
628*ruby-1.8.6_p368 (07 May 2009)
629
630 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
631 +ruby-1.8.7_p160.ebuild:
632 Version bump as per secbug 268515. NB: These are the first ebuilds that
633 no longer use ruby-config.
634
635*ruby-1.9.1-r1 (03 Apr 2009)
636*ruby-1.8.7_p72-r11 (03 Apr 2009)
637*ruby-1.8.6_p287-r13 (03 Apr 2009)
638
639 03 Apr 2009; Alex Legler <a3li@gentoo.org>
640 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
641 +files/ruby18-mkmf-parallel-install.patch,
642 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
643 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
644 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
645 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
646 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
647 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
648 happy.
649
650*ruby-1.9.1 (21 Mar 2009)
651
652 21 Mar 2009; Alex Legler <a3li@gentoo.org>
653 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
654 +ruby-1.9.1.ebuild:
655 Adding Ruby 1.9.1 for preliminary testing
656
657 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
658 ruby-1.8.6_p287-r12.ebuild:
659 Marked ~ppc for bug #252315.
660
661 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
662 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
663 bug 261982.
664
665 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
666 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
667 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
668 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
669 Cleanup
670
671*ruby-1.8.7_p72-r10 (07 Mar 2009)
672
673 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
674 +ruby-1.8.7_p72-r10.ebuild:
675 Add a revision of ruby 1.8.7 using eselect ruby.
676
677 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
678 ~mips keyworded, bug #252315.
679
680 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
681 ruby-1.8.6_p287-r5.ebuild:
682 ppc stable, bug #260006
683
684 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
685 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
686
687 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
688 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
689 Fixing Tk USE flag test, bug 258893.
690
691 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
692 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
693
694 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
695 ruby-1.8.6_p287-r5.ebuild:
696 amd64 stable wrt security bug #260006
697
698 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
699 Stable for HPPA (bug #260006).
700
701 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
702 ruby-1.8.6_p287-r5.ebuild:
703 Stable on alpha, bug #260006
704
705*ruby-1.8.7_p72-r2 (23 Feb 2009)
706*ruby-1.8.6_p287-r12 (23 Feb 2009)
707*ruby-1.8.6_p287-r5 (23 Feb 2009)
708
709 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
710 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
711 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
712 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
713 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
714 now before compilation if Tk useflags don't match) and 230748 (adding
715 --enable-option-checking=no for newer versions of autoconf).
716
717 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
718 arm/ia64/s390/sh/sparc stable wrt #254307
719
720 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
721 ruby-1.8.6_p287-r4.ebuild:
722 Stable on alpha, bug #254307
723
724 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
725 ruby-1.8.6_p287-r11.ebuild:
726 keyword ~x86-fbsd, bug #252315
727
728 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
729 ppc stable #254307
730
731 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
732 amd64/x86 stable, bug #254307
733
734 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
735 stable ppc64, bug 254307
736
737 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
738 Stable for HPPA (bug #254307).
739
740 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
741 ruby-1.8.6_p287-r11.ebuild:
742 Marked ~hppa (bug #252315).
743
744*ruby-1.8.6_p287-r11 (11 Jan 2009)
745
746 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
747 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
748 +ruby-1.8.6_p287-r11.ebuild:
749 Backport conditional definition of missing openssl functions from ruby 1.8.7.
750 Fixes #254307.
751
752 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
753 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
754
755 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
756 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
757
758 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
759 ruby-1.8.6_p287-r10.ebuild:
760 Add ~sparc keyword, bug #252315
761
762*ruby-1.8.6_p287-r10 (23 Dec 2008)
763
764 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
765 +ruby-1.8.6_p287-r10.ebuild:
766 Version bump which switches from ruby-config to eselect-ruby. Dropped most
767 keywords since eselect-ruby does not yet have these keywords.
768
769 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
770 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
771 Revert the ruby-config changes. We can't remove them until we provide an
772 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
773 for breaking things as mentioned in bug #251833.
774
775 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
776 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
777 ruby-1.8.7_p72-r1.ebuild:
778 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
779 Thanks for the people noticing this in bug #251833.
780
781 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
782 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
783 ruby-1.8.7_p72-r1.ebuild:
784 Drop dependency on ruby-config, which will be removed from the tree. We
785 currently only have one major version of ruby in the tree (Ruby 1.8), so there
786 is no need for ruby-config at this moment. For newer versions of Ruby we will
787 use eselect-ruby, which can be found in the ruby overlay at the moment.
788
789 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
790 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
791 Use mirror://ruby in SRC_URI, fixes #237392.
792
793 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
794 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
795 -ruby-1.8.7_p72.ebuild:
796 Remove old versions. Leave one old stable version with cjk support.
797
798*ruby-1.8.6_p287-r3 (29 Nov 2008)
799
800 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
801 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
802 +ruby-1.8.6_p287-r3.ebuild:
803 Fix our expansion limit patch according to debian bug report
804 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
805 make sure people will pick up the fixed version. Thanks to Alex Legler for
806 mentioning the patch.
807
808*ruby-1.8.7_p72-r1 (26 Nov 2008)
809*ruby-1.8.6_p287-r2 (26 Nov 2008)
810
811 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
812 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
813 +ruby-1.8.7_p72-r1.ebuild:
814 Fix problem with shortname constants #247790, already fixed in upstream SVN.
815 Thanks to Alex Legler for providing the patch.
816
817 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
818 -ruby-1.8.6_p287.ebuild:
819 Remove versions that will not become stable
820
821 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
822 ruby-1.8.6_p287-r1.ebuild:
823 ppc stable, bug #225465
824
825 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
826 ruby-1.8.6_p287-r1.ebuild:
827 amd64 stable wrt security bug #225465
828
829 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
830 alpha/ia64/x86 stable wrt #225465
831
832 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
833 ruby-1.8.6_p287-r1.ebuild:
834 Sparc stable --- Security Bug #225465 --- good since late August.
835
836 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
837 Stable on ppc64; bug #225465
838
839 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
840 Stable for HPPA (bug #225465).
841
842*ruby-1.8.6_p287-r1 (29 Aug 2008)
843
844 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
845 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
846 +ruby-1.8.6_p287-r1.ebuild:
847 Fix REXML security issues, bug #236060.
848
849 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
850 Add GLEP 56 USE flag descriptions.
851
852*ruby-1.8.7_p72 (15 Aug 2008)
853
854 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
855 +ruby-1.8.7_p72.ebuild:
856 bump 1.8.7 to latest patch release
857
858*ruby-1.8.6_p287 (11 Aug 2008)
859
860 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
861 Version bump for brown paper bag relelease.
862
863 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
864 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
865 Remove broken version in favor of the just-added 1.8.6_p286
866
867*ruby-1.8.6_p286 (10 Aug 2008)
868
869 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
870 Version bump to latest released version of ruby 1.8.6. This version fixes the
871 security issues reported in #225465 and #234224. The cjk USE flag has been
872 dropped since no compatible patches have been released yet.
873
874 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
875 ruby-1.8.6_p230.ebuild:
876 drop cjk from SRC_URI as well
877
878 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
879 Drop cjk support since the most recent oniguruma patches no longer apply to
880 this version, #230111.
881
882 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
883 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
884 Try to fix the security issues reported in #225465 for ruby 1.8.6.
885 Unfortunately the official p230 has a change which causes segmentation faults
886 for applications like Rails and RSpec, so we are reverting that specific
887 change.
888
889*ruby-1.8.7_p22 (29 Jun 2008)
890
891 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
892 +ruby-1.8.7_p22.ebuild:
893 bump 1.8.7 for security fix
894
895 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
896 nevermind, don't bump this yet
897
898*ruby-1.8.6_p230 (20 Jun 2008)
899
900 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
901 version bump
902
903*ruby-1.8.7 (10 Jun 2008)
904
905 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
906 +ruby-1.8.7.ebuild:
907 bump 1.8.7 to final
908
909*ruby-1.8.7_pre2 (21 Apr 2008)
910
911 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
912 +ruby-1.8.7_pre2.ebuild:
913 Version Bump
914
915*ruby-1.8.7_pre1 (16 Apr 2008)
916
917 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
918 Version bump. Drop cjk until a new version of oniguruma appears.
919
920 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
921 amd64 stable, bug 212264
922
923 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
924 Stable for HPPA (bug #212264).
925
926 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
927 ruby-1.8.6_p114.ebuild:
928 ppc stable, bug #212264
929
930 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
931 alpha/ia64 stable wrt #212264
932
933 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
934 ruby-1.8.6_p114.ebuild:
935 stable x86, security bug 212264
936
937 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
938 Sparc stable, Security Bug #212264, builds and installs, initial tests run
939 as expected.
940
941 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
942 Marking ruby-1.8.6_p114 ppc64 for bug 212264
943
944*ruby-1.8.6_p114 (05 Mar 2008)
945
946 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
947 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
948 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
949 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
950 Version bump for #212264. Remove old ebuilds.
951
952 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
953 alpha/ia64 stable wrt #208916
954
955 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
956 Stable on ppc wrt bug 208916
957
958 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
959 x86 stable, bug #208916
960
961 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
962 ruby-1.8.6_p111-r1.ebuild:
963 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
964
965 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
966 -files/ruby-1.8.6-exit-status.patch,
967 -files/ruby-1.8.6_p110-net-http-p111.patch,
968 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
969 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
970 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
971 Remove old versions
972
973 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
974 Stable on ppc64
975
976 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
977 Stable on amd64; bug 199191
978
979 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
980 alpha/ia64/sparc stable wrt #199191
981
982 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
983 Remove now-obsolete warning about coreutils versions, #203156.
984
985 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
986 Stable for HPPA (bug #199191).
987
988*ruby-1.8.6_p111-r1 (23 Dec 2007)
989
990 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
991 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
992 ssl USE flags. Patch to p113.
993
994 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
995 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
996
997 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
998 x86 stable, security bug #199191
999
1000*ruby-1.8.6_p111 (23 Dec 2007)
1001
1002 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
1003 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
1004 Version bump with patch for bug #199191
1005
1006 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1007 Move dependency on (X)Emacs modes to PDEPEND.
1008
1009 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1010 Add back ~hppa keyword now that XEmacs support files have been keyworded,
1011 bug 196413
1012
1013*ruby-1.8.6_p110-r2 (21 Oct 2007)
1014
1015 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
1016 +ruby-1.8.6_p110-r2.ebuild:
1017 Add emacs and xemacs USE flags and use them to pull in the correct editing
1018 mode for each. Had to drop several arch keywords as reported on bug 196413.
1019
1020 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1021 amd64 stable, security bug 194236
1022
1023 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
1024 ruby-1.8.6_p110-r1.ebuild:
1025 Stable on ppc64; bug #194236
1026
1027 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
1028 amd64 stable, security bug 194236
1029
1030 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1031 Stable for HPPA (bug #194236).
1032
1033 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1034 alpha/ia64/sparc stable wrt security #194236
1035
1036 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
1037 ruby-1.8.6_p110-r1.ebuild:
1038 ppc stable, bug #194236
1039
1040 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1041 ruby-1.8.6_p110-r1.ebuild:
1042 stable x86, security bug 194236
1043
1044 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1045 ruby-1.8.5_p113.ebuild:
1046 stable x86, security bug 194236
1047
1048 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1049 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1050 -ruby-1.8.6_p110.ebuild:
1051 Remove old versions
1052
1053*ruby-1.8.6_p110-r1 (30 Sep 2007)
1054*ruby-1.8.5_p113 (30 Sep 2007)
1055
1056 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1057 +files/ruby-1.8.5_p113-net-http-p114.patch,
1058 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1059 +ruby-1.8.6_p110-r1.ebuild:
1060 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1061 using 1.8.6-p110 as base ebuild.
1062
1063 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1064 More fixes from gentoo-dev and graaff
1065
1066 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1067 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1068
1069*ruby-1.8.6_p110 (24 Sep 2007)
1070
1071 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1072 Version bump
1073
1074*ruby-1.8.6_p36-r4 (26 Aug 2007)
1075
1076 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1077 +ruby-1.8.6_p36-r4.ebuild:
1078 Use user LDFLAGS, #181436
1079
1080 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1081 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1082 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1083 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1084
1085 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1086 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1087 -ruby-1.8.6_p36-r2.ebuild:
1088 Remove some older versions that will not be promoted to stable, keeping at
1089 least one version of each release.
1090
1091 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1092 ruby-1.8.6_p36-r3.ebuild:
1093 (QA) RESTRICT clean up.
1094
1095*ruby-1.8.6_p36-r3 (04 Jul 2007)
1096
1097 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1098 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1099 fixed memory leak loading .so bug #182946
1100
1101 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1102 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1103 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1104 ruby-1.8.6_p36-r2.ebuild:
1105 (QA) RESTRICT clean up.
1106
1107 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1108 Re-add stable keyword for alpha as per bug #181110
1109
1110 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1111 Back to ~amd64 wrt bug 181110
1112
1113 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1114 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
4 1115
5*ruby-1.8.6_p36-r2 (20 Jun 2007) 1116*ruby-1.8.6_p36-r2 (20 Jun 2007)
6 1117
7 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild: 1118 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
8 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671 1119 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671

Legend:
Removed from v.1.285  
changed lines
  Added in v.1.537

  ViewVC Help
Powered by ViewVC 1.1.20