/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.285 Revision 1.539
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.285 2007/06/20 14:17:14 rbrown Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.539 2012/07/22 14:07:45 nixnut Exp $
4
5 22 Jul 2012; <nixnut@gentoo.org> ruby-1.9.3_p125.ebuild:
6 ppc stable #411507
7
8 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p194-r1.ebuild:
9 PDEPEND on rubygems since 1.9.x won't work without it installed. Fixes bug
10 424611.
11
12*ruby-1.8.7_p370 (07 Jul 2012)
13
14 07 Jul 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p370.ebuild:
15 Version bump. Fix bug 378567 thanks to slyfox.
16
17 25 Jun 2012; Andreas Schuerch <nativemad@gentoo.org> ruby-1.9.3_p125.ebuild:
18 x86 stable, see bug 411507
19
20 27 May 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p125.ebuild:
21 arm stable, bug #411507
22
23 20 May 2012; Agostino Sarubbo <ago@gentoo.org> ruby-1.9.3_p125.ebuild:
24 Stable for amd64, wrt bug #411507
25
26*ruby-1.9.3_p194-r1 (12 May 2012)
27
28 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org>
29 +ruby-1.9.3_p194-r1.ebuild:
30 Revision bump to fix mkmf for parallel build/install. Also enable verbose
31 build, so that the log makes sense if it fails.
32
33*ruby-1.9.3_p194 (30 Apr 2012)
34
35 30 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p194.ebuild:
36 Version bump.
37
38 26 Apr 2012; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p358.ebuild:
39 keyword ~amd64-fbsd
40
41*ruby-1.8.7_p358 (20 Apr 2012)
42
43 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p358.ebuild:
44 Version bump. Also include p359 as a patch to fix marshall bugs exposed by
45 Rails 3.2.
46
47 01 Mar 2012; Naohiro Aota <naota@gentoo.org> ruby-1.9.3_p125.ebuild:
48 Add ~x86-fbsd, #332593
49
50*ruby-1.9.3_p125 (18 Feb 2012)
51
52 18 Feb 2012; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p125.ebuild:
53 Version bump, thanks to Sven Schwyn for reporting in bug 203706.
54
55 05 Feb 2012; Markus Meier <maekke@gentoo.org> ruby-1.9.3_p0.ebuild:
56 add ~arm, bug #332593
57
58 08 Jan 2012; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p357.ebuild:
59 alpha/arm/ia64/s390/sh/sparc stable wrt #396301
60
61 04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ruby-1.8.7_p357.ebuild:
62 x86 stable wrt bug #396301
63
64 30 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p357.ebuild:
65 Stable for HPPA (bug #396301).
66
67 29 Dec 2011; Mark Loeser <halcy0n@gentoo.org> ruby-1.8.7_p357.ebuild:
68 Stable for ppc/ppc64; bug #396301
69
70 29 Dec 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_p0.ebuild:
71 Marked ~hppa (bug #332593).
72
73 29 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
74 Add back ~alpha keyword now that rubygems is keyworded.
75
76 29 Dec 2011; Agostino Sarubbo <ago@gentoo.org> ruby-1.8.7_p357.ebuild:
77 Stable for AMD64, wrt security bug #396301
78
79*ruby-1.8.7_p357 (28 Dec 2011)
80
81 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p357.ebuild:
82 Version bump for security bug 396301.
83
84 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
85 Drop alpha, arm, hppa for now since each missing a dependency, bug 332593.
86
87 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
88 Drop alpha keyword for now because alpha doesn't have a new enough rubygems
89 keyworded, bug 332593.
90
91 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> ruby-1.9.3_p0.ebuild:
92 Block older versions of packages that are no longer compatible. Remove
93 ancient blocks on packags long gone from the tree.
94
95 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p334-r1.ebuild,
96 -ruby-1.8.7_p334-r2.ebuild, -ruby-1.9.2_p290.ebuild, -ruby-1.9.3_rc1.ebuild:
97 Remove old versions.
98
99*ruby-1.9.3_p0 (18 Dec 2011)
100
101 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_p0.ebuild:
102 Version bump to 1.9.3p0. Still has massive failures in the rubytests test
103 suite which need to be diagnosed first.
104
105 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
106 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
107 #332593).
108
109 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
110 Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
111 #332593).
112
113 22 Oct 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p352.ebuild:
114 alpha/ia64/s390/sh/sparc stable wrt #386369
115
116*ruby-1.9.3_rc1 (22 Oct 2011)
117
118 22 Oct 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.3_rc1.ebuild:
119 Version bump.
120
121 15 Oct 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p352.ebuild:
122 arm stable, bug #386369
123
124 14 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> ruby-1.8.7_p352.ebuild:
125 x86 stable, bug 386369
126
127 10 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p352.ebuild:
128 Stable for HPPA (bug #386369).
129
130 09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.8.7_p352.ebuild:
131 ppc/ppc64 stable wrt #386369
132
133 09 Oct 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p352.ebuild:
134 Stable on amd64 wrt bug #386369
135
136 09 Oct 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.9.2-r1.ebuild:
137 Remove vulnerable version, bug 386369.
138
139*ruby-1.8.7_p352 (30 Aug 2011)
140
141 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p334.ebuild,
142 +ruby-1.8.7_p352.ebuild:
143 Patchlevel bump for ruby:1.8. Removing old version
144
145*ruby-1.9.2_p290 (30 Aug 2011)
146
147 30 Aug 2011; Alex Legler <a3li@gentoo.org> -ruby-1.9.2_rc2-r1.ebuild,
148 -ruby-1.9.2.ebuild, +ruby-1.9.2_p290.ebuild:
149 Patchlevel bump. Thanks to Shota Fukumori for proposing an ebuild. Removing
150 old patchlevels.
151
152 10 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
153 ruby-1.8.7_p334-r2.ebuild:
154 ppc/ppc64 stable wrt #378691
155
156*ruby-1.8.7_p334-r2 (22 Jul 2011)
157
158 22 Jul 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.7_p334-r2.ebuild:
159 Add patch to fix threading bug on ppc64, bug 375075. Thanks to Kacper Kowalik
160 for chasing down upstream and us.
161
162 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
163 Added ~mips, bug 332593
164
165 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
166 ruby-1.8.7_p334-r1.ebuild:
167 ppc64 stable wrt #369141
168
169 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
170 ia64/s390/sh/sparc stable wrt #369141
171
172 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
173 Stable for HPPA (bug #369141).
174
175 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
176 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
177
178 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
179 arm/x86 stable, bug #369141
180
181 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
182 Stable on amd64 wrt bug #369141
183
184 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
185 ruby-1.8.7_p334-r1.ebuild:
186 Stable on alpha, bug #369141
187
188*ruby-1.8.7_p334-r1 (31 May 2011)
189
190 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
191 Revision bump for security bug 369141 (CVE-2011-0188)
192
193*ruby-1.9.2-r1 (16 May 2011)
194
195 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
196 Don't remove racc files since all other ruby targets ship these files
197 themselves as well. Closes bug 363419.
198
199 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
200 ruby-1.8.7_p334.ebuild:
201 Remove old version. Remove obsolete and unused old-style virtual/ruby.
202
203 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
204 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
205
206 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
207 Add append-flags -mieee on sh, bug #357559
208
209 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
210 alpha/arm/ia64/s390/sh stable wrt #355439
211
212 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
213 Marked ~ppc64 wrt #332593
214
215 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
216 ruby-1.8.7_p334.ebuild:
217 x86 stable wrt security bug #355439
218
219 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
220 ruby-1.8.7_p334.ebuild:
221 ppc/ppc64 stable wrt #355439
222
223 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
224 Stable on amd64 wrt bug #355439
225
226 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
227 Stable for HPPA (bug #355439).
228
229*ruby-1.8.7_p334 (19 Feb 2011)
230
231 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
232 Version bump 1.8.7 series, security bug 355439
233
234 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
235 ruby-1.9.2.ebuild:
236 Remove PROVIDE for old-style virtual/ruby per bug 265054.
237
238 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
239 Remove masked ruby 1.8.6 per bug 332597.
240
241 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
242 -ruby-1.9.2_rc2.ebuild:
243 Removing old and vulnerable ebuilds
244
245 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
246 Marking ruby-1.8.7_p302 ppc64 for bug 332957
247
248 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
249 alpha/ia64/s390/sh/sparc stable wrt #332957
250
251*ruby-1.9.2 (24 Aug 2010)
252
253 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
254 metadata.xml:
255 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
256 and x86-fbsd due to a new dependency on rdoc.
257
258 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
259 arm stable, bug #332957
260
261 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
262 ruby-1.8.7_p302.ebuild:
263 x86 stable wrt security bug #332957
264
265 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
266 Stable on amd64 wrt bug #332957
267
268 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
269 Stable for PPC (bug #332957).
270
271 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
272 Stable for HPPA (bug #332957).
273
274*ruby-1.8.7_p302 (21 Aug 2010)
275
276 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
277 +ruby-1.8.7_p302.ebuild:
278 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
279 installation path.
280
281*ruby-1.8.6_p399 (19 Aug 2010)
282
283 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
284 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
285 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
286 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
287 installation path (reported by the x86 team in bug 332597)
288
289*ruby-1.9.2_rc2-r1 (18 Aug 2010)
290
291 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
292 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
293 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
294 the rubygems loading code. Add USE flag for psych.
295
296 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
297 ruby-1.9.2_rc2.ebuild:
298 Remove two keepdir that will try to keep an empty path, closes bug
299 #333163.
300
301 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
302 Marked ~ppc (bug #332593).
303
304 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
305 ruby-1.9.2_rc2.ebuild:
306 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
307
308 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
309 ruby-1.8.7_p299.ebuild:
310 Bump eselect-ruby dependency
311
312 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
313 -ruby-1.9.1_p429.ebuild:
314 Remove ebuild that is not target for unmask anyway.
315
316 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
317 ruby-1.9.2_rc2.ebuild:
318 Try 2 to fix the berkdb 5 issue on 1.9.
319
320 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
321 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
322 ruby-1.9.2_rc2.ebuild:
323 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
324 support for adding new patchsets without bumping the revision for all the
325 old ebuilds as well.
326
327*ruby-1.9.2_rc2 (14 Jul 2010)
328
329 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
330 +ruby-1.9.2_rc2.ebuild:
331 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
332 might cause _further_ build failures as it changed slightly behaviour.
333 You're going to need to rebuild rubygems and then all the packages
334 previously installed after upgrading to this.
335
336 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
337 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
338 -ruby-1.9.1_p376.ebuild:
339 Cleanup old versions.
340
341*ruby-1.9.1_p429 (04 Jul 2010)
342
343 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
344 +ruby-1.9.1_p429.ebuild:
345 Version bump to new 1.9.1 release.
346
347*ruby-1.8.7_p299 (23 Jun 2010)
348
349 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
350 +ruby-1.8.7_p299.ebuild:
351 Version bump.
352
353 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
354 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
355 remove useless comments
356
357 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
358 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
359 ruby-1.9.1_p376.ebuild:
360 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
361 dev.gentoo.org now.
362
363 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
364 ruby-1.9.1_p376.ebuild:
365 Use the correct RUBYLIB.
366
367*ruby-1.8.7_p249-r2 (18 May 2010)
368*ruby-1.8.6_p388-r1 (18 May 2010)
369
370 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
371 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
372 ruby-1.9.1_p376.ebuild, metadata.xml:
373 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
374 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
375 add USE flags for ncurses, readline and libedit, and properly depend on
376 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
377 Emacs versions support ruby-mode themselves and it should be even more
378 updated.
379
380*ruby-1.8.7_p249-r1 (06 May 2010)
381
382 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
383 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
384 309789 by Sune Kloppenborg Jeppesen.
385
386 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
387 ruby-1.8.7_p249.ebuild:
388 Use $PVR instead of $PV in patchset names
389
390 06 May 2010; Alex Legler <a3li@gentoo.org>
391 -files/ruby-1.8.6-memory-leak.diff,
392 -files/ruby18-mkmf-parallel-install.patch,
393 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
394 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
395 Remove old version. Cleanup in files/
396
397*ruby-1.9.1_p376 (01 May 2010)
398
399 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
400 Version bump. Fixes security bugs 296052 and 300468. No longer installs
401 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
402 instead.
403
404 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
405 -ruby-1.8.7_p174-r1.ebuild:
406 Remove vulnerable ebuilds, 300468
407
408 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
409 ruby-1.8.7_p249.ebuild:
410 amd64 stable, security bug 300468
411
412 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
413 ruby-1.8.7_p249.ebuild:
414 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
415
416 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
417 Stable for HPPA (bug #300468).
418
419 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
420 Stable for HPPA (bug #300468).
421
422 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
423 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
424
425 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
426 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
427
428 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
429 ruby-1.8.6_p388.ebuild:
430 stable x86, security bug 300468
431
432 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
433 ruby-1.8.7_p249.ebuild:
434 stable x86, security bug 300468
435
436*ruby-1.8.6_p388 (10 Jan 2010)
437
438 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
439 +ruby-1.8.6_p388.ebuild:
440 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
441 version. The new ebuild also has the fix for bug 168939.
442
443*ruby-1.8.7_p249 (10 Jan 2010)
444
445 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
446 +ruby-1.8.7_p249.ebuild:
447 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
448 version
449
450 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
451 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
452
453*ruby-1.8.7_p248 (25 Dec 2009)
454
455 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
456 Version bump
457
458 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
459 Remove old version.
460
461 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
462 Remove old version.
463
464 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
465 ia64/s390/sh stable wrt #288699
466
467 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
468 stable sparc, bug 288699
469
470 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
471 arm stable, bug #288699
472
473 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
474 amd64/x86 stable, bug #288699
475
476 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
477 ruby-1.8.7_p174-r1.ebuild:
478 Stable on alpha, bug #288699
479
480 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
481 ppc stable #288699
482
483 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
484 Stable for HPPA (bug #288699).
485
486 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
487 Marked ~hppa too.
488
489*ruby-1.8.7_p174-r1 (06 Oct 2009)
490
491 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
492 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
493 eselect-ruby cleanup feature.
494
495*ruby-1.9.1_p243 (09 Sep 2009)
496
497 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
498 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
499 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
500 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
501 -files/ruby19-rubygems-proxy.patch,
502 -files/ruby-1.9.1_p129-parallelmake.patch,
503 -files/ruby19-mkmf-parallel-install.patch:
504 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
505 168939. Cleaning up old patches.
506
507*ruby-1.8.6_p383 (20 Aug 2009)
508
509 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
510 Patchlevel bump.
511
512 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
513 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
514 ruby-1.9.1_p129-r1.ebuild:
515 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
516
517 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
518 Removing vulnerable ebuild, bug 273213.
519
520 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
521 Marking ruby-1.8.6_p369 ppc for bug 273213
522
523 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
524 ruby-1.9.1_p129-r1.ebuild:
525 Prepend our library path instead of overwriting it during src_install.
526 Thanks to the reporter of bug #274824.
527
528*ruby-1.8.7_p174 (18 Jun 2009)
529
530 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
531 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
532 Replacing 187_p173 with _p174 because of a regression. Unifying the
533 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
534 patchsets.
535
536 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
537 Marking ruby-1.8.6_p369 ppc64 for bug 273213
538
539 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
540 arm/ia64/s390/sh/sparc stable wrt #273213
541
542 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
543 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
544 Removing old version, minor cleanup
545
546 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
547 -files/ruby-1.8.6-openssl.patch,
548 -files/ruby-1.8.6-shortname_constants.patch,
549 -files/ruby-1.8.6_p111-r13657.patch,
550 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
551 Removing vulnerable old Ruby version and stale patches, bug 274108.
552
553 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
554 ruby-1.8.6_p369.ebuild:
555 Stable on alpha, bug #273213
556
557 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
558 Stable for HPPA (bug #273213).
559
560 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
561 ruby-1.8.6_p369.ebuild:
562 stable x86, security bug 273213
563
564 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
565 amd64 stable, security bug 273213.
566
567*ruby-1.8.7_p173 (10 Jun 2009)
568*ruby-1.8.6_p369 (10 Jun 2009)
569
570 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
571 +ruby-1.8.7_p173.ebuild:
572 Version bumps for bug #273213.
573
574*ruby-1.9.1_p129-r1 (27 May 2009)
575
576 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
577 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
578 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
579 +files/ruby-1.9.1_p129-parallelmake.patch:
580 Revision bump, add patches 1) to make Ruby behave more similarly between
581 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
582 extensions (undefined symbols in them will cause abort at runtime 3) to
583 remove a concurrency issue when building the dl extension that could
584 result in a broken dl.so.
585
586 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
587 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
588 Don't block rdoc-2 or later (which may enter Portage one day as it's
589 needed by some Rakefiles).
590
591 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
592 ruby-1.9.1_p129.ebuild:
593 Add ~x86-fbsd keyword.
594
595 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
596 keyword ~sparc-fbsd, bug #252315
597
598*ruby-1.9.1_p129 (15 May 2009)
599
600 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
601 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
602 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
603 included in every release.
604
605 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
606 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
607 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
608 ruby-1.8.7_p160.ebuild:
609 Removing vulnerable versions (#268515), fixing license (#233747).
610
611 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
612 Stable for HPPA (bug #268515).
613
614 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
615 Adapting rubygems notice.
616
617 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
618 amd64 stable, bug #268515.
619
620 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
621 arm/ia64/s390/sh/sparc stable wrt #268515
622
623 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
624 ruby-1.8.6_p368.ebuild:
625 stable x86, security bug 268515
626
627 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
628 ruby-1.8.6_p368.ebuild:
629 Stable on alpha, bug #268515
630
631 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
632 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
633
634*ruby-1.8.7_p160 (07 May 2009)
635*ruby-1.8.6_p368 (07 May 2009)
636
637 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
638 +ruby-1.8.7_p160.ebuild:
639 Version bump as per secbug 268515. NB: These are the first ebuilds that
640 no longer use ruby-config.
641
642*ruby-1.9.1-r1 (03 Apr 2009)
643*ruby-1.8.7_p72-r11 (03 Apr 2009)
644*ruby-1.8.6_p287-r13 (03 Apr 2009)
645
646 03 Apr 2009; Alex Legler <a3li@gentoo.org>
647 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
648 +files/ruby18-mkmf-parallel-install.patch,
649 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
650 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
651 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
652 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
653 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
654 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
655 happy.
656
657*ruby-1.9.1 (21 Mar 2009)
658
659 21 Mar 2009; Alex Legler <a3li@gentoo.org>
660 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
661 +ruby-1.9.1.ebuild:
662 Adding Ruby 1.9.1 for preliminary testing
663
664 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
665 ruby-1.8.6_p287-r12.ebuild:
666 Marked ~ppc for bug #252315.
667
668 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
669 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
670 bug 261982.
671
672 09 Mar 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p287-r1.ebuild,
673 -ruby-1.8.6_p287-r3.ebuild, -ruby-1.8.6_p287-r4.ebuild,
674 -ruby-1.8.6_p287-r10.ebuild, -ruby-1.8.6_p287-r11.ebuild,
675 -ruby-1.8.7_p72-r1.ebuild, -ruby-1.8.7_p72-r2.ebuild:
676 Cleanup
677
678*ruby-1.8.7_p72-r10 (07 Mar 2009)
679
680 07 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
681 +ruby-1.8.7_p72-r10.ebuild:
682 Add a revision of ruby 1.8.7 using eselect ruby.
683
684 03 Mar 2009; Peter Volkov <pva@gentoo.org> ruby-1.8.6_p287-r12.ebuild:
685 ~mips keyworded, bug #252315.
686
687 25 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
688 ruby-1.8.6_p287-r5.ebuild:
689 ppc stable, bug #260006
690
691 25 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
692 arm/ia64/s390/sh/sparc/x86 stable wrt #260006
693
694 24 Feb 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p287-r5.ebuild,
695 ruby-1.8.6_p287-r12.ebuild, ruby-1.8.7_p72-r2.ebuild:
696 Fixing Tk USE flag test, bug 258893.
697
698 23 Feb 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
699 Marking ruby-1.8.6_p287-r5 ppc64 for bug 260006
700
701 23 Feb 2009; Tobias Heinlein <keytoaster@gentoo.org>
702 ruby-1.8.6_p287-r5.ebuild:
703 amd64 stable wrt security bug #260006
704
705 23 Feb 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r5.ebuild:
706 Stable for HPPA (bug #260006).
707
708 23 Feb 2009; Tobias Klausmann <klausman@gentoo.org>
709 ruby-1.8.6_p287-r5.ebuild:
710 Stable on alpha, bug #260006
711
712*ruby-1.8.7_p72-r2 (23 Feb 2009)
713*ruby-1.8.6_p287-r12 (23 Feb 2009)
714*ruby-1.8.6_p287-r5 (23 Feb 2009)
715
716 23 Feb 2009; Alex Legler <a3li@gentoo.org> +files/ruby-mkconfig.patch,
717 +files/ruby-ossl_ocsp-verification.patch, +ruby-1.8.6_p287-r5.ebuild,
718 +ruby-1.8.6_p287-r12.ebuild, +ruby-1.8.7_p72-r2.ebuild:
719 Revision bumps for security bug 260006 (X.509 certificate spoofing). Also
720 fixing bugs 234877 (backported patch for mkconfig), 258893 (ebuild dies
721 now before compilation if Tk useflags don't match) and 230748 (adding
722 --enable-option-checking=no for newer versions of autoconf).
723
724 10 Feb 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
725 arm/ia64/s390/sh/sparc stable wrt #254307
726
727 25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
728 ruby-1.8.6_p287-r4.ebuild:
729 Stable on alpha, bug #254307
730
731 20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
732 ruby-1.8.6_p287-r11.ebuild:
733 keyword ~x86-fbsd, bug #252315
734
735 17 Jan 2009; nixnut <nixnut@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
736 ppc stable #254307
737
738 15 Jan 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
739 amd64/x86 stable, bug #254307
740
741 14 Jan 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
742 stable ppc64, bug 254307
743
744 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r4.ebuild:
745 Stable for HPPA (bug #254307).
746
747 14 Jan 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r10.ebuild,
748 ruby-1.8.6_p287-r11.ebuild:
749 Marked ~hppa (bug #252315).
750
751*ruby-1.8.6_p287-r11 (11 Jan 2009)
752
753 11 Jan 2009; Hans de Graaff <graaff@gentoo.org>
754 +files/ruby-1.8.6-openssl.patch, +ruby-1.8.7_p287-r4,
755 +ruby-1.8.6_p287-r11.ebuild:
756 Backport conditional definition of missing openssl functions from ruby 1.8.7.
757 Fixes #254307.
758
759 29 Dec 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
760 Marking ruby-1.8.6_p287-r10 ~ppc64 for bug 252315
761
762 26 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r10.ebuild:
763 Add ~alpha/~arm/~ia64/~s390/~sh wrt #251159
764
765 24 Dec 2008; Friedrich Oslage <bluebird@gentoo.org>
766 ruby-1.8.6_p287-r10.ebuild:
767 Add ~sparc keyword, bug #252315
768
769*ruby-1.8.6_p287-r10 (23 Dec 2008)
770
771 23 Dec 2008; Hans de Graaff <graaff@gentoo.org>
772 +ruby-1.8.6_p287-r10.ebuild:
773 Version bump which switches from ruby-config to eselect-ruby. Dropped most
774 keywords since eselect-ruby does not yet have these keywords.
775
776 23 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
777 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
778 Revert the ruby-config changes. We can't remove them until we provide an
779 alternative outside the ebuilds, and eselect-ruby isn't stable yet. Apologies
780 for breaking things as mentioned in bug #251833.
781
782 22 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
783 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
784 ruby-1.8.7_p72-r1.ebuild:
785 Remove pkg_postinst and pkg_postrm functions now that ruby-config is gone.
786 Thanks for the people noticing this in bug #251833.
787
788 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
789 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild,
790 ruby-1.8.7_p72-r1.ebuild:
791 Drop dependency on ruby-config, which will be removed from the tree. We
792 currently only have one major version of ruby in the tree (Ruby 1.8), so there
793 is no need for ruby-config at this moment. For newer versions of Ruby we will
794 use eselect-ruby, which can be found in the ruby overlay at the moment.
795
796 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p114.ebuild,
797 ruby-1.8.6_p287-r1.ebuild, ruby-1.8.6_p287-r3.ebuild:
798 Use mirror://ruby in SRC_URI, fixes #237392.
799
800 21 Dec 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p111.ebuild,
801 -ruby-1.8.6_p111-r1.ebuild, -ruby-1.8.6_p287-r2.ebuild,
802 -ruby-1.8.7_p72.ebuild:
803 Remove old versions. Leave one old stable version with cjk support.
804
805*ruby-1.8.6_p287-r3 (29 Nov 2008)
806
807 29 Nov 2008; Hans de Graaff <graaff@gentoo.org>
808 files/ruby-1.8.6_p287-entity_expansion_limit.diff,
809 +ruby-1.8.6_p287-r3.ebuild:
810 Fix our expansion limit patch according to debian bug report
811 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502535 and bump the ebuild to
812 make sure people will pick up the fixed version. Thanks to Alex Legler for
813 mentioning the patch.
814
815*ruby-1.8.7_p72-r1 (26 Nov 2008)
816*ruby-1.8.6_p287-r2 (26 Nov 2008)
817
818 26 Nov 2008; Hans de Graaff <graaff@gentoo.org>
819 +files/ruby-1.8.6-shortname_constants.patch, +ruby-1.8.6_p287-r2.ebuild,
820 +ruby-1.8.7_p72-r1.ebuild:
821 Fix problem with shortname constants #247790, already fixed in upstream SVN.
822 Thanks to Alex Legler for providing the patch.
823
824 26 Nov 2008; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p286.ebuild,
825 -ruby-1.8.6_p287.ebuild:
826 Remove versions that will not become stable
827
828 16 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
829 ruby-1.8.6_p287-r1.ebuild:
830 ppc stable, bug #225465
831
832 11 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
833 ruby-1.8.6_p287-r1.ebuild:
834 amd64 stable wrt security bug #225465
835
836 11 Sep 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
837 alpha/ia64/x86 stable wrt #225465
838
839 11 Sep 2008; Ferris McCormick <fmccor@gentoo.org>
840 ruby-1.8.6_p287-r1.ebuild:
841 Sparc stable --- Security Bug #225465 --- good since late August.
842
843 11 Sep 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
844 Stable on ppc64; bug #225465
845
846 11 Sep 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p287-r1.ebuild:
847 Stable for HPPA (bug #225465).
848
849*ruby-1.8.6_p287-r1 (29 Aug 2008)
850
851 29 Aug 2008; Hans de Graaff <graaff@gentoo.org>
852 +files/ruby-1.8.6_p287-entity_expansion_limit.diff,
853 +ruby-1.8.6_p287-r1.ebuild:
854 Fix REXML security issues, bug #236060.
855
856 23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
857 Add GLEP 56 USE flag descriptions.
858
859*ruby-1.8.7_p72 (15 Aug 2008)
860
861 15 Aug 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_p22.ebuild,
862 +ruby-1.8.7_p72.ebuild:
863 bump 1.8.7 to latest patch release
864
865*ruby-1.8.6_p287 (11 Aug 2008)
866
867 11 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p287.ebuild:
868 Version bump for brown paper bag relelease.
869
870 10 Aug 2008; Hans de Graaff <graaff@gentoo.org>
871 -files/ruby-1.8.6-revert-r15856.patch, -ruby-1.8.6_p230.ebuild:
872 Remove broken version in favor of the just-added 1.8.6_p286
873
874*ruby-1.8.6_p286 (10 Aug 2008)
875
876 10 Aug 2008; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p286.ebuild:
877 Version bump to latest released version of ruby 1.8.6. This version fixes the
878 security issues reported in #225465 and #234224. The cjk USE flag has been
879 dropped since no compatible patches have been released yet.
880
881 25 Jul 2008; Michael Sterrett <mr_bones_@gentoo.org>
882 ruby-1.8.6_p230.ebuild:
883 drop cjk from SRC_URI as well
884
885 15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
886 Drop cjk support since the most recent oniguruma patches no longer apply to
887 this version, #230111.
888
889 29 Jun 2008; Hans de Graaff <graaff@gentoo.org>
890 +files/ruby-1.8.6-revert-r15856.patch, +ruby-1.8.6_p230.ebuild:
891 Try to fix the security issues reported in #225465 for ruby 1.8.6.
892 Unfortunately the official p230 has a change which causes segmentation faults
893 for applications like Rails and RSpec, so we are reverting that specific
894 change.
895
896*ruby-1.8.7_p22 (29 Jun 2008)
897
898 29 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7.ebuild,
899 +ruby-1.8.7_p22.ebuild:
900 bump 1.8.7 for security fix
901
902 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
903 nevermind, don't bump this yet
904
905*ruby-1.8.6_p230 (20 Jun 2008)
906
907 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6_p230.ebuild:
908 version bump
909
910*ruby-1.8.7 (10 Jun 2008)
911
912 10 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.7_pre2.ebuild,
913 +ruby-1.8.7.ebuild:
914 bump 1.8.7 to final
915
916*ruby-1.8.7_pre2 (21 Apr 2008)
917
918 21 Apr 2008; Richard Brown <rbrown@gentoo.org> -ruby-1.8.7_pre1.ebuild,
919 +ruby-1.8.7_pre2.ebuild:
920 Version Bump
921
922*ruby-1.8.7_pre1 (16 Apr 2008)
923
924 16 Apr 2008; Richard Brown <rbrown@gentoo.org> +ruby-1.8.7_pre1.ebuild:
925 Version bump. Drop cjk until a new version of oniguruma appears.
926
927 06 Mar 2008; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p114.ebuild:
928 amd64 stable, bug 212264
929
930 06 Mar 2008; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p114.ebuild:
931 Stable for HPPA (bug #212264).
932
933 05 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
934 ruby-1.8.6_p114.ebuild:
935 ppc stable, bug #212264
936
937 05 Mar 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p114.ebuild:
938 alpha/ia64 stable wrt #212264
939
940 05 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
941 ruby-1.8.6_p114.ebuild:
942 stable x86, security bug 212264
943
944 05 Mar 2008; Ferris McCormick <fmccor@gentoo.org> ruby-1.8.6_p114.ebuild:
945 Sparc stable, Security Bug #212264, builds and installs, initial tests run
946 as expected.
947
948 05 Mar 2008; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p114.ebuild:
949 Marking ruby-1.8.6_p114 ppc64 for bug 212264
950
951*ruby-1.8.6_p114 (05 Mar 2008)
952
953 05 Mar 2008; Richard Brown <rbrown@gentoo.org>
954 -files/ruby-1.8.4-glibc24-eaccess.diff, -files/ruby-1.8.4-yaml.diff,
955 -files/ruby-1.8.5_p113-net-http-p114.patch, -ruby-1.8.4-r3.ebuild,
956 -ruby-1.8.5_p113.ebuild, +ruby-1.8.6_p114.ebuild:
957 Version bump for #212264. Remove old ebuilds.
958
959 17 Feb 2008; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
960 alpha/ia64 stable wrt #208916
961
962 17 Feb 2008; nixnut <nixnut@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
963 Stable on ppc wrt bug 208916
964
965 16 Feb 2008; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
966 x86 stable, bug #208916
967
968 16 Feb 2008; Ferris McCormick <fmccor@gentoo.org>
969 ruby-1.8.6_p111-r1.ebuild:
970 Sparc stable --- Bug #208916 --- working well for about 6 weeks.
971
972 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
973 -files/ruby-1.8.6-exit-status.patch,
974 -files/ruby-1.8.6_p110-net-http-p111.patch,
975 -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
976 -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
977 -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
978 Remove old versions
979
980 05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
981 Stable on ppc64
982
983 26 Dec 2007; Peter Weller <welp@gentoo.org> ruby-1.8.6_p111.ebuild:
984 Stable on amd64; bug 199191
985
986 24 Dec 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p111.ebuild:
987 alpha/ia64/sparc stable wrt #199191
988
989 24 Dec 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
990 Remove now-obsolete warning about coreutils versions, #203156.
991
992 24 Dec 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
993 Stable for HPPA (bug #199191).
994
995*ruby-1.8.6_p111-r1 (23 Dec 2007)
996
997 23 Dec 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p111-r1.ebuild:
998 Remove dependencies on system packages. Add berkdb (bug #199705), gdbm and
999 ssl USE flags. Patch to p113.
1000
1001 23 Dec 2007; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p111.ebuild:
1002 Marking ruby-1.8.6_p111 ppc and ppc64 for bug 199191
1003
1004 23 Dec 2007; Markus Meier <maekke@gentoo.org> ruby-1.8.6_p111.ebuild:
1005 x86 stable, security bug #199191
1006
1007*ruby-1.8.6_p111 (23 Dec 2007)
1008
1009 23 Dec 2007; Richard Brown <rbrown@gentoo.org>
1010 +files/ruby-1.8.6_p111-r13657.patch, +ruby-1.8.6_p111.ebuild:
1011 Version bump with patch for bug #199191
1012
1013 14 Dec 2007; Ulrich Mueller <ulm@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1014 Move dependency on (X)Emacs modes to PDEPEND.
1015
1016 25 Oct 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p110-r2.ebuild:
1017 Add back ~hppa keyword now that XEmacs support files have been keyworded,
1018 bug 196413
1019
1020*ruby-1.8.6_p110-r2 (21 Oct 2007)
1021
1022 21 Oct 2007; Hans de Graaff <graaff@gentoo.org>
1023 +ruby-1.8.6_p110-r2.ebuild:
1024 Add emacs and xemacs USE flags and use them to pull in the correct editing
1025 mode for each. Had to drop several arch keywords as reported on bug 196413.
1026
1027 13 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1028 amd64 stable, security bug 194236
1029
1030 11 Oct 2007; Markus Rothe <corsair@gentoo.org> ruby-1.8.5_p113.ebuild,
1031 ruby-1.8.6_p110-r1.ebuild:
1032 Stable on ppc64; bug #194236
1033
1034 09 Oct 2007; Steve Dibb <beandog@gentoo.org> ruby-1.8.6-r1.ebuild:
1035 amd64 stable, security bug 194236
1036
1037 08 Oct 2007; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1038 Stable for HPPA (bug #194236).
1039
1040 08 Oct 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p110-r1.ebuild:
1041 alpha/ia64/sparc stable wrt security #194236
1042
1043 07 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
1044 ruby-1.8.6_p110-r1.ebuild:
1045 ppc stable, bug #194236
1046
1047 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1048 ruby-1.8.6_p110-r1.ebuild:
1049 stable x86, security bug 194236
1050
1051 07 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
1052 ruby-1.8.5_p113.ebuild:
1053 stable x86, security bug 194236
1054
1055 07 Oct 2007; Richard Brown <rbrown@gentoo.org> -ruby-1.8.5_p35.ebuild,
1056 -ruby-1.8.6_p36-r3.ebuild, -ruby-1.8.6_p36-r4.ebuild,
1057 -ruby-1.8.6_p110.ebuild:
1058 Remove old versions
1059
1060*ruby-1.8.6_p110-r1 (30 Sep 2007)
1061*ruby-1.8.5_p113 (30 Sep 2007)
1062
1063 30 Sep 2007; Richard Brown <rbrown@gentoo.org>
1064 +files/ruby-1.8.5_p113-net-http-p114.patch,
1065 +files/ruby-1.8.6_p110-net-http-p111.patch, +ruby-1.8.5_p113.ebuild,
1066 +ruby-1.8.6_p110-r1.ebuild:
1067 Fix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113,
1068 using 1.8.6-p110 as base ebuild.
1069
1070 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1071 More fixes from gentoo-dev and graaff
1072
1073 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
1074 Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
1075
1076*ruby-1.8.6_p110 (24 Sep 2007)
1077
1078 24 Sep 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p110.ebuild:
1079 Version bump
1080
1081*ruby-1.8.6_p36-r4 (26 Aug 2007)
1082
1083 26 Aug 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
1084 +ruby-1.8.6_p36-r4.ebuild:
1085 Use user LDFLAGS, #181436
1086
1087 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> ruby-1.8.4-r3.ebuild,
1088 ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p35.ebuild:
1089 MANIFEST was already gone in ruby 1.8.4, so remove it also from the old
1090 ebuilds, including the currently stable 1.8.5_p2-r1, #189241.
1091
1092 17 Aug 2007; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.5_p2.ebuild,
1093 -ruby-1.8.5_p12.ebuild, -ruby-1.8.6_p36-r1.ebuild,
1094 -ruby-1.8.6_p36-r2.ebuild:
1095 Remove some older versions that will not be promoted to stable, keeping at
1096 least one version of each release.
1097
1098 05 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
1099 ruby-1.8.6_p36-r3.ebuild:
1100 (QA) RESTRICT clean up.
1101
1102*ruby-1.8.6_p36-r3 (04 Jul 2007)
1103
1104 04 Jul 2007; Mike Doty <kingtaco@gentoo.org>
1105 +files/ruby-1.8.6-memory-leak.diff, +ruby-1.8.6_p36-r3.ebuild:
1106 fixed memory leak loading .so bug #182946
1107
1108 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ruby-1.8.4-r3.ebuild,
1109 ruby-1.8.5_p2.ebuild, ruby-1.8.5_p2-r1.ebuild, ruby-1.8.5_p12.ebuild,
1110 ruby-1.8.5_p35.ebuild, ruby-1.8.6-r1.ebuild, ruby-1.8.6_p36-r1.ebuild,
1111 ruby-1.8.6_p36-r2.ebuild:
1112 (QA) RESTRICT clean up.
1113
1114 21 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> ruby-1.8.6-r1.ebuild:
1115 Re-add stable keyword for alpha as per bug #181110
1116
1117 21 Jun 2007; Christoph Mende <angelos@gentoo.org> ruby-1.8.6-r1.ebuild:
1118 Back to ~amd64 wrt bug 181110
1119
1120 21 Jun 2007; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6-r1.ebuild:
1121 Mark 1.8.6 unstable on alpha/ia64/x86 wrt #181110
4 1122
5*ruby-1.8.6_p36-r2 (20 Jun 2007) 1123*ruby-1.8.6_p36-r2 (20 Jun 2007)
6 1124
7 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild: 1125 20 Jun 2007; Richard Brown <rbrown@gentoo.org> +ruby-1.8.6_p36-r2.ebuild:
8 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671 1126 Re-add cjk USE flag, thanks to Hannes Wyss, bug #182671

Legend:
Removed from v.1.285  
changed lines
  Added in v.1.539

  ViewVC Help
Powered by ViewVC 1.1.20