/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.386 Revision 1.463
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.386 2009/03/10 14:43:35 a3li Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.463 2010/08/17 15:57:31 flameeyes Exp $
4
5 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
6 ruby-1.9.2_rc2.ebuild:
7 Remove two keepdir that will try to keep an empty path, closes bug
8 #333163.
9
10 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
11 Marked ~ppc (bug #332593).
12
13 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
14 ruby-1.9.2_rc2.ebuild:
15 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
16
17 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
18 ruby-1.8.7_p299.ebuild:
19 Bump eselect-ruby dependency
20
21 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
22 -ruby-1.9.1_p429.ebuild:
23 Remove ebuild that is not target for unmask anyway.
24
25 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
26 ruby-1.9.2_rc2.ebuild:
27 Try 2 to fix the berkdb 5 issue on 1.9.
28
29 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
30 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
31 ruby-1.9.2_rc2.ebuild:
32 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
33 support for adding new patchsets without bumping the revision for all the
34 old ebuilds as well.
35
36*ruby-1.9.2_rc2 (14 Jul 2010)
37
38 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
39 +ruby-1.9.2_rc2.ebuild:
40 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
41 might cause _further_ build failures as it changed slightly behaviour.
42 You're going to need to rebuild rubygems and then all the packages
43 previously installed after upgrading to this.
44
45 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
46 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
47 -ruby-1.9.1_p376.ebuild:
48 Cleanup old versions.
49
50*ruby-1.9.1_p429 (04 Jul 2010)
51
52 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
53 +ruby-1.9.1_p429.ebuild:
54 Version bump to new 1.9.1 release.
55
56*ruby-1.8.7_p299 (23 Jun 2010)
57
58 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
59 +ruby-1.8.7_p299.ebuild:
60 Version bump.
61
62 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
63 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
64 remove useless comments
65
66 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
67 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
68 ruby-1.9.1_p376.ebuild:
69 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
70 dev.gentoo.org now.
71
72 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
73 ruby-1.9.1_p376.ebuild:
74 Use the correct RUBYLIB.
75
76*ruby-1.8.7_p249-r2 (18 May 2010)
77*ruby-1.8.6_p388-r1 (18 May 2010)
78
79 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
80 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
81 ruby-1.9.1_p376.ebuild, metadata.xml:
82 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
83 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
84 add USE flags for ncurses, readline and libedit, and properly depend on
85 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
86 Emacs versions support ruby-mode themselves and it should be even more
87 updated.
88
89*ruby-1.8.7_p249-r1 (06 May 2010)
90
91 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
92 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
93 309789 by Sune Kloppenborg Jeppesen.
94
95 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
96 ruby-1.8.7_p249.ebuild:
97 Use $PVR instead of $PV in patchset names
98
99 06 May 2010; Alex Legler <a3li@gentoo.org>
100 -files/ruby-1.8.6-memory-leak.diff,
101 -files/ruby18-mkmf-parallel-install.patch,
102 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
103 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
104 Remove old version. Cleanup in files/
105
106*ruby-1.9.1_p376 (01 May 2010)
107
108 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
109 Version bump. Fixes security bugs 296052 and 300468. No longer installs
110 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
111 instead.
112
113 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
114 -ruby-1.8.7_p174-r1.ebuild:
115 Remove vulnerable ebuilds, 300468
116
117 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
118 ruby-1.8.7_p249.ebuild:
119 amd64 stable, security bug 300468
120
121 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
122 ruby-1.8.7_p249.ebuild:
123 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
124
125 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
126 Stable for HPPA (bug #300468).
127
128 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
129 Stable for HPPA (bug #300468).
130
131 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
132 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
133
134 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
135 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
136
137 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
138 ruby-1.8.6_p388.ebuild:
139 stable x86, security bug 300468
140
141 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
142 ruby-1.8.7_p249.ebuild:
143 stable x86, security bug 300468
144
145*ruby-1.8.6_p388 (10 Jan 2010)
146
147 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
148 +ruby-1.8.6_p388.ebuild:
149 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
150 version. The new ebuild also has the fix for bug 168939.
151
152*ruby-1.8.7_p249 (10 Jan 2010)
153
154 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
155 +ruby-1.8.7_p249.ebuild:
156 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
157 version
158
159 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
160 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
161
162*ruby-1.8.7_p248 (25 Dec 2009)
163
164 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
165 Version bump
166
167 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
168 Remove old version.
169
170 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
171 Remove old version.
172
173 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
174 ia64/s390/sh stable wrt #288699
175
176 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
177 stable sparc, bug 288699
178
179 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
180 arm stable, bug #288699
181
182 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
183 amd64/x86 stable, bug #288699
184
185 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
186 ruby-1.8.7_p174-r1.ebuild:
187 Stable on alpha, bug #288699
188
189 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
190 ppc stable #288699
191
192 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
193 Stable for HPPA (bug #288699).
194
195 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
196 Marked ~hppa too.
197
198*ruby-1.8.7_p174-r1 (06 Oct 2009)
199
200 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
201 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
202 eselect-ruby cleanup feature.
203
204*ruby-1.9.1_p243 (09 Sep 2009)
205
206 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
207 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
208 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
209 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
210 -files/ruby19-rubygems-proxy.patch,
211 -files/ruby-1.9.1_p129-parallelmake.patch,
212 -files/ruby19-mkmf-parallel-install.patch:
213 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
214 168939. Cleaning up old patches.
215
216*ruby-1.8.6_p383 (20 Aug 2009)
217
218 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
219 Patchlevel bump.
220
221 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
222 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
223 ruby-1.9.1_p129-r1.ebuild:
224 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
225
226 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
227 Removing vulnerable ebuild, bug 273213.
228
229 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
230 Marking ruby-1.8.6_p369 ppc for bug 273213
231
232 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
233 ruby-1.9.1_p129-r1.ebuild:
234 Prepend our library path instead of overwriting it during src_install.
235 Thanks to the reporter of bug #274824.
236
237*ruby-1.8.7_p174 (18 Jun 2009)
238
239 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
240 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
241 Replacing 187_p173 with _p174 because of a regression. Unifying the
242 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
243 patchsets.
244
245 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
246 Marking ruby-1.8.6_p369 ppc64 for bug 273213
247
248 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
249 arm/ia64/s390/sh/sparc stable wrt #273213
250
251 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
252 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
253 Removing old version, minor cleanup
254
255 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
256 -files/ruby-1.8.6-openssl.patch,
257 -files/ruby-1.8.6-shortname_constants.patch,
258 -files/ruby-1.8.6_p111-r13657.patch,
259 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
260 Removing vulnerable old Ruby version and stale patches, bug 274108.
261
262 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
263 ruby-1.8.6_p369.ebuild:
264 Stable on alpha, bug #273213
265
266 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
267 Stable for HPPA (bug #273213).
268
269 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
270 ruby-1.8.6_p369.ebuild:
271 stable x86, security bug 273213
272
273 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
274 amd64 stable, security bug 273213.
275
276*ruby-1.8.7_p173 (10 Jun 2009)
277*ruby-1.8.6_p369 (10 Jun 2009)
278
279 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
280 +ruby-1.8.7_p173.ebuild:
281 Version bumps for bug #273213.
282
283*ruby-1.9.1_p129-r1 (27 May 2009)
284
285 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
286 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
287 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
288 +files/ruby-1.9.1_p129-parallelmake.patch:
289 Revision bump, add patches 1) to make Ruby behave more similarly between
290 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
291 extensions (undefined symbols in them will cause abort at runtime 3) to
292 remove a concurrency issue when building the dl extension that could
293 result in a broken dl.so.
294
295 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
296 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
297 Don't block rdoc-2 or later (which may enter Portage one day as it's
298 needed by some Rakefiles).
299
300 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
301 ruby-1.9.1_p129.ebuild:
302 Add ~x86-fbsd keyword.
303
304 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
305 keyword ~sparc-fbsd, bug #252315
306
307*ruby-1.9.1_p129 (15 May 2009)
308
309 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
310 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
311 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
312 included in every release.
313
314 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
315 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
316 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
317 ruby-1.8.7_p160.ebuild:
318 Removing vulnerable versions (#268515), fixing license (#233747).
319
320 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
321 Stable for HPPA (bug #268515).
322
323 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
324 Adapting rubygems notice.
325
326 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
327 amd64 stable, bug #268515.
328
329 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
330 arm/ia64/s390/sh/sparc stable wrt #268515
331
332 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
333 ruby-1.8.6_p368.ebuild:
334 stable x86, security bug 268515
335
336 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
337 ruby-1.8.6_p368.ebuild:
338 Stable on alpha, bug #268515
339
340 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
341 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
342
343*ruby-1.8.7_p160 (07 May 2009)
344*ruby-1.8.6_p368 (07 May 2009)
345
346 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
347 +ruby-1.8.7_p160.ebuild:
348 Version bump as per secbug 268515. NB: These are the first ebuilds that
349 no longer use ruby-config.
350
351*ruby-1.9.1-r1 (03 Apr 2009)
352*ruby-1.8.7_p72-r11 (03 Apr 2009)
353*ruby-1.8.6_p287-r13 (03 Apr 2009)
354
355 03 Apr 2009; Alex Legler <a3li@gentoo.org>
356 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
357 +files/ruby18-mkmf-parallel-install.patch,
358 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
359 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
360 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
361 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
362 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
363 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
364 happy.
365
366*ruby-1.9.1 (21 Mar 2009)
367
368 21 Mar 2009; Alex Legler <a3li@gentoo.org>
369 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
370 +ruby-1.9.1.ebuild:
371 Adding Ruby 1.9.1 for preliminary testing
372
373 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
374 ruby-1.8.6_p287-r12.ebuild:
375 Marked ~ppc for bug #252315.
4 376
5 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild: 377 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
6 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes 378 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
7 bug 261982. 379 bug 261982.
8 380

Legend:
Removed from v.1.386  
changed lines
  Added in v.1.463

  ViewVC Help
Powered by ViewVC 1.1.20