/[gentoo-x86]/dev-lang/ruby/ChangeLog
Gentoo

Diff of /dev-lang/ruby/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.386 Revision 1.500
1# ChangeLog for dev-lang/ruby 1# ChangeLog for dev-lang/ruby
2# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.386 2009/03/10 14:43:35 a3li Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.500 2011/07/15 17:25:03 mattst88 Exp $
4
5 15 Jul 2011; Matt Turner <mattst88@gentoo.org> ruby-1.9.2-r1.ebuild:
6 Added ~mips, bug 332593
7
8 07 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
9 ruby-1.8.7_p334-r1.ebuild:
10 ppc64 stable wrt #369141
11
12 03 Jun 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
13 ia64/s390/sh/sparc stable wrt #369141
14
15 03 Jun 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
16 Stable for HPPA (bug #369141).
17
18 03 Jun 2011; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
19 Marking ruby-1.8.7_p334-r1 ppc for bug 369141
20
21 02 Jun 2011; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
22 arm/x86 stable, bug #369141
23
24 01 Jun 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334-r1.ebuild:
25 Stable on amd64 wrt bug #369141
26
27 01 Jun 2011; Tobias Klausmann <klausman@gentoo.org>
28 ruby-1.8.7_p334-r1.ebuild:
29 Stable on alpha, bug #369141
30
31*ruby-1.8.7_p334-r1 (31 May 2011)
32
33 31 May 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334-r1.ebuild:
34 Revision bump for security bug 369141 (CVE-2011-0188)
35
36*ruby-1.9.2-r1 (16 May 2011)
37
38 16 May 2011; Hans de Graaff <graaff@gentoo.org> +ruby-1.9.2-r1.ebuild:
39 Don't remove racc files since all other ruby targets ship these files
40 themselves as well. Closes bug 363419.
41
42 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p302.ebuild,
43 ruby-1.8.7_p334.ebuild:
44 Remove old version. Remove obsolete and unused old-style virtual/ruby.
45
46 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
47 Add ~alpha/~arm/~ia64/~s390/~sh/~sparc wrt #332593
48
49 07 Mar 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.9.2.ebuild:
50 Add append-flags -mieee on sh, bug #357559
51
52 26 Feb 2011; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p334.ebuild:
53 alpha/arm/ia64/s390/sh stable wrt #355439
54
55 26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ruby-1.9.2.ebuild:
56 Marked ~ppc64 wrt #332593
57
58 20 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
59 ruby-1.8.7_p334.ebuild:
60 x86 stable wrt security bug #355439
61
62 20 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
63 ruby-1.8.7_p334.ebuild:
64 ppc/ppc64 stable wrt #355439
65
66 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p334.ebuild:
67 Stable on amd64 wrt bug #355439
68
69 19 Feb 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p334.ebuild:
70 Stable for HPPA (bug #355439).
71
72*ruby-1.8.7_p334 (19 Feb 2011)
73
74 19 Feb 2011; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p334.ebuild:
75 Version bump 1.8.7 series, security bug 355439
76
77 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> ruby-1.9.2_rc2-r1.ebuild,
78 ruby-1.9.2.ebuild:
79 Remove PROVIDE for old-style virtual/ruby per bug 265054.
80
81 31 Dec 2010; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.6_p399.ebuild:
82 Remove masked ruby 1.8.6 per bug 332597.
83
84 07 Sep 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p249.ebuild,
85 -ruby-1.9.2_rc2.ebuild:
86 Removing old and vulnerable ebuilds
87
88 06 Sep 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p302.ebuild:
89 Marking ruby-1.8.7_p302 ppc64 for bug 332957
90
91 28 Aug 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p302.ebuild:
92 alpha/ia64/s390/sh/sparc stable wrt #332957
93
94*ruby-1.9.2 (24 Aug 2010)
95
96 24 Aug 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.2.ebuild,
97 metadata.xml:
98 Version bump. Fixes rdoc handling wrt bug 333897 by Park Ji-in. Drop hppa
99 and x86-fbsd due to a new dependency on rdoc.
100
101 23 Aug 2010; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p302.ebuild:
102 arm stable, bug #332957
103
104 21 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
105 ruby-1.8.7_p302.ebuild:
106 x86 stable wrt security bug #332957
107
108 21 Aug 2010; Markos Chandras <hwoarang@gentoo.org> ruby-1.8.7_p302.ebuild:
109 Stable on amd64 wrt bug #332957
110
111 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
112 Stable for PPC (bug #332957).
113
114 21 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p302.ebuild:
115 Stable for HPPA (bug #332957).
116
117*ruby-1.8.7_p302 (21 Aug 2010)
118
119 21 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p299.ebuild,
120 +ruby-1.8.7_p302.ebuild:
121 Revision bump to 1.8.7_p302 for security bug 332957. Fix rubytests
122 installation path.
123
124*ruby-1.8.6_p399 (19 Aug 2010)
125
126 19 Aug 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p388.ebuild,
127 -ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.6_p399.ebuild:
128 Last patchlevel bump for Ruby 1.8.6 to 399, fixes CVE-2010-0541 (bug
129 332957). Also restrict Tk and OpenSSL dependencies and fix rubytests
130 installation path (reported by the x86 team in bug 332597)
131
132*ruby-1.9.2_rc2-r1 (18 Aug 2010)
133
134 18 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
135 +ruby-1.9.2_rc2-r1.ebuild, metadata.xml:
136 Update ebuild; apply webrick security patch; unbundle minitest, rdoc 2 and
137 the rubygems loading code. Add USE flag for psych.
138
139 17 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
140 ruby-1.9.2_rc2.ebuild:
141 Remove two keepdir that will try to keep an empty path, closes bug
142 #333163.
143
144 16 Aug 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_rc2.ebuild:
145 Marked ~ppc (bug #332593).
146
147 15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
148 ruby-1.9.2_rc2.ebuild:
149 Remove libedit USE flag from 1.9.2 because of upstream bug #3698.
150
151 13 Aug 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
152 ruby-1.8.7_p299.ebuild:
153 Bump eselect-ruby dependency
154
155 13 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
156 -ruby-1.9.1_p429.ebuild:
157 Remove ebuild that is not target for unmask anyway.
158
159 21 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
160 ruby-1.9.2_rc2.ebuild:
161 Try 2 to fix the berkdb 5 issue on 1.9.
162
163 20 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
164 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p299.ebuild, ruby-1.9.1_p429.ebuild,
165 ruby-1.9.2_rc2.ebuild:
166 Add a new patchset to add support for Berkeley DB 5.0 (bug #326937). Add
167 support for adding new patchsets without bumping the revision for all the
168 old ebuilds as well.
169
170*ruby-1.9.2_rc2 (14 Jul 2010)
171
172 14 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
173 +ruby-1.9.2_rc2.ebuild:
174 Bump to 1.9.2 release candidate, that works with OpenSSL 1. This version
175 might cause _further_ build failures as it changed slightly behaviour.
176 You're going to need to rebuild rubygems and then all the packages
177 previously installed after upgrading to this.
178
179 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
180 -ruby-1.8.7_p249-r1.ebuild, -ruby-1.8.7_p249-r2.ebuild,
181 -ruby-1.9.1_p376.ebuild:
182 Cleanup old versions.
183
184*ruby-1.9.1_p429 (04 Jul 2010)
185
186 04 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
187 +ruby-1.9.1_p429.ebuild:
188 Version bump to new 1.9.1 release.
189
190*ruby-1.8.7_p299 (23 Jun 2010)
191
192 23 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org>
193 +ruby-1.8.7_p299.ebuild:
194 Version bump.
195
196 19 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388-r1.ebuild,
197 ruby-1.8.7_p249-r2.ebuild, ruby-1.9.1_p376.ebuild:
198 remove useless comments
199
200 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
201 ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
202 ruby-1.9.1_p376.ebuild:
203 Update ebuilds to be consistent with ruby-enterprise; patches are moved to
204 dev.gentoo.org now.
205
206 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
207 ruby-1.9.1_p376.ebuild:
208 Use the correct RUBYLIB.
209
210*ruby-1.8.7_p249-r2 (18 May 2010)
211*ruby-1.8.6_p388-r1 (18 May 2010)
212
213 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
214 +ruby-1.8.6_p388-r1.ebuild, +ruby-1.8.7_p249-r2.ebuild,
215 ruby-1.9.1_p376.ebuild, metadata.xml:
216 Add patches to build with BerkDB 5.0 (bug #319583) and OpenSSL 1.0 (bug
217 #304427) to Ruby 1.8.x. Also use --no-undefined as it's done for 1.9. Also
218 add USE flags for ncurses, readline and libedit, and properly depend on
219 zlib. Drop emacs USE flag and dependency on app-emacs/ruby-mode as the new
220 Emacs versions support ruby-mode themselves and it should be even more
221 updated.
222
223*ruby-1.8.7_p249-r1 (06 May 2010)
224
225 06 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p249-r1.ebuild:
226 Revbump 1.8.7 to add patch for threading/timeout-related hangs. Closes bug
227 309789 by Sune Kloppenborg Jeppesen.
228
229 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
230 ruby-1.8.7_p249.ebuild:
231 Use $PVR instead of $PV in patchset names
232
233 06 May 2010; Alex Legler <a3li@gentoo.org>
234 -files/ruby-1.8.6-memory-leak.diff,
235 -files/ruby18-mkmf-parallel-install.patch,
236 -files/ruby-1.8.6-uclibc-udp.patch, -ruby-1.9.1_p243.ebuild,
237 -files/auto_gem.rb, -files/ruby-mkconfig.patch:
238 Remove old version. Cleanup in files/
239
240*ruby-1.9.1_p376 (01 May 2010)
241
242 01 May 2010; Alex Legler <a3li@gentoo.org> +ruby-1.9.1_p376.ebuild:
243 Version bump. Fixes security bugs 296052 and 300468. No longer installs
244 rubygems or auto_gem.rb. Use dev-ruby/rubygems[ruby_targets_ruby19]
245 instead.
246
247 13 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p369.ebuild,
248 -ruby-1.8.7_p174-r1.ebuild:
249 Remove vulnerable ebuilds, 300468
250
251 13 Jan 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
252 ruby-1.8.7_p249.ebuild:
253 amd64 stable, security bug 300468
254
255 13 Jan 2010; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p388.ebuild,
256 ruby-1.8.7_p249.ebuild:
257 alpha/arm/ia64/s390/sh/sparc stable wrt #300468
258
259 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p249.ebuild:
260 Stable for HPPA (bug #300468).
261
262 12 Jan 2010; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p388.ebuild:
263 Stable for HPPA (bug #300468).
264
265 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p249.ebuild:
266 Marking ruby-1.8.7_p249 ppc64 and ppc for bug 300468
267
268 11 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p388.ebuild:
269 Marking ruby-1.8.6_p388 ppc64 and ppc for bug 300468
270
271 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
272 ruby-1.8.6_p388.ebuild:
273 stable x86, security bug 300468
274
275 11 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
276 ruby-1.8.7_p249.ebuild:
277 stable x86, security bug 300468
278
279*ruby-1.8.6_p388 (10 Jan 2010)
280
281 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p383.ebuild,
282 +ruby-1.8.6_p388.ebuild:
283 Version bump (1.8.6), security bug 300468. Remove unneded vulnerable
284 version. The new ebuild also has the fix for bug 168939.
285
286*ruby-1.8.7_p249 (10 Jan 2010)
287
288 10 Jan 2010; Alex Legler <a3li@gentoo.org> -ruby-1.8.7_p248.ebuild,
289 +ruby-1.8.7_p249.ebuild:
290 Version bump (1.8.7) for security bug 300468, removing unneeded vulnerable
291 version
292
293 02 Jan 2010; Brent Baude <ranger@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
294 Marking ruby-1.8.7_p174-r1 ppc64 for bug 288699
295
296*ruby-1.8.7_p248 (25 Dec 2009)
297
298 25 Dec 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p248.ebuild:
299 Version bump
300
301 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
302 Remove old version.
303
304 18 Dec 2009; Hans de Graaff <graaff@gentoo.org> -ruby-1.8.7_p174.ebuild:
305 Remove old version.
306
307 15 Dec 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
308 ia64/s390/sh stable wrt #288699
309
310 11 Nov 2009; Tiago Cunha <tcunha@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
311 stable sparc, bug 288699
312
313 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
314 arm stable, bug #288699
315
316 25 Oct 2009; Markus Meier <maekke@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
317 amd64/x86 stable, bug #288699
318
319 24 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
320 ruby-1.8.7_p174-r1.ebuild:
321 Stable on alpha, bug #288699
322
323 24 Oct 2009; nixnut <nixnut@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
324 ppc stable #288699
325
326 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.7_p174-r1.ebuild:
327 Stable for HPPA (bug #288699).
328
329 12 Oct 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.9.1_p243.ebuild:
330 Marked ~hppa too.
331
332*ruby-1.8.7_p174-r1 (06 Oct 2009)
333
334 06 Oct 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.7_p174-r1.ebuild:
335 Revision bump. Added fix for bug 168939 (ipv6), now uses the new
336 eselect-ruby cleanup feature.
337
338*ruby-1.9.1_p243 (09 Sep 2009)
339
340 09 Sep 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1_p129.ebuild,
341 -ruby-1.9.1_p129-r1.ebuild, +ruby-1.9.1_p243.ebuild,
342 -files/ruby-1.9.1_p129-gfbsd7.patch, -files/ruby19-rubygems-gentoo.patch,
343 -files/ruby-1.9.1_p129-no-undefined-ext.patch,
344 -files/ruby19-rubygems-proxy.patch,
345 -files/ruby-1.9.1_p129-parallelmake.patch,
346 -files/ruby19-mkmf-parallel-install.patch:
347 Version bump. Fixing bugs 278899 by Daniel Robbins, 279825, 277210 and
348 168939. Cleaning up old patches.
349
350*ruby-1.8.6_p383 (20 Aug 2009)
351
352 20 Aug 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p383.ebuild:
353 Patchlevel bump.
354
355 31 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
356 ruby-1.8.6_p369.ebuild, ruby-1.8.7_p174.ebuild, ruby-1.9.1_p129.ebuild,
357 ruby-1.9.1_p129-r1.ebuild:
358 Move USE defaults berkdb and gdbm from profiles/base/package.use to here.
359
360 28 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p368.ebuild:
361 Removing vulnerable ebuild, bug 273213.
362
363 21 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
364 Marking ruby-1.8.6_p369 ppc for bug 273213
365
366 20 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
367 ruby-1.9.1_p129-r1.ebuild:
368 Prepend our library path instead of overwriting it during src_install.
369 Thanks to the reporter of bug #274824.
370
371*ruby-1.8.7_p174 (18 Jun 2009)
372
373 18 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild,
374 -ruby-1.8.7_p173.ebuild, +ruby-1.8.7_p174.ebuild:
375 Replacing 187_p173 with _p174 because of a regression. Unifying the
376 ebuilds by adding unset RUBYOPT to the 186 ebuild. Migrated 187_p174 to
377 patchsets.
378
379 17 Jun 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p369.ebuild:
380 Marking ruby-1.8.6_p369 ppc64 for bug 273213
381
382 16 Jun 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p369.ebuild:
383 arm/ia64/s390/sh/sparc stable wrt #273213
384
385 16 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild,
386 ruby-1.8.6_p369.ebuild, -ruby-1.8.7_p160.ebuild:
387 Removing old version, minor cleanup
388
389 14 Jun 2009; Alex Legler <a3li@gentoo.org> -ruby-1.8.6_p114.ebuild,
390 -files/ruby-1.8.6-openssl.patch,
391 -files/ruby-1.8.6-shortname_constants.patch,
392 -files/ruby-1.8.6_p111-r13657.patch,
393 -files/ruby-1.8.6_p287-entity_expansion_limit.diff:
394 Removing vulnerable old Ruby version and stale patches, bug 274108.
395
396 11 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
397 ruby-1.8.6_p369.ebuild:
398 Stable on alpha, bug #273213
399
400 10 Jun 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p369.ebuild:
401 Stable for HPPA (bug #273213).
402
403 10 Jun 2009; Christian Faulhammer <fauli@gentoo.org>
404 ruby-1.8.6_p369.ebuild:
405 stable x86, security bug 273213
406
407 10 Jun 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p369.ebuild:
408 amd64 stable, security bug 273213.
409
410*ruby-1.8.7_p173 (10 Jun 2009)
411*ruby-1.8.6_p369 (10 Jun 2009)
412
413 10 Jun 2009; Hans de Graaff <graaff@gentoo.org> +ruby-1.8.6_p369.ebuild,
414 +ruby-1.8.7_p173.ebuild:
415 Version bumps for bug #273213.
416
417*ruby-1.9.1_p129-r1 (27 May 2009)
418
419 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
420 +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
421 +files/ruby-1.9.1_p129-no-undefined-ext.patch,
422 +files/ruby-1.9.1_p129-parallelmake.patch:
423 Revision bump, add patches 1) to make Ruby behave more similarly between
424 Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
425 extensions (undefined symbols in them will cause abort at runtime 3) to
426 remove a concurrency issue when building the dl extension that could
427 result in a broken dl.so.
428
429 24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
430 ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
431 Don't block rdoc-2 or later (which may enter Portage one day as it's
432 needed by some Rakefiles).
433
434 15 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
435 ruby-1.9.1_p129.ebuild:
436 Add ~x86-fbsd keyword.
437
438 15 May 2009; Alexis Ballier <aballier@gentoo.org> ruby-1.8.7_p160.ebuild:
439 keyword ~sparc-fbsd, bug #252315
440
441*ruby-1.9.1_p129 (15 May 2009)
442
443 15 May 2009; Alex Legler <a3li@gentoo.org> -ruby-1.9.1-r1.ebuild,
444 +ruby-1.9.1_p129.ebuild, -files/ruby-ossl_ocsp-verification.patch:
445 Patchlevel bump, closes bug 267453. Removing OSCP verification patch, now
446 included in every release.
447
448 10 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p114.ebuild,
449 -ruby-1.8.6_p287-r5.ebuild, -ruby-1.8.6_p287-r13.ebuild,
450 ruby-1.8.6_p368.ebuild, -ruby-1.8.7_p72-r11.ebuild,
451 ruby-1.8.7_p160.ebuild:
452 Removing vulnerable versions (#268515), fixing license (#233747).
453
454 09 May 2009; Jeroen Roovers <jer@gentoo.org> ruby-1.8.6_p368.ebuild:
455 Stable for HPPA (bug #268515).
456
457 09 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.9.1-r1.ebuild:
458 Adapting rubygems notice.
459
460 08 May 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p368.ebuild:
461 amd64 stable, bug #268515.
462
463 08 May 2009; Raúl Porcel <armin76@gentoo.org> ruby-1.8.6_p368.ebuild:
464 arm/ia64/s390/sh/sparc stable wrt #268515
465
466 07 May 2009; Christian Faulhammer <fauli@gentoo.org>
467 ruby-1.8.6_p368.ebuild:
468 stable x86, security bug 268515
469
470 07 May 2009; Tobias Klausmann <klausman@gentoo.org>
471 ruby-1.8.6_p368.ebuild:
472 Stable on alpha, bug #268515
473
474 07 May 2009; Brent Baude <ranger@gentoo.org> ruby-1.8.6_p368.ebuild:
475 Marking ruby-1.8.6_p368 ppc64 and ppc for bug 268515
476
477*ruby-1.8.7_p160 (07 May 2009)
478*ruby-1.8.6_p368 (07 May 2009)
479
480 07 May 2009; Alex Legler <a3li@gentoo.org> +ruby-1.8.6_p368.ebuild,
481 +ruby-1.8.7_p160.ebuild:
482 Version bump as per secbug 268515. NB: These are the first ebuilds that
483 no longer use ruby-config.
484
485*ruby-1.9.1-r1 (03 Apr 2009)
486*ruby-1.8.7_p72-r11 (03 Apr 2009)
487*ruby-1.8.6_p287-r13 (03 Apr 2009)
488
489 03 Apr 2009; Alex Legler <a3li@gentoo.org>
490 +files/ruby-1.8.6-uclibc-udp.patch, +files/auto_gem.rb,
491 +files/ruby18-mkmf-parallel-install.patch,
492 +files/ruby19-mkmf-parallel-install.patch, -ruby-1.8.6_p287-r12.ebuild,
493 +ruby-1.8.6_p287-r13.ebuild, -ruby-1.8.7_p72-r10.ebuild,
494 +ruby-1.8.7_p72-r11.ebuild, -ruby-1.9.1.ebuild, +ruby-1.9.1-r1.ebuild:
495 Revbumps fixing bugs 239101 (thanks to matsuu) and 260760 (thanks to Tom
496 Lloyd), ruby-1.9.1 is now EAPI-2. Removing old versions. Adding fake
497 auto_gem.rb for Ruby 1.9.1. Removing redundant WANT_AUTO* to make repoman
498 happy.
499
500*ruby-1.9.1 (21 Mar 2009)
501
502 21 Mar 2009; Alex Legler <a3li@gentoo.org>
503 +files/ruby19-rubygems-gentoo.patch, +files/ruby19-rubygems-proxy.patch,
504 +ruby-1.9.1.ebuild:
505 Adding Ruby 1.9.1 for preliminary testing
506
507 20 Mar 2009; Joseph Jezak <josejx@gentoo.org> ruby-1.8.7_p72-r10.ebuild,
508 ruby-1.8.6_p287-r12.ebuild:
509 Marked ~ppc for bug #252315.
4 510
5 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild: 511 10 Mar 2009; Alex Legler <a3li@gentoo.org> ruby-1.8.7_p72-r10.ebuild:
6 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes 512 Unsetting RUBYOPT in src_install, backport from Ruby 1.9 ebuilds, fixes
7 bug 261982. 513 bug 261982.
8 514

Legend:
Removed from v.1.386  
changed lines
  Added in v.1.500

  ViewVC Help
Powered by ViewVC 1.1.20