/[gentoo-x86]/dev-ml/ocamlduce/ocamlduce-3.10.0.ebuild
Gentoo

Contents of /dev-ml/ocamlduce/ocamlduce-3.10.0.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.4 - (show annotations) (download)
Thu Dec 11 08:11:46 2008 UTC (11 years, 2 months ago) by aballier
Branch: MAIN
CVS Tags: HEAD
Changes since 1.3: +1 -1 lines
FILE REMOVED
remove old
(Portage version: 2.2_rc17/cvs/Linux 2.6.27.8 x86_64)

1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlduce/ocamlduce-3.10.0.ebuild,v 1.3 2008/09/25 12:25:35 aballier Exp $
4
5 inherit eutils findlib
6
7 EAPI="1"
8
9 MY_P="${P/_p/pl}"
10 DESCRIPTION="OCamlDuce is a merger between OCaml and CDuce"
11 HOMEPAGE="http://www.cduce.org/ocaml.html"
12 SRC_URI="http://gallium.inria.fr/~frisch/ocamlcduce/download/${MY_P}.tar.gz"
13
14 LICENSE="QPL-1.0 LGPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86 ~x86-fbsd"
17 IUSE="+ocamlopt"
18
19 DEPEND=">=dev-lang/ocaml-3.10.0
20 >=dev-ml/findlib-1.1.2"
21
22 RDEPEND="${DEPEND}"
23
24 S="${WORKDIR}/${MY_P}"
25
26 pkg_setup() {
27 if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
28 eerror "In order to build ${PN} with native code support from ocaml"
29 eerror "You first need to have a native code ocaml compiler."
30 eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
31 die "Please install ocaml with ocamlopt useflag"
32 fi
33 }
34
35 src_compile() {
36 if use ocamlopt; then
37 emake -j1 all opt || die "emake failed"
38 else
39 emake CAMLC="ocamlc" CAMLDEP="ocamldep" -j1 all || die "emake failed"
40 fi
41 }
42
43 src_install() {
44 dodir /usr/bin
45 use ocamlopt && findlib_src_install BINDIR="${D}/usr/bin"
46 use ocamlopt || findlib_src_install BINDIR="${D}/usr/bin" CAMLC="ocamlc" CAMLDEP="ocamldep" OPT_VARIANTS=""
47 }

  ViewVC Help
Powered by ViewVC 1.1.20