/[gentoo-x86]/dev-python/PyAmanith/PyAmanith-0.3.34.ebuild
Gentoo

Contents of /dev-python/PyAmanith/PyAmanith-0.3.34.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.3 - (hide annotations) (download)
Mon May 12 07:25:10 2008 UTC (12 years, 5 months ago) by hawking
Branch: MAIN
Changes since 1.2: +8 -6 lines
Use NEED_PYTHON to depend on python. Use distutils_src_unpack. swig is not a runtime dependency, bug 221467.
(Portage version: 2.1.5_rc10)

1 hawking 1.3 # Copyright 1999-2008 Gentoo Foundation
2 vapier 1.1 # Distributed under the terms of the GNU General Public License v2
3 hawking 1.3 # $Header: /var/cvsroot/gentoo-x86/dev-python/PyAmanith/PyAmanith-0.3.34.ebuild,v 1.2 2006/10/13 17:03:03 pythonhead Exp $
4    
5     NEED_PYTHON=2.3
6 vapier 1.1
7     inherit eutils distutils
8    
9     DESCRIPTION="Python wrapper for the Amanith 2D vector graphics library"
10     HOMEPAGE="http://louhi.kempele.fi/~skyostil/projects/pyamanith/"
11     SRC_URI="http://louhi.kempele.fi/~skyostil/projects/pyamanith/dist/${P}.tar.gz"
12    
13     LICENSE="as-is"
14     SLOT="0"
15     KEYWORDS="~amd64 ~x86"
16     IUSE=""
17    
18 hawking 1.3 RDEPEND=">=media-libs/amanith-0.3"
19     DEPEND="${RDEPEND}
20 pythonhead 1.2 >=dev-lang/swig-1.3.29"
21 vapier 1.1
22     src_unpack() {
23 hawking 1.3 distutils_src_unpack
24    
25 vapier 1.1 # perhaps someone with more swig/distutils clout can make this
26     # package stop sucking so hard
27     sed -i \
28     -e '/include/s:build/amanith/include/::' \
29     headers.i
30     epatch "${FILESDIR}"/${P}-build.patch
31     }

  ViewVC Help
Powered by ViewVC 1.1.20