/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.109 Revision 1.201
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.109 2010/02/16 06:47:45 abcd Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.201 2012/10/28 16:01:01 hwoarang Exp $
4
5 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.9.4.ebuild,
6 PyQt4-4.9.4-r1.ebuild:
7 Promote 4.9.4-r1 bugfix rel ebuild to stable. Drop old
8
9 28 Oct 2012; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.8.4.ebuild,
10 -PyQt4-4.9.1.ebuild:
11 Remove old
12
13*PyQt4-4.9.5 (05 Oct 2012)
14
15 05 Oct 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.5.ebuild:
16 Version bump
17
18 09 Sep 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.4.ebuild:
19 alpha/ia64/sparc stable wrt #429042
20
21*PyQt4-4.9.4-r1 (03 Sep 2012)
22
23 03 Sep 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4-r1.ebuild,
24 +files/PyQt4-4.9.4-pyuic-custom-widgets.patch:
25 Apply upstream patch to fix regression in pyuic's handling of custom widgets
26 (bug 431070 by Laurent Bachelier).
27
28 20 Aug 2012; Johannes Huber <johu@gentoo.org> PyQt4-4.9.4.ebuild:
29 Stable for x86, wrt bug #429042
30
31 11 Aug 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.4.ebuild:
32 Stable for amd64, wrt bug #429042
33
34 11 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
35 Stable ppc64, bug #429042
36
37 10 Aug 2012; Anthony G. Basile <blueness@gentoo.org> PyQt4-4.9.4.ebuild:
38 Stable ppc, bug #429042
39
40 09 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild:
41 ia64 stable
42
43 09 Jul 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.8.1.ebuild,
44 -files/PyQt4-4.6.1-configure-multilib.patch:
45 Remove old.
46
47 08 Jul 2012; Raúl Porcel <armin76@gentoo.org> PyQt4-4.9.1.ebuild,
48 PyQt4-4.9.4.ebuild:
49 alpha/ia64/sparc stable wrt #412929
50
51*PyQt4-4.9.4 (02 Jul 2012)
52
53 02 Jul 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.4.ebuild,
54 -PyQt4-4.9.3.ebuild:
55 Version bump.
56
57*PyQt4-4.9.3 (27 Jun 2012)
58
59 27 Jun 2012; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.9.3.ebuild,
60 -PyQt4-4.9.2.ebuild:
61 Version bump.
62
63 23 Jun 2012; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.9.2.ebuild:
64 Raise dev-python/sip dependency to 4.13.3 thanks to Arfrever
65
66*PyQt4-4.9.2 (21 Jun 2012)
67
68 21 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.2.ebuild:
69 Version bump
70
71 14 Jun 2012; Ben de Groot <yngwin@gentoo.org> PyQt4-4.8.1.ebuild:
72 Destabling to ~ia64 because last available stable qt will be masked pending
73 removal
74
75 23 May 2012; Jeff Horelick <jdhore@gentoo.org> PyQt4-4.9.1.ebuild:
76 marked x86 per bug 412929
77
78 21 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
79 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
80 Inherit eutils.
81
82 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
83 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
84 Revert previous change.
85
86 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
87 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
88 Restrict python 3.1 to match dev-python/dbus-python.
89
90 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
91 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
92
93 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
94 Migrating dev-util/pkgconfig -> virtual/pkgconfig
95
96 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
97 Stable for amd64, wrt bug #412929
98
99 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
100 Stable on alpha, bug #354033
101
102 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
103 PyQt4-4.8.4.ebuild:
104 PyQt4-4.8 does not build with sip-4.13, bug 407291
105
106 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
107 Slightly improve the ewarn message in pkg_postinst().
108
109 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
110 Put qt as the primary herd in metadata.
111
112 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
113 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
114 <slong@rathaus.eclipse.co.uk> in bug #407281.
115
116 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
117 Switch to EAPI 4, add REQUIRED_USE.
118
119 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
120 PyQt4-4.8.4.ebuild:
121 Drop ~x86-fbsd because of unkeyworded dependencies.
122
123 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
124 Don't enable QtAssistant module because it was removed in qt-4.7 and we
125 already depend on 4.7.2 or later.
126
127 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
128 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
129 Restrict pypy for older versions too.
130
131 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
132 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
133 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
134 version.
135
136 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
137 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
138 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
139 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
140 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
141 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
142
143 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
144 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
145 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
146 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
147 Fixing pypy restricts to actually work
148
149*PyQt4-4.9.1 (12 Feb 2012)
150
151 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
152 version bump
153
154 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
155 builds with qt-opengl-4.8.0[egl], updated dep
156
157 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
158 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
159 Fixes backported from Progress Overlay. Patch by Arfrever.
160
161*PyQt4-4.9 (24 Dec 2011)
162
163 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
164 Version bump
165
166*PyQt4-4.8.6 (11 Nov 2011)
167
168 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
169 Version bump
170
171 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
172 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
173 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
174 python overlay.
175
176*PyQt4-4.8.5 (19 Aug 2011)
177
178 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
179 Version bump
180
181 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
182 ppc/ppc64 stable wrt #374591
183
184 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
185 x86 stable, bug #374591
186
187 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
188 ppc64 stable wrt #354033
189
190 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
191 Stable on amd64 wrt bug #374591
192
193 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
194 Marking PyQt4-4.8.3 ppc stable for bug 354033
195
196 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
197 Stable on amd64 wrt bug #354033
198
199 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
200 x86 stable per bug 354033
201
202*PyQt4-4.8.4 (02 May 2011)
203
204 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
205 +PyQt4-4.8.4.ebuild:
206 Version bump.
207
208 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
209 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
210 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
211 Adapt phonon dependency for package move
212
213 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
214 ppc64 stable wrt #349607
215
216 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
217 ia64/sparc stable wrt #349607
218
219 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
220 Stable on alpha, bug #349607
221
222 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
223 PyQt4-4.8.3.ebuild:
224 Update dependencies (bug #353053).
225
226*PyQt4-4.8.3 (25 Jan 2011)
227
228 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
229 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
230 Version bump.
231
232 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
233 x86 stable wrt bug #349607
234
235 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
236 Marking PyQt4-4.8.1 ppc stable for bug 349607
237
238 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
239 Stable on amd64 wrt bug #349607
240
241 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
242 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
243 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
244
245*PyQt4-4.8.1-r1 (30 Dec 2010)
246
247 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
248 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
249 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
250
251 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
252 PyQt4-4.8.2.ebuild:
253 Fix dependencies (bug #349672).
254
255*PyQt4-4.8.2 (24 Dec 2010)
256
257 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
258 +PyQt4-4.8.2.ebuild:
259 Version bump.
260
261 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
262 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
263 Restrict Jython ABIs.
264
265 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
266 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
267 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
268 -files/configure.py.patch:
269 Delete.
270
271 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
272 old, depends on qt 4.5
273
274 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
275 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
276 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
277 Remove HPPA keywording (bug #239441).
278
279*PyQt4-4.8.1 (30 Oct 2010)
280
281 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
282 +PyQt4-4.8.1.ebuild:
283 Version bump.
284
285 23 Oct 2010; Raúl Porcel <armin76@gentoo.org> PyQt4-4.7.3.ebuild:
286 ia64/sparc stable wrt #315775
287
288*PyQt4-4.8 (23 Oct 2010)
289
290 23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
291 -PyQt4-4.7.ebuild, -PyQt4-4.7.5.ebuild, -PyQt4-4.7.7.ebuild,
292 +PyQt4-4.8.ebuild, metadata.xml:
293 Version bump.
294
295*PyQt4-4.7.7-r1 (06 Oct 2010)
296
297 06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
298 +PyQt4-4.7.7-r1.ebuild, +files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff:
299 Revision bump, add patch that fixes compilation with PyKDE 4.5.2
300
301*PyQt4-4.7.7 (21 Sep 2010)
302
303 21 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.6.ebuild,
304 +PyQt4-4.7.7.ebuild:
305 Version bump. Remove old bogus version
306
307 13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.7.3.ebuild:
308 Stable on alpha, bug #315775
309
310 13 Sep 2010; Joseph Jezak <josejx@gentoo.org> PyQt4-4.7.3.ebuild:
311 Marked ppc stable for bug #315775.
312
313 10 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
314 PyQt4-4.7.6.ebuild:
315 Update EAPI. Fix dependencies.
316
317*PyQt4-4.7.6 (08 Sep 2010)
318
319 08 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.2.ebuild,
320 +PyQt4-4.7.6.ebuild:
321 Version bump. Remove old ebuild
322
323 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.4.ebuild,
324 PyQt4-4.7.5.ebuild:
325 Drop old bogus ebuild. Drop RESTRICT_PYTHON_ABIS from latest ebuild
326
327*PyQt4-4.7.5 (01 Sep 2010)
328
329 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild,
330 +PyQt4-4.7.5.ebuild:
331 Version bump
332
333 18 Aug 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.7.3.ebuild:
334 Stable for HPPA (bug #315775).
335
336 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild:
337 Bump sip dependency to 4.10.3. Fix arm epatch command
338
339*PyQt4-4.7.4 (13 Jul 2010)
340
341 13 Jul 2010; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.7.4.ebuild:
342 Version bump
343
344 05 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> PyQt4-4.7.3.ebuild:
345 ppc64 stable wrt #315775
346
347 16 Jun 2010; Tomas Touceda <chiiph@gentoo.org> PyQt4-4.7.3.ebuild,
348 +files/PyQt4-4.7.3-qreal_float_support.patch:
349 Add patch for qreal/float support in ARM wrt bug 322349
350
351 03 Jun 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.7.3.ebuild:
352 x86 stable wrt bug 315775
353
354 25 May 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.3.ebuild:
355 Stable on amd64 wrt bug 315775
356
357 23 Apr 2010; Theo Chatzimichos <tampakrap@gentoo.org> PyQt4-4.7.ebuild,
358 PyQt4-4.7.2.ebuild, PyQt4-4.7.3.ebuild:
359 Fix sip dep in PyQt4 ebuilds
360
361*PyQt4-4.7.3 (17 Apr 2010)
362
363 17 Apr 2010; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.7.3.ebuild:
364 Version bump
365
366 11 Apr 2010; <nixnut@gentoo.org> PyQt4-4.7.ebuild:
367 ppc stable #301105
368
369*PyQt4-4.7.2 (18 Mar 2010)
370
371 18 Mar 2010; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.7.2.ebuild,
372 +files/PyQt4-4.7.2-configure.py.patch:
373 Version bump. ChangeLog is no longer shipped. Update patch.
374
375 03 Mar 2010; Christian Faulhammer <fauli@gentoo.org> PyQt4-4.7.ebuild:
376 stable x86, bug 301105
377
378 02 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> PyQt4-4.7.ebuild:
379 amd64 stable wrt #301105
4 380
5 16 Feb 2010; Jonathan Callen <abcd@gentoo.org> 381 16 Feb 2010; Jonathan Callen <abcd@gentoo.org>
6 -files/PyQt4-4.4.4-qgraphicsproxywidget-avoid-event-callback-loop.patch, 382 -files/PyQt4-4.4.4-qgraphicsproxywidget-avoid-event-callback-loop.patch,
7 -files/fix_license_check.patch: 383 -files/fix_license_check.patch:
8 Drop old patches 384 Drop old patches
444*PyQt4-4.0_beta1 (05 May 2006) 820*PyQt4-4.0_beta1 (05 May 2006)
445 821
446 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml, 822 05 May 2006; Caleb Tennis <caleb@gentoo.org> +metadata.xml,
447 +PyQt4-4.0_beta1.ebuild: 823 +PyQt4-4.0_beta1.ebuild:
448 initial import, from bug #121554 824 initial import, from bug #121554
449

Legend:
Removed from v.1.109  
changed lines
  Added in v.1.201

  ViewVC Help
Powered by ViewVC 1.1.20