/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.121 Revision 1.184
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.121 2010/07/15 11:19:50 hwoarang Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.184 2012/05/23 04:48:54 jdhore Exp $
4
5 23 May 2012; Jeff Horelick <jdhore@gentoo.org> PyQt4-4.9.1.ebuild:
6 marked x86 per bug 412929
7
8 21 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
9 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
10 Inherit eutils.
11
12 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
13 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
14 Revert previous change.
15
16 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
17 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
18 Restrict python 3.1 to match dev-python/dbus-python.
19
20 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
21 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
22
23 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
24 Migrating dev-util/pkgconfig -> virtual/pkgconfig
25
26 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
27 Stable for amd64, wrt bug #412929
28
29 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
30 Stable on alpha, bug #354033
31
32 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
33 PyQt4-4.8.4.ebuild:
34 PyQt4-4.8 does not build with sip-4.13, bug 407291
35
36 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
37 Slightly improve the ewarn message in pkg_postinst().
38
39 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
40 Put qt as the primary herd in metadata.
41
42 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
43 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
44 <slong@rathaus.eclipse.co.uk> in bug #407281.
45
46 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
47 Switch to EAPI 4, add REQUIRED_USE.
48
49 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
50 PyQt4-4.8.4.ebuild:
51 Drop ~x86-fbsd because of unkeyworded dependencies.
52
53 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
54 Don't enable QtAssistant module because it was removed in qt-4.7 and we
55 already depend on 4.7.2 or later.
56
57 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
58 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
59 Restrict pypy for older versions too.
60
61 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
62 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
63 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
64 version.
65
66 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
67 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
68 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
69 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
70 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
71 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
72
73 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
74 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
75 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
76 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
77 Fixing pypy restricts to actually work
78
79*PyQt4-4.9.1 (12 Feb 2012)
80
81 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
82 version bump
83
84 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
85 builds with qt-opengl-4.8.0[egl], updated dep
86
87 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
88 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
89 Fixes backported from Progress Overlay. Patch by Arfrever.
90
91*PyQt4-4.9 (24 Dec 2011)
92
93 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
94 Version bump
95
96*PyQt4-4.8.6 (11 Nov 2011)
97
98 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
99 Version bump
100
101 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
102 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
103 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
104 python overlay.
105
106*PyQt4-4.8.5 (19 Aug 2011)
107
108 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
109 Version bump
110
111 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
112 ppc/ppc64 stable wrt #374591
113
114 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
115 x86 stable, bug #374591
116
117 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
118 ppc64 stable wrt #354033
119
120 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
121 Stable on amd64 wrt bug #374591
122
123 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
124 Marking PyQt4-4.8.3 ppc stable for bug 354033
125
126 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
127 Stable on amd64 wrt bug #354033
128
129 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
130 x86 stable per bug 354033
131
132*PyQt4-4.8.4 (02 May 2011)
133
134 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
135 +PyQt4-4.8.4.ebuild:
136 Version bump.
137
138 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
139 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
140 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
141 Adapt phonon dependency for package move
142
143 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
144 ppc64 stable wrt #349607
145
146 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
147 ia64/sparc stable wrt #349607
148
149 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
150 Stable on alpha, bug #349607
151
152 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
153 PyQt4-4.8.3.ebuild:
154 Update dependencies (bug #353053).
155
156*PyQt4-4.8.3 (25 Jan 2011)
157
158 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
159 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
160 Version bump.
161
162 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
163 x86 stable wrt bug #349607
164
165 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
166 Marking PyQt4-4.8.1 ppc stable for bug 349607
167
168 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
169 Stable on amd64 wrt bug #349607
170
171 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
172 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
173 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
174
175*PyQt4-4.8.1-r1 (30 Dec 2010)
176
177 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
178 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
179 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
180
181 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
182 PyQt4-4.8.2.ebuild:
183 Fix dependencies (bug #349672).
184
185*PyQt4-4.8.2 (24 Dec 2010)
186
187 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
188 +PyQt4-4.8.2.ebuild:
189 Version bump.
190
191 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
192 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
193 Restrict Jython ABIs.
194
195 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
196 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
197 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
198 -files/configure.py.patch:
199 Delete.
200
201 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
202 old, depends on qt 4.5
203
204 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
205 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
206 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
207 Remove HPPA keywording (bug #239441).
208
209*PyQt4-4.8.1 (30 Oct 2010)
210
211 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
212 +PyQt4-4.8.1.ebuild:
213 Version bump.
214
215 23 Oct 2010; Raúl Porcel <armin76@gentoo.org> PyQt4-4.7.3.ebuild:
216 ia64/sparc stable wrt #315775
217
218*PyQt4-4.8 (23 Oct 2010)
219
220 23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
221 -PyQt4-4.7.ebuild, -PyQt4-4.7.5.ebuild, -PyQt4-4.7.7.ebuild,
222 +PyQt4-4.8.ebuild, metadata.xml:
223 Version bump.
224
225*PyQt4-4.7.7-r1 (06 Oct 2010)
226
227 06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
228 +PyQt4-4.7.7-r1.ebuild, +files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff:
229 Revision bump, add patch that fixes compilation with PyKDE 4.5.2
230
231*PyQt4-4.7.7 (21 Sep 2010)
232
233 21 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.6.ebuild,
234 +PyQt4-4.7.7.ebuild:
235 Version bump. Remove old bogus version
236
237 13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.7.3.ebuild:
238 Stable on alpha, bug #315775
239
240 13 Sep 2010; Joseph Jezak <josejx@gentoo.org> PyQt4-4.7.3.ebuild:
241 Marked ppc stable for bug #315775.
242
243 10 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
244 PyQt4-4.7.6.ebuild:
245 Update EAPI. Fix dependencies.
246
247*PyQt4-4.7.6 (08 Sep 2010)
248
249 08 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.2.ebuild,
250 +PyQt4-4.7.6.ebuild:
251 Version bump. Remove old ebuild
252
253 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.4.ebuild,
254 PyQt4-4.7.5.ebuild:
255 Drop old bogus ebuild. Drop RESTRICT_PYTHON_ABIS from latest ebuild
256
257*PyQt4-4.7.5 (01 Sep 2010)
258
259 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild,
260 +PyQt4-4.7.5.ebuild:
261 Version bump
262
263 18 Aug 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.7.3.ebuild:
264 Stable for HPPA (bug #315775).
4 265
5 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild: 266 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild:
6 Bump sip dependency to 4.10.3. Fix arm epatch command 267 Bump sip dependency to 4.10.3. Fix arm epatch command
7 268
8*PyQt4-4.7.4 (13 Jul 2010) 269*PyQt4-4.7.4 (13 Jul 2010)

Legend:
Removed from v.1.121  
changed lines
  Added in v.1.184

  ViewVC Help
Powered by ViewVC 1.1.20