/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.133 Revision 1.174
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.133 2010/10/30 18:23:26 arfrever Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.174 2012/03/07 18:46:36 pesa Exp $
4
5 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
6 Put qt as the primary herd in metadata.
7
8 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
9 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
10 <slong@rathaus.eclipse.co.uk> in bug #407281.
11
12 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
13 Switch to EAPI 4, add REQUIRED_USE.
14
15 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
16 PyQt4-4.8.4.ebuild:
17 Drop ~x86-fbsd because of unkeyworded dependencies.
18
19 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
20 Don't enable QtAssistant module because it was removed in qt-4.7 and we
21 already depend on 4.7.2 or later.
22
23 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
24 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
25 Restrict pypy for older versions too.
26
27 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
28 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
29 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
30 version.
31
32 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
33 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
34 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
35 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
36 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
37 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
38
39 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
40 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
41 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
42 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
43 Fixing pypy restricts to actually work
44
45*PyQt4-4.9.1 (12 Feb 2012)
46
47 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
48 version bump
49
50 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
51 builds with qt-opengl-4.8.0[egl], updated dep
52
53 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
54 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
55 Fixes backported from Progress Overlay. Patch by Arfrever.
56
57*PyQt4-4.9 (24 Dec 2011)
58
59 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
60 Version bump
61
62*PyQt4-4.8.6 (11 Nov 2011)
63
64 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
65 Version bump
66
67 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
68 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
69 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
70 python overlay.
71
72*PyQt4-4.8.5 (19 Aug 2011)
73
74 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
75 Version bump
76
77 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
78 ppc/ppc64 stable wrt #374591
79
80 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
81 x86 stable, bug #374591
82
83 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
84 ppc64 stable wrt #354033
85
86 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
87 Stable on amd64 wrt bug #374591
88
89 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
90 Marking PyQt4-4.8.3 ppc stable for bug 354033
91
92 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
93 Stable on amd64 wrt bug #354033
94
95 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
96 x86 stable per bug 354033
97
98*PyQt4-4.8.4 (02 May 2011)
99
100 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
101 +PyQt4-4.8.4.ebuild:
102 Version bump.
103
104 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
105 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
106 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
107 Adapt phonon dependency for package move
108
109 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
110 ppc64 stable wrt #349607
111
112 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
113 ia64/sparc stable wrt #349607
114
115 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
116 Stable on alpha, bug #349607
117
118 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
119 PyQt4-4.8.3.ebuild:
120 Update dependencies (bug #353053).
121
122*PyQt4-4.8.3 (25 Jan 2011)
123
124 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
125 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
126 Version bump.
127
128 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
129 x86 stable wrt bug #349607
130
131 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
132 Marking PyQt4-4.8.1 ppc stable for bug 349607
133
134 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
135 Stable on amd64 wrt bug #349607
136
137 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
138 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
139 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
140
141*PyQt4-4.8.1-r1 (30 Dec 2010)
142
143 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
144 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
145 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
146
147 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
148 PyQt4-4.8.2.ebuild:
149 Fix dependencies (bug #349672).
150
151*PyQt4-4.8.2 (24 Dec 2010)
152
153 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
154 +PyQt4-4.8.2.ebuild:
155 Version bump.
156
157 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
158 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
159 Restrict Jython ABIs.
160
161 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
162 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
163 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
164 -files/configure.py.patch:
165 Delete.
166
167 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
168 old, depends on qt 4.5
169
170 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
171 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
172 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
173 Remove HPPA keywording (bug #239441).
4 174
5*PyQt4-4.8.1 (30 Oct 2010) 175*PyQt4-4.8.1 (30 Oct 2010)
6 176
7 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org> 177 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
8 +PyQt4-4.8.1.ebuild: 178 +PyQt4-4.8.1.ebuild:

Legend:
Removed from v.1.133  
changed lines
  Added in v.1.174

  ViewVC Help
Powered by ViewVC 1.1.20