/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.133 Revision 1.179
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.133 2010/10/30 18:23:26 arfrever Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.179 2012/05/04 15:12:12 patrick Exp $
4
5 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
6 Migrating dev-util/pkgconfig -> virtual/pkgconfig
7
8 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
9 Stable for amd64, wrt bug #412929
10
11 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
12 Stable on alpha, bug #354033
13
14 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
15 PyQt4-4.8.4.ebuild:
16 PyQt4-4.8 does not build with sip-4.13, bug 407291
17
18 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
19 Slightly improve the ewarn message in pkg_postinst().
20
21 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
22 Put qt as the primary herd in metadata.
23
24 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
25 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
26 <slong@rathaus.eclipse.co.uk> in bug #407281.
27
28 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
29 Switch to EAPI 4, add REQUIRED_USE.
30
31 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
32 PyQt4-4.8.4.ebuild:
33 Drop ~x86-fbsd because of unkeyworded dependencies.
34
35 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
36 Don't enable QtAssistant module because it was removed in qt-4.7 and we
37 already depend on 4.7.2 or later.
38
39 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
40 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
41 Restrict pypy for older versions too.
42
43 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
44 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
45 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
46 version.
47
48 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
49 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
50 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
51 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
52 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
53 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
54
55 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
56 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
57 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
58 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
59 Fixing pypy restricts to actually work
60
61*PyQt4-4.9.1 (12 Feb 2012)
62
63 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
64 version bump
65
66 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
67 builds with qt-opengl-4.8.0[egl], updated dep
68
69 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
70 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
71 Fixes backported from Progress Overlay. Patch by Arfrever.
72
73*PyQt4-4.9 (24 Dec 2011)
74
75 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
76 Version bump
77
78*PyQt4-4.8.6 (11 Nov 2011)
79
80 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
81 Version bump
82
83 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
84 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
85 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
86 python overlay.
87
88*PyQt4-4.8.5 (19 Aug 2011)
89
90 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
91 Version bump
92
93 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
94 ppc/ppc64 stable wrt #374591
95
96 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
97 x86 stable, bug #374591
98
99 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
100 ppc64 stable wrt #354033
101
102 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
103 Stable on amd64 wrt bug #374591
104
105 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
106 Marking PyQt4-4.8.3 ppc stable for bug 354033
107
108 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
109 Stable on amd64 wrt bug #354033
110
111 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
112 x86 stable per bug 354033
113
114*PyQt4-4.8.4 (02 May 2011)
115
116 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
117 +PyQt4-4.8.4.ebuild:
118 Version bump.
119
120 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
121 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
122 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
123 Adapt phonon dependency for package move
124
125 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
126 ppc64 stable wrt #349607
127
128 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
129 ia64/sparc stable wrt #349607
130
131 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
132 Stable on alpha, bug #349607
133
134 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
135 PyQt4-4.8.3.ebuild:
136 Update dependencies (bug #353053).
137
138*PyQt4-4.8.3 (25 Jan 2011)
139
140 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
141 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
142 Version bump.
143
144 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
145 x86 stable wrt bug #349607
146
147 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
148 Marking PyQt4-4.8.1 ppc stable for bug 349607
149
150 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
151 Stable on amd64 wrt bug #349607
152
153 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
154 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
155 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
156
157*PyQt4-4.8.1-r1 (30 Dec 2010)
158
159 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
160 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
161 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
162
163 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
164 PyQt4-4.8.2.ebuild:
165 Fix dependencies (bug #349672).
166
167*PyQt4-4.8.2 (24 Dec 2010)
168
169 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
170 +PyQt4-4.8.2.ebuild:
171 Version bump.
172
173 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
174 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
175 Restrict Jython ABIs.
176
177 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
178 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
179 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
180 -files/configure.py.patch:
181 Delete.
182
183 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
184 old, depends on qt 4.5
185
186 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
187 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
188 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
189 Remove HPPA keywording (bug #239441).
4 190
5*PyQt4-4.8.1 (30 Oct 2010) 191*PyQt4-4.8.1 (30 Oct 2010)
6 192
7 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org> 193 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
8 +PyQt4-4.8.1.ebuild: 194 +PyQt4-4.8.1.ebuild:

Legend:
Removed from v.1.133  
changed lines
  Added in v.1.179

  ViewVC Help
Powered by ViewVC 1.1.20