/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.159 Revision 1.173
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.159 2011/08/19 10:12:33 hwoarang Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.173 2012/03/07 18:43:03 pesa Exp $
4
5 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
6 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
7 <slong@rathaus.eclipse.co.uk> in bug #407281.
8
9 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
10 Switch to EAPI 4, add REQUIRED_USE.
11
12 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
13 PyQt4-4.8.4.ebuild:
14 Drop ~x86-fbsd because of unkeyworded dependencies.
15
16 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
17 Don't enable QtAssistant module because it was removed in qt-4.7 and we
18 already depend on 4.7.2 or later.
19
20 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
21 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
22 Restrict pypy for older versions too.
23
24 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
25 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
26 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
27 version.
28
29 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
30 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
31 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
32 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
33 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
34 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
35
36 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
37 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
38 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
39 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
40 Fixing pypy restricts to actually work
41
42*PyQt4-4.9.1 (12 Feb 2012)
43
44 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
45 version bump
46
47 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
48 builds with qt-opengl-4.8.0[egl], updated dep
49
50 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
51 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
52 Fixes backported from Progress Overlay. Patch by Arfrever.
53
54*PyQt4-4.9 (24 Dec 2011)
55
56 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
57 Version bump
58
59*PyQt4-4.8.6 (11 Nov 2011)
60
61 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
62 Version bump
63
64 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
65 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
66 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
67 python overlay.
4 68
5*PyQt4-4.8.5 (19 Aug 2011) 69*PyQt4-4.8.5 (19 Aug 2011)
6 70
7 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild: 71 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
8 Version bump 72 Version bump

Legend:
Removed from v.1.159  
changed lines
  Added in v.1.173

  ViewVC Help
Powered by ViewVC 1.1.20