/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.126 Revision 1.176
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.126 2010/09/10 22:02:27 arfrever Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.176 2012/03/07 21:47:34 dilfridge Exp $
4
5 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
6 PyQt4-4.8.4.ebuild:
7 PyQt4-4.8 does not build with sip-4.13, bug 407291
8
9 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
10 Slightly improve the ewarn message in pkg_postinst().
11
12 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
13 Put qt as the primary herd in metadata.
14
15 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
16 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
17 <slong@rathaus.eclipse.co.uk> in bug #407281.
18
19 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
20 Switch to EAPI 4, add REQUIRED_USE.
21
22 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
23 PyQt4-4.8.4.ebuild:
24 Drop ~x86-fbsd because of unkeyworded dependencies.
25
26 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
27 Don't enable QtAssistant module because it was removed in qt-4.7 and we
28 already depend on 4.7.2 or later.
29
30 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
31 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
32 Restrict pypy for older versions too.
33
34 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
35 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
36 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
37 version.
38
39 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
40 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
41 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
42 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
43 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
44 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
45
46 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
47 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
48 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
49 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
50 Fixing pypy restricts to actually work
51
52*PyQt4-4.9.1 (12 Feb 2012)
53
54 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
55 version bump
56
57 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
58 builds with qt-opengl-4.8.0[egl], updated dep
59
60 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
61 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
62 Fixes backported from Progress Overlay. Patch by Arfrever.
63
64*PyQt4-4.9 (24 Dec 2011)
65
66 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
67 Version bump
68
69*PyQt4-4.8.6 (11 Nov 2011)
70
71 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
72 Version bump
73
74 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
75 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
76 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
77 python overlay.
78
79*PyQt4-4.8.5 (19 Aug 2011)
80
81 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
82 Version bump
83
84 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
85 ppc/ppc64 stable wrt #374591
86
87 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
88 x86 stable, bug #374591
89
90 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
91 ppc64 stable wrt #354033
92
93 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
94 Stable on amd64 wrt bug #374591
95
96 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
97 Marking PyQt4-4.8.3 ppc stable for bug 354033
98
99 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
100 Stable on amd64 wrt bug #354033
101
102 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
103 x86 stable per bug 354033
104
105*PyQt4-4.8.4 (02 May 2011)
106
107 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
108 +PyQt4-4.8.4.ebuild:
109 Version bump.
110
111 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
112 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
113 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
114 Adapt phonon dependency for package move
115
116 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
117 ppc64 stable wrt #349607
118
119 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
120 ia64/sparc stable wrt #349607
121
122 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
123 Stable on alpha, bug #349607
124
125 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
126 PyQt4-4.8.3.ebuild:
127 Update dependencies (bug #353053).
128
129*PyQt4-4.8.3 (25 Jan 2011)
130
131 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
132 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
133 Version bump.
134
135 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
136 x86 stable wrt bug #349607
137
138 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
139 Marking PyQt4-4.8.1 ppc stable for bug 349607
140
141 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
142 Stable on amd64 wrt bug #349607
143
144 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
145 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
146 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
147
148*PyQt4-4.8.1-r1 (30 Dec 2010)
149
150 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
151 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
152 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
153
154 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
155 PyQt4-4.8.2.ebuild:
156 Fix dependencies (bug #349672).
157
158*PyQt4-4.8.2 (24 Dec 2010)
159
160 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
161 +PyQt4-4.8.2.ebuild:
162 Version bump.
163
164 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
165 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
166 Restrict Jython ABIs.
167
168 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
169 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
170 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
171 -files/configure.py.patch:
172 Delete.
173
174 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
175 old, depends on qt 4.5
176
177 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
178 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
179 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
180 Remove HPPA keywording (bug #239441).
181
182*PyQt4-4.8.1 (30 Oct 2010)
183
184 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
185 +PyQt4-4.8.1.ebuild:
186 Version bump.
187
188 23 Oct 2010; Raúl Porcel <armin76@gentoo.org> PyQt4-4.7.3.ebuild:
189 ia64/sparc stable wrt #315775
190
191*PyQt4-4.8 (23 Oct 2010)
192
193 23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
194 -PyQt4-4.7.ebuild, -PyQt4-4.7.5.ebuild, -PyQt4-4.7.7.ebuild,
195 +PyQt4-4.8.ebuild, metadata.xml:
196 Version bump.
197
198*PyQt4-4.7.7-r1 (06 Oct 2010)
199
200 06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
201 +PyQt4-4.7.7-r1.ebuild, +files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff:
202 Revision bump, add patch that fixes compilation with PyKDE 4.5.2
203
204*PyQt4-4.7.7 (21 Sep 2010)
205
206 21 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.6.ebuild,
207 +PyQt4-4.7.7.ebuild:
208 Version bump. Remove old bogus version
209
210 13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.7.3.ebuild:
211 Stable on alpha, bug #315775
212
213 13 Sep 2010; Joseph Jezak <josejx@gentoo.org> PyQt4-4.7.3.ebuild:
214 Marked ppc stable for bug #315775.
4 215
5 10 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org> 216 10 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
6 PyQt4-4.7.6.ebuild: 217 PyQt4-4.7.6.ebuild:
7 Update EAPI. Fix dependencies. 218 Update EAPI. Fix dependencies.
8 219

Legend:
Removed from v.1.126  
changed lines
  Added in v.1.176

  ViewVC Help
Powered by ViewVC 1.1.20