/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.21 Revision 1.181
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.21 2007/12/26 00:56:22 caleb Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.181 2012/05/16 01:55:01 floppym Exp $
4
5 16 May 2012; Mike Gilbert <floppym@gentoo.org> PyQt4-4.8.1.ebuild,
6 PyQt4-4.8.4.ebuild, PyQt4-4.9.1.ebuild:
7 Restrict python 3.1 to match dev-python/dbus-python.
8
9 13 May 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
10 Fix kde USE flag description (media-libs/phonon vs. media-sound/phonon).
11
12 04 May 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.9.1.ebuild:
13 Migrating dev-util/pkgconfig -> virtual/pkgconfig
14
15 24 Apr 2012; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.9.1.ebuild:
16 Stable for amd64, wrt bug #412929
17
18 31 Mar 2012; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.4.ebuild:
19 Stable on alpha, bug #354033
20
21 07 Mar 2012; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.8.1.ebuild,
22 PyQt4-4.8.4.ebuild:
23 PyQt4-4.8 does not build with sip-4.13, bug 407291
24
25 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
26 Slightly improve the ewarn message in pkg_postinst().
27
28 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> metadata.xml:
29 Put qt as the primary herd in metadata.
30
31 07 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.4.ebuild:
32 Fix insecure RUNPATH in qpy/QtOpenGL, thanks to Steve L
33 <slong@rathaus.eclipse.co.uk> in bug #407281.
34
35 03 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
36 Switch to EAPI 4, add REQUIRED_USE.
37
38 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.8.1.ebuild,
39 PyQt4-4.8.4.ebuild:
40 Drop ~x86-fbsd because of unkeyworded dependencies.
41
42 02 Mar 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
43 Don't enable QtAssistant module because it was removed in qt-4.7 and we
44 already depend on 4.7.2 or later.
45
46 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.3.ebuild,
47 PyQt4-4.8.1.ebuild, PyQt4-4.8.4.ebuild:
48 Restrict pypy for older versions too.
49
50 21 Feb 2012; Davide Pesavento <pesa@gentoo.org> PyQt4-4.9.1.ebuild:
51 Build QtTest module only with USE="X" because it needs QtGui (bug #348349).
52 Add build-time dep on pkgconfig with USE="dbus". Raise minimum required Qt
53 version.
54
55 20 Feb 2012; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.7.7-r1.ebuild,
56 -PyQt4-4.8.1-r1.ebuild, -PyQt4-4.8.2.ebuild, -PyQt4-4.8.3.ebuild,
57 -PyQt4-4.8.5.ebuild, -PyQt4-4.8.6.ebuild, -PyQt4-4.9.ebuild,
58 -files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff,
59 -files/PyQt4-4.8.3-configure-multilib.patch, metadata.xml:
60 Add <upstream> tag to metadata. Cleanup old ebuilds and patches.
61
62 20 Feb 2012; Patrick Lauer <patrick@gentoo.org> PyQt4-4.7.3.ebuild,
63 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.1.ebuild,
64 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild, PyQt4-4.8.4.ebuild,
65 PyQt4-4.8.5.ebuild, PyQt4-4.8.6.ebuild, PyQt4-4.9.1.ebuild, PyQt4-4.9.ebuild:
66 Fixing pypy restricts to actually work
67
68*PyQt4-4.9.1 (12 Feb 2012)
69
70 12 Feb 2012; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.1.ebuild:
71 version bump
72
73 25 Jan 2012; Alex Alexander <wired@gentoo.org> PyQt4-4.9.ebuild:
74 builds with qt-opengl-4.8.0[egl], updated dep
75
76 27 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> PyQt4-4.9.ebuild:
77 Enable versioning of /usr/bin/pyuic4. Run eqmake4() in qpy/QtDBus directory.
78 Fixes backported from Progress Overlay. Patch by Arfrever.
79
80*PyQt4-4.9 (24 Dec 2011)
81
82 24 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.9.ebuild:
83 Version bump
84
85*PyQt4-4.8.6 (11 Nov 2011)
86
87 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.6.ebuild:
88 Version bump
89
90 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
91 Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
92 Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
93 python overlay.
94
95*PyQt4-4.8.5 (19 Aug 2011)
96
97 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.8.5.ebuild:
98 Version bump
99
100 25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.4.ebuild:
101 ppc/ppc64 stable wrt #374591
102
103 21 Jul 2011; Markus Meier <maekke@gentoo.org> PyQt4-4.8.4.ebuild:
104 x86 stable, bug #374591
105
106 13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.3.ebuild:
107 ppc64 stable wrt #354033
108
109 10 Jul 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.4.ebuild:
110 Stable on amd64 wrt bug #374591
111
112 01 Jun 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.3.ebuild:
113 Marking PyQt4-4.8.3 ppc stable for bug 354033
114
115 09 May 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.3.ebuild:
116 Stable on amd64 wrt bug #354033
117
118 09 May 2011; Thomas Kahle <tomka@gentoo.org> PyQt4-4.8.3.ebuild:
119 x86 stable per bug 354033
120
121*PyQt4-4.8.4 (02 May 2011)
122
123 02 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
124 +PyQt4-4.8.4.ebuild:
125 Version bump.
126
127 26 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org> PyQt4-4.7.3.ebuild,
128 PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild,
129 PyQt4-4.8.2.ebuild, PyQt4-4.8.3.ebuild:
130 Adapt phonon dependency for package move
131
132 16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> PyQt4-4.8.1.ebuild:
133 ppc64 stable wrt #349607
134
135 27 Feb 2011; Raúl Porcel <armin76@gentoo.org> PyQt4-4.8.1.ebuild:
136 ia64/sparc stable wrt #349607
137
138 27 Feb 2011; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.8.1.ebuild:
139 Stable on alpha, bug #349607
140
141 28 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
142 PyQt4-4.8.3.ebuild:
143 Update dependencies (bug #353053).
144
145*PyQt4-4.8.3 (25 Jan 2011)
146
147 25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
148 +PyQt4-4.8.3.ebuild, +files/PyQt4-4.8.3-configure-multilib.patch:
149 Version bump.
150
151 16 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.8.1.ebuild:
152 x86 stable wrt bug #349607
153
154 07 Jan 2011; Brent Baude <ranger@gentoo.org> PyQt4-4.8.1.ebuild:
155 Marking PyQt4-4.8.1 ppc stable for bug 349607
156
157 04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.1.ebuild:
158 Stable on amd64 wrt bug #349607
159
160 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
161 PyQt4-4.8.1.ebuild, PyQt4-4.8.1-r1.ebuild, PyQt4-4.8.2.ebuild:
162 Require x11-libs/qt-opengl[-egl] until bug #344513 is fixed.
163
164*PyQt4-4.8.1-r1 (30 Dec 2010)
165
166 30 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
167 PyQt4-4.8.1.ebuild, +PyQt4-4.8.1-r1.ebuild:
168 Copy 4.8.1 to 4.8.1-r1. Delete "declarative" USE flag in 4.8.1.
169
170 25 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
171 PyQt4-4.8.2.ebuild:
172 Fix dependencies (bug #349672).
173
174*PyQt4-4.8.2 (24 Dec 2010)
175
176 24 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
177 +PyQt4-4.8.2.ebuild:
178 Version bump.
179
180 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
181 PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
182 Restrict Jython ABIs.
183
184 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
185 -files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
186 -files/configure-4.6.1.py.patch, -PyQt4-4.6.2.ebuild, -PyQt4-4.8.ebuild,
187 -files/configure.py.patch:
188 Delete.
189
190 06 Dec 2010; Alex Alexander <wired@gentoo.org> -PyQt4-4.5.4-r4.ebuild:
191 old, depends on qt 4.5
192
193 06 Nov 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild,
194 PyQt4-4.6.2.ebuild, PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild,
195 PyQt4-4.8.ebuild, PyQt4-4.8.1.ebuild:
196 Remove HPPA keywording (bug #239441).
197
198*PyQt4-4.8.1 (30 Oct 2010)
199
200 30 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
201 +PyQt4-4.8.1.ebuild:
202 Version bump.
203
204 23 Oct 2010; Raúl Porcel <armin76@gentoo.org> PyQt4-4.7.3.ebuild:
205 ia64/sparc stable wrt #315775
206
207*PyQt4-4.8 (23 Oct 2010)
208
209 23 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
210 -PyQt4-4.7.ebuild, -PyQt4-4.7.5.ebuild, -PyQt4-4.7.7.ebuild,
211 +PyQt4-4.8.ebuild, metadata.xml:
212 Version bump.
213
214*PyQt4-4.7.7-r1 (06 Oct 2010)
215
216 06 Oct 2010; Theo Chatzimichos <tampakrap@gentoo.org>
217 +PyQt4-4.7.7-r1.ebuild, +files/PyQt4-4.7.7-fix-scpk-and-flag-issue.diff:
218 Revision bump, add patch that fixes compilation with PyKDE 4.5.2
219
220*PyQt4-4.7.7 (21 Sep 2010)
221
222 21 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.6.ebuild,
223 +PyQt4-4.7.7.ebuild:
224 Version bump. Remove old bogus version
225
226 13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.7.3.ebuild:
227 Stable on alpha, bug #315775
228
229 13 Sep 2010; Joseph Jezak <josejx@gentoo.org> PyQt4-4.7.3.ebuild:
230 Marked ppc stable for bug #315775.
231
232 10 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
233 PyQt4-4.7.6.ebuild:
234 Update EAPI. Fix dependencies.
235
236*PyQt4-4.7.6 (08 Sep 2010)
237
238 08 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.2.ebuild,
239 +PyQt4-4.7.6.ebuild:
240 Version bump. Remove old ebuild
241
242 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.7.4.ebuild,
243 PyQt4-4.7.5.ebuild:
244 Drop old bogus ebuild. Drop RESTRICT_PYTHON_ABIS from latest ebuild
245
246*PyQt4-4.7.5 (01 Sep 2010)
247
248 01 Sep 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild,
249 +PyQt4-4.7.5.ebuild:
250 Version bump
251
252 18 Aug 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.7.3.ebuild:
253 Stable for HPPA (bug #315775).
254
255 15 Jul 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.4.ebuild:
256 Bump sip dependency to 4.10.3. Fix arm epatch command
257
258*PyQt4-4.7.4 (13 Jul 2010)
259
260 13 Jul 2010; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.7.4.ebuild:
261 Version bump
262
263 05 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> PyQt4-4.7.3.ebuild:
264 ppc64 stable wrt #315775
265
266 16 Jun 2010; Tomas Touceda <chiiph@gentoo.org> PyQt4-4.7.3.ebuild,
267 +files/PyQt4-4.7.3-qreal_float_support.patch:
268 Add patch for qreal/float support in ARM wrt bug 322349
269
270 03 Jun 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> PyQt4-4.7.3.ebuild:
271 x86 stable wrt bug 315775
272
273 25 May 2010; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.7.3.ebuild:
274 Stable on amd64 wrt bug 315775
275
276 23 Apr 2010; Theo Chatzimichos <tampakrap@gentoo.org> PyQt4-4.7.ebuild,
277 PyQt4-4.7.2.ebuild, PyQt4-4.7.3.ebuild:
278 Fix sip dep in PyQt4 ebuilds
279
280*PyQt4-4.7.3 (17 Apr 2010)
281
282 17 Apr 2010; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.7.3.ebuild:
283 Version bump
284
285 11 Apr 2010; <nixnut@gentoo.org> PyQt4-4.7.ebuild:
286 ppc stable #301105
287
288*PyQt4-4.7.2 (18 Mar 2010)
289
290 18 Mar 2010; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.7.2.ebuild,
291 +files/PyQt4-4.7.2-configure.py.patch:
292 Version bump. ChangeLog is no longer shipped. Update patch.
293
294 03 Mar 2010; Christian Faulhammer <fauli@gentoo.org> PyQt4-4.7.ebuild:
295 stable x86, bug 301105
296
297 02 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> PyQt4-4.7.ebuild:
298 amd64 stable wrt #301105
299
300 16 Feb 2010; Jonathan Callen <abcd@gentoo.org>
301 -files/PyQt4-4.4.4-qgraphicsproxywidget-avoid-event-callback-loop.patch,
302 -files/fix_license_check.patch:
303 Drop old patches
304
305 10 Feb 2010; Jeroen Roovers <jer@gentoo.org> PyQt4-4.6.2.ebuild:
306 Stable for HPPA (bug #300713).
307
308 08 Feb 2010; Christian Faulhammer <fauli@gentoo.org> PyQt4-4.6.2.ebuild:
309 stable x86, bug 300713
310
311 02 Feb 2010; Alex Alexander <wired@gentoo.org> PyQt4-4.5.4-r4.ebuild,
312 PyQt4-4.6.2.ebuild:
313 updated SRC_URI to use gentoo mirrors, upstream doesn't provide these
314 versions anymore
315
316 31 Jan 2010; <hwoarang@gentoo.org> PyQt4-4.6.2.ebuild:
317 Stable on amd64 wrt bug #300713
318
319 20 Jan 2010; Jonathan Callen <abcd@gentoo.org> PyQt4-4.7.ebuild:
320 Add prefix keywords, support
321
322*PyQt4-4.7 (15 Jan 2010)
323
324 15 Jan 2010; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.7.ebuild:
325 Version bump
326
327 11 Jan 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
328 PyQt4-4.5.4-r4.ebuild, PyQt4-4.6.2.ebuild:
329 Don't call python_need_rebuild().
330
331 06 Jan 2010; <hwoarang@gentoo.org> PyQt4-4.6.2.ebuild:
332 Migrate to qt4-r2 eclass
333
334 02 Jan 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
335 PyQt4-4.5.4-r4.ebuild, PyQt4-4.6.2.ebuild:
336 Only restrict Python 3.2.
337
338 02 Jan 2010; Ben de Groot <yngwin@gentoo.org> PyQt4-4.5.4-r4.ebuild,
339 PyQt4-4.6.2.ebuild:
340 Adding RESTRICT_PYTHON_ABIS for python3. Current PyQt4 versions only work
341 with python2. Fixes bug 292419.
342
343 13 Dec 2009; Ben de Groot <yngwin@gentoo.org> -PyQt4-4.4.4-r2.ebuild,
344 -PyQt4-4.4.4-r5.ebuild, -PyQt4-4.5.2.ebuild, -PyQt4-4.5.4-r3.ebuild,
345 PyQt4-4.5.4-r4.ebuild, -PyQt4-4.6.1.ebuild, -PyQt4-4.6.1-r1.ebuild,
346 PyQt4-4.6.2.ebuild, metadata.xml:
347 Remove obsolete versions. Pin 4.5.4 on correct sip and Qt versions. Remove
348 qt3support useflag description from metadata, as it is no longer in use.
349
350 30 Nov 2009; Joseph Jezak <josejx@gentoo.org> PyQt4-4.5.4-r4.ebuild:
351 Marked ppc64 stable.
352
353*PyQt4-4.6.2 (20 Nov 2009)
354
355 20 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
356 +PyQt4-4.6.2.ebuild:
357 Version bump.
358
359*PyQt4-4.6.1-r1 (05 Nov 2009)
360
361 05 Nov 2009; Alex Alexander <wired@gentoo.org> +PyQt4-4.6.1-r1.ebuild,
362 +files/PyQt4-4.6.1-configure-multilib.patch:
363 added multilib patch wrt bug #283936
364
365*PyQt4-4.6.1 (28 Oct 2009)
366
367 28 Oct 2009; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.6.1.ebuild,
368 +files/configure-4.6.1.py.patch:
369 Version bump. Add new configuration patch
370
371 18 Oct 2009; Raúl Porcel <armin76@gentoo.org> PyQt4-4.5.4-r4.ebuild:
372 alpha/ia64/sparc stable wrt #284707
373
374 27 Sep 2009; nixnut <nixnut@gentoo.org> PyQt4-4.5.4-r4.ebuild:
375 ppc stable #284707
376
377 22 Sep 2009; Markus Meier <maekke@gentoo.org> PyQt4-4.5.4-r4.ebuild:
378 add ~arm
379
380 22 Sep 2009; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild:
381 Stable for HPPA (bug #284707).
382
383 22 Sep 2009; Markus Meier <maekke@gentoo.org> PyQt4-4.5.4-r4.ebuild:
384 amd64 stable, bug #284707
385
386 16 Sep 2009; Christian Faulhammer <fauli@gentoo.org>
387 PyQt4-4.5.4-r4.ebuild:
388 stable x86, bug 284707
389
390 06 Sep 2009; Christian Ruppert <idl0r@gentoo.org>
391 -files/PyQt4-4.4_compile.patch:
392 Remove unused patch.
393
394 16 Aug 2009; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.5.4.ebuild,
395 -PyQt4-4.5.4-r2.ebuild:
396 Remove old ebuilds
397
398 16 Aug 2009; Thomas Anderson <gentoofan23@gentoo.org>
399 PyQt4-4.4.4-r5.ebuild:
400 stable amd64, bug 276852
401
402 16 Aug 2009; Raúl Porcel <armin76@gentoo.org> PyQt4-4.4.4-r5.ebuild:
403 ia64 stable wrt #276852
404
405*PyQt4-4.5.4-r4 (15 Aug 2009)
406
407 15 Aug 2009; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.5.4-r4.ebuild:
408 Build QtScriptTools bindings. Fixes bug 279945. Thanks to Davide Pesavento
409 <davidepesa@gmail.com> for the patch
410
411*PyQt4-4.5.4-r3 (12 Aug 2009)
412
413 12 Aug 2009; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.5.4-r1.ebuild,
414 +PyQt4-4.5.4-r3.ebuild,
415 +files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch:
416 Added patch for removing items from QGraphicsLinearLayout. Fixes bug
417 280634 .
418 THanks to Fabio Erculiani <lxnay@sabayonlinux.org> for the patch
419
420*PyQt4-4.5.4-r2 (11 Aug 2009)
421
422 11 Aug 2009; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.5.4-r2.ebuild:
423 Respect LINK, add missing inherit. Thanks to Davide Pesavento
424
425*PyQt4-4.5.4-r1 (05 Aug 2009)
426
427 05 Aug 2009; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.5.4-r1.ebuild:
428 New revision including various QA fixes due to eqmake4 usage
429
430 04 Aug 2009; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.5.4.ebuild:
431 Fix bug #280055 for real this time
432
433 02 Aug 2009; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.5.4.ebuild:
434 Fix QtCore rpath without checking X use flag. Install all html
435 documentation (
436 bug #280055 )
437
438 02 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
439 PyQt4-4.5.4.ebuild:
440 Set SUPPORT_PYTHON_ABIS.
441
442*PyQt4-4.5.4 (31 Jul 2009)
443
444 31 Jul 2009; Alex Alexander <wired@gentoo.org> +PyQt4-4.5.4.ebuild:
445 version bump
446
447 27 Jul 2009; nixnut <nixnut@gentoo.org> PyQt4-4.4.4-r5.ebuild:
448 ppc stable #276852
449
450 21 Jul 2009; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.4.4-r5.ebuild:
451 Stable on alpha, bug #276852
452
453 17 Jul 2009; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.4.4-r4.ebuild,
454 -PyQt4-4.5.1.ebuild:
455 Remove old ebuilds
456
457*PyQt4-4.5.2 (14 Jul 2009)
458
459 14 Jul 2009; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.5.2.ebuild:
460 Version bump
461
462 09 Jul 2009; Ferris McCormick <fmccor@gentoo.org> PyQt4-4.4.4-r5.ebuild:
463 Sparc stable, Bug #276852.
464
465 08 Jul 2009; Christian Faulhammer <fauli@gentoo.org>
466 PyQt4-4.4.4-r5.ebuild:
467 stable x86, bug 276852
468
469 08 Jul 2009; Jeroen Roovers <jer@gentoo.org> PyQt4-4.4.4-r5.ebuild:
470 Stable for HPPA (bug #276852).
471
472 28 Jun 2009; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.5.ebuild:
473 Remove old ebuild
474
475 20 Jun 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
476 PyQt4-4.5.1.ebuild:
477 Don't install modules specific for other versions of Python (bug #274499).
478
479 16 Jun 2009; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.5.1.ebuild:
480 Raise sip dependency to 4.8.1
481
482*PyQt4-4.5.1 (16 Jun 2009)
483
484 16 Jun 2009; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.4.4-r5.ebuild,
485 PyQt4-4.5.ebuild, +PyQt4-4.5.1.ebuild:
486 Drop qt3support use flag. Version bump. Bug-fix release
487
488 09 Jun 2009; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.4.4-r2.ebuild,
489 PyQt4-4.4.4-r4.ebuild, PyQt4-4.4.4-r5.ebuild:
490 Add correct sip dependencies, fixes bug 273430
491
492*PyQt4-4.5 (09 Jun 2009)
493
494 09 Jun 2009; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.5.ebuild:
495 Version bump
496
497 05 Jun 2009; Ben de Groot <yngwin@gentoo.org> PyQt4-4.4.4-r5.ebuild:
498 Specify !kde for qt-phonon dep
499
500 03 Jun 2009; Ben de Groot <yngwin@gentoo.org> PyQt4-4.4.4-r5.ebuild,
501 metadata.xml:
502 Add kde useflag, for selecting media-sound/phonon, bug 270188
503
504 02 Jun 2009; Ben de Groot <yngwin@gentoo.org> PyQt4-4.4.4-r5.ebuild:
505 QtDesigner is triggered by USE=X, so hide sed behind X useflag. Thanks
506 to Davide Pesavento for alerting.
507
508 01 Jun 2009; Markos Chandras <hwoarang@gentoo.org>
509 +files/fix_license_check.patch:
510 Add missing patch. Fixes bug 272126
511
512*PyQt4-4.4.4-r5 (01 Jun 2009)
513
514 01 Jun 2009; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.4.4-r5.ebuild,
515 files/configure.py.patch, metadata.xml:
516 Fixed automagic dependency issue. ( bug 236341 ). Fixed rpath issues ( bug
517 235819 , bug 271870 ). Thanks to Davide Pesavento <davidepesa@gmail.com>
518 for the ebuilds and the rpath patch.
519
520 20 May 2009; Ben de Groot <yngwin@gentoo.org> -PyQt4-4.4-r1.ebuild,
521 -PyQt4-4.4.4-r1.ebuild, -PyQt4-4.4.4-r3.ebuild, PyQt4-4.4.4-r4.ebuild:
522 Turn on default useflags for all Qt modules. Remove old. Move src_unpack
523 content to src_prepare, where it belongs.
524
525 15 May 2009; Alexis Ballier <aballier@gentoo.org> PyQt4-4.4.4-r4.ebuild:
526 keyword ~x86-fbsd, bug #269880
527
528*PyQt4-4.4.4-r4 (26 Apr 2009)
529
530 26 Apr 2009; Markos Chandras <hwoarang@gentoo.org>
531 +files/PyQt4-4.4.4-qgraphicsproxywidget-avoid-event-callback-loop.patch,
532 +PyQt4-4.4.4-r4.ebuild:
533 Adding qt-xmlpatterns as dependency. Add patch for QGraphicsProxyWidget (
534 thanks to Fabio Erculiani <lxnay@sabayonlinux.org> for providing the patch
535 ). Fixes bug #267012
536
537*PyQt4-4.4.4-r3 (07 Apr 2009)
538
539 07 Apr 2009; Markos Chandras <hwoarang@gentoo.org>
540 +files/configure.py.patch, +PyQt4-4.4.4-r3.ebuild:
541 Fixed bug #204877 ( thanks to Davide Pesavento <davidepesa@gmail.com> )
542
543 27 Mar 2009; Jeroen Roovers <jer@gentoo.org> PyQt4-4.4.4-r2.ebuild:
544 Stable for HPPA (bug #261652).
545
546 24 Mar 2009; Brent Baude <ranger@gentoo.org> PyQt4-4.4.4-r2.ebuild:
547 stable ppc64, bug 261652
548
549 22 Mar 2009; Markus Meier <maekke@gentoo.org> PyQt4-4.4.4-r2.ebuild:
550 amd64 stable, bug #261652
551
552 20 Mar 2009; Raúl Porcel <armin76@gentoo.org> PyQt4-4.4.4-r2.ebuild:
553 alpha/ia64/sparc/x86 stable wrt #261652
554
555 20 Mar 2009; Brent Baude <ranger@gentoo.org> PyQt4-4.4.4-r2.ebuild:
556 stable ppc, bug 261652
557
558 20 Mar 2009; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.3.1.ebuild,
559 -PyQt4-4.3.3.ebuild:
560 Dropping old packages due to qt-4.3 removal
561
562 18 Feb 2009; Jeroen Roovers <jer@gentoo.org> PyQt4-4.4.4-r1.ebuild:
563 Stable for HPPA (bug #248083).
564
565 06 Feb 2009; Raúl Porcel <armin76@gentoo.org> PyQt4-4.4.4-r1.ebuild:
566 ia64/sparc stable wrt #248038
567
568 04 Feb 2009; Brent Baude <ranger@gentoo.org> PyQt4-4.4.4-r1.ebuild:
569 Marking PyQt4-4.4.4-r1 ppc64 stable for bug 248038
570
571 31 Jan 2009; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.4.4-r1.ebuild:
572 Stable on alpha, bug #248038
573
574*PyQt4-4.4.4-r2 (25 Jan 2009)
575
576 25 Jan 2009; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.4.4-r2.ebuild:
577 Add dbus-python dep, thanks to Maciej Mrozowski. Remove no longer needed
578 zlib useflag check.
579
580 18 Jan 2009; Markus Meier <maekke@gentoo.org> PyQt4-4.4.4-r1.ebuild:
581 amd64/x86 stable, bug #248038
582
583 17 Jan 2009; nixnut <nixnut@gentoo.org> PyQt4-4.4.4-r1.ebuild:
584 ppc stable #248038
585
586 09 Jan 2009; Patrick Lauer <patrick@gentoo.org> -PyQt4-4.4.3.ebuild,
587 -PyQt4-4.4.4.ebuild:
588 Removing old
589
590*PyQt4-4.4.4-r1 (23 Nov 2008)
591
592 23 Nov 2008; Patrick Lauer <patrick@gentoo.org> +PyQt4-4.4.4-r1.ebuild:
593 Adding webkit useflag. Fixes pykde failing to build because of ordering
594 issues.
595
596*PyQt4-4.4.4 (21 Nov 2008)
597
598 21 Nov 2008; Ben de Groot <yngwin@gentoo.org> -PyQt4-4.4.2.ebuild,
599 PyQt4-4.4.3.ebuild, +PyQt4-4.4.4.ebuild:
600 Drop ~x86-fbsd, as qt-core isn't keyworded for that arch yet.
601 Version bump, with updated deps. Remove hardmasked 4.4.2 version.
602
603 07 Oct 2008; Jeroen Roovers <jer@gentoo.org> PyQt4-4.3.3.ebuild:
604 Stable for HPPA too.
605
606*PyQt4-4.4.3 (06 Sep 2008)
607
608 06 Sep 2008; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.4.3.ebuild:
609 Version bump. Fixes bug 234559.
610
611 06 Aug 2008; Jesus Rivero <neurogeek@gentoo.org> metadata.xml:
612 add GLEP 56 USE flag desc from use.local.desc
613
614*PyQt4-4.4-r1 (31 Jul 2008)
615
616 31 Jul 2008; Jesus Rivero <neurogeek@gentoo.org>
617 +files/PyQt4-4.4_compile.patch, -PyQt4-4.4.ebuild, +PyQt4-4.4-r1.ebuild:
618 Fixes bugs #233369 and #222435, thanks to Remy Bosch for the patch.
619 Removed old version
620
621 25 May 2008; Ingmar Vanhassel <ingmar@gentoo.org> PyQt4-4.4.2.ebuild:
622 dev-python/PyQt4-4.4.2 needs Qt-4.4.0, fix dependencies, mask package.
623
624*PyQt4-4.4.2 (24 May 2008)
625
626 24 May 2008; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.4.2.ebuild:
627 Version bump. Updated homepage URL. Added split qt deps from bug 222709.
628
629*PyQt4-4.4 (14 May 2008)
630
631 14 May 2008; Ali Polatel <hawking@gentoo.org> PyQt4-4.3.1.ebuild,
632 PyQt4-4.3.3.ebuild, +PyQt4-4.4.ebuild:
633 Version bump. Change SRC_URI of old ebuilds to mirror://gentoo because
634 upstream doesn't have it anymore.
635
636 13 May 2008; Ali Polatel <hawking@gentoo.org> PyQt4-4.3.1.ebuild,
637 PyQt4-4.3.3.ebuild:
638 Changed HOMEPAGE. Thanks to Elias Probst, #220653
639
640 12 May 2008; Markus Rothe <corsair@gentoo.org> PyQt4-4.3.3.ebuild:
641 Stable on ppc64
642
643 07 Apr 2008; Alexis Ballier <aballier@gentoo.org> PyQt4-4.3.3.ebuild:
644 keyword ~x86-fbsd
645
646 02 Mar 2008; Wulf C. Krueger <philantrop@gentoo.org> PyQt4-4.3.1.ebuild:
647 Marked stable on amd64 as per bug 201474.
648
649 21 Feb 2008; Raúl Porcel <armin76@gentoo.org> PyQt4-4.3.3.ebuild:
650 alpha/ia64/sparc stable
651
652 15 Feb 2008; nixnut <nixnut@gentoo.org> PyQt4-4.3.1.ebuild:
653 Stable on ppc wrt bug 201474
654
655 09 Feb 2008; Markus Ullmann <jokey@gentoo.org> PyQt4-4.3.3.ebuild:
656 Stable on x86
657
658 28 Dec 2007; Caleb Tennis <caleb@gentoo.org> PyQt4-4.3.1.ebuild,
659 PyQt4-4.3.3.ebuild:
660 Explicitly depend on Qt 4.3 for these versions
4 661
5*PyQt4-4.3.3 (26 Dec 2007) 662*PyQt4-4.3.3 (26 Dec 2007)
6 663
7 26 Dec 2007; Caleb Tennis <caleb@gentoo.org> +PyQt4-4.3.3.ebuild: 664 26 Dec 2007; Caleb Tennis <caleb@gentoo.org> +PyQt4-4.3.3.ebuild:
8 version bump 665 version bump

Legend:
Removed from v.1.21  
changed lines
  Added in v.1.181

  ViewVC Help
Powered by ViewVC 1.1.20