/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.21 Revision 1.99
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.21 2007/12/26 00:56:22 caleb Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.99 2010/01/02 15:43:09 yngwin Exp $
4
5 02 Jan 2010; Ben de Groot <yngwin@gentoo.org> PyQt4-4.5.4-r4.ebuild,
6 PyQt4-4.6.2.ebuild:
7 Adding RESTRICT_PYTHON_ABIS for python3. Current PyQt4 versions only work
8 with python2. Fixes bug 292419.
9
10 13 Dec 2009; Ben de Groot <yngwin@gentoo.org> -PyQt4-4.4.4-r2.ebuild,
11 -PyQt4-4.4.4-r5.ebuild, -PyQt4-4.5.2.ebuild, -PyQt4-4.5.4-r3.ebuild,
12 PyQt4-4.5.4-r4.ebuild, -PyQt4-4.6.1.ebuild, -PyQt4-4.6.1-r1.ebuild,
13 PyQt4-4.6.2.ebuild, metadata.xml:
14 Remove obsolete versions. Pin 4.5.4 on correct sip and Qt versions. Remove
15 qt3support useflag description from metadata, as it is no longer in use.
16
17 30 Nov 2009; Joseph Jezak <josejx@gentoo.org> PyQt4-4.5.4-r4.ebuild:
18 Marked ppc64 stable.
19
20*PyQt4-4.6.2 (20 Nov 2009)
21
22 20 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
23 +PyQt4-4.6.2.ebuild:
24 Version bump.
25
26*PyQt4-4.6.1-r1 (05 Nov 2009)
27
28 05 Nov 2009; Alex Alexander <wired@gentoo.org> +PyQt4-4.6.1-r1.ebuild,
29 +files/PyQt4-4.6.1-configure-multilib.patch:
30 added multilib patch wrt bug #283936
31
32*PyQt4-4.6.1 (28 Oct 2009)
33
34 28 Oct 2009; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.6.1.ebuild,
35 +files/configure-4.6.1.py.patch:
36 Version bump. Add new configuration patch
37
38 18 Oct 2009; Raúl Porcel <armin76@gentoo.org> PyQt4-4.5.4-r4.ebuild:
39 alpha/ia64/sparc stable wrt #284707
40
41 27 Sep 2009; nixnut <nixnut@gentoo.org> PyQt4-4.5.4-r4.ebuild:
42 ppc stable #284707
43
44 22 Sep 2009; Markus Meier <maekke@gentoo.org> PyQt4-4.5.4-r4.ebuild:
45 add ~arm
46
47 22 Sep 2009; Jeroen Roovers <jer@gentoo.org> PyQt4-4.5.4-r4.ebuild:
48 Stable for HPPA (bug #284707).
49
50 22 Sep 2009; Markus Meier <maekke@gentoo.org> PyQt4-4.5.4-r4.ebuild:
51 amd64 stable, bug #284707
52
53 16 Sep 2009; Christian Faulhammer <fauli@gentoo.org>
54 PyQt4-4.5.4-r4.ebuild:
55 stable x86, bug 284707
56
57 06 Sep 2009; Christian Ruppert <idl0r@gentoo.org>
58 -files/PyQt4-4.4_compile.patch:
59 Remove unused patch.
60
61 16 Aug 2009; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.5.4.ebuild,
62 -PyQt4-4.5.4-r2.ebuild:
63 Remove old ebuilds
64
65 16 Aug 2009; Thomas Anderson <gentoofan23@gentoo.org>
66 PyQt4-4.4.4-r5.ebuild:
67 stable amd64, bug 276852
68
69 16 Aug 2009; Raúl Porcel <armin76@gentoo.org> PyQt4-4.4.4-r5.ebuild:
70 ia64 stable wrt #276852
71
72*PyQt4-4.5.4-r4 (15 Aug 2009)
73
74 15 Aug 2009; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.5.4-r4.ebuild:
75 Build QtScriptTools bindings. Fixes bug 279945. Thanks to Davide Pesavento
76 <davidepesa@gmail.com> for the patch
77
78*PyQt4-4.5.4-r3 (12 Aug 2009)
79
80 12 Aug 2009; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.5.4-r1.ebuild,
81 +PyQt4-4.5.4-r3.ebuild,
82 +files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch:
83 Added patch for removing items from QGraphicsLinearLayout. Fixes bug
84 280634 .
85 THanks to Fabio Erculiani <lxnay@sabayonlinux.org> for the patch
86
87*PyQt4-4.5.4-r2 (11 Aug 2009)
88
89 11 Aug 2009; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.5.4-r2.ebuild:
90 Respect LINK, add missing inherit. Thanks to Davide Pesavento
91
92*PyQt4-4.5.4-r1 (05 Aug 2009)
93
94 05 Aug 2009; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.5.4-r1.ebuild:
95 New revision including various QA fixes due to eqmake4 usage
96
97 04 Aug 2009; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.5.4.ebuild:
98 Fix bug #280055 for real this time
99
100 02 Aug 2009; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.5.4.ebuild:
101 Fix QtCore rpath without checking X use flag. Install all html
102 documentation (
103 bug #280055 )
104
105 02 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
106 PyQt4-4.5.4.ebuild:
107 Set SUPPORT_PYTHON_ABIS.
108
109*PyQt4-4.5.4 (31 Jul 2009)
110
111 31 Jul 2009; Alex Alexander <wired@gentoo.org> +PyQt4-4.5.4.ebuild:
112 version bump
113
114 27 Jul 2009; nixnut <nixnut@gentoo.org> PyQt4-4.4.4-r5.ebuild:
115 ppc stable #276852
116
117 21 Jul 2009; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.4.4-r5.ebuild:
118 Stable on alpha, bug #276852
119
120 17 Jul 2009; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.4.4-r4.ebuild,
121 -PyQt4-4.5.1.ebuild:
122 Remove old ebuilds
123
124*PyQt4-4.5.2 (14 Jul 2009)
125
126 14 Jul 2009; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.5.2.ebuild:
127 Version bump
128
129 09 Jul 2009; Ferris McCormick <fmccor@gentoo.org> PyQt4-4.4.4-r5.ebuild:
130 Sparc stable, Bug #276852.
131
132 08 Jul 2009; Christian Faulhammer <fauli@gentoo.org>
133 PyQt4-4.4.4-r5.ebuild:
134 stable x86, bug 276852
135
136 08 Jul 2009; Jeroen Roovers <jer@gentoo.org> PyQt4-4.4.4-r5.ebuild:
137 Stable for HPPA (bug #276852).
138
139 28 Jun 2009; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.5.ebuild:
140 Remove old ebuild
141
142 20 Jun 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
143 PyQt4-4.5.1.ebuild:
144 Don't install modules specific for other versions of Python (bug #274499).
145
146 16 Jun 2009; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.5.1.ebuild:
147 Raise sip dependency to 4.8.1
148
149*PyQt4-4.5.1 (16 Jun 2009)
150
151 16 Jun 2009; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.4.4-r5.ebuild,
152 PyQt4-4.5.ebuild, +PyQt4-4.5.1.ebuild:
153 Drop qt3support use flag. Version bump. Bug-fix release
154
155 09 Jun 2009; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.4.4-r2.ebuild,
156 PyQt4-4.4.4-r4.ebuild, PyQt4-4.4.4-r5.ebuild:
157 Add correct sip dependencies, fixes bug 273430
158
159*PyQt4-4.5 (09 Jun 2009)
160
161 09 Jun 2009; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.5.ebuild:
162 Version bump
163
164 05 Jun 2009; Ben de Groot <yngwin@gentoo.org> PyQt4-4.4.4-r5.ebuild:
165 Specify !kde for qt-phonon dep
166
167 03 Jun 2009; Ben de Groot <yngwin@gentoo.org> PyQt4-4.4.4-r5.ebuild,
168 metadata.xml:
169 Add kde useflag, for selecting media-sound/phonon, bug 270188
170
171 02 Jun 2009; Ben de Groot <yngwin@gentoo.org> PyQt4-4.4.4-r5.ebuild:
172 QtDesigner is triggered by USE=X, so hide sed behind X useflag. Thanks
173 to Davide Pesavento for alerting.
174
175 01 Jun 2009; Markos Chandras <hwoarang@gentoo.org>
176 +files/fix_license_check.patch:
177 Add missing patch. Fixes bug 272126
178
179*PyQt4-4.4.4-r5 (01 Jun 2009)
180
181 01 Jun 2009; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.4.4-r5.ebuild,
182 files/configure.py.patch, metadata.xml:
183 Fixed automagic dependency issue. ( bug 236341 ). Fixed rpath issues ( bug
184 235819 , bug 271870 ). Thanks to Davide Pesavento <davidepesa@gmail.com>
185 for the ebuilds and the rpath patch.
186
187 20 May 2009; Ben de Groot <yngwin@gentoo.org> -PyQt4-4.4-r1.ebuild,
188 -PyQt4-4.4.4-r1.ebuild, -PyQt4-4.4.4-r3.ebuild, PyQt4-4.4.4-r4.ebuild:
189 Turn on default useflags for all Qt modules. Remove old. Move src_unpack
190 content to src_prepare, where it belongs.
191
192 15 May 2009; Alexis Ballier <aballier@gentoo.org> PyQt4-4.4.4-r4.ebuild:
193 keyword ~x86-fbsd, bug #269880
194
195*PyQt4-4.4.4-r4 (26 Apr 2009)
196
197 26 Apr 2009; Markos Chandras <hwoarang@gentoo.org>
198 +files/PyQt4-4.4.4-qgraphicsproxywidget-avoid-event-callback-loop.patch,
199 +PyQt4-4.4.4-r4.ebuild:
200 Adding qt-xmlpatterns as dependency. Add patch for QGraphicsProxyWidget (
201 thanks to Fabio Erculiani <lxnay@sabayonlinux.org> for providing the patch
202 ). Fixes bug #267012
203
204*PyQt4-4.4.4-r3 (07 Apr 2009)
205
206 07 Apr 2009; Markos Chandras <hwoarang@gentoo.org>
207 +files/configure.py.patch, +PyQt4-4.4.4-r3.ebuild:
208 Fixed bug #204877 ( thanks to Davide Pesavento <davidepesa@gmail.com> )
209
210 27 Mar 2009; Jeroen Roovers <jer@gentoo.org> PyQt4-4.4.4-r2.ebuild:
211 Stable for HPPA (bug #261652).
212
213 24 Mar 2009; Brent Baude <ranger@gentoo.org> PyQt4-4.4.4-r2.ebuild:
214 stable ppc64, bug 261652
215
216 22 Mar 2009; Markus Meier <maekke@gentoo.org> PyQt4-4.4.4-r2.ebuild:
217 amd64 stable, bug #261652
218
219 20 Mar 2009; Raúl Porcel <armin76@gentoo.org> PyQt4-4.4.4-r2.ebuild:
220 alpha/ia64/sparc/x86 stable wrt #261652
221
222 20 Mar 2009; Brent Baude <ranger@gentoo.org> PyQt4-4.4.4-r2.ebuild:
223 stable ppc, bug 261652
224
225 20 Mar 2009; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.3.1.ebuild,
226 -PyQt4-4.3.3.ebuild:
227 Dropping old packages due to qt-4.3 removal
228
229 18 Feb 2009; Jeroen Roovers <jer@gentoo.org> PyQt4-4.4.4-r1.ebuild:
230 Stable for HPPA (bug #248083).
231
232 06 Feb 2009; Raúl Porcel <armin76@gentoo.org> PyQt4-4.4.4-r1.ebuild:
233 ia64/sparc stable wrt #248038
234
235 04 Feb 2009; Brent Baude <ranger@gentoo.org> PyQt4-4.4.4-r1.ebuild:
236 Marking PyQt4-4.4.4-r1 ppc64 stable for bug 248038
237
238 31 Jan 2009; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.4.4-r1.ebuild:
239 Stable on alpha, bug #248038
240
241*PyQt4-4.4.4-r2 (25 Jan 2009)
242
243 25 Jan 2009; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.4.4-r2.ebuild:
244 Add dbus-python dep, thanks to Maciej Mrozowski. Remove no longer needed
245 zlib useflag check.
246
247 18 Jan 2009; Markus Meier <maekke@gentoo.org> PyQt4-4.4.4-r1.ebuild:
248 amd64/x86 stable, bug #248038
249
250 17 Jan 2009; nixnut <nixnut@gentoo.org> PyQt4-4.4.4-r1.ebuild:
251 ppc stable #248038
252
253 09 Jan 2009; Patrick Lauer <patrick@gentoo.org> -PyQt4-4.4.3.ebuild,
254 -PyQt4-4.4.4.ebuild:
255 Removing old
256
257*PyQt4-4.4.4-r1 (23 Nov 2008)
258
259 23 Nov 2008; Patrick Lauer <patrick@gentoo.org> +PyQt4-4.4.4-r1.ebuild:
260 Adding webkit useflag. Fixes pykde failing to build because of ordering
261 issues.
262
263*PyQt4-4.4.4 (21 Nov 2008)
264
265 21 Nov 2008; Ben de Groot <yngwin@gentoo.org> -PyQt4-4.4.2.ebuild,
266 PyQt4-4.4.3.ebuild, +PyQt4-4.4.4.ebuild:
267 Drop ~x86-fbsd, as qt-core isn't keyworded for that arch yet.
268 Version bump, with updated deps. Remove hardmasked 4.4.2 version.
269
270 07 Oct 2008; Jeroen Roovers <jer@gentoo.org> PyQt4-4.3.3.ebuild:
271 Stable for HPPA too.
272
273*PyQt4-4.4.3 (06 Sep 2008)
274
275 06 Sep 2008; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.4.3.ebuild:
276 Version bump. Fixes bug 234559.
277
278 06 Aug 2008; Jesus Rivero <neurogeek@gentoo.org> metadata.xml:
279 add GLEP 56 USE flag desc from use.local.desc
280
281*PyQt4-4.4-r1 (31 Jul 2008)
282
283 31 Jul 2008; Jesus Rivero <neurogeek@gentoo.org>
284 +files/PyQt4-4.4_compile.patch, -PyQt4-4.4.ebuild, +PyQt4-4.4-r1.ebuild:
285 Fixes bugs #233369 and #222435, thanks to Remy Bosch for the patch.
286 Removed old version
287
288 25 May 2008; Ingmar Vanhassel <ingmar@gentoo.org> PyQt4-4.4.2.ebuild:
289 dev-python/PyQt4-4.4.2 needs Qt-4.4.0, fix dependencies, mask package.
290
291*PyQt4-4.4.2 (24 May 2008)
292
293 24 May 2008; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.4.2.ebuild:
294 Version bump. Updated homepage URL. Added split qt deps from bug 222709.
295
296*PyQt4-4.4 (14 May 2008)
297
298 14 May 2008; Ali Polatel <hawking@gentoo.org> PyQt4-4.3.1.ebuild,
299 PyQt4-4.3.3.ebuild, +PyQt4-4.4.ebuild:
300 Version bump. Change SRC_URI of old ebuilds to mirror://gentoo because
301 upstream doesn't have it anymore.
302
303 13 May 2008; Ali Polatel <hawking@gentoo.org> PyQt4-4.3.1.ebuild,
304 PyQt4-4.3.3.ebuild:
305 Changed HOMEPAGE. Thanks to Elias Probst, #220653
306
307 12 May 2008; Markus Rothe <corsair@gentoo.org> PyQt4-4.3.3.ebuild:
308 Stable on ppc64
309
310 07 Apr 2008; Alexis Ballier <aballier@gentoo.org> PyQt4-4.3.3.ebuild:
311 keyword ~x86-fbsd
312
313 02 Mar 2008; Wulf C. Krueger <philantrop@gentoo.org> PyQt4-4.3.1.ebuild:
314 Marked stable on amd64 as per bug 201474.
315
316 21 Feb 2008; Raúl Porcel <armin76@gentoo.org> PyQt4-4.3.3.ebuild:
317 alpha/ia64/sparc stable
318
319 15 Feb 2008; nixnut <nixnut@gentoo.org> PyQt4-4.3.1.ebuild:
320 Stable on ppc wrt bug 201474
321
322 09 Feb 2008; Markus Ullmann <jokey@gentoo.org> PyQt4-4.3.3.ebuild:
323 Stable on x86
324
325 28 Dec 2007; Caleb Tennis <caleb@gentoo.org> PyQt4-4.3.1.ebuild,
326 PyQt4-4.3.3.ebuild:
327 Explicitly depend on Qt 4.3 for these versions
4 328
5*PyQt4-4.3.3 (26 Dec 2007) 329*PyQt4-4.3.3 (26 Dec 2007)
6 330
7 26 Dec 2007; Caleb Tennis <caleb@gentoo.org> +PyQt4-4.3.3.ebuild: 331 26 Dec 2007; Caleb Tennis <caleb@gentoo.org> +PyQt4-4.3.3.ebuild:
8 version bump 332 version bump

Legend:
Removed from v.1.21  
changed lines
  Added in v.1.99

  ViewVC Help
Powered by ViewVC 1.1.20