/[gentoo-x86]/dev-python/PyQt4/ChangeLog
Gentoo

Diff of /dev-python/PyQt4/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.237 Revision 1.293
1# ChangeLog for dev-python/PyQt4 1# ChangeLog for dev-python/PyQt4
2# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.237 2013/09/10 05:19:12 maekke Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.293 2015/07/25 00:00:51 pesa Exp $
4
5 25 Jul 2015; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.1.ebuild,
6 PyQt4-4.11.4.ebuild:
7 Update HOMEPAGE.
8
9 29 Jun 2015; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.3-r2.ebuild:
10 Drop old version. As of now, sparc no longer has a stable PyQt4, see bug
11 #523322 comment #15.
12
13 17 Jun 2015; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.11.3.ebuild:
14 Drop version that is not going to get stabilized.
15
16 14 Jun 2015; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.4.ebuild:
17 Use the new --no-python-dbus configure option.
18
19 14 Jun 2015; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.4.ebuild:
20 PyQt4 became GPL-3 only.
21
22*PyQt4-4.11.4 (14 Jun 2015)
23
24 14 Jun 2015; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.4.ebuild:
25 Version bump.
26
27 09 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
28 Updating remote-id in metadata.xml
29
30 11 May 2015; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.11.2.ebuild,
31 PyQt4-4.11.3.ebuild:
32 Enable tracing with USE=debug; enable configure verbose output to get useful
33 build logs in bug reports; stop passing deprecated --no-timestamp option; use
34 qt4_get_bindir().
35
36 14 Apr 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
37 Stable for ia64, wrt bug #523322
38
39 08 Apr 2015; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.3-r2.ebuild:
40 Drop old Python implementations
41
42 17 Feb 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
43 Stable for ppc64, wrt bug #517344
44
45 16 Feb 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
46 Stable for ppc, wrt bug #517344
47
48 14 Feb 2015; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
49 Stable for x86, wrt bug #517344
50
51 09 Jan 2015; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.3.ebuild:
52 Stop using deprecated python_parallel_foreach_impl.
53
54 31 Dec 2014; Michael Palimaka <kensington@gentoo.org> PyQt4-4.10.3-r2.ebuild,
55 PyQt4-4.11.1.ebuild, PyQt4-4.11.2.ebuild:
56 Enforce USE dependency for media-libs/phonon.
57
58 10 Dec 2014; Mikle Kolyada <zlogene@gentoo.org> PyQt4-4.11.1.ebuild:
59 amd64 stable wrt bug #517344
60
61 22 Nov 2014; Tobias Klausmann <klausman@gentoo.org> PyQt4-4.11.1.ebuild:
62 Stable on alpha, bug 523322
63
64*PyQt4-4.11.3 (15 Nov 2014)
65
66 15 Nov 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.3.ebuild,
67 -PyQt4-4.11.3_pre20141024.ebuild:
68 Version bump.
69
70*PyQt4-4.11.3_pre20141024 (01 Nov 2014)
71
72 01 Nov 2014; Davide Pesavento <pesa@gentoo.org>
73 +PyQt4-4.11.3_pre20141024.ebuild, -PyQt4-4.11.2-r1.ebuild:
74 Bump to 4.11.3 prerelease, which contains upstream fixes for bugs #525392 and
75 #525470. Also switch to out-of-source builds.
76
77 15 Oct 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.2-r1.ebuild:
78 Fix bug #525392.
79
80 14 Oct 2014; Davide Pesavento <pesa@gentoo.org>
81 +files/PyQt4-4.11.2-phonon.patch, PyQt4-4.11.2-r1.ebuild:
82 Fix building against media-libs/phonon (bug 525354).
83
84*PyQt4-4.11.2-r1 (13 Oct 2014)
85
86 13 Oct 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.2-r1.ebuild,
87 metadata.xml:
88 Switch to new upstream build system. Introduce USE=testlib to decouple QtTest
89 from QtGui.
90
91 09 Oct 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.1.ebuild:
92 Revert to ~amd64, see bug #523322 comment #4.
93
94 09 Oct 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.11.1.ebuild:
95 Stable for amd64, wrt bug #523322
96
97 04 Oct 2014; Markus Meier <maekke@gentoo.org> PyQt4-4.11.1.ebuild:
98 arm stable, bug #523322
99
100*PyQt4-4.11.2 (20 Sep 2014)
101
102 20 Sep 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.2.ebuild,
103 PyQt4-4.11.1.ebuild:
104 Version bump. Silence harmless repoman warning.
105
106 13 Sep 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.11.1.ebuild:
107 Drop deprecated python versions.
108
109 13 Sep 2014; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.3-r3.ebuild,
110 PyQt4-4.11.1.ebuild:
111 Stop using dohtml, remove old.
112
113 17 Jul 2014; Michael Palimaka <kensington@gentoo.org> -PyQt4-4.11.ebuild:
114 Remove old.
115
116*PyQt4-4.11.1 (15 Jul 2014)
117
118 15 Jul 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.1.ebuild,
119 PyQt4-4.11.ebuild:
120 Version bump.
121
122 20 Jun 2014; Ian Delaney <idella4@gentoo.org> PyQt4-4.10.3-r3.ebuild,
123 PyQt4-4.11.ebuild:
124 add py3.4 support req'd to support py packages such as pandas
125
126 30 May 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.3-r2.ebuild,
127 PyQt4-4.10.3-r3.ebuild:
128 Restrict sip dep to =4.15* for older PyQt4 versions.
129
130*PyQt4-4.11 (30 May 2014)
131
132 30 May 2014; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.11.ebuild:
133 Version bump.
134
135 21 May 2014; Davide Pesavento <pesa@gentoo.org> PyQt4-4.10.3-r2.ebuild,
136 PyQt4-4.10.3-r3.ebuild, metadata.xml:
137 Update pypi identifier in HOMEPAGE and <upstream> metadata tag. Thanks to
138 Martin Walch in bug 510812.
139
140 19 May 2014; Michał Górny <mgorny@gentoo.org> -PyQt4-4.10.2.ebuild,
141 -PyQt4-4.10.3.ebuild:
142 Drop the old versions that required python-exec:0.
143
144 02 Apr 2014; Michael Palimaka <kensington@gentoo.org> metadata.xml:
145 Remove python herd as discussed with them.
146
147*PyQt4-4.10.3-r3 (27 Mar 2014)
148
149 27 Mar 2014; Michał Górny <mgorny@gentoo.org> +PyQt4-4.10.3-r3.ebuild:
150 Replace manual Python wrapping with proper eclass functions, bug #484404.
151
152 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
153 Stable for sparc, wrt bug #495638
154
155 23 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
156 Stable for x86, wrt bug #495638
157
158 19 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
159 Stable for alpha, wrt bug #495638
160
161 18 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
162 Stable for ia64, wrt bug #495638
163
164 14 Mar 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
165 Stable for ppc64, wrt bug #495638
166
167 08 Mar 2014; Pacho Ramos <pacho@gentoo.org> PyQt4-4.10.3-r2.ebuild:
168 amd64 stable, bug 495638
169
170 02 Feb 2014; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.3-r2.ebuild:
171 Stable for ppc, wrt bug #495638
172
173 30 Jan 2014; Markus Meier <maekke@gentoo.org> PyQt4-4.10.3-r2.ebuild:
174 arm stable, bug #495638
175
176 28 Dec 2013; Steve Arnold <nerdboy@gentoo.org>
177 files/PyQt4-4.7.3-qreal_float_support.patch:
178 Updated qreal_float patch to remove first hunk (already applied
179 upstream). Tested on arm chromebook; no existing bug.
180
181*PyQt4-4.10.3-r2 (25 Dec 2013)
182
183 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> +PyQt4-4.10.3-r2.ebuild,
184 -PyQt4-4.10.3-r1.ebuild, metadata.xml:
185 Introduce USE="designer".
186
187 25 Dec 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.9.6-r2.ebuild:
188 old
189
190 23 Dec 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:
191 Stable for sparc, wrt bug #483112
192
193 31 Oct 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.2.ebuild,
194 PyQt4-4.10.3-r1.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
195 Update the ebuilds to dep on dev-lang/python-exec.
196
197 23 Oct 2013; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.1.ebuild:
198 old
199
200*PyQt4-4.10.3-r1 (23 Oct 2013)
201
202 23 Oct 2013; Michał Górny <mgorny@gentoo.org> +PyQt4-4.10.3-r1.ebuild:
203 Support python-exec:2.
204
205 19 Sep 2013; Ben de Groot <yngwin@gentoo.org> PyQt4-4.10.3.ebuild:
206 Depend on sip >=4.15.0 to fix build failure (bug #485274)
207
208 17 Sep 2013; Michał Górny <mgorny@gentoo.org> PyQt4-4.10.1.ebuild,
209 PyQt4-4.10.2.ebuild, PyQt4-4.10.3.ebuild, PyQt4-4.9.6-r2.ebuild:
210 Add explicit dep on python-exec:0 since the package wraps the script manually.
211
212*PyQt4-4.10.3 (17 Sep 2013)
213
214 17 Sep 2013; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.10.3.ebuild:
215 Version bump
216
217 13 Sep 2013; Jonathan Callen <jcallen@gentoo.org> PyQt4-4.10.1.ebuild,
218 PyQt4-4.10.2.ebuild, PyQt4-4.9.6-r2.ebuild:
219 Add missing [${PYTHON_USEDEP}] on dbus-python DEPEND
4 220
5 10 Sep 2013; Markus Meier <maekke@gentoo.org> PyQt4-4.10.2.ebuild: 221 10 Sep 2013; Markus Meier <maekke@gentoo.org> PyQt4-4.10.2.ebuild:
6 arm stable, bug #483112 222 arm stable, bug #483112
7 223
8 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild: 224 05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> PyQt4-4.10.2.ebuild:

Legend:
Removed from v.1.237  
changed lines
  Added in v.1.293

  ViewVC Help
Powered by ViewVC 1.1.20