/[gentoo-x86]/media-video/vlc/vlc-9999.ebuild
Gentoo

Contents of /media-video/vlc/vlc-9999.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.51 - (hide annotations) (download)
Sat Dec 12 18:19:23 2009 UTC (7 years, 9 months ago) by aballier
Branch: MAIN
Changes since 1.50: +3 -7 lines
remove X useflag, only xcb is available now, enable xcb by default
(Portage version: 2.2_rc58/cvs/Linux x86_64)

1 aballier 1.1 # Copyright 1999-2009 Gentoo Foundation
2     # Distributed under the terms of the GNU General Public License v2
3 aballier 1.51 # $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.50 2009/12/05 08:59:38 aballier Exp $
4 aballier 1.1
5 aballier 1.22 EAPI="2"
6 aballier 1.1
7     SCM=""
8     if [ "${PV%9999}" != "${PV}" ] ; then
9     SCM=git
10     EGIT_REPO_URI="git://git.videolan.org/vlc.git"
11     EGIT_BOOTSTRAP="bootstrap"
12     if [ "${PV%.9999}" != "${PV}" ] ; then
13     EGIT_BRANCH=${PV%.9999}-bugfix
14     else
15     EGIT_BRANCH=master
16     fi
17     fi
18    
19     inherit eutils multilib autotools toolchain-funcs gnome2 nsplugins qt4 flag-o-matic ${SCM}
20    
21     MY_PV="${PV/_/-}"
22     MY_PV="${MY_PV/-beta/-test}"
23     MY_P="${PN}-${MY_PV}"
24     VLC_SNAPSHOT_TIME="0013"
25    
26 aballier 1.38 PATCHLEVEL="72"
27 aballier 1.1 DESCRIPTION="VLC media player - Video player and streamer"
28     HOMEPAGE="http://www.videolan.org/vlc/"
29     if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
30     SRC_URI=""
31     elif [[ "${P}" == *_alpha* ]]; then # Snapshots taken from nightlies.videolan.org
32     SRC_URI="http://nightlies.videolan.org/build/source/trunk-${PV/*_alpha/}-${VLC_SNAPSHOT_TIME}/${PN}-snapshot-${PV/*_alpha/}.tar.bz2"
33     MY_P="${P/_alpha*/}-git"
34     elif [[ "${MY_P}" == "${P}" ]]; then
35     SRC_URI="http://download.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.bz2"
36     else
37     SRC_URI="http://download.videolan.org/pub/videolan/testing/${MY_P}/${MY_P}.tar.bz2"
38     fi
39    
40     SRC_URI="${SRC_URI}
41 aballier 1.47 mirror://gentoo/${PN}-patches-${PATCHLEVEL}.tar.bz2"
42 aballier 1.1
43     LICENSE="GPL-2"
44     SLOT="0"
45    
46     KEYWORDS=""
47     IUSE="a52 aac aalib alsa altivec atmo avahi bidi cdda cddax cddb cdio dbus dc1394
48 aballier 1.36 debug dirac directfb dts dvb dvd elibc_glibc fbcon fluidsynth +ffmpeg flac fontconfig
49 aballier 1.46 +gcrypt ggi gnome gnutls httpd id3tag ieee1394 jack kate libass libcaca
50 aballier 1.48 libnotify libproxy libsysfs libtiger libv4l libv4l2 lirc live lua matroska mmx
51 aballier 1.18 modplug mp3 mpeg mtp musepack ncurses nsplugin ogg opengl optimisememory oss
52 aballier 1.38 png projectm pulseaudio pvr +qt4 remoteosd rtsp run-as-root samba
53 aballier 1.50 schroedinger sdl sdl-image seamonkey shine shout skins speex sqlite sse stream
54 aballier 1.43 svg svga taglib theora truetype twolame udev upnp v4l v4l2 vcdinfo vcdx vlm
55 aballier 1.51 vorbis win32codecs wma-fixed x264 +xcb xml xosd xv zvbi"
56 aballier 1.1
57     RDEPEND="
58 aballier 1.24 !!<=media-video/vlc-1.0.99999
59 aballier 1.1 sys-libs/zlib
60 aballier 1.20 >=media-libs/libdvbpsi-0.1.6
61 aballier 1.1 a52? ( >=media-libs/a52dec-0.7.4-r3 )
62     aalib? ( media-libs/aalib )
63     aac? ( >=media-libs/faad2-2.6.1 )
64     alsa? ( media-libs/alsa-lib )
65     avahi? ( >=net-dns/avahi-0.6 )
66     bidi? ( >=dev-libs/fribidi-0.10.4 )
67     cdda? ( cddb? ( >=media-libs/libcddb-1.2.0 ) )
68     cddax? ( cddb? ( >=media-libs/libcddb-1.2.0 ) )
69     cdio? ( >=dev-libs/libcdio-0.78.2 )
70     dbus? ( >=sys-apps/dbus-1.0.2 )
71 aballier 1.18 dc1394? ( >=sys-libs/libraw1394-2.0.1
72     >=media-libs/libdc1394-2.0.2 )
73 aballier 1.1 dirac? ( >=media-video/dirac-0.10.0 )
74 aballier 1.37 directfb? ( dev-libs/DirectFB sys-libs/zlib )
75 aballier 1.1 dts? ( media-libs/libdca )
76     dvd? ( media-libs/libdvdread
77     >=media-libs/libdvdnav-0.1.9
78     media-libs/libdvdplay )
79 aballier 1.36 elibc_glibc? ( >=sys-libs/glibc-2.8 )
80 aballier 1.1 ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20090201 )
81     flac? ( media-libs/libogg
82     >=media-libs/flac-1.1.2 )
83     fluidsynth? ( media-sound/fluidsynth )
84     fontconfig? ( media-libs/fontconfig )
85 pva 1.16 gcrypt? ( >=dev-libs/libgcrypt-1.2.0 )
86 aballier 1.1 ggi? ( media-libs/libggi )
87     gnome? ( gnome-base/gnome-vfs )
88 aballier 1.8 gnutls? ( >=net-libs/gnutls-1.7.4 )
89 aballier 1.37 id3tag? ( media-libs/libid3tag sys-libs/zlib )
90 aballier 1.18 ieee1394? ( >=sys-libs/libraw1394-2.0.1 >=sys-libs/libavc1394-0.5.3 )
91 aballier 1.1 jack? ( >=media-sound/jack-audio-connection-kit-0.99.0-r1 )
92     kate? ( >=media-libs/libkate-0.1.1 )
93 aballier 1.31 libass? ( >=media-libs/libass-0.9.6 media-libs/fontconfig )
94 aballier 1.1 libcaca? ( media-libs/libcaca )
95     libnotify? ( x11-libs/libnotify )
96 aballier 1.13 libproxy? ( net-libs/libproxy )
97 aballier 1.1 libsysfs? ( sys-fs/sysfsutils )
98 aballier 1.17 libtiger? ( media-libs/libtiger )
99 aballier 1.1 lirc? ( app-misc/lirc )
100     live? ( >=media-plugins/live-2008.07.06 )
101     lua? ( >=dev-lang/lua-5.1 )
102     matroska? (
103     >=dev-libs/libebml-0.7.6
104     >=media-libs/libmatroska-0.8.0 )
105     modplug? ( media-libs/libmodplug )
106     mp3? ( media-libs/libmad )
107     mpeg? ( >=media-libs/libmpeg2-0.3.2 )
108     mtp? ( >=media-libs/libmtp-0.3.0 )
109 ssuominen 1.44 musepack? ( >=media-sound/musepack-tools-444 )
110 aballier 1.1 ncurses? ( sys-libs/ncurses )
111     nsplugin? (
112     seamonkey? ( =www-client/seamonkey-1* )
113     !seamonkey? ( >=net-libs/xulrunner-1.8 )
114     )
115     ogg? ( media-libs/libogg )
116 aballier 1.51 opengl? ( virtual/opengl )
117 aballier 1.37 png? ( media-libs/libpng sys-libs/zlib )
118 aballier 1.21 projectm? ( media-libs/libprojectm )
119 aballier 1.9 pulseaudio? ( >=media-sound/pulseaudio-0.9.11 )
120 aballier 1.35 qt4? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 x11-libs/libX11 )
121 aballier 1.1 remoteosd? ( >=dev-libs/libgcrypt-1.2.0 )
122 patrick 1.42 samba? ( || ( >=net-fs/samba-libs-3.4[smbclient]
123     <net-fs/samba-3.4 ) )
124 aballier 1.12 schroedinger? ( >=media-libs/schroedinger-1.0.6 )
125 aballier 1.1 sdl? ( >=media-libs/libsdl-1.2.8
126 aballier 1.37 sdl-image? ( media-libs/sdl-image sys-libs/zlib ) )
127 aballier 1.1 shout? ( media-libs/libshout )
128 aballier 1.35 skins? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 x11-libs/libXext x11-libs/libX11 )
129 aballier 1.1 speex? ( media-libs/speex )
130 aballier 1.50 sqlite? ( dev-db/sqlite:3 )
131 aballier 1.1 svg? ( >=gnome-base/librsvg-2.9.0 )
132     svga? ( media-libs/svgalib )
133 aballier 1.37 taglib? ( >=media-libs/taglib-1.5 sys-libs/zlib )
134 aballier 1.6 theora? ( >=media-libs/libtheora-1.0_beta3 )
135 aballier 1.1 truetype? ( media-libs/freetype
136 aballier 1.25 media-fonts/dejavu )
137 aballier 1.1 twolame? ( media-sound/twolame )
138 aballier 1.45 udev? ( >=sys-fs/udev-142 )
139 aballier 1.1 upnp? ( net-libs/libupnp )
140     v4l2? ( libv4l2? ( media-libs/libv4l ) )
141 aballier 1.48 v4l? ( libv4l? ( media-libs/libv4l ) )
142 aballier 1.1 vcdinfo? ( >=media-video/vcdimager-0.7.22 )
143     vorbis? ( media-libs/libvorbis )
144     win32codecs? ( media-libs/win32codecs )
145 aballier 1.40 x264? ( >=media-libs/x264-0.0.20090923 )
146 aballier 1.2 xcb? ( x11-libs/libxcb x11-libs/xcb-util )
147 aballier 1.1 xml? ( dev-libs/libxml2 )
148     xosd? ( x11-libs/xosd )
149     zvbi? ( >=media-libs/zvbi-0.2.25 )
150     "
151    
152     DEPEND="${RDEPEND}
153     dvb? ( sys-kernel/linux-headers )
154     v4l? ( sys-kernel/linux-headers )
155 aballier 1.28 v4l2? ( >=sys-kernel/linux-headers-2.6.25 )
156 aballier 1.2 xcb? ( x11-proto/xproto )
157 aballier 1.1 dev-util/pkgconfig"
158    
159     S="${WORKDIR}/${MY_P}"
160    
161 aballier 1.5 # Displays a warning if the first use flag is set but the second is not
162 aballier 1.1 vlc_use_needs() {
163     use $1 && use !$2 && ewarn "USE=$1 requires $2, $1 will be disabled."
164     }
165    
166     # Notify the user that some useflag have been forced on
167     vlc_use_force() {
168     use $1 && use !$2 && ewarn "USE=$1 requires $2, $2 will be enabled."
169     }
170    
171     # Use when $2 depends strictly on $3
172     # if use $1 then enable $2 and $3, otherwise disable $2
173     vlc_use_enable_force() {
174     if use $1 ; then
175     echo "--enable-$2 --enable-$3"
176     else
177     echo "--disable-$2"
178     fi
179     }
180    
181     pkg_setup() {
182 aballier 1.23 if has_version '<=media-video/vlc-1.0.99999'; then
183     eerror "Please unmerge vlc-1.0.x first before installing ${P}"
184 aballier 1.11 eerror "If you don't do that, some plugins will get linked against"
185     eerror "the old ${PN} version and will not work."
186 aballier 1.23 die "Unmerge vlc 1.0.x first"
187 aballier 1.11 fi
188 aballier 1.1 vlc_use_needs skins truetype
189     vlc_use_force skins qt4
190     vlc_use_needs cddax cdio
191     vlc_use_needs vcdx cdio
192     vlc_use_needs vcdx vcdinfo
193     vlc_use_needs vcdinfo cdio
194     vlc_use_needs bidi truetype
195 pva 1.14 vlc_use_force remoteosd gcrypt
196 aballier 1.1 vlc_use_needs fontconfig truetype
197     vlc_use_needs libv4l2 v4l2
198 aballier 1.48 vlc_use_needs libv4l v4l
199 aballier 1.17 vlc_use_needs libtiger kate
200 aballier 1.39 vlc_use_needs xv xcb
201 aballier 1.1 use cddb && use !cdda && use !cddax && ewarn "USE=cddb requires either cdda or cddax, cddb will be disabled."
202 aballier 1.5 if use qt4 || use skins ; then
203     qt4_pkg_setup
204 aballier 1.1 else
205     ewarn "You have disabled the qt4 useflag, ${PN} will not have any"
206     ewarn "graphical interface. Maybe that is not what you want..."
207     fi
208     }
209    
210     src_unpack() {
211     unpack ${A}
212     if [ "${PV%9999}" != "${PV}" ] ; then
213     git_src_unpack
214     fi
215 aballier 1.22 }
216 aballier 1.1
217 aballier 1.22 src_prepare() {
218     if [ "${PV%9999}" != "${PV}" ] ; then
219     git_src_prepare
220     fi
221 aballier 1.1 # Make it build with libtool 1.5
222     rm -f m4/lt* m4/libtool.m4
223    
224     EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
225 aballier 1.47 eautoreconf
226 aballier 1.1 }
227    
228 aballier 1.22 src_configure() {
229 aballier 1.1
230     # It would fail if -fforce-addr is used due to too few registers...
231     use x86 && filter-flags -fforce-addr
232    
233     local MOZILLA_PC
234    
235     if use nsplugin; then
236     if use seamonkey; then
237     MOZILLA_PC=seamonkey-plugin
238     else
239     if has_version 'net-libs/xulrunner:1.9' ; then
240     MOZILLA_PC=libxul
241     else
242     MOZILLA_PC=xulrunner-plugin
243     fi
244     fi
245     fi
246    
247     econf \
248     $(use_enable a52) \
249     $(use_enable aalib aa) \
250     $(use_enable aac faad) \
251     $(use_enable alsa) \
252     $(use_enable altivec) \
253     --disable-asademux \
254     $(use_enable atmo) \
255     $(use_enable avahi bonjour) \
256     $(use_enable bidi fribidi) \
257     $(use_enable cdda vcd) \
258     $(use_enable cddax)\
259     $(use_enable cddb libcddb) \
260     $(use_enable cdio libcdio) \
261     $(use_enable dbus) $(use_enable dbus dbus-control) \
262     $(use_enable dirac) \
263     $(use_enable directfb) \
264     $(use_enable dc1394) \
265     $(use_enable debug) \
266     $(use_enable dts dca) \
267     $(use_enable dvb) \
268     $(use_enable dvd dvdread) $(use_enable dvd dvdnav) \
269     $(use_enable fbcon fb) \
270 aballier 1.10 $(use_enable ffmpeg avcodec) $(use_enable ffmpeg avformat) $(use_enable ffmpeg swscale) $(use_enable ffmpeg postproc) \
271 aballier 1.1 $(use_enable flac) \
272     $(use_enable fluidsynth) \
273     $(use_enable fontconfig) \
274     $(use_enable ggi) \
275     $(use_enable gnome gnomevfs) \
276     $(use_enable gnutls) \
277     $(use_enable httpd) \
278     $(use_enable id3tag) \
279 aballier 1.18 $(use_enable ieee1394 dv) \
280 aballier 1.1 $(use_enable jack) \
281     $(use_enable kate) \
282     $(use_enable libass) \
283     $(use_enable libcaca caca) \
284 pva 1.14 $(use_enable gcrypt libgcrypt) \
285 aballier 1.1 $(use_enable libnotify notify) \
286 aballier 1.13 $(use_enable libproxy) \
287 aballier 1.1 --disable-libtar \
288 aballier 1.17 $(use_enable libtiger tiger) \
289 aballier 1.1 $(use_enable libsysfs) \
290 aballier 1.48 $(use_enable libv4l) \
291 aballier 1.1 $(use_enable libv4l2) \
292     $(use_enable lirc) \
293     $(use_enable live live555) \
294     $(use_enable lua) \
295     $(use_enable matroska mkv) \
296     $(use_enable mmx) \
297     $(use_enable modplug mod) \
298     $(use_enable mp3 mad) \
299     $(use_enable mpeg libmpeg2) \
300     $(use_enable mtp) \
301     $(use_enable musepack mpc) \
302     $(use_enable ncurses) \
303     $(use_enable nsplugin mozilla) --with-mozilla-pkg="${MOZILLA_PC}" \
304     $(use_enable ogg) \
305 aballier 1.30 $(use_enable opengl glx) $(use_enable opengl) \
306 aballier 1.1 $(use_enable optimisememory optimize-memory) \
307     $(use_enable oss) \
308     $(use_enable png) \
309     --disable-portaudio \
310 aballier 1.21 $(use_enable projectm) \
311 aballier 1.1 $(use_enable pulseaudio pulse) \
312     $(use_enable pvr) \
313     $(use_enable qt4) \
314     $(use_enable rtsp realrtsp) \
315     $(use_enable run-as-root) \
316     $(use_enable samba smb) \
317     $(use_enable schroedinger) \
318     $(use_enable sdl) \
319     $(use_enable sdl-image) \
320     $(use_enable shine) \
321     $(use_enable shout) \
322     $(use_enable skins skins2) \
323     $(use_enable speex) \
324 aballier 1.50 $(use_enable sqlite) \
325 aballier 1.1 $(use_enable sse) \
326     $(use_enable stream sout) \
327     $(use_enable svg) \
328     $(use_enable svga svgalib) \
329     $(use_enable taglib) \
330     $(use_enable theora) \
331     $(use_enable truetype freetype) \
332     $(use_enable twolame) \
333 aballier 1.43 $(use_enable udev) \
334 aballier 1.1 $(use_enable upnp) \
335     $(use_enable v4l) \
336     $(use_enable v4l2) \
337     $(use_enable vcdinfo) \
338     $(use_enable vcdx) \
339     $(use_enable vorbis) \
340     $(use_enable win32codecs loader) \
341     $(use_enable wma-fixed) \
342     $(use_enable x264) \
343 aballier 1.2 $(use_enable xcb) \
344 aballier 1.1 $(use_enable xml libxml2) \
345     $(use_enable xosd) \
346     $(use_enable xv xvideo) \
347 aballier 1.26 $(use_enable zvbi) $(use_enable !zvbi telx) \
348 aballier 1.1 --disable-snapshot \
349     --disable-growl \
350     --disable-optimizations \
351     --enable-fast-install \
352     $(vlc_use_enable_force vlm vlm sout) \
353     $(vlc_use_enable_force skins skins2 qt4) \
354 alexxy 1.15 $(vlc_use_enable_force remoteosd remoteosd libgcrypt)
355 aballier 1.1 }
356    
357     src_install() {
358     emake DESTDIR="${D}" install || die "make install failed"
359    
360 aballier 1.48 dodoc AUTHORS HACKING THANKS NEWS README \
361 aballier 1.1 doc/fortunes.txt doc/intf-cdda.txt doc/intf-vcd.txt
362    
363     rm -rf "${D}/usr/share/doc/vlc" \
364     "${D}"/usr/share/vlc/vlc{16x16,32x32,48x48,128x128}.{png,xpm,ico}
365    
366     if use nsplugin; then
367     dodir "/usr/$(get_libdir)/${PLUGINS_DIR}"
368     mv "${D}"/usr/$(get_libdir)/mozilla/plugins/* \
369     "${D}/usr/$(get_libdir)/${PLUGINS_DIR}/"
370     fi
371    
372     use skins || rm -rf "${D}/usr/share/vlc/skins2"
373    
374     for res in 16 32 48; do
375     insinto /usr/share/icons/hicolor/${res}x${res}/apps/
376     newins "${S}"/share/vlc${res}x${res}.png vlc.png
377     done
378     }

  ViewVC Help
Powered by ViewVC 1.1.20