/[gentoo-x86]/net-misc/curl/curl-7.16.0.ebuild
Gentoo

Contents of /net-misc/curl/curl-7.16.0.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.3 - (show annotations) (download)
Sat Apr 14 00:35:26 2007 UTC (12 years, 7 months ago) by dragonheart
Branch: MAIN
CVS Tags: HEAD
Changes since 1.2: +1 -1 lines
FILE REMOVED
version bump. remove old versions. remove krb4 as per bug #173354
(Portage version: 2.1.2.2)

1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.16.0.ebuild,v 1.2 2007/02/11 04:07:12 dragonheart Exp $
4
5 # NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
6
7 inherit libtool eutils
8
9 DESCRIPTION="A Client that groks URLs"
10 HOMEPAGE="http://curl.haxx.se/"
11 SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
12
13 LICENSE="MIT X11"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
16 IUSE="ssl ipv6 ldap ares gnutls idn kerberos krb4 test"
17
18 RDEPEND="gnutls? ( net-libs/gnutls )
19 ssl? ( !gnutls? ( dev-libs/openssl ) )
20 ldap? ( net-nds/openldap )
21 idn? ( net-dns/libidn )
22 ares? ( net-dns/c-ares )
23 kerberos? ( virtual/krb5 )
24 krb4? ( app-crypt/kth-krb )"
25
26 DEPEND="${RDEPEND}
27 test? (
28 sys-apps/diffutils
29 dev-lang/perl
30 )"
31 # used - but can do without in self test: net-misc/stunnel
32
33 src_unpack() {
34 unpack ${A}
35 cd "${S}"
36 epatch ${FILESDIR}/${PN}-7.15-strip-ldflags.patch
37 epatch ${FILESDIR}/curl-7.15.1-test62.patch
38 elibtoolize
39 }
40
41 src_compile() {
42
43 myconf="$(use_enable ldap)
44 $(use_with idn libidn)
45 $(use_enable kerberos gssapi)
46 $(use_enable ipv6)
47 --enable-http
48 --enable-ftp
49 --enable-gopher
50 --enable-file
51 --enable-dict
52 --enable-manual
53 --enable-telnet
54 --enable-nonblocking
55 --enable-largefile
56 --enable-maintainer-mode"
57
58 if use ipv6 && use ares; then
59 ewarn "c-ares support disabled because it is incompatible with ipv6."
60 myconf="${myconf} --disable-ares"
61 else
62 myconf="${myconf} $(use_enable ares)"
63 fi
64
65 if use ipv6 && use krb4; then
66 ewarn "kerberos-4 support disabled because it is incompatible with ipv6."
67 myconf="${myconf} --disable-krb4"
68 else
69 myconf="${myconf} $(use_enable krb4)"
70 fi
71
72 if use gnutls; then
73 myconf="${myconf} --without-ssl --with-gnutls=/usr"
74 elif use ssl; then
75 myconf="${myconf} --without-gnutls --with-ssl=/usr"
76 else
77 myconf="${myconf} --without-gnutls --without-ssl"
78 fi
79
80 if use kerberos; then
81 myconf="${myconf} --with-gssapi=/usr"
82 fi
83
84 econf ${myconf} || die 'configure failed'
85 emake || die "install failed for current version"
86 }
87
88 src_install() {
89 make DESTDIR="${D}" install || die "installed failed for current version"
90
91 insinto /usr/share/aclocal
92 doins docs/libcurl/libcurl.m4
93
94 dodoc CHANGES README
95 dodoc docs/FEATURES docs/INTERNALS
96 dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
97 }
98
99 pkg_postinst() {
100 if [[ -e "${ROOT}"/usr/$(get_libdir)/libcurl.so.3 ]] ; then
101 ewarn "You must re-compile all packages that are linked against"
102 ewarn "curl-7.15.* by using revdep-rebuild from gentoolkit:"
103 ewarn "# revdep-rebuild --library libcurl.so.3"
104 fi
105 }

  ViewVC Help
Powered by ViewVC 1.1.20