/[gentoo-x86]/net-misc/openssh/openssh-3.5_p1-r1.ebuild
Gentoo

Diff of /net-misc/openssh/openssh-3.5_p1-r1.ebuild

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.11 Revision 1.12
1# Copyright 1999-2003 Gentoo Technologies, Inc. 1# Copyright 1999-2003 Gentoo Technologies, Inc.
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/Attic/openssh-3.5_p1-r1.ebuild,v 1.11 2003/03/30 22:15:22 method Exp $ 3# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/Attic/openssh-3.5_p1-r1.ebuild,v 1.12 2003/06/06 23:58:22 rphillips Exp $
4 4
5inherit eutils 5inherit eutils
6 6
7IUSE="ipv6 static pam tcpd kerberos selinux" 7IUSE="ipv6 static pam tcpd kerberos selinux"
8 8
17 17
18# openssh recognizes when openssl has been slightly upgraded and refuses to run. 18# openssh recognizes when openssl has been slightly upgraded and refuses to run.
19# This new rev will use the new openssl. 19# This new rev will use the new openssl.
20RDEPEND="virtual/glibc 20RDEPEND="virtual/glibc
21 pam? ( >=sys-libs/pam-0.73 >=sys-apps/shadow-4.0.2-r2 ) 21 pam? ( >=sys-libs/pam-0.73 >=sys-apps/shadow-4.0.2-r2 )
22 kerberos? ( app-crypt/krb5 ) 22 kerberos? ( app-crypt/mit-krb5 )
23 selinux? ( sys-apps/selinux-small ) 23 selinux? ( sys-apps/selinux-small )
24 >=dev-libs/openssl-0.9.6d 24 >=dev-libs/openssl-0.9.6d
25 sys-libs/zlib" 25 sys-libs/zlib"
26 26
27DEPEND="${RDEPEND} 27DEPEND="${RDEPEND}
50 use tcpd && myconf="${myconf} --with-tcp-wrappers" 50 use tcpd && myconf="${myconf} --with-tcp-wrappers"
51 use pam || myconf="${myconf} --without-pam" 51 use pam || myconf="${myconf} --without-pam"
52 use pam && myconf="${myconf} --with-pam" 52 use pam && myconf="${myconf} --with-pam"
53 use ipv6 || myconf="${myconf} --with-ipv4-default" 53 use ipv6 || myconf="${myconf} --with-ipv4-default"
54 54
55 # app-crypt/krb5 55 # app-crypt/mit-krb5
56 use kerberos && myconf="${myconf} --with-kerberos5" 56 use kerberos && myconf="${myconf} --with-kerberos5"
57 57
58 # app-crypt/kth-krb 58 # app-crypt/kth-krb
59 # KTH's implementation of kerberos IV 59 # KTH's implementation of kerberos IV
60 # KTH_KRB="yes" emerge openssh-3.5_p1-r1.ebuild 60 # KTH_KRB="yes" emerge openssh-3.5_p1-r1.ebuild

Legend:
Removed from v.1.11  
changed lines
  Added in v.1.12

  ViewVC Help
Powered by ViewVC 1.1.20