/[gentoo-x86]/net-misc/openssh/openssh-5.9_p1-r1.ebuild
Gentoo

Contents of /net-misc/openssh/openssh-5.9_p1-r1.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.3 - (show annotations) (download)
Wed Sep 14 21:46:19 2011 UTC (8 years, 1 month ago) by polynomial-c
Branch: MAIN
CVS Tags: HEAD
Changes since 1.2: +1 -1 lines
FILE REMOVED
Fixed deprecated opts variable (bug #382227) and removed --stop option from reload function (bug #382975)

(Portage version: 2.2.0_alpha56/cvs/Linux x86_64)

1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.9_p1-r1.ebuild,v 1.2 2011/09/12 05:38:10 vapier Exp $
4
5 EAPI="2"
6 inherit eutils flag-o-matic multilib autotools pam
7
8 # Make it more portable between straight releases
9 # and _p? releases.
10 PARCH=${P/_}
11
12 HPN_PATCH="${PARCH}-hpn13v11.diff.gz"
13 LDAP_PATCH="${PARCH/-/-lpk-}-0.3.14.patch.gz"
14 #X509_VER="7.0" X509_PATCH="${PARCH}+x509-${X509_VER}.diff.gz"
15
16 DESCRIPTION="Port of OpenBSD's free SSH release"
17 HOMEPAGE="http://www.openssh.org/"
18 SRC_URI="mirror://openbsd/OpenSSH/portable/${PARCH}.tar.gz
19 ${HPN_PATCH:+hpn? ( http://www.psc.edu/networking/projects/hpn-ssh/${HPN_PATCH} mirror://gentoo/${HPN_PATCH} )}
20 ${LDAP_PATCH:+ldap? ( mirror://gentoo/${LDAP_PATCH} )}
21 ${X509_PATCH:+X509? ( http://roumenpetrov.info/openssh/x509-${X509_VER}/${X509_PATCH} )}
22 "
23
24 LICENSE="as-is"
25 SLOT="0"
26 #KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
27 IUSE="${HPN_PATCH:++}hpn kerberos ldap libedit pam selinux skey static tcpd X X509"
28
29 RDEPEND="pam? ( virtual/pam )
30 kerberos? ( virtual/krb5 )
31 selinux? ( >=sys-libs/libselinux-1.28 )
32 skey? ( >=sys-auth/skey-1.1.5-r1 )
33 ldap? ( net-nds/openldap )
34 libedit? ( dev-libs/libedit )
35 >=dev-libs/openssl-0.9.6d
36 >=sys-libs/zlib-1.2.3
37 tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
38 X? ( x11-apps/xauth )
39 userland_GNU? ( sys-apps/shadow )"
40 DEPEND="${RDEPEND}
41 dev-util/pkgconfig
42 virtual/os-headers
43 sys-devel/autoconf"
44 RDEPEND="${RDEPEND}
45 pam? ( >=sys-auth/pambase-20081028 )"
46
47 S=${WORKDIR}/${PARCH}
48
49 pkg_setup() {
50 # this sucks, but i'd rather have people unable to `emerge -u openssh`
51 # than not be able to log in to their server any more
52 maybe_fail() { [[ -z ${!2} ]] && echo ${1} ; }
53 local fail="
54 $(use X509 && maybe_fail X509 X509_PATCH)
55 $(use ldap && maybe_fail ldap LDAP_PATCH)
56 $(use hpn && maybe_fail hpn HPN_PATCH)
57 "
58 fail=$(echo ${fail})
59 if [[ -n ${fail} ]] ; then
60 eerror "Sorry, but this version does not yet support features"
61 eerror "that you requested: ${fail}"
62 eerror "Please mask ${PF} for now and check back later:"
63 eerror " # echo '=${CATEGORY}/${PF}' >> /etc/portage/package.mask"
64 die "booooo"
65 fi
66 }
67
68 src_prepare() {
69 sed -i \
70 -e '/_PATH_XAUTH/s:/usr/X11R6/bin/xauth:/usr/bin/xauth:' \
71 pathnames.h || die
72 # keep this as we need it to avoid the conflict between LPK and HPN changing
73 # this file.
74 cp version.h version.h.pristine
75
76 # don't break .ssh/authorized_keys2 for fun
77 sed -i '/^AuthorizedKeysFile/s:^:#:' sshd_config || die
78
79 if use X509 ; then
80 epatch "${WORKDIR}"/${X509_PATCH%.*}
81 epatch "${FILESDIR}"/${PN}-5.8_p1-x509-hpn-glue.patch
82 fi
83 if ! use X509 ; then
84 if [[ -n ${LDAP_PATCH} ]] && use ldap ; then
85 epatch "${WORKDIR}"/${LDAP_PATCH%.*}
86 #epatch "${FILESDIR}"/${PN}-5.2p1-ldap-stdargs.diff #266654 - merged
87 # version.h patch conflict avoidence
88 mv version.h version.h.lpk
89 cp -f version.h.pristine version.h
90 fi
91 else
92 use ldap && ewarn "Sorry, X509 and LDAP conflict internally, disabling LDAP"
93 fi
94 epatch "${FILESDIR}"/${PN}-5.9_p1-sshd-gssapi-multihomed.patch #378361
95 epatch "${FILESDIR}"/${PN}-4.7_p1-GSSAPI-dns.patch #165444 integrated into gsskex
96 if [[ -n ${HPN_PATCH} ]] && use hpn; then
97 epatch "${WORKDIR}"/${HPN_PATCH%.*}
98 epatch "${FILESDIR}"/${PN}-5.6_p1-hpn-progressmeter.patch
99 # version.h patch conflict avoidence
100 mv version.h version.h.hpn
101 cp -f version.h.pristine version.h
102 # The AES-CTR multithreaded variant is broken, and causes random hangs
103 # when combined background threading and control sockets. To avoid
104 # this, we change the internal table to use the non-multithread version
105 # for the meantime. Do NOT remove this in new versions. See bug #354113
106 # comment #6 for testcase.
107 # Upstream reference: http://www.psc.edu/networking/projects/hpn-ssh/
108 ## Additionally, the MT-AES-CTR mode cipher replaces the default ST-AES-CTR mode
109 ## cipher. Be aware that if the client process is forked using the -f command line
110 ## option the process will hang as the parent thread gets 'divorced' from the key
111 ## generation threads. This issue will be resolved as soon as possible
112 sed -i \
113 -e '/aes...-ctr.*SSH_CIPHER_SSH2/s,evp_aes_ctr_mt,evp_aes_128_ctr,' \
114 cipher.c || die
115 fi
116
117 sed -i "s:-lcrypto:$(pkg-config --libs openssl):" configure{,.ac} || die
118
119 # Disable PATH reset, trust what portage gives us. bug 254615
120 sed -i -e 's:^PATH=/:#PATH=/:' configure || die
121
122 # Now we can build a sane merged version.h
123 (
124 sed '/^#define SSH_RELEASE/d' version.h.* | sort -u
125 printf '#define SSH_RELEASE SSH_VERSION SSH_PORTABLE %s %s\n' \
126 "$([ -e version.h.hpn ] && echo SSH_HPN)" \
127 "$([ -e version.h.lpk ] && echo SSH_LPK)"
128 ) > version.h
129
130 eautoreconf
131 }
132
133 static_use_with() {
134 local flag=$1
135 if use static && use ${flag} ; then
136 ewarn "Disabling '${flag}' support because of USE='static'"
137 # rebuild args so that we invert the first one (USE flag)
138 # but otherwise leave everything else working so we can
139 # just leverage use_with
140 shift
141 [[ -z $1 ]] && flag="${flag} ${flag}"
142 set -- !${flag} "$@"
143 fi
144 use_with "$@"
145 }
146
147 src_configure() {
148 addwrite /dev/ptmx
149 addpredict /etc/skey/skeykeys #skey configure code triggers this
150
151 use static && append-ldflags -static
152
153 econf \
154 --with-ldflags="${LDFLAGS}" \
155 --disable-strip \
156 --sysconfdir=/etc/ssh \
157 --libexecdir=/usr/$(get_libdir)/misc \
158 --datadir=/usr/share/openssh \
159 --with-privsep-path=/var/empty \
160 --with-privsep-user=sshd \
161 --with-md5-passwords \
162 --with-ssl-engine \
163 $(static_use_with pam) \
164 $(static_use_with kerberos kerberos5 /usr) \
165 ${LDAP_PATCH:+$(use X509 || ( use ldap && use_with ldap ))} \
166 $(use_with libedit) \
167 $(use_with selinux) \
168 $(use_with skey) \
169 $(use_with tcpd tcp-wrappers)
170 }
171
172 src_install() {
173 emake install-nokeys DESTDIR="${D}" || die
174 fperms 600 /etc/ssh/sshd_config
175 dobin contrib/ssh-copy-id || die
176 newinitd "${FILESDIR}"/sshd.rc6.3 sshd
177 newconfd "${FILESDIR}"/sshd.confd sshd
178 keepdir /var/empty
179
180 # not all openssl installs support ecc, or are functional #352645
181 if ! grep -q '#define OPENSSL_HAS_ECC 1' config.h ; then
182 dosed 's:&& gen_key ecdsa::' /etc/init.d/sshd || die
183 fi
184
185 newpamd "${FILESDIR}"/sshd.pam_include.2 sshd
186 if use pam ; then
187 sed -i \
188 -e "/^#UsePAM /s:.*:UsePAM yes:" \
189 -e "/^#PasswordAuthentication /s:.*:PasswordAuthentication no:" \
190 -e "/^#PrintMotd /s:.*:PrintMotd no:" \
191 -e "/^#PrintLastLog /s:.*:PrintLastLog no:" \
192 "${D}"/etc/ssh/sshd_config || die "sed of configuration file failed"
193 fi
194
195 # This instruction is from the HPN webpage,
196 # Used for the server logging functionality
197 if [[ -n ${HPN_PATCH} ]] && use hpn ; then
198 keepdir /var/empty/dev
199 fi
200
201 doman contrib/ssh-copy-id.1
202 dodoc ChangeLog CREDITS OVERVIEW README* TODO sshd_config
203
204 diropts -m 0700
205 dodir /etc/skel/.ssh
206 }
207
208 src_test() {
209 local t tests skipped failed passed shell
210 tests="interop-tests compat-tests"
211 skipped=""
212 shell=$(getent passwd ${UID} | cut -d: -f7)
213 if [[ ${shell} == */nologin ]] || [[ ${shell} == */false ]] ; then
214 elog "Running the full OpenSSH testsuite"
215 elog "requires a usable shell for the 'portage'"
216 elog "user, so we will run a subset only."
217 skipped="${skipped} tests"
218 else
219 tests="${tests} tests"
220 fi
221 # It will also attempt to write to the homedir .ssh
222 local sshhome=${T}/homedir
223 mkdir -p "${sshhome}"/.ssh
224 for t in ${tests} ; do
225 # Some tests read from stdin ...
226 HOMEDIR="${sshhome}" \
227 emake -k -j1 ${t} </dev/null \
228 && passed="${passed}${t} " \
229 || failed="${failed}${t} "
230 done
231 einfo "Passed tests: ${passed}"
232 ewarn "Skipped tests: ${skipped}"
233 if [[ -n ${failed} ]] ; then
234 ewarn "Failed tests: ${failed}"
235 die "Some tests failed: ${failed}"
236 else
237 einfo "Failed tests: ${failed}"
238 return 0
239 fi
240 }
241
242 pkg_postinst() {
243 enewgroup sshd 22
244 enewuser sshd 22 -1 /var/empty sshd
245
246 elog "Starting with openssh-5.8p1, the server will default to a newer key"
247 elog "algorithm (ECDSA). You are encouraged to manually update your stored"
248 elog "keys list as servers update theirs. See ssh-keyscan(1) for more info."
249 echo
250 ewarn "Remember to merge your config files in /etc/ssh/ and then"
251 ewarn "reload sshd: '/etc/init.d/sshd reload'."
252 if use pam ; then
253 echo
254 ewarn "Please be aware users need a valid shell in /etc/passwd"
255 ewarn "in order to be allowed to login."
256 fi
257 # This instruction is from the HPN webpage,
258 # Used for the server logging functionality
259 if [[ -n ${HPN_PATCH} ]] && use hpn ; then
260 echo
261 einfo "For the HPN server logging patch, you must ensure that"
262 einfo "your syslog application also listens at /var/empty/dev/log."
263 fi
264 }

  ViewVC Help
Powered by ViewVC 1.1.20