/[gentoo-x86]/net-misc/openssh/openssh-6.6_p1.ebuild
Gentoo

Contents of /net-misc/openssh/openssh-6.6_p1.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.5 - (show annotations) (download)
Thu Mar 20 20:42:44 2014 UTC (5 years, 7 months ago) by polynomial-c
Branch: MAIN
CVS Tags: HEAD
Changes since 1.4: +1 -1 lines
FILE REMOVED
Fixed hpn patch to not add a false patch level to ssh's version string (6.6p2). Committed straight to stable where -r0 was stable

(Portage version: 2.2.8-r1/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 0x981CA6FC)

1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-6.6_p1.ebuild,v 1.4 2014/03/20 18:17:47 ago Exp $
4
5 EAPI="4"
6 inherit eutils user flag-o-matic multilib autotools pam systemd versionator
7
8 # Make it more portable between straight releases
9 # and _p? releases.
10 PARCH=${P/_}
11
12 HPN_PATCH="${PN}-6.6p1-hpnssh14v4.diff.gz"
13 LDAP_PATCH="${PN}-lpk-6.5p1-0.3.14.patch.gz"
14 X509_VER="7.9" X509_PATCH="${PARCH}+x509-${X509_VER}.diff.gz"
15
16 DESCRIPTION="Port of OpenBSD's free SSH release"
17 HOMEPAGE="http://www.openssh.org/"
18 SRC_URI="mirror://openbsd/OpenSSH/portable/${PARCH}.tar.gz
19 ${HPN_PATCH:+hpn? ( mirror://sourceforge/hpnssh/${HPN_PATCH} )}
20 ${LDAP_PATCH:+ldap? ( mirror://gentoo/${LDAP_PATCH} )}
21 ${X509_PATCH:+X509? ( http://roumenpetrov.info/openssh/x509-${X509_VER}/${X509_PATCH} )}
22 "
23
24 LICENSE="BSD GPL-2"
25 SLOT="0"
26 KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
27 IUSE="bindist ${HPN_PATCH:++}hpn kerberos ldap ldns libedit pam selinux skey static tcpd X X509"
28
29 LIB_DEPEND="selinux? ( >=sys-libs/libselinux-1.28[static-libs(+)] )
30 skey? ( >=sys-auth/skey-1.1.5-r1[static-libs(+)] )
31 libedit? ( dev-libs/libedit[static-libs(+)] )
32 >=dev-libs/openssl-0.9.6d:0[bindist=]
33 dev-libs/openssl[static-libs(+)]
34 >=sys-libs/zlib-1.2.3[static-libs(+)]
35 tcpd? ( >=sys-apps/tcp-wrappers-7.6[static-libs(+)] )"
36 RDEPEND="
37 !static? (
38 ${LIB_DEPEND//\[static-libs(+)]}
39 ldns? (
40 !bindist? ( net-libs/ldns[ecdsa,ssl] )
41 bindist? ( net-libs/ldns[-ecdsa,ssl] )
42 )
43 )
44 pam? ( virtual/pam )
45 kerberos? ( virtual/krb5 )
46 ldap? ( net-nds/openldap )"
47 DEPEND="${RDEPEND}
48 static? (
49 ${LIB_DEPEND}
50 ldns? (
51 !bindist? ( net-libs/ldns[ecdsa,ssl,static-libs(+)] )
52 bindist? ( net-libs/ldns[-ecdsa,ssl,static-libs(+)] )
53 )
54 )
55 virtual/pkgconfig
56 virtual/os-headers
57 sys-devel/autoconf"
58 RDEPEND="${RDEPEND}
59 pam? ( >=sys-auth/pambase-20081028 )
60 userland_GNU? ( virtual/shadow )
61 X? ( x11-apps/xauth )"
62
63 S=${WORKDIR}/${PARCH}
64
65 pkg_setup() {
66 # this sucks, but i'd rather have people unable to `emerge -u openssh`
67 # than not be able to log in to their server any more
68 maybe_fail() { [[ -z ${!2} ]] && echo "$1" ; }
69 local fail="
70 $(use X509 && maybe_fail X509 X509_PATCH)
71 $(use ldap && maybe_fail ldap LDAP_PATCH)
72 $(use hpn && maybe_fail hpn HPN_PATCH)
73 "
74 fail=$(echo ${fail})
75 if [[ -n ${fail} ]] ; then
76 eerror "Sorry, but this version does not yet support features"
77 eerror "that you requested: ${fail}"
78 eerror "Please mask ${PF} for now and check back later:"
79 eerror " # echo '=${CATEGORY}/${PF}' >> /etc/portage/package.mask"
80 die "booooo"
81 fi
82 }
83
84 save_version() {
85 # version.h patch conflict avoidence
86 mv version.h version.h.$1
87 cp -f version.h.pristine version.h
88 }
89
90 src_prepare() {
91 sed -i \
92 -e "/_PATH_XAUTH/s:/usr/X11R6/bin/xauth:${EPREFIX}/usr/bin/xauth:" \
93 pathnames.h || die
94 # keep this as we need it to avoid the conflict between LPK and HPN changing
95 # this file.
96 cp version.h version.h.pristine
97
98 # don't break .ssh/authorized_keys2 for fun
99 sed -i '/^AuthorizedKeysFile/s:^:#:' sshd_config || die
100
101 epatch "${FILESDIR}"/${PN}-5.9_p1-sshd-gssapi-multihomed.patch #378361
102 if use X509 ; then
103 pushd .. >/dev/null
104 epatch "${FILESDIR}"/${PN}-6.6_p1-x509-glue.patch
105 use hpn && epatch "${FILESDIR}"/${PN}-6.6_p1-x509-hpn14v4-glue-p2.patch
106 popd >/dev/null
107 epatch "${WORKDIR}"/${X509_PATCH%.*}
108 epatch "${FILESDIR}"/${PN}-6.3_p1-x509-hpn14v2-glue.patch
109 save_version X509
110 fi
111 if ! use X509 ; then
112 if [[ -n ${LDAP_PATCH} ]] && use ldap ; then
113 epatch "${WORKDIR}"/${LDAP_PATCH%.*}
114 save_version LPK
115 fi
116 else
117 use ldap && ewarn "Sorry, X509 and LDAP conflict internally, disabling LDAP"
118 fi
119 epatch "${FILESDIR}"/${PN}-4.7_p1-GSSAPI-dns.patch #165444 integrated into gsskex
120 epatch "${FILESDIR}"/${PN}-6.6_p1-openssl-ignore-status.patch
121 if [[ -n ${HPN_PATCH} ]] && use hpn; then
122 epatch "${WORKDIR}"/${HPN_PATCH%.*}
123 epatch "${FILESDIR}"/${PN}-6.5_p1-hpn-cipher-align.patch #498632
124 save_version HPN
125 fi
126
127 tc-export PKG_CONFIG
128 local sed_args=(
129 -e "s:-lcrypto:$(${PKG_CONFIG} --libs openssl):"
130 # Disable PATH reset, trust what portage gives us #254615
131 -e 's:^PATH=/:#PATH=/:'
132 # Disable fortify flags ... our gcc does this for us
133 -e 's:-D_FORTIFY_SOURCE=2::'
134 )
135 sed -i "${sed_args[@]}" configure{,.ac} || die
136
137 epatch_user #473004
138
139 # Now we can build a sane merged version.h
140 (
141 sed '/^#define SSH_RELEASE/d' version.h.* | sort -u
142 macros=()
143 for p in HPN LPK X509 ; do [ -e version.h.${p} ] && macros+=( SSH_${p} ) ; done
144 printf '#define SSH_RELEASE SSH_VERSION SSH_PORTABLE %s\n' "${macros}"
145 ) > version.h
146
147 eautoreconf
148 }
149
150 static_use_with() {
151 local flag=$1
152 if use static && use ${flag} ; then
153 ewarn "Disabling '${flag}' support because of USE='static'"
154 # rebuild args so that we invert the first one (USE flag)
155 # but otherwise leave everything else working so we can
156 # just leverage use_with
157 shift
158 [[ -z $1 ]] && flag="${flag} ${flag}"
159 set -- !${flag} "$@"
160 fi
161 use_with "$@"
162 }
163
164 src_configure() {
165 local myconf
166 addwrite /dev/ptmx
167 addpredict /etc/skey/skeykeys #skey configure code triggers this
168
169 use static && append-ldflags -static
170
171 # Special settings for Gentoo/FreeBSD 9.0 or later (see bug #391011)
172 if use elibc_FreeBSD && version_is_at_least 9.0 "$(uname -r|sed 's/\(.\..\).*/\1/')" ; then
173 myconf="${myconf} --disable-utmp --disable-wtmp --disable-wtmpx"
174 append-ldflags -lutil
175 fi
176
177 econf \
178 --with-ldflags="${LDFLAGS}" \
179 --disable-strip \
180 --with-pid-dir="${EPREFIX}"/var/run \
181 --sysconfdir="${EPREFIX}"/etc/ssh \
182 --libexecdir="${EPREFIX}"/usr/$(get_libdir)/misc \
183 --datadir="${EPREFIX}"/usr/share/openssh \
184 --with-privsep-path="${EPREFIX}"/var/empty \
185 --with-privsep-user=sshd \
186 --with-md5-passwords \
187 --with-ssl-engine \
188 $(static_use_with pam) \
189 $(static_use_with kerberos kerberos5 /usr) \
190 ${LDAP_PATCH:+$(use X509 || ( use ldap && use_with ldap ))} \
191 $(use_with ldns) \
192 $(use_with libedit) \
193 $(use_with selinux) \
194 $(use_with skey) \
195 $(use_with tcpd tcp-wrappers) \
196 ${myconf}
197 }
198
199 src_install() {
200 emake install-nokeys DESTDIR="${D}"
201 fperms 600 /etc/ssh/sshd_config
202 dobin contrib/ssh-copy-id
203 newinitd "${FILESDIR}"/sshd.rc6.4 sshd
204 newconfd "${FILESDIR}"/sshd.confd sshd
205 keepdir /var/empty
206
207 # not all openssl installs support ecc, or are functional #352645
208 if ! grep -q '#define OPENSSL_HAS_ECC 1' config.h ; then
209 elog "dev-libs/openssl was built with 'bindist' - disabling ecdsa support"
210 sed -i 's:&& gen_key ecdsa::' "${ED}"/etc/init.d/sshd || die
211 fi
212
213 newpamd "${FILESDIR}"/sshd.pam_include.2 sshd
214 if use pam ; then
215 sed -i \
216 -e "/^#UsePAM /s:.*:UsePAM yes:" \
217 -e "/^#PasswordAuthentication /s:.*:PasswordAuthentication no:" \
218 -e "/^#PrintMotd /s:.*:PrintMotd no:" \
219 -e "/^#PrintLastLog /s:.*:PrintLastLog no:" \
220 "${ED}"/etc/ssh/sshd_config || die "sed of configuration file failed"
221 fi
222
223 # Gentoo tweaks to default config files
224 cat <<-EOF >> "${ED}"/etc/ssh/sshd_config
225
226 # Allow client to pass locale environment variables #367017
227 AcceptEnv LANG LC_*
228 EOF
229 cat <<-EOF >> "${ED}"/etc/ssh/ssh_config
230
231 # Send locale environment variables #367017
232 SendEnv LANG LC_*
233 EOF
234
235 # This instruction is from the HPN webpage,
236 # Used for the server logging functionality
237 if [[ -n ${HPN_PATCH} ]] && use hpn ; then
238 keepdir /var/empty/dev
239 fi
240
241 if ! use X509 && [[ -n ${LDAP_PATCH} ]] && use ldap ; then
242 insinto /etc/openldap/schema/
243 newins openssh-lpk_openldap.schema openssh-lpk.schema
244 fi
245
246 doman contrib/ssh-copy-id.1
247 dodoc ChangeLog CREDITS OVERVIEW README* TODO sshd_config
248
249 diropts -m 0700
250 dodir /etc/skel/.ssh
251
252 systemd_dounit "${FILESDIR}"/sshd.{service,socket}
253 systemd_newunit "${FILESDIR}"/sshd_at.service 'sshd@.service'
254 }
255
256 src_test() {
257 local t tests skipped failed passed shell
258 tests="interop-tests compat-tests"
259 skipped=""
260 shell=$(egetshell ${UID})
261 if [[ ${shell} == */nologin ]] || [[ ${shell} == */false ]] ; then
262 elog "Running the full OpenSSH testsuite"
263 elog "requires a usable shell for the 'portage'"
264 elog "user, so we will run a subset only."
265 skipped="${skipped} tests"
266 else
267 tests="${tests} tests"
268 fi
269 # It will also attempt to write to the homedir .ssh
270 local sshhome=${T}/homedir
271 mkdir -p "${sshhome}"/.ssh
272 for t in ${tests} ; do
273 # Some tests read from stdin ...
274 HOMEDIR="${sshhome}" \
275 emake -k -j1 ${t} </dev/null \
276 && passed="${passed}${t} " \
277 || failed="${failed}${t} "
278 done
279 einfo "Passed tests: ${passed}"
280 ewarn "Skipped tests: ${skipped}"
281 if [[ -n ${failed} ]] ; then
282 ewarn "Failed tests: ${failed}"
283 die "Some tests failed: ${failed}"
284 else
285 einfo "Failed tests: ${failed}"
286 return 0
287 fi
288 }
289
290 pkg_preinst() {
291 enewgroup sshd 22
292 enewuser sshd 22 -1 /var/empty sshd
293 }
294
295 pkg_postinst() {
296 if has_version "<${CATEGORY}/${PN}-5.8_p1" ; then
297 elog "Starting with openssh-5.8p1, the server will default to a newer key"
298 elog "algorithm (ECDSA). You are encouraged to manually update your stored"
299 elog "keys list as servers update theirs. See ssh-keyscan(1) for more info."
300 fi
301 ewarn "Remember to merge your config files in /etc/ssh/ and then"
302 ewarn "reload sshd: '/etc/init.d/sshd reload'."
303 # This instruction is from the HPN webpage,
304 # Used for the server logging functionality
305 if [[ -n ${HPN_PATCH} ]] && use hpn ; then
306 echo
307 einfo "For the HPN server logging patch, you must ensure that"
308 einfo "your syslog application also listens at /var/empty/dev/log."
309 fi
310 }

  ViewVC Help
Powered by ViewVC 1.1.20