/[gentoo-x86]/net-misc/plowshare/plowshare-2.1.1.ebuild
Gentoo

Contents of /net-misc/plowshare/plowshare-2.1.1.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.1 - (show annotations) (download)
Mon May 4 16:16:07 2015 UTC (4 years, 7 months ago) by voyageur
Branch: MAIN
CVS Tags: HEAD
Version bump

(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 00F7AB331B0F097F)

1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/net-misc/plowshare/plowshare-2.1.0-r1.ebuild,v 1.2 2015/04/30 14:47:02 voyageur Exp $
4
5 EAPI=5
6
7 inherit bash-completion-r1
8
9 DESCRIPTION="Command-line downloader and uploader for file-sharing websites"
10 HOMEPAGE="https://github.com/mcrapet/plowshare"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="~amd64 ~arm ~ppc ~x86"
15 IUSE="bash-completion +javascript view-captcha"
16
17 SRC_URI="https://github.com/mcrapet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
18
19 RDEPEND="
20 >=app-shells/bash-4
21 || ( app-text/recode ( dev-lang/perl dev-perl/HTML-Parser ) )
22 dev-vcs/git
23 || ( media-gfx/imagemagick[tiff] media-gfx/graphicsmagick[imagemagick,tiff] )
24 net-misc/curl
25 sys-apps/util-linux
26 javascript? ( || ( dev-lang/spidermonkey:0 dev-java/rhino ) )
27 view-captcha? ( || ( media-gfx/aview media-libs/libcaca ) )"
28 DEPEND=""
29
30 # NOTES:
31 # javascript dep should be any javascript interpreter using /usr/bin/js
32
33 src_prepare() {
34 # Fix doc install path
35 sed -i -e "/^DOCDIR/s|plowshare|${PF}|" Makefile || die "sed failed"
36
37 if ! use bash-completion
38 then
39 sed -i -e \ "/^install:/s/install_bash_completion//" \
40 Makefile || die "sed failed"
41 fi
42 }
43
44 src_compile() {
45 # There is a Makefile but it's not compiling anything, let's not try.
46 :
47 }
48
49 src_test() {
50 # Disable tests because all of them need a working Internet connection.
51 :
52 }
53
54 src_install() {
55 emake DESTDIR="${D}" PREFIX="/usr" \
56 PLOWSHARE_FORCE_VERSION="${PV}" install
57 }
58
59 pkg_postinst() {
60 elog "plowshare is not delivered with modules by default anymore"
61 elog "Per-user modules can be installed/updated with the plowmod command"
62 if ! use javascript; then
63 ewarn "Without javascript you will not be able to use modules"
64 ewarn "requering a Javascript shell (/usr/bin/js)"
65 fi
66 }

  ViewVC Help
Powered by ViewVC 1.1.20