/[gentoo-x86]/net-wireless/orinoco-usb/orinoco-usb-9999.ebuild
Gentoo

Contents of /net-wireless/orinoco-usb/orinoco-usb-9999.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.5 - (show annotations) (download)
Mon Feb 15 20:40:27 2010 UTC (10 years, 4 months ago) by ssuominen
Branch: MAIN
CVS Tags: HEAD
Changes since 1.4: +3 -2 lines
Missing IUSE.
(Portage version: 2.2_rc62/cvs/Linux x86_64)

1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/net-wireless/orinoco-usb/orinoco-usb-9999.ebuild,v 1.4 2007/08/29 19:07:45 genstef Exp $
4
5 inherit linux-mod subversion
6
7 ESVN_REPO_URI="http://orinoco.svn.sourceforge.net/svnroot/orinoco/branches/usb"
8
9 DESCRIPTION="ORiNOCO IEEE 802.11 wireless LAN driver"
10 HOMEPAGE="http://www.nongnu.org/orinoco/"
11 SRC_URI=""
12
13 LICENSE="GPL-2 MPL-1.1"
14 SLOT="0"
15 KEYWORDS=""
16 IUSE=""
17
18 RDEPEND="!net-wireless/orinoco-sn
19 net-wireless/wireless-tools
20 net-wireless/orinoco-fwutils"
21
22 BUILD_TARGETS="all"
23
24 CONFIG_CHECK="FW_LOADER WIRELESS_EXT USB"
25 ERROR_FW_LOADER="${P} requires support for loading firmware (CONFIG_FWLOADER)."
26 ERROR_WIRELESS_EXT="${P} requires support for Wireless LAN drivers (non-hamradio) & Wireless Extensions (CONFIG_WIRELESS_EXT)."
27 ERROR_USB="${P} requires USB support (CONFIG_USB)."
28
29 pkg_setup() {
30 linux-mod_pkg_setup
31
32 if kernel_is lt 2 6 21; then
33 eerror "${P} requires kernel 2.6.21 or above."
34 die "Kernel version too old."
35 fi
36
37 MOD_PATH="/net/wireless"
38 MODULE_NAMES="orinoco(${MOD_PATH}:) orinoco_usb(${MOD_PATH}:)"
39 BUILD_PARAMS="KERNEL_PATH=${KV_OUT_DIR}"
40 }
41
42 # Don't have modified install in order to provide docs, since docs are too old

  ViewVC Help
Powered by ViewVC 1.1.20