/[gentoo-x86]/net-wireless/wpa_supplicant/wpa_supplicant-0.7.3-r5.ebuild
Gentoo

Contents of /net-wireless/wpa_supplicant/wpa_supplicant-0.7.3-r5.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.9 - (hide annotations) (download)
Fri Oct 28 05:31:07 2011 UTC (8 years, 9 months ago) by mgorny
Branch: MAIN
Changes since 1.8: +5 -4 lines
Fix systemd patching to work w/ USE=wimax.

(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)

1 gurligebis 1.1 # Copyright 1999-2011 Gentoo Foundation
2     # Distributed under the terms of the GNU General Public License v2
3 mgorny 1.9 # $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.7.3-r5.ebuild,v 1.8 2011/10/27 19:24:26 gurligebis Exp $
4 gurligebis 1.1
5 scarabeus 1.6 EAPI=4
6 gurligebis 1.1
7     inherit eutils toolchain-funcs qt4-r2 systemd multilib
8    
9     DESCRIPTION="IEEE 802.1X/WPA supplicant for secure wireless transfers"
10     HOMEPAGE="http://hostap.epitest.fi/wpa_supplicant/"
11     SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz"
12     LICENSE="|| ( GPL-2 BSD )"
13    
14     SLOT="0"
15 gurligebis 1.2 KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
16 gurligebis 1.1 IUSE="dbus debug gnutls eap-sim fasteap madwifi ps3 qt4 readline ssl wimax wps kernel_linux kernel_FreeBSD"
17    
18     RDEPEND="dbus? ( sys-apps/dbus )
19     kernel_linux? (
20     eap-sim? ( sys-apps/pcsc-lite )
21 scarabeus 1.6 madwifi? (
22     || (
23     >net-wireless/madwifi-ng-tools-0.9.3
24     net-wireless/madwifi-old
25     )
26 gurligebis 1.1 )
27 gurligebis 1.8 dev-libs/libnl:1.1
28 gurligebis 1.1 )
29     !kernel_linux? ( net-libs/libpcap )
30 scarabeus 1.6 qt4? (
31     x11-libs/qt-gui:4
32     x11-libs/qt-svg:4
33     )
34     readline? (
35     sys-libs/ncurses
36     sys-libs/readline
37     )
38 gurligebis 1.1 ssl? ( dev-libs/openssl )
39     !ssl? ( gnutls? ( net-libs/gnutls ) )
40     !ssl? ( !gnutls? ( dev-libs/libtommath ) )"
41     DEPEND="${RDEPEND}
42     dev-util/pkgconfig"
43    
44     S="${WORKDIR}/${P}/${PN}"
45    
46     pkg_setup() {
47     if use fasteap && (use gnutls || use ssl) ; then
48     die "If you use fasteap, you must build with wpa_supplicant's internal TLS implementation. That is, both 'gnutls' and 'ssl' USE flags must be disabled"
49     fi
50    
51     if use gnutls && use ssl ; then
52     einfo "You have both 'gnutls' and 'ssl' USE flags enabled: defaulting to USE=\"ssl\""
53     fi
54     }
55    
56     src_prepare() {
57     # net/bpf.h needed for net-libs/libpcap on Gentoo/FreeBSD
58     sed -i \
59     -e "s:\(#include <pcap\.h>\):#include <net/bpf.h>\n\1:" \
60     ../src/l2_packet/l2_packet_freebsd.c || die
61    
62     # People seem to take the example configuration file too literally (bug #102361)
63     sed -i \
64     -e "s:^\(opensc_engine_path\):#\1:" \
65     -e "s:^\(pkcs11_engine_path\):#\1:" \
66     -e "s:^\(pkcs11_module_path\):#\1:" \
67     wpa_supplicant.conf || die
68    
69     # Change configuration to match Gentoo locations (bug #143750)
70     sed -i \
71     -e "s:/usr/lib/opensc:/usr/$(get_libdir):" \
72     -e "s:/usr/lib/pkcs11:/usr/$(get_libdir):" \
73     wpa_supplicant.conf || die
74    
75     epatch "${FILESDIR}/${P}-dbus_path_fix.patch"
76    
77 mgorny 1.9 # systemd entries to D-Bus service files (bug #372877)
78     echo 'SystemdService=wpa_supplicant.service' \
79     | tee -a dbus/*.service >/dev/null || die
80    
81 gurligebis 1.1 if use wimax; then
82     cd "${WORKDIR}/${P}"
83     epatch "${FILESDIR}/${P}-generate-libeap-peer.patch"
84    
85     # multilib-strict fix (bug #373685)
86     sed -e "s/\/usr\/lib/\/usr\/$(get_libdir)/" -i src/eap_peer/Makefile
87     fi
88    
89     # bug (320097)
90     epatch "${FILESDIR}/do-not-call-dbus-functions-with-NULL-path.patch"
91     # https://bugzilla.gnome.org/show_bug.cgi?id=644634
92     epatch "${FILESDIR}/${P}-dbus-api-changes.patch"
93     # bug (374089)
94     epatch "${FILESDIR}/${P}-dbus-WPAIE-fix.patch"
95     }
96    
97     src_configure() {
98     # Toolchain setup
99 gurligebis 1.3 tc-export CC
100 gurligebis 1.1
101     # Basic setup
102     echo "CONFIG_CTRL_IFACE=y" >> .config
103     echo "CONFIG_BACKEND=file" >> .config
104    
105     # Basic authentication methods
106     # NOTE: we don't set GPSK or SAKE as they conflict
107     # with the below options
108     echo "CONFIG_EAP_GTC=y" >> .config
109     echo "CONFIG_EAP_MD5=y" >> .config
110     echo "CONFIG_EAP_OTP=y" >> .config
111     echo "CONFIG_EAP_PAX=y" >> .config
112     echo "CONFIG_EAP_PSK=y" >> .config
113     echo "CONFIG_EAP_TLV=y" >> .config
114     echo "CONFIG_IEEE8021X_EAPOL=y" >> .config
115     echo "CONFIG_PKCS12=y" >> .config
116     echo "CONFIG_PEERKEY=y" >> .config
117     echo "CONFIG_EAP_LEAP=y" >> .config
118     echo "CONFIG_EAP_MSCHAPV2=y" >> .config
119     echo "CONFIG_EAP_PEAP=y" >> .config
120     echo "CONFIG_EAP_TLS=y" >> .config
121     echo "CONFIG_EAP_TTLS=y" >> .config
122    
123     if use dbus ; then
124     echo "CONFIG_CTRL_IFACE_DBUS=y" >> .config
125     echo "CONFIG_CTRL_IFACE_DBUS_NEW=y" >> .config
126     echo "CONFIG_CTRL_IFACE_DBUS_INTRO=y" >> .config
127     fi
128    
129     if use debug ; then
130     echo "CONFIG_DEBUG_FILE=y" >> .config
131     fi
132    
133     if use eap-sim ; then
134     # Smart card authentication
135     echo "CONFIG_EAP_SIM=y" >> .config
136     echo "CONFIG_EAP_AKA=y" >> .config
137     echo "CONFIG_EAP_AKA_PRIME=y" >> .config
138     echo "CONFIG_PCSC=y" >> .config
139     fi
140    
141     if use fasteap ; then
142     echo "CONFIG_EAP_FAST=y" >> .config
143     fi
144    
145     if use readline ; then
146     # readline/history support for wpa_cli
147     echo "CONFIG_READLINE=y" >> .config
148     fi
149    
150     # SSL authentication methods
151     if use ssl ; then
152     echo "CONFIG_TLS=openssl" >> .config
153     echo "CONFIG_SMARTCARD=y" >> .config
154     elif use gnutls ; then
155     echo "CONFIG_TLS=gnutls" >> .config
156     echo "CONFIG_GNUTLS_EXTRA=y" >> .config
157     else
158     echo "CONFIG_TLS=internal" >> .config
159     fi
160    
161     if use kernel_linux ; then
162     # Linux specific drivers
163     echo "CONFIG_DRIVER_ATMEL=y" >> .config
164     #echo "CONFIG_DRIVER_BROADCOM=y" >> .config
165     #echo "CONFIG_DRIVER_HERMES=y" >> .config
166     echo "CONFIG_DRIVER_HOSTAP=y" >> .config
167     echo "CONFIG_DRIVER_IPW=y" >> .config
168     echo "CONFIG_DRIVER_NDISWRAPPER=y" >> .config
169     echo "CONFIG_DRIVER_NL80211=y" >> .config
170     #echo "CONFIG_DRIVER_PRISM54=y" >> .config
171     echo "CONFIG_DRIVER_RALINK=y" >> .config
172     echo "CONFIG_DRIVER_WEXT=y" >> .config
173     echo "CONFIG_DRIVER_WIRED=y" >> .config
174    
175     if use madwifi ; then
176     # Add include path for madwifi-driver headers
177     echo "CFLAGS += -I/usr/include/madwifi" >> .config
178     echo "CONFIG_DRIVER_MADWIFI=y" >> .config
179     fi
180    
181     if use ps3 ; then
182     echo "CONFIG_DRIVER_PS3=y" >> .config
183     fi
184    
185     elif use kernel_FreeBSD ; then
186     # FreeBSD specific driver
187     echo "CONFIG_DRIVER_BSD=y" >> .config
188     fi
189    
190     # Wi-Fi Protected Setup (WPS)
191     if use wps ; then
192     echo "CONFIG_WPS=y" >> .config
193     fi
194    
195     # Enable mitigation against certain attacks against TKIP
196     echo "CONFIG_DELAYED_MIC_ERROR_REPORT=y" >> .config
197    
198 gurligebis 1.5 # If we are using libnl 2.0 and above, enable support for it
199     # Bug 382159
200 gurligebis 1.8 # Removed for now, since the 3.2 version is broken, and we don't
201     # support it.
202     #if has_version ">=dev-libs/libnl-2.0"; then
203     # echo "CONFIG_LIBNL20=y" >> .config
204     #fi
205 scarabeus 1.6
206     if use qt4 ; then
207     pushd "${S}"/wpa_gui-qt4 > /dev/null
208     eqmake4 wpa_gui.pro
209     popd > /dev/null
210     fi
211 gurligebis 1.1 }
212    
213     src_compile() {
214     einfo "Building wpa_supplicant"
215 scarabeus 1.6 emake
216 gurligebis 1.1
217     if use wimax; then
218 scarabeus 1.6 emake -C ../src/eap_peer clean
219     emake -C ../src/eap_peer
220 gurligebis 1.1 fi
221    
222     if use qt4 ; then
223 scarabeus 1.6 pushd "${S}"/wpa_gui-qt4 > /dev/null
224 gurligebis 1.1 einfo "Building wpa_gui"
225 scarabeus 1.6 emake
226     popd > /dev/null
227 gurligebis 1.1 fi
228     }
229    
230     src_install() {
231 scarabeus 1.6 dosbin wpa_supplicant
232     dobin wpa_cli wpa_passphrase
233 gurligebis 1.1
234     # baselayout-1 compat
235     if has_version "<sys-apps/baselayout-2.0.0"; then
236     dodir /sbin
237 scarabeus 1.6 dosym /usr/sbin/wpa_supplicant /sbin/wpa_supplicant
238 gurligebis 1.1 dodir /bin
239 scarabeus 1.6 dosym /usr/bin/wpa_cli /bin/wpa_cli
240 gurligebis 1.1 fi
241    
242     if has_version ">=sys-apps/openrc-0.5.0"; then
243     newinitd "${FILESDIR}/${PN}-init.d" wpa_supplicant
244     newconfd "${FILESDIR}/${PN}-conf.d" wpa_supplicant
245     fi
246    
247     exeinto /etc/wpa_supplicant/
248     newexe "${FILESDIR}/wpa_cli.sh" wpa_cli.sh
249    
250     dodoc ChangeLog {eap_testing,todo}.txt README{,-WPS} \
251 scarabeus 1.6 wpa_supplicant.conf
252 gurligebis 1.1
253 scarabeus 1.6 doman doc/docbook/*.{5,8}
254 gurligebis 1.1
255     if use qt4 ; then
256     into /usr
257 scarabeus 1.6 dobin wpa_gui-qt4/wpa_gui
258     doicon wpa_gui-qt4/icons/wpa_gui.svg
259 gurligebis 1.1 make_desktop_entry wpa_gui "WPA Supplicant Administration GUI" "wpa_gui" "Qt;Network;"
260     fi
261    
262 scarabeus 1.6 use wimax && emake DESTDIR="${D}" -C ../src/eap_peer install
263 gurligebis 1.1
264     if use dbus ; then
265 scarabeus 1.6 pushd "${S}"/dbus > /dev/null
266 gurligebis 1.1 insinto /etc/dbus-1/system.d
267 scarabeus 1.6 newins dbus-wpa_supplicant.conf wpa_supplicant.conf
268 gurligebis 1.1 insinto /usr/share/dbus-1/system-services
269 scarabeus 1.6 doins fi.epitest.hostap.WPASupplicant.service fi.w1.wpa_supplicant1.service
270 gurligebis 1.1 keepdir /var/run/wpa_supplicant
271 scarabeus 1.6 popd > /dev/null
272 gurligebis 1.1 fi
273    
274 mgorny 1.4 # systemd stuff
275 gurligebis 1.1 systemd_dounit "${FILESDIR}"/wpa_supplicant.service
276 scarabeus 1.6 systemd_newunit "${FILESDIR}"/wpa_supplicant_at.service 'wpa_supplicant@.service'
277 gurligebis 1.1 }
278    
279     pkg_postinst() {
280     einfo "If this is a clean installation of wpa_supplicant, you"
281     einfo "have to create a configuration file named"
282     einfo "/etc/wpa_supplicant/wpa_supplicant.conf"
283     einfo
284     einfo "An example configuration file is available for reference in"
285     einfo "/usr/share/doc/${PF}/"
286    
287     if [[ -e ${ROOT}etc/wpa_supplicant.conf ]] ; then
288     echo
289     ewarn "WARNING: your old configuration file ${ROOT}etc/wpa_supplicant.conf"
290     ewarn "needs to be moved to ${ROOT}etc/wpa_supplicant/wpa_supplicant.conf"
291     fi
292    
293     if use madwifi ; then
294     echo
295     einfo "This package compiles against the headers installed by"
296     einfo "madwifi-old, madwifi-ng or madwifi-ng-tools."
297     einfo "You should re-emerge ${PN} after upgrading these packages."
298     fi
299 mgorny 1.4
300     # Mea culpa, feel free to remove that after some time --mgorny.
301     local fn
302     for fn in wpa_supplicant{,@wlan0}.service; do
303     if [[ -e "${ROOT}"/etc/systemd/system/network.target.wants/${fn} ]]
304     then
305     ebegin "Moving ${fn} to multi-user.target"
306     mv "${ROOT}"/etc/systemd/system/network.target.wants/${fn} \
307     "${ROOT}"/etc/systemd/system/multi-user.target.wants/
308     eend ${?} \
309     "Please try to re-enable ${fn}"
310     fi
311     done
312 gurligebis 1.1 }

  ViewVC Help
Powered by ViewVC 1.1.20