/[gentoo-x86]/net-wireless/wpa_supplicant/wpa_supplicant-2.1.ebuild
Gentoo

Contents of /net-wireless/wpa_supplicant/wpa_supplicant-2.1.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.3 - (hide annotations) (download)
Tue Feb 25 07:53:52 2014 UTC (6 years, 5 months ago) by gurligebis
Branch: MAIN
CVS Tags: HEAD
Changes since 1.2: +1 -1 lines
FILE REMOVED
Adding patch to fix bug #501828

(Portage version: 2.2.8-r1/cvs/Linux i686, signed Manifest commit with key 15AE484C)

1 gurligebis 1.1 # Copyright 1999-2014 Gentoo Foundation
2     # Distributed under the terms of the GNU General Public License v2
3 gurligebis 1.3 # $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-2.1.ebuild,v 1.2 2014/02/14 08:20:31 gurligebis Exp $
4 gurligebis 1.1
5     EAPI=4
6    
7     inherit eutils toolchain-funcs qt4-r2 systemd multilib
8    
9     DESCRIPTION="IEEE 802.1X/WPA supplicant for secure wireless transfers"
10     HOMEPAGE="http://hostap.epitest.fi/wpa_supplicant/"
11     SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz"
12     LICENSE="|| ( GPL-2 BSD )"
13    
14     SLOT="0"
15     KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
16     IUSE="ap dbus gnutls eap-sim fasteap p2p ps3 qt4 readline selinux smartcard ssl wimax wps kernel_linux kernel_FreeBSD"
17     REQUIRED_USE="fasteap? ( !gnutls !ssl ) smartcard? ( ssl )"
18    
19     RDEPEND="dbus? ( sys-apps/dbus )
20     kernel_linux? (
21     eap-sim? ( sys-apps/pcsc-lite )
22     dev-libs/libnl:3
23     net-wireless/crda
24     )
25     !kernel_linux? ( net-libs/libpcap )
26     qt4? (
27     dev-qt/qtgui:4
28     dev-qt/qtsvg:4
29     )
30     readline? (
31     sys-libs/ncurses
32     sys-libs/readline
33     )
34     ssl? ( dev-libs/openssl )
35     !ssl? ( gnutls? ( net-libs/gnutls ) )
36     !ssl? ( !gnutls? ( dev-libs/libtommath ) )
37     selinux? ( sec-policy/selinux-networkmanager )"
38     DEPEND="${RDEPEND}
39     virtual/pkgconfig"
40    
41     S="${WORKDIR}/${P}/${PN}"
42    
43     pkg_setup() {
44     if use gnutls && use ssl ; then
45     elog "You have both 'gnutls' and 'ssl' USE flags enabled: defaulting to USE=\"ssl\""
46     fi
47     }
48    
49     src_prepare() {
50     # net/bpf.h needed for net-libs/libpcap on Gentoo/FreeBSD
51     sed -i \
52     -e "s:\(#include <pcap\.h>\):#include <net/bpf.h>\n\1:" \
53     ../src/l2_packet/l2_packet_freebsd.c || die
54    
55     # People seem to take the example configuration file too literally (bug #102361)
56     sed -i \
57     -e "s:^\(opensc_engine_path\):#\1:" \
58     -e "s:^\(pkcs11_engine_path\):#\1:" \
59     -e "s:^\(pkcs11_module_path\):#\1:" \
60     wpa_supplicant.conf || die
61    
62     # Change configuration to match Gentoo locations (bug #143750)
63     sed -i \
64     -e "s:/usr/lib/opensc:/usr/$(get_libdir):" \
65     -e "s:/usr/lib/pkcs11:/usr/$(get_libdir):" \
66     wpa_supplicant.conf || die
67    
68     if use dbus; then
69     epatch "${FILESDIR}/${P}-dbus-path-fix.patch"
70     fi
71    
72     # systemd entries to D-Bus service files (bug #372877)
73     echo 'SystemdService=wpa_supplicant.service' \
74     | tee -a dbus/*.service >/dev/null || die
75    
76     cd "${WORKDIR}/${P}"
77    
78     if use wimax; then
79     # generate-libeap-peer.patch comes before
80     # fix-undefined-reference-to-random_get_bytes.patch
81     epatch "${FILESDIR}/${P}-generate-libeap-peer.patch"
82     epatch "${FILESDIR}/${P}-fix-undefined-reference-to-random_get_bytes.patch"
83    
84     # multilib-strict fix (bug #373685)
85     sed -e "s/\/usr\/lib/\/usr\/$(get_libdir)/" -i src/eap_peer/Makefile
86     fi
87    
88 gurligebis 1.2 if use wps; then
89     # In version 2.1, there is a bug, what causes compile to fail.
90     epatch "${FILESDIR}/${P}-NFC-fix.patch"
91     fi
92    
93 gurligebis 1.1 # bug (320097)
94     epatch "${FILESDIR}/${P}-do-not-call-dbus-functions-with-NULL-path.patch"
95    
96     # TODO - NEED TESTING TO SEE IF STILL NEEDED, NOT COMPATIBLE WITH 1.0 OUT OF THE BOX,
97     # SO WOULD BE NICE TO JUST DROP IT, IF IT IS NOT NEEDED.
98     # bug (374089)
99     #epatch "${FILESDIR}/${P}-dbus-WPAIE-fix.patch"
100     }
101    
102     src_configure() {
103     # Toolchain setup
104     tc-export CC
105    
106     # Basic setup
107     echo "CONFIG_CTRL_IFACE=y" >> .config
108     echo "CONFIG_BACKEND=file" >> .config
109    
110     # Basic authentication methods
111     # NOTE: we don't set GPSK or SAKE as they conflict
112     # with the below options
113     echo "CONFIG_EAP_GTC=y" >> .config
114     echo "CONFIG_EAP_MD5=y" >> .config
115     echo "CONFIG_EAP_OTP=y" >> .config
116     echo "CONFIG_EAP_PAX=y" >> .config
117     echo "CONFIG_EAP_PSK=y" >> .config
118     echo "CONFIG_EAP_TLV=y" >> .config
119     echo "CONFIG_EAP_EXE=y" >> .config
120     echo "CONFIG_IEEE8021X_EAPOL=y" >> .config
121     echo "CONFIG_PKCS12=y" >> .config
122     echo "CONFIG_PEERKEY=y" >> .config
123     echo "CONFIG_EAP_LEAP=y" >> .config
124     echo "CONFIG_EAP_MSCHAPV2=y" >> .config
125     echo "CONFIG_EAP_PEAP=y" >> .config
126     echo "CONFIG_EAP_TLS=y" >> .config
127     echo "CONFIG_EAP_TTLS=y" >> .config
128    
129     # Enabling background scanning.
130     echo "CONFIG_BGSCAN_SIMPLE=y" >> .config
131     echo "CONFIG_BGSCAN_LEARN=y" >> .config
132    
133     if use dbus ; then
134     echo "CONFIG_CTRL_IFACE_DBUS=y" >> .config
135     echo "CONFIG_CTRL_IFACE_DBUS_NEW=y" >> .config
136     echo "CONFIG_CTRL_IFACE_DBUS_INTRO=y" >> .config
137     fi
138    
139     # Enable support for writing debug info to a log file.
140     echo "CONFIG_DEBUG_FILE=y" >> .config
141    
142     if use eap-sim ; then
143     # Smart card authentication
144     echo "CONFIG_EAP_SIM=y" >> .config
145     echo "CONFIG_EAP_AKA=y" >> .config
146     echo "CONFIG_EAP_AKA_PRIME=y" >> .config
147     echo "CONFIG_PCSC=y" >> .config
148     fi
149    
150     if use fasteap ; then
151     echo "CONFIG_EAP_FAST=y" >> .config
152     fi
153    
154     if use readline ; then
155     # readline/history support for wpa_cli
156     echo "CONFIG_READLINE=y" >> .config
157     fi
158    
159     # SSL authentication methods
160     if use ssl ; then
161     echo "CONFIG_TLS=openssl" >> .config
162     elif use gnutls ; then
163     echo "CONFIG_TLS=gnutls" >> .config
164     echo "CONFIG_GNUTLS_EXTRA=y" >> .config
165     else
166     echo "CONFIG_TLS=internal" >> .config
167     fi
168    
169     if use smartcard ; then
170     echo "CONFIG_SMARTCARD=y" >> .config
171     fi
172    
173     if use kernel_linux ; then
174     # Linux specific drivers
175     echo "CONFIG_DRIVER_ATMEL=y" >> .config
176     echo "CONFIG_DRIVER_HOSTAP=y" >> .config
177     echo "CONFIG_DRIVER_IPW=y" >> .config
178     echo "CONFIG_DRIVER_NL80211=y" >> .config
179     echo "CONFIG_DRIVER_RALINK=y" >> .config
180     echo "CONFIG_DRIVER_WEXT=y" >> .config
181     echo "CONFIG_DRIVER_WIRED=y" >> .config
182    
183     if use ps3 ; then
184     echo "CONFIG_DRIVER_PS3=y" >> .config
185     fi
186    
187     elif use kernel_FreeBSD ; then
188     # FreeBSD specific driver
189     echo "CONFIG_DRIVER_BSD=y" >> .config
190     fi
191    
192     # Wi-Fi Protected Setup (WPS)
193     if use wps ; then
194     echo "CONFIG_WPS=y" >> .config
195     echo "CONFIG_WPS2=y" >> .config
196     # USB Flash Drive
197     echo "CONFIG_WPS_UFD=y" >> .config
198     # External Registrar
199     echo "CONFIG_WPS_ER=y" >> .config
200     # Universal Plug'n'Play
201     echo "CONFIG_WPS_UPNP=y" >> .config
202     # Near Field Communication
203     echo "CONFIG_WPS_NFC=y" >> .config
204     fi
205    
206     # Wi-Fi Direct (WiDi)
207     if use p2p ; then
208     echo "CONFIG_P2P=y" >> .config
209     fi
210    
211     # Access Point Mode
212     if use ap ; then
213     echo "CONFIG_AP=y" >> .config
214     fi
215    
216     # Enable mitigation against certain attacks against TKIP
217     echo "CONFIG_DELAYED_MIC_ERROR_REPORT=y" >> .config
218    
219     # If we are using libnl 2.0 and above, enable support for it
220     # Bug 382159
221     # Removed for now, since the 3.2 version is broken, and we don't
222     # support it.
223     if has_version ">=dev-libs/libnl-3.2"; then
224     echo "CONFIG_LIBNL32=y" >> .config
225     fi
226    
227     if use qt4 ; then
228     pushd "${S}"/wpa_gui-qt4 > /dev/null
229     eqmake4 wpa_gui.pro
230     popd > /dev/null
231     fi
232     }
233    
234     src_compile() {
235     einfo "Building wpa_supplicant"
236     emake V=1
237    
238     if use wimax; then
239     emake -C ../src/eap_peer clean
240     emake -C ../src/eap_peer
241     fi
242    
243     if use qt4 ; then
244     pushd "${S}"/wpa_gui-qt4 > /dev/null
245     einfo "Building wpa_gui"
246     emake
247     popd > /dev/null
248     fi
249     }
250    
251     src_install() {
252     dosbin wpa_supplicant
253     dobin wpa_cli wpa_passphrase
254    
255     # baselayout-1 compat
256     if has_version "<sys-apps/baselayout-2.0.0"; then
257     dodir /sbin
258     dosym /usr/sbin/wpa_supplicant /sbin/wpa_supplicant
259     dodir /bin
260     dosym /usr/bin/wpa_cli /bin/wpa_cli
261     fi
262    
263     if has_version ">=sys-apps/openrc-0.5.0"; then
264     newinitd "${FILESDIR}/${PN}-init.d" wpa_supplicant
265     newconfd "${FILESDIR}/${PN}-conf.d" wpa_supplicant
266     fi
267    
268     exeinto /etc/wpa_supplicant/
269     newexe "${FILESDIR}/wpa_cli.sh" wpa_cli.sh
270    
271     dodoc ChangeLog {eap_testing,todo}.txt README{,-WPS} \
272     wpa_supplicant.conf
273    
274     doman doc/docbook/*.{5,8}
275    
276     if use qt4 ; then
277     into /usr
278     dobin wpa_gui-qt4/wpa_gui
279     doicon wpa_gui-qt4/icons/wpa_gui.svg
280     make_desktop_entry wpa_gui "WPA Supplicant Administration GUI" "wpa_gui" "Qt;Network;"
281     fi
282    
283     use wimax && emake DESTDIR="${D}" -C ../src/eap_peer install
284    
285     if use dbus ; then
286     pushd "${S}"/dbus > /dev/null
287     insinto /etc/dbus-1/system.d
288     newins dbus-wpa_supplicant.conf wpa_supplicant.conf
289     insinto /usr/share/dbus-1/system-services
290     doins fi.epitest.hostap.WPASupplicant.service fi.w1.wpa_supplicant1.service
291     keepdir /var/run/wpa_supplicant
292     popd > /dev/null
293     fi
294    
295     # systemd stuff
296     systemd_dounit "${FILESDIR}"/wpa_supplicant.service
297     systemd_newunit "${FILESDIR}"/wpa_supplicant_at.service 'wpa_supplicant@.service'
298     }
299    
300     pkg_postinst() {
301     elog "If this is a clean installation of wpa_supplicant, you"
302     elog "have to create a configuration file named"
303     elog "/etc/wpa_supplicant/wpa_supplicant.conf"
304     elog
305     elog "An example configuration file is available for reference in"
306     elog "/usr/share/doc/${PF}/"
307    
308     if [[ -e ${ROOT}etc/wpa_supplicant.conf ]] ; then
309     echo
310     ewarn "WARNING: your old configuration file ${ROOT}etc/wpa_supplicant.conf"
311     ewarn "needs to be moved to ${ROOT}etc/wpa_supplicant/wpa_supplicant.conf"
312     fi
313    
314     # Mea culpa, feel free to remove that after some time --mgorny.
315     local fn
316     for fn in wpa_supplicant{,@wlan0}.service; do
317     if [[ -e "${ROOT}"/etc/systemd/system/network.target.wants/${fn} ]]
318     then
319     ebegin "Moving ${fn} to multi-user.target"
320     mv "${ROOT}"/etc/systemd/system/network.target.wants/${fn} \
321     "${ROOT}"/etc/systemd/system/multi-user.target.wants/
322     eend ${?} \
323     "Please try to re-enable ${fn}"
324     fi
325     done
326     }

  ViewVC Help
Powered by ViewVC 1.1.20