/[gentoo-x86]/profiles/package.mask
Gentoo

Contents of /profiles/package.mask

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.16517 - (show annotations) (download)
Sun May 3 23:22:10 2015 UTC (15 hours, 6 minutes ago) by zlogene
Branch: MAIN
CVS Tags: HEAD
Changes since 1.16516: +1 -20 lines
Drop obsolete perl masks

1 ####################################################################
2 # $Header: /var/cvsroot/gentoo-x86/profiles/package.mask,v 1.16516 2015/05/03 08:08:23 graaff Exp $
3 #
4 # When you add an entry to the top of this file, add your name, the date, and
5 # an explanation of why something is getting masked. Please be extremely
6 # careful not to commit atoms that are not valid, as it can cause large-scale
7 # breakage, especially if it ends up in the daily snapshot.
8 #
9 ## Example:
10 ##
11 ## # Dev E. Loper <developer@gentoo.org> (28 Jun 2012)
12 ## # Masking these versions until we can get the
13 ## # v4l stuff to work properly again
14 ## =media-video/mplayer-0.90_pre5
15 ## =media-video/mplayer-0.90_pre5-r1
16 #
17 # - Best last rites (removal) practices -
18 # Include the following info:
19 # a) reason for masking
20 # b) bug # for the removal (and yes you should have one)
21 # c) date of removal (either the date or "in x days")
22 #
23 ## Example:
24 ##
25 ## # Dev E. Loper <developer@gentoo.org> (25 Jul 2014)
26 ## # Masked for removal in 30 days. Doesn't work
27 ## # with new libfoo. Upstream dead, gtk-1, smells
28 ## # funny. (bug #987654)
29 ## app-misc/some-package
30
31 #--- END OF EXAMPLES ---
32
33 # Hans de Graaff <graaff@gentoo.org> (3 May 2015)
34 # dev-ruby/fssm is deprecated by its author and nothing
35 # in the tree depends on it anymore. Use dev-ruby/listen
36 # as an alternative. Masked for removal in 30 days.
37 dev-ruby/fssm
38
39 # Brian Evans <grknight@gentoo.org> (30 Apr 2015)
40 # It is unclear if dev-php/smarty-2* is affected by
41 # security bug 526542. Masked for removal in 30 days
42 # Please update your code to the latest version
43 <dev-php/smarty-2.6.29
44 =dev-php/PEAR-PhpDocumentor-1.4.4
45
46 # Ryan Hill <rhill@gentoo.org> (28 Apr 2015)
47 # Moving to /lib/gentoo/functions.sh broke the eclass
48 # by changing output it relies on. See bug #504118,
49 # 547586, and 547962.
50 >=sys-devel/gcc-config-1.8-r1
51
52 # Ulrich Müller <ulm@gentoo.org> (28 Apr 2015)
53 # Superseded by the newer "breqn" and "mathtools"
54 # modules in dev-texlive/texlive-latexrecommended.
55 # mh is no longer maintained upstream. Bug 524114.
56 # Masked for removal in 30 days.
57 dev-tex/mh
58
59 # Sebastian Pipping <sping@gentoo.org> (28 Apr 2015)
60 # Get rid of vulnerable releases.
61 # Masked for removal in 30 days.
62 <www-apps/wordpress-4.2.1
63
64 # Hans de Graaff <graaff@gentoo.org> (27 Apr 2015)
65 # This version of rubinius is old and only very few
66 # packages ever got the associated "rbx" RUBY_TARGET.
67 # If you would like to keep rubinius in Gentoo, please
68 # help us to get the currently masked rubinius 2.x
69 # versions ready. Masked for removal in 30 days.
70 =dev-lang/rubinius-1*
71
72 # Hans de Graaff <graaff@gentoo.org> (27 Apr 2015)
73 # rubyforge.org has not been available for almost a year, making the
74 # rubyforge package obsolete. echoe is a leaf package that still
75 # depends on it. Masked for removal in 30 days.
76 dev-ruby/echoe
77 dev-ruby/rubyforge
78
79 # Hans de Graaff <graaff@gentoo.org> (26 Apr 2015)
80 # Ruby packages that only work with ruby19. Masked for removal in 30
81 # days.
82 #
83 # Only compatible with ruby19.
84 app-misc/booh
85 # Only compatible with ruby19. New versions bring in many new
86 # dependencies and this would require a dedicated maintainer.
87 dev-ruby/adhearsion
88 dev-ruby/adhearsion-loquacious
89 # Newer versions depend on beta versions of unreleased and
90 # unmaintained software. No upstream release in two years.
91 dev-ruby/em-http-request
92 # Old slot, nothing in the tree depends on it.
93 dev-ruby/haml:0
94 # Only compatible with ruby19.
95 dev-ruby/ipaddress
96
97 # Sergey Popov <pinkbyte@gentoo.org> (24 Apr 2015)
98 # Dead upstream, nothing in tree uses it
99 # Masked for removal in 30 days
100 net-libs/libcapsinetwork
101
102 # Michael Sterrett <mr_bones_@gentoo.org> (21 Apr 2015)
103 # Upstream has discontinued the project; doesn't build on modern systems.
104 # Bug #510262
105 # masked for removal on 20150521
106 games-util/searchtool
107
108 # Michael Sterrett <mr_bones_@gentoo.org> (21 Apr 2015)
109 # Upstream is dead; doesn't build on modern systems.
110 # masked for removal on 20150521
111 games-strategy/freecnc
112
113 # Hans de Graaff <graaff@gentoo.org> (19 Apr 2015)
114 # Pure-ruby implementation of dev-ruby/json for uses where a compiled
115 # version is not possible. This implementation is not needed on Gentoo
116 # and slower than the compiled version, so all packages should depend
117 # on dev-ruby/json instead. Nothing depends on this package.
118 # Removal in 30 days.
119 dev-ruby/json_pure
120
121 # James Le Cuirot <chewi@gentoo.org> (18 Apr 2015)
122 # Old, unmaintained, not used by anything, and superseded by
123 # plexus-classworlds. There is a newer version in java-overlay that
124 # can't go yet but will go eventually. Removal in 30 days.
125 dev-java/classworlds
126
127 # Pawel Hajdan, Jr. <phajdan.jr@gentoo.org> (17 Apr 2015)
128 # Dev channel releases are only for people who are developers or want more
129 # experimental features and accept a more unstable release.
130 >=www-client/chromium-44
131
132 # James Le Cuirot <chewi@gentoo.org> (14 Apr 2015)
133 # Not updated beyond Java 6, no longer supported upstream, full of
134 # holes, and probably doesn't work. This is the last VM currently
135 # available to FreeBSD until we try icedtea but BSD team are cool with
136 # this. Removal in 30 days.
137 dev-java/diablo-jdk
138 dev-java/diablo-jre-bin
139
140 # Patrice Clement <monsieurp@gentoo.org> (14 Apr 2014)
141 # Upstream seems to be dead. No updates since 12 March 2007.
142 # Masked for removal in 30 days. See bug 546506.
143 dev-java/openjms
144
145 # Andreas K. Huettel <dilfridge@gentoo.org> (11 Apr 2015)
146 # media-libs/lcms:0 has serious security issues, is unmaintained
147 # and will be removed soon, see bug 526642
148 # Here we remove its last unconditional/unported reverse dependencies,
149 # media-libs/sk1libs media-gfx/uniconvw sci-libs/libecwj2
150 # (removal in 30 days).
151 media-gfx/uniconvw
152 media-libs/sk1libs
153 sci-libs/libecwj2
154
155 # Patrick Lauer <patrick@gentoo.org> (10 Apr 2015)
156 # Breaks pretty much all consumers, like samba
157 # Mask until it's more usable
158 >=net-libs/gnutls-3.4.0
159
160 # Michael Sterrett <mr_bones_@gentoo.org> (08 Apr 2015)
161 # Upstream went away; GPL but no source.
162 # masked for removal on 20150508
163 games-arcade/mtp-target-bin
164
165 # Aaron Bauman <bman@gentoo.org> (6 Apr 2015)
166 # Superseded by net-misc/gns3-gui and net-misc/gns3-server.
167 # Removal in 30 days.
168 net-misc/gns3
169
170 # Maciej Mrozowski <reavertm@gentoo.org> (06 Apr 2015)
171 # Does not link against latest ncurses and no interest to fix it.
172 # Superseded by LVM2 and all clusters should be migrated by now.
173 # Removal in 30 days.
174 sys-fs/evms
175
176 # James Le Cuirot <chewi@gentoo.org> (05 Apr 2015)
177 # A 32-on-64 Java VM is no longer considered necessary and a multilib
178 # icedtea-bin would be preferred anyway. sun-j2me-bin depends on this
179 # but it has been superseded by Oracle's JME and I doubt we'll ever
180 # need that either. Removal in 30 days.
181 app-emulation/emul-linux-x86-java
182 dev-java/sun-j2me-bin
183
184 # Christoph Junghans <ottxor@gentoo.org> (3 Apr 2015)
185 # Dead upstream. Fails to build (bug #543644).
186 >=sys-devel/dragonegg-3.6
187
188 # Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org> (30 Mar 2015)
189 # Does not build against glibc-2.20 or modern X servers, bug #544904.
190 # Removal in 30 days.
191 <x11-drivers/xf86-input-synaptics-1.7
192
193 # Andreas K. Huettel <dilfridge@gentoo.org> (29 Mar 2015)
194 # Mask Perl 5.18 for removal. Please upgrade to Perl 5.20
195 =dev-lang/perl-5.18.2-r2
196 =virtual/perl-Archive-Tar-1.900.0-r2
197 =virtual/perl-Attribute-Handlers-0.940.0-r1
198 =virtual/perl-AutoLoader-5.730.0-r2
199 =virtual/perl-B-Debug-1.180.0-r2
200 =virtual/perl-CGI-3.630.0-r2
201 =virtual/perl-CPAN-Meta-Requirements-2.122.0-r2
202 =virtual/perl-CPAN-Meta-YAML-0.8.0-r2
203 =virtual/perl-CPAN-Meta-2.120.921-r2
204 =virtual/perl-CPAN-2.0.0-r1
205 =virtual/perl-Carp-1.290.0-r1
206 =virtual/perl-Compress-Raw-Bzip2-2.60.0-r2
207 =virtual/perl-Compress-Raw-Zlib-2.60.0-r2
208 =virtual/perl-DB_File-1.827.0-r2
209 =virtual/perl-Devel-PPPort-3.200.0-r4
210 =virtual/perl-Digest-MD5-2.520.0-r2
211 =virtual/perl-Encode-2.490.0-r2
212 =virtual/perl-Exporter-5.680.0-r2
213 =virtual/perl-ExtUtils-CBuilder-0.280.210-r1
214 =virtual/perl-ExtUtils-Command-1.170.0-r6
215 =virtual/perl-ExtUtils-Install-1.590.0-r1
216 =virtual/perl-ExtUtils-MakeMaker-6.660.0-r1
217 =virtual/perl-ExtUtils-ParseXS-3.180.0-r2
218 =virtual/perl-File-Spec-3.400.0-r2
219 =virtual/perl-File-Temp-0.230.0-r1
220 =virtual/perl-Filter-Simple-0.890.0-r1
221 =virtual/perl-Getopt-Long-2.390.0-r1
222 =virtual/perl-I18N-LangTags-0.390.0
223 =virtual/perl-IO-Compress-2.60.0-r1
224 =virtual/perl-IO-1.280.0-r1
225 =virtual/perl-IPC-Cmd-0.800.0-r1
226 =virtual/perl-JSON-PP-2.272.20-r1
227 =virtual/perl-Locale-Maketext-1.230.0-r1
228 =virtual/perl-MIME-Base64-3.130.0-r4
229 =virtual/perl-Math-BigInt-FastCalc-0.300.0-r4
230 =virtual/perl-Math-BigInt-1.999.100
231 =virtual/perl-Math-BigRat-0.260.400
232 =virtual/perl-Module-Build-0.400.300-r1
233 =virtual/perl-Module-CoreList-3.30.0
234 =virtual/perl-Module-Load-Conditional-0.540.0-r1
235 =virtual/perl-Module-Load-0.240.0-r1
236 =virtual/perl-Module-Metadata-1.0.11-r1
237 =virtual/perl-Net-Ping-2.41-r1
238 =virtual/perl-Package-Constants-0.20.0-r5
239 =virtual/perl-Params-Check-0.360.0-r1
240 =virtual/perl-Parse-CPAN-Meta-1.440.400-r1
241 =virtual/perl-Perl-OSType-1.3.0-r1
242 =virtual/perl-Pod-Escapes-1.40.0-r5
243 =virtual/perl-Pod-Parser-1.600.0
244 =virtual/perl-Safe-2.350.0-r2
245 =virtual/perl-Scalar-List-Utils-1.270.0-r2
246 =virtual/perl-Socket-2.9.0-r2
247 =virtual/perl-Storable-2.410.0-r1
248 =virtual/perl-Sys-Syslog-0.320.0-r2
249 =virtual/perl-Term-ReadLine-1.120.0
250 =virtual/perl-Test-Harness-3.260.0-r2
251 =virtual/perl-Test-Simple-0.980.0-r6
252 =virtual/perl-Text-ParseWords-3.280.0-r2
253 =virtual/perl-Thread-Queue-3.20.0-r1
254 =virtual/perl-Time-HiRes-1.972.500-r3
255 =virtual/perl-Time-Piece-1.20-r2
256 =virtual/perl-XSLoader-0.160.0-r2
257 =virtual/perl-bignum-0.330.0
258 =virtual/perl-if-0.60.200-r2
259 =virtual/perl-libnet-1.220.0-r3
260 =virtual/perl-parent-0.225.0-r5
261 =virtual/perl-threads-shared-1.430.0-r1
262 =virtual/perl-threads-1.860.0-r4
263 =virtual/perl-version-0.990.200-r1
264
265 # Ben de Groot <yngwin@gentoo.org> (29 Mar 2015)
266 # Merged with qtcurve-qt4 into x11-themes/qtcurve (with gtk useflag)
267 # Removal in 30 days. See also bug #544406.
268 x11-themes/gtk-engines-qtcurve
269
270 # Michał Górny <mgorny@gentoo.org> (28 Mar 2015)
271 # on behalf of gx86-multilib project <multilib@gentoo.org>
272 # Mask emul-linux-x86 packages along with unported old versions
273 # of reverse dependencies for removal in 60 days, bug #544876.
274 # Please use multilib ebuilds with abi_x86_32 instead.
275 app-emulation/emul-linux-x86-baselibs
276 app-emulation/emul-linux-x86-cpplibs
277 app-emulation/emul-linux-x86-db
278 app-emulation/emul-linux-x86-gstplugins
279 app-emulation/emul-linux-x86-gtklibs
280 app-emulation/emul-linux-x86-gtkmmlibs
281 app-emulation/emul-linux-x86-medialibs
282 app-emulation/emul-linux-x86-motif
283 app-emulation/emul-linux-x86-opengl
284 app-emulation/emul-linux-x86-qtlibs
285 app-emulation/emul-linux-x86-sdl
286 app-emulation/emul-linux-x86-soundlibs
287 app-emulation/emul-linux-x86-xlibs
288 app-emulation/emul-linux-x86-jna
289 <x11-drivers/ati-drivers-14
290
291 # Ian Delaney <idella4@gentoo.org> (28 Mar 2015)
292 # old package with no active maintainers
293 # No evidence of support or use.
294 # Masked for removal in 30 days.
295 sci-geosciences/LatLongUTMconversion
296
297 # Ian Delaney <idella4@gentoo.org> (24 Mar 2015)
298 # the cffi requires setting ':=' which isn't reliable in a virtual
299 # Masked while a solution is found
300 virtual/python-cffi
301
302 # Brian Evans <grknight@gentoo.org> (22 Mar 2015)
303 # PHP 5.3.x is vulnerable to several security bugs and has
304 # reached EOL status. (Bugs #533998, #537586, #537590, #538822, #541098)
305 # Masked pending resolution to bug #538756
306 dev-lang/php:5.3
307 virtual/httpd-php:5.3
308 =mail-client/squirrelmail-1.4.22
309
310 # Ulrich Müller <ulm@gentoo.org> (9 Mar 2015)
311 # Broken multilib dependencies causing blockers, bug 542728.
312 # Masked by QA until maintainer will sort this out.
313 =net-misc/teamviewer-10.0.36281
314
315 # Lars Wendler <polynomial-c@gentoo.org> (8 Mar 2015)
316 # Masked for testing
317 >=net-fs/samba-4.2.0
318
319 # Justin Lecher <jlec@gentoo.org> (28 Feb 2015)
320 # Unfixed security problems
321 # CVE-2015-{0219,0220,0221,0222}
322 # #536586
323 =dev-python/django-1.5*
324
325 # Michał Górny <mgorny@gentoo.org> (11 Feb 2015)
326 # Potentially destructive to @world, bug #539746.
327 =sys-apps/portage-2.2.16
328
329 # Eray Aslan <eras@gentoo.org> (03 Feb 2015)
330 # Mask experimental software
331 =mail-mta/postfix-3.1*
332
333 # Sergei Trofimovich <slyfox@gentoo.org> (29 Jan 2015)
334 # Mask live ebuild
335 =dev-util/radare2-9999
336
337 # Anthony G. Basile <blueness@gentoo.org> (28 Jan 2015)
338 # Its broken and we're waiting for fixes from upstream, bug #536196
339 =net-misc/tor-0.2.6.2_alpha-r1
340
341 # Anthony G. Basile <blueness@gentoo.org> (9 Jan 2015)
342 # p.mask the -9999 version
343 =dev-misc/i2pd-9999
344
345 # Tony Vroon <chainsaw@gentoo.org> (5 Jan 2015)
346 # Asterisk 13 is an LTS release but has not seen
347 # sufficient releases to be considered ready for
348 # production usage. You are welcome to have a go
349 # but please be careful.
350 =net-misc/asterisk-13*
351
352 # Aaron W. Swenson <titanofold@gentoo.org> (28 Dec 2014)
353 # Split ebuilds are no longer maintained. Migrate to the unified
354 # ebuilds invoking the following, substituting SLOT for the desired
355 # slot and optionally enabling the server and/or docs USE flags:
356 # emerge dev-db/postgresql:SLOT
357 # No further action is required.
358 dev-db/postgresql-docs
359 dev-db/postgresql-base
360 dev-db/postgresql-server
361
362 # Sergey Popov <pinkbyte@gentoo.org> (24 Dec 2014)
363 # Mask new version of Boost - it's known to cause breakages
364 ~dev-util/boost-build-1.57.0
365 ~dev-libs/boost-1.57.0
366
367 # Jeroen Roovers <jer@gentoo.org> (12 Dec 2014)
368 # The 96 and 173 branches are no longer supported and remain vulnerable to
369 # CVE-2014-8298 (bug #532342). You may be able to mitigate the vulnerability by
370 # disabling GLX indirect rendering protocol support on the X server.
371 <x11-drivers/nvidia-drivers-304
372
373 # Sergey Popov <pinkbyte@gentoo.org> (09 Dec 2014)
374 # Security mask, wrt bug #529728
375 <app-antivirus/clamav-0.98.5
376
377 # Ian Stakenvicius <axs@gentoo.org> (03 Dec 2014)
378 # masked for testing
379 media-libs/openh264
380
381 # Justin Lecher <jlec@gentoo.org> (02 Dec 2014)
382 # Not supported by upstream anymore
383 # Revdeps broken, #531392
384 net-analyzer/openvas-administrator
385
386 # Richard Yao <ryao@gentoo.org> (29 Nov 2014)
387 # Depends on media-libs/lcms:0, which has unspecified security vulnerabilities.
388 # Masked until mscms.dll.so that links to media-libs/lcms:2 is backported from
389 # a newer wine, bug #526806.
390 <app-emulation/crossover-bin-12.5.0
391
392 # Patrick Lauer <patrick@gentoo.org> (24 Nov 2014)
393 # Missing deps, uninstallable
394 www-apps/trac-downloads
395
396 # Markos Chandras <hwoarang@gentoo.org> (18 Nov 2014)
397 # Mask latest development version for testing
398 =x11-misc/lightdm-1.14*
399
400 # Samuli Suominen <ssuominen@gentoo.org> (05 Nov 2014)
401 # ConsoleKit2 from github by Eric Koegel, auth of xfce4-power-manager
402 # The ConsoleKit in freedesktop.org git won't be continued anymore,
403 # making this the new official release
404 # Masked for testing
405 >=sys-auth/consolekit-0.9.2
406
407 # Mike Pagano <mpagano@gentoo.org> (16 Oct 2014)
408 # A regression in kernels 3.17.0 lead to file system corruption
409 # for affected systems. This has been fixed in >= 3.17.1
410 # Expires (16 Oct 2016)
411 # See Bug #525548.
412 =sys-kernel/vanilla-sources-3.17.0
413 =sys-kernel/gentoo-sources-3.17.0
414 =sys-kernel/aufs-sources-3.17.0
415
416 # Michał Górny <mgorny@gentoo.org> (15 Sep 2014)
417 # Causes undefined references few layers down (in mediastreamer),
418 # someone needs to investigate.
419 >=net-libs/libzrtpcpp-4
420
421 # Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org> (03 Sep 2014)
422 # Temporary mask until it is verified to work
423 =media-libs/raspberrypi-userland-0_pre20140830
424
425 # Christian Faulhammer <fauli@gentoo.org> (02 Sep 2014)
426 # website not working anymore and will stay like this,
427 # tool is useless. See bug 504734
428 app-admin/hwreport
429
430 # Sergey Popov <pinkbyte@gentoo.org> (28 Aug 2014)
431 # Security mask, wrt bug #519650
432 # If your application is broken due to this mask,
433 # please file a separate bug report
434 <net-dialup/ppp-2.4.7
435
436 # Samuli Suominen <ssuominen@gentoo.org> (23 Aug 2014)
437 # Some compile problems with media-libs/openexr >= 2.2.0
438 # See http://bugs.gentoo.org/520240 for more information
439 >=media-libs/ilmbase-2.2.0
440 >=media-libs/openexr-2.2.0
441 >=media-gfx/openexr_viewers-2.2.0
442
443 # Robin H. Johnson <robbat2@gentoo.org> (04 Aug 2014)
444 # Masked for testing, presently fails upstream testsuite:
445 # FAIL:07:02:35 (00:00:00) db_dump/db_load(./TESTDIR.3/recd001.db:child killed: kill signal): expected 0, got 1
446 # FAIL:07:02:35 (00:00:00) Dump/load of ./TESTDIR.3/recd001.db failed.
447 # FAIL:07:02:35 (00:00:00) db_verify_preop: expected 0, got 1
448 =sys-libs/db-6.1*
449
450 # Yixun Lan <dlan@gentoo.org> (17 Jul 2014)
451 # Masked for proper testing. (Major updates in the code).
452 =net-misc/tinc-1.1_pre*
453
454 # Ulrich Müller <ulm@gentoo.org> (15 Jul 2014)
455 # Permanently mask sys-libs/lib-compat and its reverse dependencies,
456 # pending multiple security vulnerabilities and QA issues.
457 # See bugs #515926 and #510960.
458 sys-libs/lib-compat
459 sys-libs/lib-compat-loki
460 games-action/mutantstorm-demo
461 games-action/phobiaii
462 games-emulation/handy
463 games-fps/rtcw
464 games-fps/unreal
465 games-strategy/heroes3
466 games-strategy/heroes3-demo
467 games-strategy/smac
468 sys-block/afacli
469
470 # Mikle Kolyada <zlogene@gentoo.org> (27 Jun 2014)
471 # Masked for proper testing. (Major updates in the code).
472 =dev-perl/PortageXS-0.02.12
473
474 # Robin H. Johnson <robbat2@gentoo.org> (21 Jun 2014)
475 # Needs work, but infra needs it for new VM boxes
476 app-emulation/openstack-guest-agents-unix
477 app-emulation/xe-guest-utilities
478
479 # Mike Gilbert <floppym@gentoo.org> (10 Jun 2014)
480 # Masked due to pending dev-python/imaging removal, bug 471488.
481 media-sound/decibel-audio-player
482 =net-im/pymsn-t-0.11.3-r3
483
484 # Tom Wijsman <TomWij@gentoo.org> (8 Jun 2014)
485 # Mask VLC ebuilds that are affected with security bug CVE-2013-6934:
486 #
487 # A vulnerability has been discovered in VLC Media Player, which can be
488 # exploited by malicious people to compromise a user's system.
489 #
490 # Some ebuilds also have other buffer and integer overflow security bugs like
491 # CVE-2013-1954, CVE-2013-3245, CVE-2013-4388 and CVE-2013-6283.
492 #
493 # Users should consider to upgrade VLC Media Player to at least version 2.1.2.
494 <media-video/vlc-2.1.2
495
496 # Tom Wijsman <TomWij@gentoo.org> (6 Jun 2014)
497 # Mask gentoo-sources ebuilds that are affected with security bug CVE-2014-3153.
498 #
499 # Pinkie Pie discovered an issue in the futex subsystem that allows a
500 # local user to gain ring 0 control via the futex syscall. An
501 # unprivileged user could use this flaw to crash the kernel (resulting
502 # in denial of service) or for privilege escalation.
503 #
504 # https://bugs.gentoo.org/show_bug.cgi?id=CVE-2014-3153
505 # Expires (6 Jun 2016)
506 =sys-kernel/gentoo-sources-3.2.58-r2
507 ~sys-kernel/gentoo-sources-3.4.90
508 =sys-kernel/gentoo-sources-3.4.91
509 ~sys-kernel/gentoo-sources-3.10.40
510 =sys-kernel/gentoo-sources-3.10.41
511 ~sys-kernel/gentoo-sources-3.12.20
512 =sys-kernel/gentoo-sources-3.12.21
513 ~sys-kernel/gentoo-sources-3.14.4
514 =sys-kernel/gentoo-sources-3.14.5
515
516 # Hans de Graaff <graaff@gentoo.org> (1 Jun 2014)
517 # Mask new rubinius version for testing. Current versions have some
518 # issues that should be solved in the forthcoming rubinius 2.3
519 # release.
520 =dev-lang/rubinius-2*
521
522 # Markos Chandras <hwoarang@gentoo.org> (30 May 2014)
523 # Mask beta release
524 =app-i18n/transifex-client-0.11_beta
525
526 # Tom Wijsman <TomWij@gentoo.org> (30 May 2014)
527 # CVE-2012-1721 - Remote Code Execution Vulnerability
528 #
529 # Vulnerable: IBM Java SE 5.0 SR12-FP5
530 # URL: http://www.securityfocus.com/bid/53959/
531 dev-java/ibm-jdk-bin:1.5
532
533 # Tom Wijsman <TomWij@gentoo.org> (03 May 2014)
534 # Needs to be further tested and revised by both Java and Ruby herds.
535 >=dev-java/jruby-1.7.12
536 dev-ruby/bitescript
537 dev-ruby/duby
538 dev-ruby/jruby-openssl
539 dev-ruby/weakling
540
541 # Matti Bickel <mabi@gentoo.org> (22 Apr 2014)
542 # Masked slotted lua for testing
543 app-eselect/eselect-lua
544 =dev-lang/lua-5.1.5-r2
545 =dev-lang/lua-5.1.5-r100
546 =dev-lang/lua-5.2.3
547 =dev-lang/lua-5.2.3-r1
548
549 # Gilles Dartiguelongue <eva@gentoo.org> (06 Apr 2014)
550 # Old release, never stable, not working anymore
551 # See bug #327837, #382667, #492474
552 <media-video/pitivi-0.90
553
554 # Alexander Vershilov <qnikst@gentoo.org> (02 Apr 2014)
555 # Multiple vulnerabilities, see #504724, #505860
556 <sys-kernel/openvz-sources-2.6.32.85.17
557
558 # Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org> (26 Mar 2014)
559 # Affected by multiple vulnerabilities, #445916, #471098 and #472280
560 <media-libs/mesa-9.1.4
561
562 # Sergey Popov <pinkbyte@gentoo.org> (20 Mar 2014)
563 # Security mask of vulnerable versions, wrt bug #424167
564 <net-nds/openldap-2.4.35
565
566 # Lars Wendler <polynomial-c@gentoo.org> (14 Mar 2014)
567 # Masked for security reasons.
568 # Do NOT remove this mask or the affected packages without speaking to
569 # bonsaikitten first! You have been warned!
570 <net-fs/samba-3.6
571
572 # Mike Gilbert <floppym@gentoo.org> (04 Mar 2014)
573 # Dev channel releases are only for people who are developers or want more
574 # experimental features and accept a more unstable release.
575 www-plugins/chrome-binary-plugins:unstable
576
577 # Samuli Suominen <ssuominen@gentoo.org> (03 Mar 2014)
578 # gnome-extra/polkit-gnome is the "GTK+ polkit agent" and has no extra
579 # dependencies that installing lxde-base/lxpolkit would solve, thus
580 # the only motivation for creation of lxpolkit was to drop the word
581 # 'gnome' from the package's name. The packages are near identical
582 # by the outlook, determined by the used GTK+ theme.
583 #
584 # Raise yourself above the word 'gnome' and install the de facto GTK+ agent:
585 # emerge -C lxpolkit
586 # emerge -1 polkit-gnome
587 #
588 # Removal will happen at later date, but since there is no hurry, give it
589 # until rest of the year.
590 lxde-base/lxpolkit
591
592 # Tim Harder <radhermit@gentoo.org> (04 Feb 2014)
593 # Mask development releases
594 =media-sound/lilypond-2.19*
595
596 # Mike Gilbert <floppym@gentoo.org> (19 Jan 2014)
597 # To prevent accidental switching of release channels (bug 498306),
598 # google-chrome has been split into 3 packages:
599 #
600 # www-client/google-chrome
601 # www-client/google-chrome-beta
602 # www-client/google-chrome-unstable
603 #
604 # The stable channel remains as www-client/google-chrome, but has been
605 # switched to SLOT="0".
606 #
607 # Please unmerge your currently installed version and remerge one of the new
608 # packages.
609 www-client/google-chrome:beta
610 www-client/google-chrome:stable
611 www-client/google-chrome:unstable
612
613 # Tony Vroon <chainsaw@gentoo.org> (13 Jan 2014)
614 # Asterisk 12 is a short term "standard" release
615 # containing significant architectural changes.
616 # This is not for your production kit quite yet.
617 =net-misc/asterisk-12*
618
619 # Tom Wijsman <TomWij@gentoo.org> (09 Jan 2014)
620 # Monolithic dev-dotnet/{gnome,gtk}-sharp introduction mask, see bug #382491.
621 >=dev-dotnet/gnome-sharp-2.24.2-r1
622 >=dev-dotnet/gtk-sharp-2.12.21
623
624 # Michał Górny <mgorny@gentoo.org> (15 Dec 2013)
625 # Masked for testing due to almost complete redesign. It is now
626 # completely split and no longer has an integrated GUI. Currently,
627 # the only working GUI is the PyQt4 GUI and it has license issues
628 # (bug #494524).
629 >=games-emulation/mupen64plus-2
630 games-emulation/mupen64plus-core
631 games-emulation/mupen64plus-audio-sdl
632 games-emulation/mupen64plus-input-sdl
633 games-emulation/mupen64plus-rsp-hle
634 games-emulation/mupen64plus-ui-console
635 games-emulation/mupen64plus-video-glide64mk2
636 games-emulation/mupen64plus-video-rice
637 games-emulation/m64py
638
639 # Tiziano Müller <dev-zero@gentoo.org> (24 Oct 2013)
640 # Mask mainline version branch
641 =www-servers/nginx-1.5*
642
643 # Justin Lecher <jlec@gentoo.org> (14 Oct 2013)
644 # Seems to break all deps - API change?
645 >=sci-libs/metis-5
646
647 # Diego Elio Pettenò <flameeyes@gentoo.org> (13 Oct 2013)
648 # Requires a NPN support in mod_ssl (www-server/apache) to work.
649 # See #471512 for more details.
650 www-apache/mod_spdy
651
652 # Agostino Sarubbo <ago@gentoo.org> (23 Sep 2013)
653 # Masked because of vulnerable versions
654 # DO NOT REMOVE OLDER VERSIONS
655 # temporarily disabled as it also breaks s390 keywording
656 #<net-nds/openldap-2.4.35
657
658 # Tom Wijsman <TomWij@gentoo.org> (18 Sep 2013)
659 # Temporarily masked due to QA issue during attempts to unbundle dependencies;
660 # we need to check the jar contents to check for differences, especially the
661 # stax dependency seems to be problematic in this regard but we'll check all of
662 # them to ensure that unbundling doesn't hurt some missed functionality.
663 # Bug #471942 tracks the progress of these unbundling efforts.
664 >=app-admin/ec2-api-tools-1.6.7.2-r4
665
666 # Sergey Popov <pinkbyte@gentoo.org> (18 Sep 2013)
667 # Mask development releases of botan:
668 # - causes many API breakages
669 # - do not compile in some USE-flag combinations
670 # - requires at least gcc 4.7(and possibly even 4.8 for some features)
671 >=dev-libs/botan-1.11.0
672
673 # Tom Wijsman <TomWij@gentoo.org> (15 Aug 2013)
674 # Dependencies are unable to satisfy current version,
675 # broken; needs a version bump from bug #475552.
676 dev-java/itext:5
677
678 # Julian Ospald <hasufell@gentoo.org> (21 Jul 2013)
679 # Mask all unfetchable versions and those with tons of random
680 # bugs and segfaults (all). Don't ask for a version bump unless
681 # there is a working release.
682 sci-geosciences/googleearth
683
684 # Chris Reffett <creffett@gentoo.org> (20 Jul 2013)
685 # Uses vulnerable versions of bzip2, but these versions are
686 # necessary to reconstruct older archives. Use at your own risk.
687 =app-portage/deltup-0.4.5
688
689 # Michael Weber <xmw@gentoo.org> (17 Jul 2013)
690 # Upstream next versions
691 >=sys-boot/raspberrypi-firmware-1_pre
692
693 # Sergey Popov <pinkbyte@gentoo.org> (12 Jul 2013)
694 # Probably new versions will work with hexchat too.
695 # Do not lastrite this, just leave mask by Lars Wendler's request.
696 net-irc/xchat-otr
697
698 # Tom Wijsman <TomWij@gentoo.org> (30 Jun 2013)
699 # Sun JDK and JRE contain critical vulnerabilities and receive no further
700 # updates; masking to make users aware of this, users that still need this
701 # package and have no alternative can unmask at their own risk. See bug #473830.
702 #
703 # This is continued by Oracle Corporation, which has acquired Sun Microsystems
704 # in early 2010; as per http://en.wikipedia.org/wiki/Sun_acquisition_by_Oracle
705 #
706 # Users are suggested to upgrade to one of the newer Oracle packages like
707 # dev-java/oracle-jdk-bin or dev-java/oracle-jre-bin or choose another
708 # alternative we provide; eg. the IBM JDK/JRE or the open source IcedTea.
709 #
710 # Most of these packages provide a jce USE flag for those whom need the
711 # Java Cryptographic Extension Unlimited Strength Policy USE flag; whether that
712 # works depends from VM to VM, it seems to work for most except for the IBM VMs.
713 dev-java/sun-jdk
714 dev-java/sun-jre-bin
715 dev-java/sun-jce-bin
716
717 # Julian Ospald <hasufell@gentoo.org> (26 Jun 2013)
718 # Depends on masked dev-lang/lua-5.2
719 >=games-emulation/sdlmame-0.149
720 >=games-emulation/sdlmess-0.149
721
722 # Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org> (25 Jun 2013)
723 # Mask new ptlib/opal for breakage, tracked in bug #474742
724 # Lars Wendler <polynomial-c@gentoo.org> (29 Apr 2014)
725 # Adjusted mask so newer versions get covered as well.
726 >=net-libs/ptlib-2.12.0
727 >=net-libs/opal-3.12.0
728
729 # Pacho Ramos <pacho@gentoo.org> (15 Jun 2013)
730 # Upstream stalled, improper rendering (#470818),
731 # use app-editors/efte instead.
732 =app-editors/fte-20110708
733
734 # Patrick Lauer <patrick@gentoo.org> (21 May 2013)
735 # broken dependencies -> uninstallable #470712
736 app-portage/g-ctan
737
738 # Michael Weber <xmw@gentoo.org> (18 Apr 2013)
739 # Masked due test failures
740 =app-arch/advancecomp-1.17
741
742 # Sergey Popov <pinkbyte@gentoo.org> (02 Apr 2013)
743 # Masking =media-libs/ffmpegsource-2.17.4_pre753
744 # by maintainer's request.
745 # This version does not work properly, see bug #464078
746 =media-libs/ffmpegsource-2.17.4_pre753
747
748 # Richard Freeman <rich0@gentoo.org> (24 Mar 2013)
749 # Contains known buffer overflows. Package generally works
750 # but should not be fed untrusted input (eg from strangers).
751 # Masked to ensure users are aware before they install.
752 app-text/cuneiform
753
754 # Tom Wijsman <TomWij@gentoo.org> (12 Mar 2013)
755 # 2.5.* has known security and other issues due to an affected
756 # bundled ffmpeg, see bugs #446468 and #444262.
757 <media-video/avidemux-2.6.2
758
759 # Doug Goldstein <cardoe@gentoo.org> (22 Jan 2013)
760 # Masked for development
761 =sys-block/open-iscsi-2.0.873
762
763 # Sven Wegener <swegener@gentoo.org> (21 Dec 2012)
764 # temporary mask for socket location change
765 =app-misc/screen-4.0.3-r8
766
767 # Rick Farina <zerochaos@gentoo.org> (21 Dec 2012)
768 # madwifi has been replaced by ath5k and ath9k in kernel
769 # drivers and is subject to numerous long standing bugs
770 # stable wpa_supplicant sometimes wants madwifi-ng-tools
771 #net-wireless/madwifi-ng-tools
772 net-wireless/madwifi-ng
773
774 # Pacho Ramos <pacho@gentoo.org> (25 Oct 2012)
775 # obexd changed its API without any warning, it's recommended to ship
776 # 0.46 until https://bugzilla.gnome.org/682106 is fixed to prevent
777 # bluetooth-sendto breakage.
778 >=app-mobilephone/obexd-0.47
779
780 # Ralph Sennhauser <sera@gentoo.org> (18 Jul 2012)
781 # Unmaintained, multiple vulnarabilities. #351626
782 # A more recent source build maintained by the community is available in the
783 # seden overlay. A more recent binary is available in the java-overlay.
784 <=dev-util/eclipse-sdk-3.5.1-r1
785
786 # Ian Stakenvicius <axs@gentoo.org> (19 Jun 2012)
787 # Mask new spidermonkeys until rdeps can accept it
788 # 1.8.7 will be masked indefinitely and will be removed
789 # from the tree soon.
790 ~dev-lang/spidermonkey-1.8.7
791
792 # Michael Weber <xmw@gentoo.org> (13 Jun 2012)
793 # Mask beta versions for testing
794 >sci-electronics/magic-8
795
796 # Robin H. Johnson <robbat2@gentoo.org> (09 Feb 2012)
797 # Needs to be slotted better
798 =dev-libs/yaz-4*
799
800 # Andreas K. Huettel <dilfridge@gentoo.org> (22 Mar 2012)
801 # Even its author admits that it's an ugly hack. Crashes e.g.
802 # firefox with kde-4.8. Unmask at your own risk.
803 kde-misc/kgtk
804
805 # Samuli Suominen <ssuominen@gentoo.org> (06 Mar 2012)
806 # Masked for testing since this is known to break nearly
807 # every reverse dependency wrt bug 407091
808 >=dev-lang/lua-5.2.0
809
810 # Samuli Suominen <ssuominen@gentoo.org> (30 Oct 2011)
811 # Masked for security bug #294253, use only at your own risk!
812 =media-libs/fmod-3*
813
814 # Peter Volkov <pva@gentoo.org> (23 Jul 2011)
815 # Mask release candidates
816 =dev-libs/guiloader-2.99.0
817 =dev-libs/guiloader-c++-2.99.0
818 =dev-util/crow-designer-2.99.0
819
820 # Marijn Schouten <hkBst@gentoo.org> (07 April 2011)
821 # Masked for number of issues, but can be used to
822 # test against if people are impatient ;P
823 # Known issues:
824 # - Broken emacs support (ulm has promised to look)
825 # - doesn't build when boehm-gc is built without threads
826 # - no SLOTting yet!
827 =dev-scheme/guile-2.0.0
828
829 # Ryan Hill <dirtyepic@gentoo.org> (30 Mar 2011)
830 # Masked indefinitely (until 0.40 is released).
831 # http://bugs.gentoo.org/354423
832 >=app-pda/libopensync-0.30
833 >=app-pda/libopensync-plugin-file-0.30
834 >=app-pda/libopensync-plugin-irmc-0.30
835 >=app-pda/libopensync-plugin-palm-0.30
836 >=app-pda/libopensync-plugin-python-0.30
837 app-pda/libopensync-plugin-syncml
838 app-pda/libopensync-plugin-vformat
839 app-pda/osynctool
840
841 # Ryan Hill <dirtyepic@gentoo.org> (30 Mar 2011)
842 # Work in progress
843 # http://bugs.gentoo.org/show_bug.cgi?id=354423
844 app-pda/libopensync-plugin-gnokii
845 app-pda/libopensync-plugin-gpe
846 app-pda/multisync-gui
847
848 # Markos Chandras <hwoarang@gentoo.org> (01 Nov 2010)
849 # Masking alpha releases
850 net-analyzer/ncrack
851
852 # Luca Barbato <lu_zero@gentoo.org> (21 Jul 2010)
853 # Not ready for public consumption, clashes with current mesa-git
854 media-libs/shivavg
855
856 # Stefan Briesenick <sbriesen@gentoo.org> (21 Jul 2010)
857 # doesn't compile against latest media-libs/spandsp.
858 # not needed anymore for Asterisk 1.6.
859 net-misc/asterisk-spandsp_codec_g726
860
861 # Doug Goldstein <cardoe@gentoo.org> (07 Jul 2010)
862 # No actual Gentoo support yet. If you're interested, please see bug #295993
863 net-misc/netcf
864
865 # Mike Frysinger <vapier@gentoo.org> (07 Mar 2010)
866 # Very old packages that people should have upgraded away from
867 # long ago. Courtesy mask ... time to upgrade.
868 # Added <sys-fs/e2fsprogs as well (halcy0n)
869 <sys-libs/e2fsprogs-libs-1.41.8
870 <sys-fs/e2fsprogs-1.41.9
871
872 # Robert Piasek <dagger@gentoo.org> (23 Feb 2010)
873 # Masking libmapi as it depends on masked samba4
874 >=net-libs/libmapi-0.9
875
876 # Peter Alfredsen <loki_val@gentoo.org> (21 Oct 2009)
877 # Masked because this needs a patch to be applied to portage
878 # to not install the kitchensink and everything else
879 # into /usr/src/debug with FEATURES=installsources
880 =dev-util/debugedit-4.4.6-r2
881
882 # Diego E. Pettenò <flameeyes@gmail.com> (09 Oct 2009)
883 # Untested yet; documented only in Russian, help is appreciated.
884 sys-auth/pam_keystore
885
886 # Diego E. Pettenò <flameeyes@gentoo.org> (08 Aug 2009)
887 # on behalf of QA Team
888 #
889 # Mass-masking of live ebuilds; we cannot guarantee working state of
890 # live ebuilds, nor the availability of the server hosting them. As
891 # per QA team policy, all these need to be kept masked by default, if
892 # available in the tree.
893 ~app-i18n/skk-jisyo-9999
894 =app-misc/sleepyhead-9999
895 =app-pda/libsyncml-9999
896 =app-pda/libopensync-9999
897 =app-pda/osynctool-9999
898 =app-pda/libopensync-plugin-file-9999
899 =app-pda/libopensync-plugin-gnokii-9999
900 =app-pda/libopensync-plugin-gpe-9999
901 =app-pda/libopensync-plugin-irmc-9999
902 =app-pda/libopensync-plugin-palm-9999
903 =app-pda/libopensync-plugin-python-9999
904 =app-pda/libopensync-plugin-syncml-9999
905 =app-pda/libopensync-plugin-vformat-9999
906 app-portage/layman-dbtools
907 =www-plugins/google-talkplugin-9999
908
909 # Tiziano Müller <dev-zero@gentoo.org> (08 Apr 2009)
910 # pre-releases
911 >=app-editors/gobby-0.4.91
912
913 # Diego E. Pettenò <flameeyes@gentoo.org> (03 Jan 2009)
914 # These packages are not supposed to be merged directly, instead
915 # please use sys-devel/crossdev to install them.
916 dev-libs/cygwin
917 dev-util/mingw-runtime
918 dev-util/mingw64-runtime
919 dev-util/w32api
920 sys-libs/newlib
921 dev-embedded/msp430-binutils
922 dev-embedded/msp430-gcc
923 dev-embedded/msp430-gdb
924 dev-embedded/msp430-libc
925 dev-embedded/msp430mcu
926 dev-embedded/avr-libc
927
928 # Chris Gianelloni <wolf31o2@gentoo.org> (03 Mar 2008)
929 # Masking due to security bug #194607 and security bug #204067
930 games-fps/doom3
931 games-fps/doom3-cdoom
932 games-fps/doom3-chextrek
933 games-fps/doom3-data
934 games-fps/doom3-demo
935 games-fps/doom3-ducttape
936 games-fps/doom3-eventhorizon
937 games-fps/doom3-hellcampaign
938 games-fps/doom3-inhell
939 games-fps/doom3-lms
940 games-fps/doom3-mitm
941 games-fps/doom3-phantasm
942 games-fps/doom3-roe
943 games-fps/quake4-bin
944 games-fps/quake4-data
945 games-fps/quake4-demo
946
947 # MATSUU Takuto <matsuu@gentoo.org> (05 Apr 2007)
948 # to be tested, seems unstable
949 >=app-i18n/scim-anthy-1.3.0
950
951 # Tavis Ormandy <taviso@gentoo.org> (21 Mar 2006)
952 # masked pending unresolved security issues #127167
953 games-roguelike/slashem
954
955 # Tavis Ormandy <taviso@gentoo.org> (21 Mar 2006)
956 # masked pending unresolved security issues #125902
957 games-util/hearse
958
959 # Robin H. Johnson <robbat2@gentoo.org> (11 Feb 2006)
960 # zlib interaction is badly broken. See bug #124733.
961 =dev-vcs/cvs-1.12.13*
962
963 # <klieber@gentoo.org> (01 Apr 2004)
964 # The following packages contain a remotely-exploitable
965 # security vulnerability and have been hard masked accordingly.
966 #
967 # Please see http://bugs.gentoo.org/show_bug.cgi?id=44351 for more info
968 #
969 games-fps/unreal-tournament-goty
970 games-fps/unreal-tournament-strikeforce
971 games-fps/unreal-tournament-bonuspacks
972 games-fps/aaut

  ViewVC Help
Powered by ViewVC 1.1.20