/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Diff of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.16 Revision 1.115
1# ChangeLog for sys-auth/polkit 1# ChangeLog for sys-auth/polkit
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.16 2010/05/04 16:12:59 tester Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.115 2012/11/22 13:27:07 ssuominen Exp $
4
5 22 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107.ebuild:
6 old
7
8 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
9 stable ppc64, bug #436666
10
11 22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
12 Stable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt
13 bug #436666
14
15 21 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
16 stable ppc, bug #436666, thanks peratu
17
18 19 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.108.ebuild:
19 Link against -lgmodule-2.0 to prevent underlinking (backported from upstream,
20 but using sed to avoid eautoreconf) wrt #443798
21
22*polkit-0.108 (18 Nov 2012)
23
24 18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
25 Version bump.
26
27 28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
28 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
29 Drop ~x86-fbsd due to bug #439968.
30
31 15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
32 polkit-0.107-r1.ebuild:
33 Drop HPPA keywording (bug #438368).
34
35 15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
36 Set QA_MULTILIB_PATHS for bug #424423.
37
38 09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
39 Marked ~hppa (bug #436668).
40
41 08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
42 Use pax-mark in src_compile() instead of src_install() for src_test() wrt
43 #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
44 and emphatize it's an Portage issue instead of polkit issue in src_install()
45 message.
46
47 07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
48 Stable for amd64, wrt bug #436666
49
50*polkit-0.107-r1 (20 Sep 2012)
51
52 20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
53 +files/polkit-0.107-fallback.patch:
54 Introduce upstream patch for falling back to uid 0 for authentication if list
55 of admin identities is empty.
56
57 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
58 -polkit-0.106-r7.ebuild:
59 old
60
61*polkit-0.107 (13 Jul 2012)
62
63 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
64 Version bump.
65
66 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
67 -polkit-0.106-r6.ebuild:
68 old
69
70 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
71 Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
72 #391865 by Maksim Melnikau
73
74*polkit-0.106-r7 (02 Jul 2012)
75
76 02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
77 RESTRICT="multilib-strict" since it's not compatible with the whole
78 /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
79 polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
80
81*polkit-0.106-r6 (01 Jul 2012)
82
83 01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
84 Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
85 /usr/lib to /usr/lib64 symlink.
86
87 30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
88 polkit-0.106-r5.ebuild:
89 Adding dependency on SELinux policykit module if USE=selinux is set
90
91 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
92 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
93 'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
94
95 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
96 -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
97 old
98
99*polkit-0.106-r5 (27 Jun 2012)
100
101 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
102 Revert entire unix-group:wheel experiment back to unix-user:0 because
103 PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
104 Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
105 by Doug Goldstein.
106
107*polkit-0.106-r4 (27 Jun 2012)
108
109 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
110 Stop installing polkit-backend-1.pc because upstream changed
111 libpolkit-backend-1.la to be noinst_LTLIBRARIES in
112 src/polkitbackend/Makefile.am wrt #423431 by Pim Vullers
113
114 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r3.ebuild:
115 Redefine libprivdir in install for multilib-strict wrt #423381 by Michael
116 Palimaka
117
118*polkit-0.106-r3 (25 Jun 2012)
119
120 25 Jun 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
121 +polkit-0.106-r3.ebuild:
122 pax-mark polkitd to fix crashes on hardened/PaX systems.
123
124 23 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
125 Convert pkg_postinst() message about polkitd home directory to new
126 user.eclass function esethome().
127
128 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
129 Check for mozjs187.pc for >=dev-lang/spidermonkey-1.8.7 compability.
130
131 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
132 Adapt to sys-auth/pambase with USE="systemd" wrt #372229 by Michał Górny
133
134 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r1.ebuild:
135 old
136
137*polkit-0.106-r2 (17 Jun 2012)
138
139 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r2.ebuild:
140 Revision bump to chown /var/lib/polkit-1 because diropts has no effect on
141 existing directories.
142
143 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106.ebuild:
144 old
145
146*polkit-0.106-r1 (17 Jun 2012)
147
148 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r1.ebuild:
149 Update /etc/pam.d/polkit-1 from system-login to system-local-login. Use
150 unix-group "adm" for administrators. Use /var/lib/polkit-1 as home directory
151 for unix-user polkitd. Update owners of /etc/polkit-1/rules.d and
152 /usr/share/polkit-1/rules.d to polkitd:root wrt #420269.
153
154 13 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106.ebuild:
155 Pull in dev-lang/spidermonkey >= 1.8.5 and dev-libs/glib >= 2.32 wrt
156 #420173 and #420307.
157
158*polkit-0.106 (07 Jun 2012)
159
160 07 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106.ebuild:
161 Version bump.
162
163 20 May 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.105.ebuild:
164 Improve systemd handling wrt #416317 by Christoph Brill
165
166*polkit-0.105 (14 May 2012)
167
168 14 May 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.105.ebuild:
169 Version bump.
170
171 04 May 2012; Jeff Horelick <jdhore@gentoo.org> polkit-0.104-r1.ebuild:
172 dev-util/pkgconfig -> virtual/pkgconfig
173
174 18 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.102.ebuild,
175 -polkit-0.103.ebuild, -polkit-0.104.ebuild:
176 old
177
178 25 Mar 2012; Raúl Porcel <armin76@gentoo.org> polkit-0.104-r1.ebuild:
179 ia64/sh/sparc stable wrt #401513
180
181 09 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.104-r1.ebuild:
182 ppc/ppc64 stable wrt #401513
183
184 17 Feb 2012; Tobias Klausmann <klausman@gentoo.org> polkit-0.104-r1.ebuild:
185 Stable on alpha, bug #401513
186
187 17 Feb 2012; Thomas Kahle <tomka@gentoo.org> polkit-0.104-r1.ebuild:
188 marked x86 per bug 401513
189
190 13 Feb 2012; Markus Meier <maekke@gentoo.org> polkit-0.104-r1.ebuild:
191 arm stable, bug #401513
192
193 02 Feb 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild:
194 Stable for HPPA (bug #401513).
195
196 30 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.104-r1.ebuild:
197 Stable for AMD64, wrt security bug #401513
198
199*polkit-0.104-r1 (30 Jan 2012)
200
201 30 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104-r1.ebuild:
202 Restore the default value of AdminIdentities from "wheel" to "0" like it was
203 in polkit-0.102 and ones before that. You should see files
204 50-localauthority.conf and 60-gentoo.conf in
205 /etc/polkit-1/localauthority.conf.d. You should also familiarize yourself
206 with "man 8 pklocalauthority" as soon as possible.
207
208 29 Jan 2012; Markus Meier <maekke@gentoo.org> polkit-0.103.ebuild:
209 arm stable, bug #397755
210
211 07 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.103.ebuild:
212 Stable for AMD64, wrt bug #397755
213
214*polkit-0.104 (05 Jan 2012)
215
216 05 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104.ebuild,
217 metadata.xml:
218 Version bump.
219
220 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.101-r1.ebuild:
221 old
222
223 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.102.ebuild:
224 ppc/ppc64 stable wrt #387163
225
226 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild:
227 Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo
228
229*polkit-0.103 (07 Dec 2011)
230
231 07 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.103.ebuild:
232 Version bump. Remove unrequired keepdir of /var/run/polkit-1 wrt #387903 by
233 "i.Dark_Templar"
234
235 05 Nov 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.102.ebuild:
236 alpha/arm/ia64/sh/sparc stable wrt #387163
237
238 29 Oct 2011; Markus Meier <maekke@gentoo.org> polkit-0.102.ebuild:
239 arm stable, bug #387163
240
241 19 Oct 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.102.ebuild:
242 Stable for HPPA (bug #387163).
243
244 18 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> polkit-0.102.ebuild:
245 x86 stable wrt bug #387163
246
247 15 Oct 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.102.ebuild:
248 Stable on amd64 wrt bug #387163
249
250 28 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101-r1.ebuild,
251 polkit-0.102.ebuild:
252 pambase[consolekit] support is needed to use polkit with pam, add to PDEPEND
253
254*polkit-0.102 (06 Aug 2011)
255
256 06 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.102.ebuild:
257 Version bump.
258
259 10 Jul 2011; Matt Turner <mattst88@gentoo.org> polkit-0.101-r1.ebuild:
260 Added ~mips, bug 296548
261
262 14 May 2011; Gilles Dartiguelongue <eva@gentoo.org> polkit-0.101-r1.ebuild:
263 Add missing dtd to DEPEND, bug #355505.
264
265 30 Apr 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.101-r1.ebuild:
266 alpha/arm/ia64/sh/sparc stable wrt #364973
267
268 28 Apr 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
269 polkit-0.101-r1.ebuild:
270 x86 stable wrt security bug #364973
271
272 27 Apr 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.101-r1.ebuild:
273 Stable for HPPA (bug #364973).
274
275 27 Apr 2011; Christoph Mende <angelos@gentoo.org> polkit-0.101-r1.ebuild:
276 Stable on amd64 wrt bug #364973
277
278 27 Apr 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.101-r1.ebuild:
279 ppc/ppc64 stable wrt #364973
280
281*polkit-0.101-r1 (25 Apr 2011)
282
283 25 Apr 2011; Nirbheek Chauhan <nirbheek@gentoo.org> -polkit-0.100.ebuild,
284 +polkit-0.101-r1.ebuild:
285 Add patches for CVE-2011-1485, remove vulnerable 0.100 version
286
287 22 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> polkit-0.99-r1.ebuild:
288 ppc/ppc64 stable wrt #354509
289
290 19 Mar 2011; Raúl Porcel <armin76@gentoo.org> polkit-0.99-r1.ebuild:
291 alpha/ia64/sh/sparc stable wrt #354509
292
293 15 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.101.ebuild:
294 PDEPEND on 0.101 version of polkit-gnome
295
296 13 Mar 2011; Markus Meier <maekke@gentoo.org> polkit-0.99-r1.ebuild:
297 arm stable, bug #354509
298
299*polkit-0.101 (11 Mar 2011)
300
301 11 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.101.ebuild:
302 Version bump.
303
304 07 Mar 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
305 Stable for HPPA (bug #354509).
306
307 04 Mar 2011; Thomas Kahle <tomka@gentoo.org> polkit-0.99-r1.ebuild:
308 x86 stable per bug 354509
309
310 23 Feb 2011; Markos Chandras <hwoarang@gentoo.org> polkit-0.99-r1.ebuild:
311 Stable on amd64 wrt bug #354509
312
313*polkit-0.100 (23 Feb 2011)
314
315 23 Feb 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.100.ebuild:
316 Bump to 0.100
317
318 24 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.99-r1.ebuild:
319 USE="kde" to pull in authentication agent for KDE.
320
321 21 Jan 2011; Jeroen Roovers <jer@gentoo.org> polkit-0.99-r1.ebuild:
322 Marked ~hppa (bug #296548).
323
324*polkit-0.99-r1 (25 Dec 2010)
325
326 25 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.99-r1.ebuild:
327 Revision bump to remove static archives (.a) and libtool archives (.la).
328 USE="gtk" to pull in authentication agent for GTK+ based desktops.
329
330*polkit-0.99 (25 Sep 2010)
331
332 25 Sep 2010; <nirbheek@gentoo.org> +polkit-0.99.ebuild:
333 Bump to 0.99, masked due to >=glib-2.25 requirement
334
335 18 Aug 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
336 arm stable, bug #314899
337
338 14 Aug 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96-r1.ebuild,
339 polkit-0.96-r2.ebuild:
340 alpha/ia64/sh/sparc stable
341
342 09 Aug 2010; Joseph Jezak <josejx@gentoo.org> polkit-0.96-r1.ebuild:
343 Marked ppc/ppc64 stable.
344
345 25 Jul 2010; Tobias Klausmann <klausman@gentoo.org> polkit-0.96-r2.ebuild:
346 Stable on alpha, bug #329621
347
348 20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
349 polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
350 Stable for HPPA (bug #314899).
351
352 20 Jul 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.96.ebuild,
353 polkit-0.96-r1.ebuild, polkit-0.96-r2.ebuild:
354 Drop HPPA keywording (bug #324511).
355
356 07 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org> polkit-0.96-r1.ebuild,
357 polkit-0.96-r2.ebuild:
358 Add ewarn about ensuring that consolekit sessions are working. Either the
359 user needs to login using a login-manager with consolekit support, or use
360 ck-launch-session to launch the DE as suggested in bug 291116 comment 13
361
362*polkit-0.96-r2 (02 Jul 2010)
363
364 02 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
365 +polkit-0.96-r2.ebuild, metadata.xml:
366 USE=expat was quite useless, expat is mandatory in polkit. Don't create
367 user 'polkituser', it was used by policykit, but isn't by polkit. Also,
368 add introspection support
369
370 04 Jun 2010; Markus Meier <maekke@gentoo.org> polkit-0.96-r1.ebuild:
371 x86 stable, bug #314899
4 372
5 03 May 2010; Olivier Crête <tester@gentoo.org> polkit-0.96-r1.ebuild: 373 03 May 2010; Olivier Crête <tester@gentoo.org> polkit-0.96-r1.ebuild:
6 amd64 stable, bug #314899 374 amd64 stable, bug #314899
7 375
8 25 Apr 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild, 376 25 Apr 2010; Raúl Porcel <armin76@gentoo.org> polkit-0.96.ebuild,
67 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org> 435 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
68 +files/polkit-0.92-zsh-completions.patch, 436 +files/polkit-0.92-zsh-completions.patch,
69 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild, 437 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
70 +metadata.xml: 438 +metadata.xml:
71 Initial ebuild for GNOME 2.28. 439 Initial ebuild for GNOME 2.28.
72

Legend:
Removed from v.1.16  
changed lines
  Added in v.1.115

  ViewVC Help
Powered by ViewVC 1.1.20