/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Diff of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.59 Revision 1.121
1# ChangeLog for sys-auth/polkit 1# ChangeLog for sys-auth/polkit
2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.59 2011/12/08 15:39:21 ssuominen Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.121 2012/12/21 15:00:39 ssuominen Exp $
4
5 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.108.ebuild,
6 -polkit-0.109.ebuild:
7 old
8
9*polkit-0.109-r1 (21 Dec 2012)
10
11 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109-r1.ebuild,
12 +files/polkit-0.109-XAUTHORITY-fallback.patch:
13 Backport XAUTHORITY fallback support from upstream git.
14
15 19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.108.ebuild:
16 Add ~ia64, wrt bug #436668
17
18*polkit-0.109 (19 Dec 2012)
19
20 19 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109.ebuild:
21 Version bump. Fix PaX marking logic wrt #444446 by Maxim Kammerer
22
23 18 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
24 Stable for ia64, wrt bug #436666
25
26 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
27 stable arm, bug #436666
28
29 22 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107.ebuild:
30 old
31
32 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
33 stable ppc64, bug #436666
34
35 22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
36 Stable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt
37 bug #436666
38
39 21 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
40 stable ppc, bug #436666, thanks peratu
41
42 19 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.108.ebuild:
43 Link against -lgmodule-2.0 to prevent underlinking (backported from upstream,
44 but using sed to avoid eautoreconf) wrt #443798
45
46*polkit-0.108 (18 Nov 2012)
47
48 18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
49 Version bump.
50
51 28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
52 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
53 Drop ~x86-fbsd due to bug #439968.
54
55 15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
56 polkit-0.107-r1.ebuild:
57 Drop HPPA keywording (bug #438368).
58
59 15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
60 Set QA_MULTILIB_PATHS for bug #424423.
61
62 09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
63 Marked ~hppa (bug #436668).
64
65 08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
66 Use pax-mark in src_compile() instead of src_install() for src_test() wrt
67 #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
68 and emphatize it's an Portage issue instead of polkit issue in src_install()
69 message.
70
71 07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
72 Stable for amd64, wrt bug #436666
73
74*polkit-0.107-r1 (20 Sep 2012)
75
76 20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
77 +files/polkit-0.107-fallback.patch:
78 Introduce upstream patch for falling back to uid 0 for authentication if list
79 of admin identities is empty.
80
81 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
82 -polkit-0.106-r7.ebuild:
83 old
84
85*polkit-0.107 (13 Jul 2012)
86
87 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
88 Version bump.
89
90 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
91 -polkit-0.106-r6.ebuild:
92 old
93
94 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
95 Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
96 #391865 by Maksim Melnikau
97
98*polkit-0.106-r7 (02 Jul 2012)
99
100 02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
101 RESTRICT="multilib-strict" since it's not compatible with the whole
102 /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
103 polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
104
105*polkit-0.106-r6 (01 Jul 2012)
106
107 01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
108 Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
109 /usr/lib to /usr/lib64 symlink.
110
111 30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
112 polkit-0.106-r5.ebuild:
113 Adding dependency on SELinux policykit module if USE=selinux is set
114
115 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
116 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
117 'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
118
119 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
120 -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
121 old
122
123*polkit-0.106-r5 (27 Jun 2012)
124
125 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
126 Revert entire unix-group:wheel experiment back to unix-user:0 because
127 PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
128 Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
129 by Doug Goldstein.
130
131*polkit-0.106-r4 (27 Jun 2012)
132
133 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
134 Stop installing polkit-backend-1.pc because upstream changed
135 libpolkit-backend-1.la to be noinst_LTLIBRARIES in
136 src/polkitbackend/Makefile.am wrt #423431 by Pim Vullers
137
138 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r3.ebuild:
139 Redefine libprivdir in install for multilib-strict wrt #423381 by Michael
140 Palimaka
141
142*polkit-0.106-r3 (25 Jun 2012)
143
144 25 Jun 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
145 +polkit-0.106-r3.ebuild:
146 pax-mark polkitd to fix crashes on hardened/PaX systems.
147
148 23 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
149 Convert pkg_postinst() message about polkitd home directory to new
150 user.eclass function esethome().
151
152 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
153 Check for mozjs187.pc for >=dev-lang/spidermonkey-1.8.7 compability.
154
155 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
156 Adapt to sys-auth/pambase with USE="systemd" wrt #372229 by Michał Górny
157
158 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r1.ebuild:
159 old
160
161*polkit-0.106-r2 (17 Jun 2012)
162
163 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r2.ebuild:
164 Revision bump to chown /var/lib/polkit-1 because diropts has no effect on
165 existing directories.
166
167 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106.ebuild:
168 old
169
170*polkit-0.106-r1 (17 Jun 2012)
171
172 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r1.ebuild:
173 Update /etc/pam.d/polkit-1 from system-login to system-local-login. Use
174 unix-group "adm" for administrators. Use /var/lib/polkit-1 as home directory
175 for unix-user polkitd. Update owners of /etc/polkit-1/rules.d and
176 /usr/share/polkit-1/rules.d to polkitd:root wrt #420269.
177
178 13 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106.ebuild:
179 Pull in dev-lang/spidermonkey >= 1.8.5 and dev-libs/glib >= 2.32 wrt
180 #420173 and #420307.
181
182*polkit-0.106 (07 Jun 2012)
183
184 07 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106.ebuild:
185 Version bump.
186
187 20 May 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.105.ebuild:
188 Improve systemd handling wrt #416317 by Christoph Brill
189
190*polkit-0.105 (14 May 2012)
191
192 14 May 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.105.ebuild:
193 Version bump.
194
195 04 May 2012; Jeff Horelick <jdhore@gentoo.org> polkit-0.104-r1.ebuild:
196 dev-util/pkgconfig -> virtual/pkgconfig
197
198 18 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.102.ebuild,
199 -polkit-0.103.ebuild, -polkit-0.104.ebuild:
200 old
201
202 25 Mar 2012; Raúl Porcel <armin76@gentoo.org> polkit-0.104-r1.ebuild:
203 ia64/sh/sparc stable wrt #401513
204
205 09 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.104-r1.ebuild:
206 ppc/ppc64 stable wrt #401513
207
208 17 Feb 2012; Tobias Klausmann <klausman@gentoo.org> polkit-0.104-r1.ebuild:
209 Stable on alpha, bug #401513
210
211 17 Feb 2012; Thomas Kahle <tomka@gentoo.org> polkit-0.104-r1.ebuild:
212 marked x86 per bug 401513
213
214 13 Feb 2012; Markus Meier <maekke@gentoo.org> polkit-0.104-r1.ebuild:
215 arm stable, bug #401513
216
217 02 Feb 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild:
218 Stable for HPPA (bug #401513).
219
220 30 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.104-r1.ebuild:
221 Stable for AMD64, wrt security bug #401513
222
223*polkit-0.104-r1 (30 Jan 2012)
224
225 30 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104-r1.ebuild:
226 Restore the default value of AdminIdentities from "wheel" to "0" like it was
227 in polkit-0.102 and ones before that. You should see files
228 50-localauthority.conf and 60-gentoo.conf in
229 /etc/polkit-1/localauthority.conf.d. You should also familiarize yourself
230 with "man 8 pklocalauthority" as soon as possible.
231
232 29 Jan 2012; Markus Meier <maekke@gentoo.org> polkit-0.103.ebuild:
233 arm stable, bug #397755
234
235 07 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.103.ebuild:
236 Stable for AMD64, wrt bug #397755
237
238*polkit-0.104 (05 Jan 2012)
239
240 05 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104.ebuild,
241 metadata.xml:
242 Version bump.
243
244 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.101-r1.ebuild:
245 old
246
247 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.102.ebuild:
248 ppc/ppc64 stable wrt #387163
4 249
5 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild: 250 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild:
6 Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo 251 Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo
7 252
8*polkit-0.103 (07 Dec 2011) 253*polkit-0.103 (07 Dec 2011)
214 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org> 459 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
215 +files/polkit-0.92-zsh-completions.patch, 460 +files/polkit-0.92-zsh-completions.patch,
216 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild, 461 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
217 +metadata.xml: 462 +metadata.xml:
218 Initial ebuild for GNOME 2.28. 463 Initial ebuild for GNOME 2.28.
219

Legend:
Removed from v.1.59  
changed lines
  Added in v.1.121

  ViewVC Help
Powered by ViewVC 1.1.20