/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Diff of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.59 Revision 1.152
1# ChangeLog for sys-auth/polkit 1# ChangeLog for sys-auth/polkit
2# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.59 2011/12/08 15:39:21 ssuominen Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.152 2013/09/19 17:17:05 ssuominen Exp $
4
5 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.110-r1.ebuild,
6 -files/polkit-0.110-CVE-2013-4288.patch:
7 old
8
9*polkit-0.112-r1 (19 Sep 2013)
10
11 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.112-r1.ebuild,
12 polkit-0.112.ebuild:
13 -r0 is for stabilization w/ mozjs185 and -r1 is for ~arch with mozjs 17.0
14
15 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> -polkit-0.111-r1.ebuild:
16 Remove vulnerable version
17
18*polkit-0.110-r1 (19 Sep 2013)
19
20 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org>
21 +files/polkit-0.110-CVE-2013-4288.patch, +polkit-0.110-r1.ebuild:
22 Bump for CVE-2013-4288
23
24*polkit-0.112 (19 Sep 2013)
25
26 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> +polkit-0.112.ebuild:
27 Bump for CVE-2013-4288
28
29 10 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
30 polkit-0.111-r1.ebuild:
31 Stop forcing USE="consolekit systemd" for sys-auth/pambase in PDEPEND because
32 CONFIG_AUDITSYSCALL=y is not possible on every arch and the dependency was
33 always more about convinience than being strict requirement.
34
35 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> -polkit-0.111.ebuild:
36 dropped polkit-111 in favour of -r1 now that spidermonkey-17 is unmasked, as
37 per ssuominen's approval
38
39 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> polkit-0.110.ebuild,
40 polkit-0.111-r1.ebuild:
41 Adjusted deps for dev-lang/spidermonkey to ensure SLOT=0
42
43*polkit-0.111-r1 (08 Aug 2013)
44
45 08 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111-r1.ebuild:
46 Force use of dev-lang/spidermonkey:17 because automagic dependencies are bad.
47
48*polkit-0.111 (15 May 2013)
49
50 15 May 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111.ebuild:
51 Version bump by "okias" from Freenode
52
53 19 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107-r1.ebuild,
54 -files/polkit-0.107-fallback.patch:
55 old
56
57 19 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
58 Stable for sh, wrt bug #452688
59
60 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
61 files/polkit-0.110-W_define.patch:
62 Include link to upstream bug.
63
64 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
65 +files/polkit-0.110-W_define.patch:
66 Fix missing #include <sys/wait.h> for #define's of WIFEXITED, WEXITSTATUS,
67 WIFSIGNALED and WTERMSIG (to fix building on arch "sh")
68
69 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
70 Stable for sparc, wrt bug #452688
71
72 03 Mar 2013; Mike Frysinger <vapier@gentoo.org> polkit-0.110.ebuild:
73 Add s390 keywords #457078 by Michael Palimaka.
74
75 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
76 Stable for alpha, wrt bug #452688
77
78 10 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
79 Stable for ppc64, wrt bug #452688
80
81 09 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
82 Stable for ia64, wrt bug #452688
83
84 31 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
85 Stable for ppc, wrt bug #452688
86
87 29 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
88 Force USE="debug" to be disabled in dev-lang/spidermonkey to avoid asseration
89 errors as noted by _AxS_.
90
91 26 Jan 2013; Markus Meier <maekke@gentoo.org> polkit-0.110.ebuild:
92 arm stable, bug #452688
93
94 20 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
95 x86 stable wrt #452688
96
97 19 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
98 amd64 stable wrt #452688
99
100 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.104-r1.ebuild,
101 -polkit-0.109-r1.ebuild, -files/polkit-0.109-XAUTHORITY-fallback.patch:
102 old
103
104*polkit-0.110 (11 Jan 2013)
105
106 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.110.ebuild:
107 Version bump.
108
109 06 Jan 2013; Raúl Porcel <armin76@gentoo.org> polkit-0.107-r1.ebuild,
110 polkit-0.109-r1.ebuild:
111 Add ~sh wrt #436668
112
113 01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.109-r1.ebuild:
114 Add ~ia64, wrt bug #436668
115
116 30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
117 Stable for sparc, wrt bug #436666
118
119 29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
120 Stable for alpha, wrt bug #436666
121
122 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.108.ebuild,
123 -polkit-0.109.ebuild:
124 old
125
126*polkit-0.109-r1 (21 Dec 2012)
127
128 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109-r1.ebuild,
129 +files/polkit-0.109-XAUTHORITY-fallback.patch:
130 Backport XAUTHORITY fallback support from upstream git.
131
132 19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.108.ebuild:
133 Add ~ia64, wrt bug #436668
134
135*polkit-0.109 (19 Dec 2012)
136
137 19 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109.ebuild:
138 Version bump. Fix PaX marking logic wrt #444446 by Maxim Kammerer
139
140 18 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
141 Stable for ia64, wrt bug #436666
142
143 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
144 stable arm, bug #436666
145
146 22 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107.ebuild:
147 old
148
149 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
150 stable ppc64, bug #436666
151
152 22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
153 Stable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt
154 bug #436666
155
156 21 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
157 stable ppc, bug #436666, thanks peratu
158
159 19 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.108.ebuild:
160 Link against -lgmodule-2.0 to prevent underlinking (backported from upstream,
161 but using sed to avoid eautoreconf) wrt #443798
162
163*polkit-0.108 (18 Nov 2012)
164
165 18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
166 Version bump.
167
168 28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
169 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
170 Drop ~x86-fbsd due to bug #439968.
171
172 15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
173 polkit-0.107-r1.ebuild:
174 Drop HPPA keywording (bug #438368).
175
176 15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
177 Set QA_MULTILIB_PATHS for bug #424423.
178
179 09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
180 Marked ~hppa (bug #436668).
181
182 08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
183 Use pax-mark in src_compile() instead of src_install() for src_test() wrt
184 #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
185 and emphatize it's an Portage issue instead of polkit issue in src_install()
186 message.
187
188 07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
189 Stable for amd64, wrt bug #436666
190
191*polkit-0.107-r1 (20 Sep 2012)
192
193 20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
194 +files/polkit-0.107-fallback.patch:
195 Introduce upstream patch for falling back to uid 0 for authentication if list
196 of admin identities is empty.
197
198 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
199 -polkit-0.106-r7.ebuild:
200 old
201
202*polkit-0.107 (13 Jul 2012)
203
204 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
205 Version bump.
206
207 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
208 -polkit-0.106-r6.ebuild:
209 old
210
211 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
212 Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
213 #391865 by Maksim Melnikau
214
215*polkit-0.106-r7 (02 Jul 2012)
216
217 02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
218 RESTRICT="multilib-strict" since it's not compatible with the whole
219 /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
220 polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
221
222*polkit-0.106-r6 (01 Jul 2012)
223
224 01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
225 Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
226 /usr/lib to /usr/lib64 symlink.
227
228 30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
229 polkit-0.106-r5.ebuild:
230 Adding dependency on SELinux policykit module if USE=selinux is set
231
232 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
233 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
234 'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
235
236 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
237 -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
238 old
239
240*polkit-0.106-r5 (27 Jun 2012)
241
242 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
243 Revert entire unix-group:wheel experiment back to unix-user:0 because
244 PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
245 Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
246 by Doug Goldstein.
247
248*polkit-0.106-r4 (27 Jun 2012)
249
250 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
251 Stop installing polkit-backend-1.pc because upstream changed
252 libpolkit-backend-1.la to be noinst_LTLIBRARIES in
253 src/polkitbackend/Makefile.am wrt #423431 by Pim Vullers
254
255 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r3.ebuild:
256 Redefine libprivdir in install for multilib-strict wrt #423381 by Michael
257 Palimaka
258
259*polkit-0.106-r3 (25 Jun 2012)
260
261 25 Jun 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
262 +polkit-0.106-r3.ebuild:
263 pax-mark polkitd to fix crashes on hardened/PaX systems.
264
265 23 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
266 Convert pkg_postinst() message about polkitd home directory to new
267 user.eclass function esethome().
268
269 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
270 Check for mozjs187.pc for >=dev-lang/spidermonkey-1.8.7 compability.
271
272 19 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r2.ebuild:
273 Adapt to sys-auth/pambase with USE="systemd" wrt #372229 by Michał Górny
274
275 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r1.ebuild:
276 old
277
278*polkit-0.106-r2 (17 Jun 2012)
279
280 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r2.ebuild:
281 Revision bump to chown /var/lib/polkit-1 because diropts has no effect on
282 existing directories.
283
284 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106.ebuild:
285 old
286
287*polkit-0.106-r1 (17 Jun 2012)
288
289 17 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r1.ebuild:
290 Update /etc/pam.d/polkit-1 from system-login to system-local-login. Use
291 unix-group "adm" for administrators. Use /var/lib/polkit-1 as home directory
292 for unix-user polkitd. Update owners of /etc/polkit-1/rules.d and
293 /usr/share/polkit-1/rules.d to polkitd:root wrt #420269.
294
295 13 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106.ebuild:
296 Pull in dev-lang/spidermonkey >= 1.8.5 and dev-libs/glib >= 2.32 wrt
297 #420173 and #420307.
298
299*polkit-0.106 (07 Jun 2012)
300
301 07 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106.ebuild:
302 Version bump.
303
304 20 May 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.105.ebuild:
305 Improve systemd handling wrt #416317 by Christoph Brill
306
307*polkit-0.105 (14 May 2012)
308
309 14 May 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.105.ebuild:
310 Version bump.
311
312 04 May 2012; Jeff Horelick <jdhore@gentoo.org> polkit-0.104-r1.ebuild:
313 dev-util/pkgconfig -> virtual/pkgconfig
314
315 18 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.102.ebuild,
316 -polkit-0.103.ebuild, -polkit-0.104.ebuild:
317 old
318
319 25 Mar 2012; Raúl Porcel <armin76@gentoo.org> polkit-0.104-r1.ebuild:
320 ia64/sh/sparc stable wrt #401513
321
322 09 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.104-r1.ebuild:
323 ppc/ppc64 stable wrt #401513
324
325 17 Feb 2012; Tobias Klausmann <klausman@gentoo.org> polkit-0.104-r1.ebuild:
326 Stable on alpha, bug #401513
327
328 17 Feb 2012; Thomas Kahle <tomka@gentoo.org> polkit-0.104-r1.ebuild:
329 marked x86 per bug 401513
330
331 13 Feb 2012; Markus Meier <maekke@gentoo.org> polkit-0.104-r1.ebuild:
332 arm stable, bug #401513
333
334 02 Feb 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild:
335 Stable for HPPA (bug #401513).
336
337 30 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.104-r1.ebuild:
338 Stable for AMD64, wrt security bug #401513
339
340*polkit-0.104-r1 (30 Jan 2012)
341
342 30 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104-r1.ebuild:
343 Restore the default value of AdminIdentities from "wheel" to "0" like it was
344 in polkit-0.102 and ones before that. You should see files
345 50-localauthority.conf and 60-gentoo.conf in
346 /etc/polkit-1/localauthority.conf.d. You should also familiarize yourself
347 with "man 8 pklocalauthority" as soon as possible.
348
349 29 Jan 2012; Markus Meier <maekke@gentoo.org> polkit-0.103.ebuild:
350 arm stable, bug #397755
351
352 07 Jan 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.103.ebuild:
353 Stable for AMD64, wrt bug #397755
354
355*polkit-0.104 (05 Jan 2012)
356
357 05 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.104.ebuild,
358 metadata.xml:
359 Version bump.
360
361 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.101-r1.ebuild:
362 old
363
364 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.102.ebuild:
365 ppc/ppc64 stable wrt #387163
4 366
5 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild: 367 08 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> polkit-0.103.ebuild:
6 Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo 368 Raise dev-libs/glib depend to at least 2.30 wrt #393579 by Matt Palermo
7 369
8*polkit-0.103 (07 Dec 2011) 370*polkit-0.103 (07 Dec 2011)
214 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org> 576 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
215 +files/polkit-0.92-zsh-completions.patch, 577 +files/polkit-0.92-zsh-completions.patch,
216 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild, 578 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
217 +metadata.xml: 579 +metadata.xml:
218 Initial ebuild for GNOME 2.28. 580 Initial ebuild for GNOME 2.28.
219

Legend:
Removed from v.1.59  
changed lines
  Added in v.1.152

  ViewVC Help
Powered by ViewVC 1.1.20