/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Diff of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.89 Revision 1.147
1# ChangeLog for sys-auth/polkit 1# ChangeLog for sys-auth/polkit
2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.89 2012/06/27 10:06:14 ssuominen Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.147 2013/09/19 15:47:54 cardoe Exp $
4
5*polkit-0.112 (19 Sep 2013)
6
7 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> +polkit-0.112.ebuild:
8 Bump for CVE-2013-4288
9
10 10 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
11 polkit-0.111-r1.ebuild:
12 Stop forcing USE="consolekit systemd" for sys-auth/pambase in PDEPEND because
13 CONFIG_AUDITSYSCALL=y is not possible on every arch and the dependency was
14 always more about convinience than being strict requirement.
15
16 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> -polkit-0.111.ebuild:
17 dropped polkit-111 in favour of -r1 now that spidermonkey-17 is unmasked, as
18 per ssuominen's approval
19
20 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> polkit-0.110.ebuild,
21 polkit-0.111-r1.ebuild:
22 Adjusted deps for dev-lang/spidermonkey to ensure SLOT=0
23
24*polkit-0.111-r1 (08 Aug 2013)
25
26 08 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111-r1.ebuild:
27 Force use of dev-lang/spidermonkey:17 because automagic dependencies are bad.
28
29*polkit-0.111 (15 May 2013)
30
31 15 May 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111.ebuild:
32 Version bump by "okias" from Freenode
33
34 19 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107-r1.ebuild,
35 -files/polkit-0.107-fallback.patch:
36 old
37
38 19 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
39 Stable for sh, wrt bug #452688
40
41 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
42 files/polkit-0.110-W_define.patch:
43 Include link to upstream bug.
44
45 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
46 +files/polkit-0.110-W_define.patch:
47 Fix missing #include <sys/wait.h> for #define's of WIFEXITED, WEXITSTATUS,
48 WIFSIGNALED and WTERMSIG (to fix building on arch "sh")
49
50 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
51 Stable for sparc, wrt bug #452688
52
53 03 Mar 2013; Mike Frysinger <vapier@gentoo.org> polkit-0.110.ebuild:
54 Add s390 keywords #457078 by Michael Palimaka.
55
56 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
57 Stable for alpha, wrt bug #452688
58
59 10 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
60 Stable for ppc64, wrt bug #452688
61
62 09 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
63 Stable for ia64, wrt bug #452688
64
65 31 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
66 Stable for ppc, wrt bug #452688
67
68 29 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
69 Force USE="debug" to be disabled in dev-lang/spidermonkey to avoid asseration
70 errors as noted by _AxS_.
71
72 26 Jan 2013; Markus Meier <maekke@gentoo.org> polkit-0.110.ebuild:
73 arm stable, bug #452688
74
75 20 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
76 x86 stable wrt #452688
77
78 19 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
79 amd64 stable wrt #452688
80
81 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.104-r1.ebuild,
82 -polkit-0.109-r1.ebuild, -files/polkit-0.109-XAUTHORITY-fallback.patch:
83 old
84
85*polkit-0.110 (11 Jan 2013)
86
87 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.110.ebuild:
88 Version bump.
89
90 06 Jan 2013; Raúl Porcel <armin76@gentoo.org> polkit-0.107-r1.ebuild,
91 polkit-0.109-r1.ebuild:
92 Add ~sh wrt #436668
93
94 01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.109-r1.ebuild:
95 Add ~ia64, wrt bug #436668
96
97 30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
98 Stable for sparc, wrt bug #436666
99
100 29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
101 Stable for alpha, wrt bug #436666
102
103 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.108.ebuild,
104 -polkit-0.109.ebuild:
105 old
106
107*polkit-0.109-r1 (21 Dec 2012)
108
109 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109-r1.ebuild,
110 +files/polkit-0.109-XAUTHORITY-fallback.patch:
111 Backport XAUTHORITY fallback support from upstream git.
112
113 19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.108.ebuild:
114 Add ~ia64, wrt bug #436668
115
116*polkit-0.109 (19 Dec 2012)
117
118 19 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109.ebuild:
119 Version bump. Fix PaX marking logic wrt #444446 by Maxim Kammerer
120
121 18 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
122 Stable for ia64, wrt bug #436666
123
124 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
125 stable arm, bug #436666
126
127 22 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107.ebuild:
128 old
129
130 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
131 stable ppc64, bug #436666
132
133 22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
134 Stable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt
135 bug #436666
136
137 21 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
138 stable ppc, bug #436666, thanks peratu
139
140 19 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.108.ebuild:
141 Link against -lgmodule-2.0 to prevent underlinking (backported from upstream,
142 but using sed to avoid eautoreconf) wrt #443798
143
144*polkit-0.108 (18 Nov 2012)
145
146 18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
147 Version bump.
148
149 28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
150 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
151 Drop ~x86-fbsd due to bug #439968.
152
153 15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
154 polkit-0.107-r1.ebuild:
155 Drop HPPA keywording (bug #438368).
156
157 15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
158 Set QA_MULTILIB_PATHS for bug #424423.
159
160 09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
161 Marked ~hppa (bug #436668).
162
163 08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
164 Use pax-mark in src_compile() instead of src_install() for src_test() wrt
165 #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
166 and emphatize it's an Portage issue instead of polkit issue in src_install()
167 message.
168
169 07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
170 Stable for amd64, wrt bug #436666
171
172*polkit-0.107-r1 (20 Sep 2012)
173
174 20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
175 +files/polkit-0.107-fallback.patch:
176 Introduce upstream patch for falling back to uid 0 for authentication if list
177 of admin identities is empty.
178
179 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
180 -polkit-0.106-r7.ebuild:
181 old
182
183*polkit-0.107 (13 Jul 2012)
184
185 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
186 Version bump.
187
188 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
189 -polkit-0.106-r6.ebuild:
190 old
191
192 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
193 Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
194 #391865 by Maksim Melnikau
195
196*polkit-0.106-r7 (02 Jul 2012)
197
198 02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
199 RESTRICT="multilib-strict" since it's not compatible with the whole
200 /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
201 polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
202
203*polkit-0.106-r6 (01 Jul 2012)
204
205 01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
206 Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
207 /usr/lib to /usr/lib64 symlink.
208
209 30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
210 polkit-0.106-r5.ebuild:
211 Adding dependency on SELinux policykit module if USE=selinux is set
212
213 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
214 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
215 'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
216
217 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
218 -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
219 old
220
221*polkit-0.106-r5 (27 Jun 2012)
222
223 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
224 Revert entire unix-group:wheel experiment back to unix-user:0 because
225 PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
226 Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
227 by Doug Goldstein.
4 228
5*polkit-0.106-r4 (27 Jun 2012) 229*polkit-0.106-r4 (27 Jun 2012)
6 230
7 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild: 231 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
8 Stop installing polkit-backend-1.pc because upstream changed 232 Stop installing polkit-backend-1.pc because upstream changed
333 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org> 557 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
334 +files/polkit-0.92-zsh-completions.patch, 558 +files/polkit-0.92-zsh-completions.patch,
335 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild, 559 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
336 +metadata.xml: 560 +metadata.xml:
337 Initial ebuild for GNOME 2.28. 561 Initial ebuild for GNOME 2.28.
338

Legend:
Removed from v.1.89  
changed lines
  Added in v.1.147

  ViewVC Help
Powered by ViewVC 1.1.20