/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Diff of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.89 Revision 1.151
1# ChangeLog for sys-auth/polkit 1# ChangeLog for sys-auth/polkit
2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.89 2012/06/27 10:06:14 ssuominen Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.151 2013/09/19 17:12:35 ssuominen Exp $
4
5 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.110-r1.ebuild:
6 Remove wrongly committed ebuild.
7
8*polkit-0.112-r1 (19 Sep 2013)
9
10 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.112-r1.ebuild,
11 polkit-0.112.ebuild:
12 -r0 is for stabilization w/ mozjs185 and -r1 is for ~arch with mozjs 17.0
13
14 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> -polkit-0.111-r1.ebuild:
15 Remove vulnerable version
16
17*polkit-0.110-r1 (19 Sep 2013)
18
19 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org>
20 +files/polkit-0.110-CVE-2013-4288.patch, +polkit-0.110-r1.ebuild:
21 Bump for CVE-2013-4288
22
23*polkit-0.112 (19 Sep 2013)
24
25 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> +polkit-0.112.ebuild:
26 Bump for CVE-2013-4288
27
28 10 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
29 polkit-0.111-r1.ebuild:
30 Stop forcing USE="consolekit systemd" for sys-auth/pambase in PDEPEND because
31 CONFIG_AUDITSYSCALL=y is not possible on every arch and the dependency was
32 always more about convinience than being strict requirement.
33
34 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> -polkit-0.111.ebuild:
35 dropped polkit-111 in favour of -r1 now that spidermonkey-17 is unmasked, as
36 per ssuominen's approval
37
38 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> polkit-0.110.ebuild,
39 polkit-0.111-r1.ebuild:
40 Adjusted deps for dev-lang/spidermonkey to ensure SLOT=0
41
42*polkit-0.111-r1 (08 Aug 2013)
43
44 08 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111-r1.ebuild:
45 Force use of dev-lang/spidermonkey:17 because automagic dependencies are bad.
46
47*polkit-0.111 (15 May 2013)
48
49 15 May 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111.ebuild:
50 Version bump by "okias" from Freenode
51
52 19 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107-r1.ebuild,
53 -files/polkit-0.107-fallback.patch:
54 old
55
56 19 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
57 Stable for sh, wrt bug #452688
58
59 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
60 files/polkit-0.110-W_define.patch:
61 Include link to upstream bug.
62
63 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
64 +files/polkit-0.110-W_define.patch:
65 Fix missing #include <sys/wait.h> for #define's of WIFEXITED, WEXITSTATUS,
66 WIFSIGNALED and WTERMSIG (to fix building on arch "sh")
67
68 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
69 Stable for sparc, wrt bug #452688
70
71 03 Mar 2013; Mike Frysinger <vapier@gentoo.org> polkit-0.110.ebuild:
72 Add s390 keywords #457078 by Michael Palimaka.
73
74 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
75 Stable for alpha, wrt bug #452688
76
77 10 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
78 Stable for ppc64, wrt bug #452688
79
80 09 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
81 Stable for ia64, wrt bug #452688
82
83 31 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
84 Stable for ppc, wrt bug #452688
85
86 29 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
87 Force USE="debug" to be disabled in dev-lang/spidermonkey to avoid asseration
88 errors as noted by _AxS_.
89
90 26 Jan 2013; Markus Meier <maekke@gentoo.org> polkit-0.110.ebuild:
91 arm stable, bug #452688
92
93 20 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
94 x86 stable wrt #452688
95
96 19 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
97 amd64 stable wrt #452688
98
99 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.104-r1.ebuild,
100 -polkit-0.109-r1.ebuild, -files/polkit-0.109-XAUTHORITY-fallback.patch:
101 old
102
103*polkit-0.110 (11 Jan 2013)
104
105 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.110.ebuild:
106 Version bump.
107
108 06 Jan 2013; Raúl Porcel <armin76@gentoo.org> polkit-0.107-r1.ebuild,
109 polkit-0.109-r1.ebuild:
110 Add ~sh wrt #436668
111
112 01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.109-r1.ebuild:
113 Add ~ia64, wrt bug #436668
114
115 30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
116 Stable for sparc, wrt bug #436666
117
118 29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
119 Stable for alpha, wrt bug #436666
120
121 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.108.ebuild,
122 -polkit-0.109.ebuild:
123 old
124
125*polkit-0.109-r1 (21 Dec 2012)
126
127 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109-r1.ebuild,
128 +files/polkit-0.109-XAUTHORITY-fallback.patch:
129 Backport XAUTHORITY fallback support from upstream git.
130
131 19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.108.ebuild:
132 Add ~ia64, wrt bug #436668
133
134*polkit-0.109 (19 Dec 2012)
135
136 19 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109.ebuild:
137 Version bump. Fix PaX marking logic wrt #444446 by Maxim Kammerer
138
139 18 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
140 Stable for ia64, wrt bug #436666
141
142 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
143 stable arm, bug #436666
144
145 22 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107.ebuild:
146 old
147
148 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
149 stable ppc64, bug #436666
150
151 22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
152 Stable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt
153 bug #436666
154
155 21 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
156 stable ppc, bug #436666, thanks peratu
157
158 19 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.108.ebuild:
159 Link against -lgmodule-2.0 to prevent underlinking (backported from upstream,
160 but using sed to avoid eautoreconf) wrt #443798
161
162*polkit-0.108 (18 Nov 2012)
163
164 18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
165 Version bump.
166
167 28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
168 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
169 Drop ~x86-fbsd due to bug #439968.
170
171 15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
172 polkit-0.107-r1.ebuild:
173 Drop HPPA keywording (bug #438368).
174
175 15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
176 Set QA_MULTILIB_PATHS for bug #424423.
177
178 09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
179 Marked ~hppa (bug #436668).
180
181 08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
182 Use pax-mark in src_compile() instead of src_install() for src_test() wrt
183 #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
184 and emphatize it's an Portage issue instead of polkit issue in src_install()
185 message.
186
187 07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
188 Stable for amd64, wrt bug #436666
189
190*polkit-0.107-r1 (20 Sep 2012)
191
192 20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
193 +files/polkit-0.107-fallback.patch:
194 Introduce upstream patch for falling back to uid 0 for authentication if list
195 of admin identities is empty.
196
197 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
198 -polkit-0.106-r7.ebuild:
199 old
200
201*polkit-0.107 (13 Jul 2012)
202
203 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
204 Version bump.
205
206 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
207 -polkit-0.106-r6.ebuild:
208 old
209
210 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
211 Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
212 #391865 by Maksim Melnikau
213
214*polkit-0.106-r7 (02 Jul 2012)
215
216 02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
217 RESTRICT="multilib-strict" since it's not compatible with the whole
218 /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
219 polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
220
221*polkit-0.106-r6 (01 Jul 2012)
222
223 01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
224 Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
225 /usr/lib to /usr/lib64 symlink.
226
227 30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
228 polkit-0.106-r5.ebuild:
229 Adding dependency on SELinux policykit module if USE=selinux is set
230
231 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
232 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
233 'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
234
235 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
236 -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
237 old
238
239*polkit-0.106-r5 (27 Jun 2012)
240
241 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
242 Revert entire unix-group:wheel experiment back to unix-user:0 because
243 PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
244 Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
245 by Doug Goldstein.
4 246
5*polkit-0.106-r4 (27 Jun 2012) 247*polkit-0.106-r4 (27 Jun 2012)
6 248
7 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild: 249 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
8 Stop installing polkit-backend-1.pc because upstream changed 250 Stop installing polkit-backend-1.pc because upstream changed
333 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org> 575 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
334 +files/polkit-0.92-zsh-completions.patch, 576 +files/polkit-0.92-zsh-completions.patch,
335 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild, 577 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
336 +metadata.xml: 578 +metadata.xml:
337 Initial ebuild for GNOME 2.28. 579 Initial ebuild for GNOME 2.28.
338

Legend:
Removed from v.1.89  
changed lines
  Added in v.1.151

  ViewVC Help
Powered by ViewVC 1.1.20